Subject: RE: consensus stattement on vpsl solutions

From: Sasha Vainshtein <[email-masked]>
Date: Tue, 7 Oct 2003 10:11:54 +0200

Loa and all,
Thank you for a prompt response.
Please see also some comments inline.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: Tuesday, October 07, 2003 9:00 AM
> To: Sasha Vainshtein; [email-masked]
> Cc: Vach Kompella; Rick Wilder; Thomas Narten
> Subject: Re: consensus stattement on vpsl solutions
> 
> 
> Sasha,
> 
> there were two reasons
> 
> - it is not really competing for the same solutions space
[Sasha] I agree - it does not, since, in its present form, 
it describes a way to provide a VPLS solution over an IP 
(not necessarily MPLS-enabled) network.
> - it was our impression that the interest for this draft
>    had faded, when no new editor were found
> 
[Sasha] I have probably missed something. I remember a prolonged
discussion (involving a RADIUS expert) wrt specifics of using 
RADIUS as an auto-discovery mechanism. AFAIK, the last update to
the RADIUS discovery draft has covered most (possibly) all open
issues in this area. 
>
> However, we (wg co-chairs) are quite happy that it is brought
> back on the arena and would encourage the co-author to get together
> and suggest a new document editor amomng themselves, alt. ask
> us to appoint one if one can't be found among the co-authors.
>
[Sasha] AFAIK, the last two drafts have been authored by Juha without
any co-authors. Did I miss something?
>
> Once we have the editor, we would be happy to discuss next
> steps, including making it a wg doc.
> 
> /Loa
> 
> Sasha Vainshtein wrote:
> 
> > Loa and all,
> > May I ask why the directory-based VPLS approach
> > (proposed by Juha Heinanen) has been left out of
> > even the initial list?
> > 
> > With best regards,
> >                                    Sasha Vainshtein
> > email:     [email-masked] <mailto:[email-masked]> 
> > tel:       +972-3-7659993 (office)
> >            +972-8-9254948 (res.)
> >            +972-58-674833 (cell.)
> >  
> > 
> > 
> > 
> >>-----Original Message-----
> >>From: Loa Andersson [mailto:[email-masked]]
> >>Sent: Thursday, October 02, 2003 5:09 PM
> >>To: [email-masked]
> >>Cc: Vach Kompella; Rick Wilder; Thomas Narten
> >>Subject: consensus stattement on vpsl solutions
> >>
> >>
> >>
> >>L2VPN Working group consensus statement on VPLS solutions.
> >>
> >>There has been a debate for some time about which and how many VPLS
> >>solutions should be progressed in the L2VPN WG. This started 
> >>back in the
> >>PPVPN and several suggestions
> >>on how to go forward have been offered.
> >>
> >>Vpls solutions submitted to the WG include:
> >>
> >>a. CE-based Virtual Private LAN
> >>    <draft-lee-ce-based-vpl-02.txt>
> >>
> >>b. GVPLS/LPE - Generalized VPLS Solution based on LPE Framework
> >>    <draft-radoaca-ppvpn-gvpls-02.txt>
> >>
> >>c. Virtual Private LAN Service
> >>    <draft-ietf-l2vpn-vpls-bgp-00.txt>
> >>
> >>d. Virtual Private LAN Services over MPLS
> >>    <draft-ietf-l2vpn-vpls-ldp-00.txt>
> >>
> >>The CE-based solution is not included in the working group charter.
> >>
> >>Of the remaining three proposals all three are within charter and
> >>they specify similar functionality. Opinions on how the WG should 
> >>proceed with these proposals, however, differ widely. There is a
> >>smaller group that says "Yes, lets do everything!", groups that
> >>are very much in favor one particular solutions, and a group that
> >>says "Lets take the two most popular and bring them to the market
> >>and let the market decide!"
> >>
> >>We have discussed how to define working group consensus and find
> >>a way forward, that is acceptable both for the working group and
> >>for the IETF as a standards organization.
> >>
> >>These are  our conclusions:
> >>
> >>
> >>The generalized (b) solution has only weak support as has been
> >>documented in the working group meetings and on the mailing list.
> >>We will not progress this solution further. However, there are
> >>interesting parts of the solution that, e.g. the discussion on
> >>scaling, so we recommend that the authors work with authors of
> >>the other solutions to capture these parts of (b) in other 
> solutions 
> >>documents or to publish this material as IDs in their own right.
> >>
> >>The bgp (c) and ldp (d) proposals have such support that under
> >>"normal circumstances" (i.e. no competing proposal) they would have
> >>been accepted as working group documents and rapidly progressed to
> >>Proposed Standard. Both are implemented and deployed.
> >>
> >>The functional difference between (c) and (d) is not large,
> >>however they have taken their starting point in two different
> >>networking scenarios. (c) is mostly directed towards networks
> >>based on routers that run a full suite of the Internet Protocols,
> >>while (d) takes as a starting point that it shall be possible to
> >>run also on equipment that do not have all those protocols available
> >>or deployable. We have therefore decided that there is 
> enough support
> >>in the WG for each of these two solutions and enough of a
> >>delta between them that the working group should progress 
> >>both solutions
> >>to proposed standard.
> >>
> >>
> >>In summary, the L2VPN working group co-chairs finds:
> >>
> >>- that "CE-based Virtual Private LAN" on one side has very little
> >>   support and on the other is not within charter, and will therfor
> >>   not be considered as an option for the working group vpls
> >>   solution.
> >>
> >>- that the "GVPLS/LPE - Generalized VPLS Solution based on LPE
> >>   Framework" has not enough support in the working group to be
> >>   a candidate for a working group solutions on the vpls
> >>
> >>- that there are interesting parts and discussion within this
> >>   draft that should be captured and either incorporated in the
> >>   working group vpls solution(s) or released as an ID in its own
> >>   right
> >>
> >>- that both "Virtual Private LAN Service (c) and "Virtual 
> Private LAN
> >>   Services over MPLS" (d) has enough support to be progressed
> >>   towards Proposed Standard in their own right
> >>
> >>- that there is a networking scenario delta that motivates the
> >>   differences between these two solutions
> >>
> >>
> >>Vach   Rick   Loa
> >>
> >>
> >>-- 
> >>Loa Andersson
> >>
> >>Mobile          +46 739 81 21 64
> >>Email           [email-masked]
> >>
> >>
> >>
> > 
> > 
> > 
> > 
> 
> -- 
> Loa Andersson
> 
> Mobile          +46 739 81 21 64
> Email           [email-masked]
> 
>

---

From: "Vach Kompella" <[email-masked]>
Date: Tue, 7 Oct 2003 01:21:08 -0700

Sasha,

Yes, Bernard Aboba and Juha went back and forth for a while, and yes,
the RADIUS issues were dealt with.  We now have a document which had
substantial support but no champion/editor.  What we are suggesting is
that the interested parties take up the draft and continue to work on
it.  Once the editor is found, we have no problem making it a working
group document.  It is not required that Juha be the editor (though we
would like to see him get the due credit).  He pretty much said that, as
be bowed out of ppvpn, that he was hoping someone else would carry the
ball.

-Vach 

> From: Sasha Vainshtein [mailto:[email-masked]] 
> Sent: Tuesday, October 07, 2003 1:12 AM
> To: 'Loa Andersson'
> Cc: Vach Kompella; Rick Wilder; Thomas Narten; 
> [email-masked]; [email-masked]'; Alik Shimelmits; Sharon Galtzur
> Subject: RE: consensus stattement on vpsl solutions
> 
> 
> Loa and all,
> [Sasha] I have probably missed something. I remember a 
> prolonged discussion (involving a RADIUS expert) wrt 
> specifics of using 
> RADIUS as an auto-discovery mechanism. AFAIK, the last update 
> to the RADIUS discovery draft has covered most (possibly) all 
> open issues in this area. 
> >
> > However, we (wg co-chairs) are quite happy that it is 
> brought back on 
> > the arena and would encourage the co-author to get together and 
> > suggest a new document editor amomng themselves, alt. ask us to 
> > appoint one if one can't be found among the co-authors.
> >
> [Sasha] AFAIK, the last two drafts have been authored by Juha 
> without any co-authors. Did I miss something?
> >
> > Once we have the editor, we would be happy to discuss next steps, 
> > including making it a wg doc.
> > 
> > /Loa
> > 
> > Sasha Vainshtein wrote:
> > 
> > > Loa and all,
> > >>solutions should be progressed in the L2VPN WG. This 
> started back in 
> > >>the PPVPN and several suggestions
> > >>smaller group that says "Yes, lets do everything!", 
> groups that are 
> > >>very much in favor one particular solutions, and a group 
> that says 
> > >>"Lets take the two most popular and bring them to the 
> market and let 
> > >>the market decide!"
> > >>
> > >>We have discussed how to define working group consensus 
> and find a 
> > >>way forward, that is acceptable both for the working 
> group and for 
> > >>the IETF as a standards organization.
> > >>
> > >>documented in the working group meetings and on the 
> mailing list. We 
> > >>will not progress this solution further. However, there are 
> > >>scaling, so we recommend that the authors work with 
> authors of the 
> > >>other solutions to capture these parts of (b) in other
> > solutions
> > >>The functional difference between (c) and (d) is not 
> large, however 
> > >>they have taken their starting point in two different networking 
> > >>scenarios. (c) is mostly directed towards networks based 
> on routers 
> > >>that run a full suite of the Internet Protocols, while 
> (d) takes as 
> > >>a starting point that it shall be possible to run also on 
> equipment 
> > >>that do not have all those protocols available or deployable. We 
> > >>have therefore decided that there is
> > enough support
> > >>in the WG for each of these two solutions and enough of a delta 
> > >>between them that the working group should progress both solutions
> > >>to proposed standard.
> > >>
> > >>

---

From: Juha Heinanen <[email-masked]>
Date: Tue, 7 Oct 2003 13:30:33 +0300

since i don't anymore have a sponsor for vpls related work, someone else
would need to be an editor for any radius based discovery draft.  if
something is kept from my drafts, i could be listed as a co-author.

-- juha

---

From: Loa Andersson <[email-masked]>
Date: Wed, 08 Oct 2003 20:55:22 +0200

Juha,

thanks - I'm pretty much sure that everything will be
kept from your work on this.

Sasha,

I don't know for sure but I thought that Juhas request for
someone else "to carry the torch" were made in public.

It seems I have made one mistake, the Heinanen-drafts are authored
by Juha only, so my call to the co-authors was futile. Might be
that single author-drafts are rare nowadays ;) and I just took
it for granted taht there were co-authors.

All,

the wg co-chairs will start the process of finding a new editor,
any volunteers please send an email to Vach, Rick and/or me.

/Loa

-- 
Loa Andersson

Mobile          +46 739 81 21 64
Email           [email-masked]