Subject: RE: Use of L2TP base VPLS

From: "Tissa Senevirathne" <[email-masked]>
Date: Wed, 01 Oct 2003 04:30:19 +0000

Sasha and all,

Flowing are the key diference I can see in draft-tsenevir when compared to 
draft-heinanen.

draft-tsenevir -

1. Treat VPLS  decoupled from the L2TP tunnel creations'

2.  Assumes VPLS instance can have multiple VLAN and provide oeprations to 
add/remove VLAN to the VPLS without creating new VPLS instances

3. Allow methods for originating PE to request, selectively, acknowledgments 
to a VPLS related operation of interest.

4. Use of Request-Response model allow originator to receive status of 
remote VPLS operations at the VPLS layer.

5. My personal opinion, architecture presented here in draft-tsenevir is 
modular and easy to integrate with L2TP.

Also, I personally think, it is better RADIUS discovery is independent fro 
signaling protocols. So it can be used with RSVP and like wise protocols.

>From: Sasha Vainshtein <[email-masked]>
>To: 'Tissa Senevirathne' <[email-masked]>
>CC: [email-masked]
>Subject: RE: Use of L2TP base VPLS
>Date: Mon, 29 Sep 2003 13:47:16 +0200
>
>Tissa and all,
>I have tried to compare your draft with
>draft-heinanen-radius-l2tp-vpls-00.txt.
>
>My first observation is that draft-heinanen support VPLS operation
>(subject to some auto-discovery mechanism which is out of scope
>of L2TP) without introducing any extensions to the basic L2TP level.
>IMO, the approach used in this draft can be used with any auto-discovery
>mechanism (direc tory-based, BGP-based etc.) with minimal changes.
>(Of course,I can be wrong here:-)
>
>Hence I would like to understand the rationale for far-reaching changes
>to L2TP proposed in  your draft.
>
>----------------------------------------------------------------------------
>--------
>With best regards,
>                           Sasha Vainshtein
>email:   [email-masked] <mailto:[email-masked]>
>phone:  +972-3-7659993 (office)
>             +972-8-9254948 (home)
>             +972-58-674833 (cellular)
>
>
> > -----Original Message-----
> > From: Tissa Senevirathne [mailto:[email-masked]]
> > Sent: Monday, September 29, 2003 4:34 AM
> > To: [email-masked]
> > Subject: Use of L2TP base VPLS
> >
> >
> >
> >
> > ID below present use of L2TP base signaling for VPLS. Work in
> > this ID is
> > presented as complimentary to other work currently in
> > progress at WG level.
> >
> > I appreciate your comments and feedback
> >
> > http://www.ietf.org/internet-drafts/draft-tsenevir-l2tp-vpls-00.txt
> >
> > Tissa
> >
> > _________________________________________________________________
> > Frustrated with dial-up? Get high-speed for as low as $29.95/month
> > (depending on the local service providers in your area).
> > https://broadband.msn.com
> >
> >

_________________________________________________________________
Get McAfee virus scanning and cleaning of incoming attachments.  Get Hotmail 
Extra Storage!   http://join.msn.com/?PAGE=features/es

---

From: Sasha Vainshtein <[email-masked]>
Date: Wed, 1 Oct 2003 10:34:14 +0200

Tissa and all,
Please see some answers inline.

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> Sent: Wednesday, October 01, 2003 6:30 AM
> To: Sasha Vainshtein
> Cc: [email-masked]
I do not ubderstand how this decupling can work. Please consider
the following scenario:
1. There are 3 PEs (PE1, PE2, and PE3)
2. There are 3 VPLS instances (V1, V2 and V3)
3. Initially, these instances are distributed between the PEs like
   following:
   a) V1 is instanciated in PE1 and PE2
   b) V2 and V3 are isnanciated both in PE2 and PE3
   c) Consequently, there is no need for an L2TP tunnel
      (control connection) between PE1 and PE3, since there
      is no VPLS traffic between them
4. When V2 is additionally instanciated in PE1, there is a
   need to establish an L2TP tunnel serving the VPLS application
   between PE1 and PE3 (and then to establish an appropriate
   L2TP session to carry the data).
   How can this be achieved if "tunnel creation is
   decoupled from the VPLS operation?"
> 
> 2.  Assumes VPLS instance can have multiple VLAN and provide 
> operations to 
I do not understand why this cannot be achieved in draft-heinanen. 
(IMO, adding a VLAN to a VPLS instance affects only the data plane
of the VPLS. Is this understanding incorect?)
>
> 3. Allow methods for originating PE to request, selectively, 
> acknowledgments to a VPLS related operation of interest.
> 
Sorry, I do not understand that. Can you give a specific example?
>
> 4. Use of Request-Response model allow originator to receive 
> status of remote VPLS operations at the VPLS layer.
>
Do you mean that you do not rely on the reliable transport
used by the auto-discovery and/or signaling protocols? 
> modular and easy to integrate with L2TP.
IMHO, the fact that this architecture requires additions
at the BASE L2TP level somewhat contradicts my notion of
"easy integration with L2TP". 
> signaling protocols. So it can be used with RSVP and like 
IMO, RADIUS discovery can be used with different signaling
protocols (e.g., with LDP). I do not understand the reference
to RSVP, since, to the best of my knowledge, it is not used for
the PW signaling today.

---

From: "Tissa Senevirathne" <[email-masked]>
Date: Thu, 02 Oct 2003 17:28:30 +0000

Sesha

  Even before we analyse the scenario you presented. Suppose we have a VPLS 
with PE1 and PE2 with a single VLAN spanning. Now a new PE3 is added to the 
domain.

How will that new PE3 will be added to the VPLS in draft-heinen or other 
proposals ?

So with draft-tsenevir ; adding a VLAN to the VPLS is exactly the same 
steps. draft-tsenevir is decoupling the tunnels. Hence, it will setup the 
tunnel, followed by adding VPLS instance and adding VLAN,

These steps can be extended equally when a PEx or VLANy is removed from the 
VPLS.

>To: "'Tissa Senevirathne'" <[email-masked]>
>CC: [email-masked]
>Date: Wed, 1 Oct 2003 10:34:14 +0200
>
>Tissa and all,

_________________________________________________________________
Instant message with integrated webcam using MSN Messenger 6.0. Try it now 
FREE!  http://msnmessenger-download.com

---

From: Sasha Vainshtein <[email-masked]>
Date: Thu, 2 Oct 2003 20:32:56 +0200

Tissa,
Please see inline.

With best regards,
                                   Sasha Vainshtein

> Sent: Thursday, October 02, 2003 7:29 PM
> To: Sasha Vainshtein
> Cc: [email-masked]
IMO, the question should be "how should the same VPLS instance be
added to PE3?" Drafts-heinanen (draft-heinanen-radius-pe-discovery-04.txt
and draft-heinanen-radius-l2tp-vpls-00.txt) provide an answer:
- PE3 registers itself as a member in the VPLS in question in the directory
  (RADIUS-based or other)
- PE3 learns all the other members of the VPLS in question from the
directory
- PE3 checks if L2TP control connections with any of the PEs that are
members
  in the VPLS in question exist; if not, it established them
- PE3 then establishes L2TP sessions to all the other PEs that participate
  in the VPLS in question; they use the directory info to verify that PE3
  is, indeed a member in the VPLS in question to authorize acceptance of
these
  sessions.
> steps. 
I still do not understand why signaling should be involved in adding a VLAN
to a VPLS. 
>
> draft-tsenevir is decoupling the tunnels. Hence, it 
> will setup the