Subject: RE: consensus stattement on vpsl solutions

From: Sasha Vainshtein <[email-masked]>
Date: Thu, 2 Oct 2003 18:11:44 +0200

Loa and all,
May I ask why the directory-based VPLS approach
(proposed by Juha Heinanen) has been left out of
even the initial list?

With best regards,
                                   Sasha Vainshtein
email:     [email-masked] <mailto:[email-masked]> 
tel:       +972-3-7659993 (office)
           +972-8-9254948 (res.)
           +972-58-674833 (cell.)

> -----Original Message-----
> From: Loa Andersson [mailto:[email-masked]]
> Sent: Thursday, October 02, 2003 5:09 PM
> To: [email-masked]
> Cc: Vach Kompella; Rick Wilder; Thomas Narten
> Subject: consensus stattement on vpsl solutions
> 
> 
> 
> L2VPN Working group consensus statement on VPLS solutions.
> 
> There has been a debate for some time about which and how many VPLS
> solutions should be progressed in the L2VPN WG. This started 
> back in the
> PPVPN and several suggestions
> on how to go forward have been offered.
> 
> Vpls solutions submitted to the WG include:
> 
> a. CE-based Virtual Private LAN
>     <draft-lee-ce-based-vpl-02.txt>
> 
> b. GVPLS/LPE - Generalized VPLS Solution based on LPE Framework
>     <draft-radoaca-ppvpn-gvpls-02.txt>
> 
> c. Virtual Private LAN Service
>     <draft-ietf-l2vpn-vpls-bgp-00.txt>
> 
> d. Virtual Private LAN Services over MPLS
>     <draft-ietf-l2vpn-vpls-ldp-00.txt>
> 
> The CE-based solution is not included in the working group charter.
> 
> Of the remaining three proposals all three are within charter and
> they specify similar functionality. Opinions on how the WG should 
> proceed with these proposals, however, differ widely. There is a
> smaller group that says "Yes, lets do everything!", groups that
> are very much in favor one particular solutions, and a group that
> says "Lets take the two most popular and bring them to the market
> and let the market decide!"
> 
> We have discussed how to define working group consensus and find
> a way forward, that is acceptable both for the working group and
> for the IETF as a standards organization.
> 
> These are  our conclusions:
> 
> 
> The generalized (b) solution has only weak support as has been
> documented in the working group meetings and on the mailing list.
> We will not progress this solution further. However, there are
> interesting parts of the solution that, e.g. the discussion on
> scaling, so we recommend that the authors work with authors of
> the other solutions to capture these parts of (b) in other solutions 
> documents or to publish this material as IDs in their own right.
> 
> The bgp (c) and ldp (d) proposals have such support that under
> "normal circumstances" (i.e. no competing proposal) they would have
> been accepted as working group documents and rapidly progressed to
> Proposed Standard. Both are implemented and deployed.
> 
> The functional difference between (c) and (d) is not large,
> however they have taken their starting point in two different
> networking scenarios. (c) is mostly directed towards networks
> based on routers that run a full suite of the Internet Protocols,
> while (d) takes as a starting point that it shall be possible to
> run also on equipment that do not have all those protocols available
> or deployable. We have therefore decided that there is enough support
> in the WG for each of these two solutions and enough of a
> delta between them that the working group should progress 
> both solutions
> to proposed standard.
> 
> 
> In summary, the L2VPN working group co-chairs finds:
> 
> - that "CE-based Virtual Private LAN" on one side has very little
>    support and on the other is not within charter, and will therfor
>    not be considered as an option for the working group vpls
>    solution.
> 
> - that the "GVPLS/LPE - Generalized VPLS Solution based on LPE
>    Framework" has not enough support in the working group to be
>    a candidate for a working group solutions on the vpls
> 
> - that there are interesting parts and discussion within this
>    draft that should be captured and either incorporated in the
>    working group vpls solution(s) or released as an ID in its own
>    right
> 
> - that both "Virtual Private LAN Service (c) and "Virtual Private LAN
>    Services over MPLS" (d) has enough support to be progressed
>    towards Proposed Standard in their own right
> 
> - that there is a networking scenario delta that motivates the
>    differences between these two solutions
> 
> 
> Vach   Rick   Loa
> 
> 
> -- 
> Loa Andersson
> 
> Mobile          +46 739 81 21 64
> Email           [email-masked]
> 
> 
>

---

From: Loa Andersson <[email-masked]>
Date: Tue, 07 Oct 2003 08:59:45 +0200

Sasha,

there were two reasons

- it is not really competing for the same solutions space
- it was our impression that the interest for this draft
   had faded, when no new editor were found

However, we (wg co-chairs) are quite happy that it is brought
back on the arena and would encourage the co-author to get together
and suggest a new document editor amomng themselves, alt. ask
us to appoint one if one can't be found among the co-authors.

Once we have the editor, we would be happy to discuss next
steps, including making it a wg doc.

/Loa

-- 
Loa Andersson

Mobile          +46 739 81 21 64
Email           [email-masked]