Subject: question about VPLS forwarding

From: "Keren Zik-Meirom" <[email-masked]>
Date: Tue, 9 Dec 2003 09:03:48 +0200

In the updated draft of Virtual Private LAN Services over MPLS  </internet-drafts/draft-ietf-l2vpn-vpls-ldp-01.txt> , In section 8.1. (VPLS Encapsulation actions) there is a description of how should a VPLS device handles an encapsulation received from the user, if it identifies the customer then it should be stripped.

My questions are as follows:
1. Whenever the VPLS device is working in qualified mode, the VID coming from the user side always identify the VPLS instance and therefore should be stripped according to the explanation in the draft.  
What will happen if the user wants to create a VPLS instance based on several VLANs?
If the tag will be stripped at ingress there will be no way of restoring it back at the egress? All the frames related to the same VPLS instance will always be added with the same tag at the egress.
Is that the way it should work? Does this draft intend to support such application where several VLANs are mapped to the same VPLS instance?

2. At the egress a packet may be tagged or untagged, 
To my understanding a VPLS instance must be configured with that property to tag or not a frame before transmitting it to the user, is that correct? 

3. In the same section it is written: 
   Contrariwise, if a customer packet arrives at a customer-facing port 
   with a VLAN tag that identifies a VLAN domain in the customer L2 
   network, then the tag is not modified or stripped, as it belongs 
   with the rest of the customer frame.
To my understanding a VPLS device working in unqualified mode, which receive a VLAN, tagged frame match this description.
Are their any other applications?

Thanks
Keren

--------------------------------------------------------------------------------------------------
Keren Zik Meirom
R&D Team Leader
RAD Data Communication
Tel:  03-7657025
Fax: 06-6440899
--------------------------------------------------------------------------------------------------

---

From: "Marc Lasserre" <[email-masked]>
Date: Tue, 9 Dec 2003 10:43:20 +0100

question about VPLS forwarding
  ----- Original Message ----- 
  From: Keren Zik-Meirom 
  To: [email-masked] 
  Sent: Tuesday, December 09, 2003 08:03
  Subject: question about VPLS forwarding 

Keren,

What dictates whether the VLAN-Id is stripped off depends upon this VLAN-Id being service delimiting (i.e. managed within the Service Provider space to identify) or being part of the original frame issued by the customer.

In qualified mode, the VLAN-Id is obviously part of the original frame and hence should NOT be stripped off.

In unqualified mode, all VLANs associated with a port are mapped to a single VPLS instance. A specific implementation might be able to treat multiple VLANs as being port of a "virtual" port and hence map these to a single VPLS instance. This is sort of a hybrid mode between qual. and unqual. learning which is not describe in the draft.

Note that this would require specific processing of STP BPDUs in such cases. STP BPDUs would have to be sent across the various VPLS instances. This could be dealt with in a similar way as described in the last paragraph of section 8.1.1.

No, see above.

Correct, it is a local decision of the egress PE to add (or translate) VLAN tags. This needs to be configured explicitly.

My answer above should clarify this point.

Thanks,

Marc

  Thanks

  Keren

  Keren Zik Meirom

  R&D Team Leader

  RAD Data Communication

  Tel:  03-7657025

  Fax: 06-6440899