Subject: L2 Framework: Bridge modules and Emulated LAN I/Fs

From: "Vishal Sharma" <[email-masked]>
Date: Wed, 7 Jan 2004 12:37:54 -0800

Folks,

I'm seeking some clarifications on the L2 Framework document,
and would be grateful for inputs.

i) On pp. 7/8, when discussing the VPLS reference model, 
the document specifies that each bridge module has a single
emulated LAN interface, but then goes on to say that "nor does it 
specify the number of VPLS instances which may attach to a bridge module 
over a single "Emulated LAN interface"."

How can this be possible?
Would one not need one bridge module per VPLS instance (just as
one needs one VPLS forwarder per VPLS instance), especially if
each bridge module has only a single emulated LAN interface?

ii) The document then goes to specify 3 models for VPLSs.
My question is what is the difference between Models 1 and 2?
How does a single bridge module support multiple VPLS instances
through a single emulated LAN interface? 
My understanding is that the only way to do so would be if each
instance was a VLAN on a common LAN, but then does this not
reduce to Model 1?

Thanks much for your inputs.

-Vishal

****************************************************************
Vishal Sharma, Ph.D.
Metanoia, Inc. (Critical Systems Thinking)
1600 Villa Street, Unit 352
Mountain View, CA 94041-1174
Phone: +1 408-530-8313. Cell: +1 408-394-6321 
Email: [email-masked]. http://www.metanoia-inc.com
****************************************************************

---

From: Eric Rosen <[email-masked]>
Date: Mon, 12 Jan 2004 14:03:20 -0500

> instance was a VLAN on a common LAN, but then does this not

In Model 1,  the VLANs do not have  separate PWs.  There's a set  of PWs for
the  Emulated LAN,  and 802.1Q  tagging  is used  to indicate  which of  the
packets on those PWs belong to which VLANs. 

In Model 2, each VLAN has its own set of PWs.

---

From: "Vishal Sharma" <[email-masked]>
Date: Mon, 12 Jan 2004 19:36:54 -0800

Eric,

Thanks very much for your clarification, that clears my doubt.
Perhaps it would be useful to add these 2 explanatory phrases
in the next rev. of the document, they make things much clearer.

Also, one follow-up question: so in both cases there is
still only a single _VPLS_ instance, right? 
(Except that in model
1 the VLAN tags distinguish packets from different VLANs, and
in model 2, the packets from different VLANs ride on separate
sets of PWs, each of which runs between the PEs serving the 
VPLS in question).

Thanks,
-Vishal

> -----Original Message-----
> From: Eric Rosen [mailto:[email-masked]]
> Sent: Monday, January 12, 2004 11:03 AM
> To: Vishal Sharma
> Cc: L2PPVPN; Loa Andersson
> Subject: Re: L2 Framework: Bridge modules and Emulated LAN I/Fs 
> 
> 
>

---

From: Eric Rosen <[email-masked]>
Date: Tue, 13 Jan 2004 10:23:20 -0500

Vishal> Also, one follow-up question: so in both cases there is
Vishal> still only a single _VPLS_ instance, right? 
Vishal> (Except that in model
Vishal> 1 the VLAN tags distinguish packets from different VLANs, and
Vishal> in model 2, the packets from different VLANs ride on separate
Vishal> sets of PWs, each of which runs between the PEs serving the 
Vishal> VPLS in question). 

In my use  of the term "VPLS instance",  if there is a separate  set of PWs,
there is a separate "VPLS instance".  I'll try to make this clearer.

---

From: "Vishal Sharma" <[email-masked]>
Date: Tue, 13 Jan 2004 12:56:26 -0800

Eric,

Thanks for the clarification, but I think there's still
room for some confusion in the document, as I explain below.

> From: [email-masked] [mailto:[email-masked]]On Behalf Of
> Eric Rosen
> Sent: Tuesday, January 13, 2004 7:23 AM
> To: Vishal Sharma

i) The framework specifies that there is one VPLS forwarder per VPLS
instance per PE. So, in this case, is it also implied that there
are multiple VPLS forwarders, one per set of PWs for
each VLAN (or, in your terms, one per "VPLS instance")?

ii) Also, even with a separate set of PWS for each VLAN, isn't one
VPLS forwarder sufficient for the job?
And, if it is,  then it seems that, by the specification above,
such a VPLS should also be counted as having only one VPLS
instance.

iii) And, the framework document then states:
"Each VPLS instance is thought of as a VLAN (in effect, an "Emulated VLAN"),
and the set of VPLS instances are treated as a set
of VLANs on a common LAN."

Why "thought of"? Isn't it simply then that each VPLS instance _is_
a VLAN (or rather each VLAN is a VPLS (instance)). But if that
is so, what is the entity here that corresponds to the "common LAN?"

So far, I had assumed that the "common LAN" _is_ the VPLS, but this
does not appear to be the case here. Rather, it appears that
it is the collection of
VPLS's (one per VLAN) that constitutes the "common LAN" here.
Is this what is implied?

Thanks,
-Vishal