Subject: RE: Comments on draft-ietf-l2vpn-l2tp-radius-vpls-00.txt

From: [email-masked]
Date: Thu, 22 Jan 2004 13:15:23 -0000

I am very supportive of using RADIUS for discovery and do not have any issues with providers that want to use L2TP for VPLS, but IMO this specific draft is not needed.

It is a combination of extracts from the RADIUS discovery draft, extracts from the L2TP drafts, and some text describing VPLS services (which is equivalent to the text in the BGP and LDP VPLS drafts describing the same thing). I cannot find anything new/different other than stating what the AVP attributes must be.

I think that the RADIUS extracts of this draft should be removed and it should be developed to create a L2TP equivalent of the BGP and LDP VPLS drafts. This should help address Sasha's concerns below, and RADIUS discovery could be mentioned as a possible discovery mechanism, along with BGP and DNS (as is done in the BGP and LDP VPLS drafts).

From a functional perspective the RADIUS and L2TP mechanisms are completely separate. The RADIUS discovery mechanism is a function for which the output is a list of IP addresses of PEs belonging to the same VPN. If the output is properly defined (which I believe it already is) there is no need to define new drafts for each signalling protocol that might use RADIUS discovery. If there is a need for this draft then why don't we also need -

'The-RADIUS-discovery-with-LDP-signalling-VPLS-draft"

'The-RADIUS-discovery-with-BGP-signalling-VPLS-draft"

'The-BGP-discovery-with-LDP-signalling-VPLS-draft"

'The-BGP-discovery-with-L2TP-signalling-VPLS-draft"

etc.

Regards,

Richard

-----Original Message----- 
From: [email-masked] on behalf of Sasha Vainshtein 
Sent: Thu 22/01/2004 06:19 
To: Mark Townsley (E-mail); [email-masked]'; [email-masked]' 
Cc: L2VPN (E-mail); Elena Vinkler; Sharon Galtzur; Gonen Zilber; Alik Shimelmits 
Subject: Comments on draft-ietf-l2vpn-l2tp-radius-vpls-00.txt

	Juha, Mark, Stephen and all,
	I'd like to raise a couple of issues with
	draft-ietf-l2vpn-l2tp-radius-vpls-00.txt.
	These issues both stem from comparison with
	draft-ietf-ppvpn-vpls-ldp-01.txt but are, IMO,
	orthogonal to "MPLS vs. IP" or "LDP vs. L2TP" plane(s).
	
	1. draft-ietf-ppvpn-vpls-ldp-01.txt explicitly defines that,
	in order to achieve loop-free operation without running SPT
	across the VPLS, mesh of PE-to-PE Ethermet PWs *and*
	split-horizon forwarding (where frames received from one
	of the PE-to-PE PWs will never be forwarded to another such PW).
	I did not find any reference to split-horizon forwarding in
	draft-ietf-l2vpn-l2tp-radius-vpls-00.txt. My understanding is
	that this is simply an omission. Is this correct? If yes,
	I would suggest at least explicitly stating it in the draft' otherwise
	a detailed explanation is clearly required.
	
	2. draft-ietf-ppvpn-vpls-ldp-01.txt defines, in addition to
	the "full mesh" VPLS, a hierarchical VPLS formed by two types of
	devices:
	- PE-rs (which is very much equivalent to the "full mesh" PE)
	- MTU-s (which is only connected to one or, possibly two PE-rs
	  in "hub-and-spokes" topology).
	My first impression is that such a model is equally applicable
	to RADIUS/L2TPv3-based VPLS, but the procedures need to be adapted
	accordingly.
	
	Hopefully these comments will be useful.
	
	With best regards,
	                                   Sasha Vainshtein
	email:     [email-masked]
	tel:       +972-3-7659993 (office)
	           +972-8-9254948 (res.)
	           +972-58-674833 (cell.)

---

From: "W. Mark Townsley" <[email-masked]>
Date: Thu, 29 Jan 2004 15:41:14 +0100

Hello Richard. Please see responses inline.

[email-masked] wrote:
> I am very supportive of using RADIUS for discovery and do not have any issues
> with providers that want to use L2TP for VPLS, but IMO this specific draft is
> not needed.
> 
> 
> 
> It is a combination of extracts from the RADIUS discovery draft, extracts
> from the L2TP drafts, and some text describing VPLS services (which is
> equivalent to the text in the BGP and LDP VPLS drafts describing the same
> thing). I cannot find anything new/different other than stating what the AVP
> attributes must be.
> I think that the RADIUS extracts of this draft should be removed and it
> should be developed to create a L2TP equivalent of the BGP and LDP VPLS
> drafts. This should help address Sasha's concerns below, and RADIUS discovery
> could be mentioned as a possible discovery mechanism, along with BGP and DNS
> (as is done in the BGP and LDP VPLS drafts).

draft-heinanen-radius-pe-discovery-04.txt already focuses on RADIUS discovery in 
a generic manner. If I understand you, you would like to see an L2TP draft which 
does what the draft-ietf-l2vpn-l2tp-radius-vpls-00.txt draft does for RADIUS, 
but also points to BGP and LDP as well.

> From a functional perspective the RADIUS and L2TP mechanisms are completely
> separate. 

Yes, I think that in draft-ietf-l2vpn-l2tp-radius-vpls-00.txt Juha was just 
showing how to apply the RADIUS discovery in an L2TP environment. I think that 
the text that applies to this is reasonable (perhaps it could be whittled down a 
bit as you suggest, but by some standards its a fairly terse document at barely 
6 pages text minus headers).

 > The RADIUS discovery mechanism is a function for which the output
> is a list of IP addresses of PEs belonging to the same VPN. If the output is
> properly defined (which I believe it already is) there is no need to define
> new drafts for each signalling protocol that might use RADIUS discovery. If
> there is a need for this draft then why don't we also need -
> 
> 
> 

So, I think you are suggesting that we have a generic VPLS L2TP draft, and, 
perhaps, a RADIUS, BGP and LDP section within simply as examples of how you 
might use various autodiscovery mechanisms with L2TP.

- Mark