Subject: IPLS - IP and MAC TLV IANA code information

From: "Shah, Himanshu" <[email-masked]>
Date: Mon, 8 Aug 2005 11:02:49 -0400

In the last week IETF meeting, I proposed using 0x096C type for IP+MAC
TLV that is dispatched in Label Mapping message and LDP Notification in
optional parameter 
field when establishing IP PW. This TLV contained IP and MAC address of
the local
CE.
 
Subsequent to the meeting, Loa Anderson and Vach recommended using
Address List TLV defined in LDP for this purpose. There is no change in
proposed IANA assignment for 
Status Code - 0x0000002A.
 
Following is the proposal for IP and MAC TLV as address list tlvs:
 
Reusing of Address List TLV for IPLS:
==================================================
 
   The Address List TLV is defined in RFC 3036. It is typically used
   in Address and Address Withdraw messages. The IPLS draft
   would use the same TLV when signaling IP PW. The two TLVs are
included in
   optional parameter field of the  Label Mapping Message; one
containing
   IP address of the local CE and other containing MAC address of the
local CE.
   The IPLS draft also uses the same TLVs in LDP's Notification message
to 
   signal the update in these values.
 
   Encoding of the IP Address TLV is:
 
    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |0|0| Address List (0x0101)     |      Length                   |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |     Address Family            |     CE's IP Address           |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |       CE's IP Address         |                               |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
 
   Length
      When Address Family is IPV4, Length is equal to 6 bytes;
      2 bytes for address family and 4 bytes of IP address.
 
   Address Family
      Two octet quantity containing a value from ADDRESS FAMILY NUMBERS
      in [RFC1700] that encodes the addresses contained in the Addresses
      field.
 
   CE's IP Address
      IP address of CE from Address Family specified.  The
      encoding of the individual addresse depends on the Address Family.
 
      The following address encodings are defined by this version of the
      protocol:
 
         Address Family      Address Encoding
 
         IPv4 (1)             4 octet full IPv4 address
         IPv6 (2)             16 octet full IPv6 address
 
Encoding of the MAC Address TLV is:
 
    0                   1                   2                   3
    0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1 2 3 4 5 6 7 8 9 0 1
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |0|0| Address List (0x0101)     |      Length                   |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
   |     Address Family            |     CE's MAC address          |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+                               +
   |                                                               |
   +-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+-+
 
   Length
      The length field is set to value 8 (2 for address family, 6 for 
      MAC address)
 
   Address Family
      Two octet quantity containing a value from ADDRESS FAMILY NUMBERS
      in [RFC1700] that encodes the addresses contained in the Addresses
      field.
 
   CE's IP Address
      IP address of CE from Address Family specified.  The
      encoding of the individual addresse depends on the Address Family.
 
      The following address encodings are defined by this version of the
      protocol:
 
         Address Family      Address Encoding
 
         MAC (6)             6 octet full Ethernet MAC address
 
Please review and comment.
 
/himanshu

---

From: "Shah, Himanshu" <[email-masked]>
Date: Mon, 8 Aug 2005 14:10:28 -0400

I have made a cut-and-paste error near the last paragraph.
Please read CE's MAC address instead of CE's IP address in 
MAC address TLV description below.
-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Shah, Himanshu
Sent: Monday, August 08, 2005 11:03 AM
To: [email-masked]
Subject: IPLS - IP and MAC TLV IANA code information

In the last week IETF meeting, I proposed using 0x096C type for IP+MAC TLV that is dispatched in Label Mapping message and LDP Notification in optional parameter 
field when establishing IP PW. This TLV contained IP and MAC address of the local
CE.
 
Subsequent to the meeting, Loa Anderson and Vach recommended using Address List TLV defined in LDP for this purpose. There is no change in proposed IANA assignment for 
Status Code - 0x0000002A.

 
   The Address List TLV is defined in RFC 3036. It is typically used
   in Address and Address Withdraw messages. The IPLS draft
   would use the same TLV when signaling IP PW. The two TLVs are included in
   optional parameter field of the  Label Mapping Message; one containing
   IP address of the local CE and other containing MAC address of the local CE.
   The IPLS draft also uses the same TLVs in LDP's Notification message to 
   signal the update in these values.

    0                   1                   2                   3
 
   Length
 
   Address Family
 
   CE's IP Address

 

    0                   1                   2                   3
 
   Length
 
   Address Family
 
   CE's IP Address

 

/himanshu