Subject: RE: draft-raggarwa-l2vpn-vpls-mcast-01.txt

From: "McCoy, Chris" <[email-masked]>
Date: Thu, 20 Oct 2005 18:11:51 -0700

Hello Yuji,

  I have a question about the draft.  Since this draft covers VPLS, which is
a mostly layer-2 centric technology, would it make sense to share
information between PEs referring to group MAC addresses and sources?  In
other words, still PIM/IGMP snoop, but share information based on Layer 2
addresses?  That way it can be made more generic to support future
protocols/IPv6?

Thanks,
Chris M.

-----Original Message-----
From: Yuji KAMITE [mailto:[email-masked]] 
Sent: Thursday, October 20, 2005 8:51 PM
To: [email-masked]
Cc: 'Shane Amante'
Subject: RE: draft-raggarwa-l2vpn-vpls-mcast-01.txt

I support it  (but, I'm a co-author)
-Yuji

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> On Behalf Of Shane Amante
> Sent: Wednesday, October 19, 2005 4:37 AM
> To: [email-masked]
> Subject: draft-raggarwa-l2vpn-vpls-mcast-01.txt
> 
> Folks,
> 
> Please voice your opinion and comment on whether this draft
> should become a L2VPN WG document.  There has been good 
> support for it becoming a WG document at the last IETF.  This 
> draft is important because it defines the procedures for 
> supporting Multicast Trees over VPLS.
> 
> Please let us know your opinion and comments by Tuesday, 10/25.
> 
> Vach & Shane
>

---

From: "Yuji KAMITE" <[email-masked]>
Date: Fri, 21 Oct 2005 13:38:41 +0900

Hi Chris, 

>   I have a question about the draft.  Since this draft covers 
> VPLS, which is a mostly layer-2 centric technology, would it 
> make sense to share information between PEs referring to 
> group MAC addresses and sources?  In other words, still 
> PIM/IGMP snoop, but share information based on Layer 2 
> addresses?  That way it can be made more generic to support 
> future protocols/IPv6?

IMHO one concern of that way is, it cannot always be best in terms of
preciseness of the membership in view of applications.

- MAC-only approach cannot always describe IP-based application's membership
  correctly  (i.e., ambiguity of mapping IP dst multicast address into MAC dst address)
- MAC-only approach cannot differentiate (S_1, G) and (S_2, G) tree 
   if other routers are intervening inside customer sites. 
  (i.e., source MAC would be overlapped).

These points would reside in IPv6 case too.

- Yuji

> On Behalf Of McCoy, Chris
> Sent: Friday, October 21, 2005 10:12 AM
> To: 'Yuji KAMITE'
> Cc: [email-masked]'
>   I have a question about the draft.  Since this draft covers 
> VPLS, which is a mostly layer-2 centric technology, would it 
> make sense to share information between PEs referring to 
> group MAC addresses and sources?  In other words, still 
> PIM/IGMP snoop, but share information based on Layer 2 
> addresses?  That way it can be made more generic to support 
> future protocols/IPv6?
> 
> Thanks,
> Chris M.
>