Subject: Re: [L2VPN] comments on VPLS MIB

From: [email-masked]
Date: Tue, 25 Jul 2006 14:28:08 -0400

Tom,

In response to your request for specific objects, please see following
marked "new".

VplsConfigEntry ::=
  SEQUENCE {
    vplsIndex                        Unsigned32,
   -- existing stuff --
    vplsMeshPeerCount                Counter, -- new
    vplsSpokePeerCount               Counter, -- new
    vplsServiceType                  INTEGER, -- new
    vplsMtu                          Unsigned32, -- new
    vplsRowStatus                    RowStatus
    }

vplsMeshPeerCount OBJECT-TYPE
    SYNTAX          Counter
    MAX-ACCESS      read-only
    STATUS          current
    DESCRIPTION
         "This object specifies the number of mesh peers
         present in this vpls instance."
    ::= { vplsConfigEntry 12 }

vplsSpokePeerCount OBJECT-TYPE
    SYNTAX          Counter
    MAX-ACCESS      read-only
    STATUS          current
    DESCRIPTION
         "This object specifies the number of spoke peers
         present in this vpls instance."
    ::= { vplsConfigEntry 13 }

vplsServiceType OBJECT-TYPE
    SYNTAX          INTEGER {
                             vlan        (1),
                             ethernet    (2)
                     }
    MAX-ACCESS      read-only
    STATUS          current
    DESCRIPTION
         "This object specifies the type of service being
         emulated by this vpls instance."
    ::= { vplsConfigEntry 14 }

vplsMtu OBJECT-TYPE
    SYNTAX          Unsigned32 (64..1518)
    MAX-ACCESS      read-create
    STATUS          current
    DESCRIPTION
         "This object specifies the MTU of this vpls instance."
    DEFVAL          { 1518 }
    ::= { vplsConfigEntry 15 }

VplsPwBindEntry ::=
    SEQUENCE {
        vplsPwIndex                     PwIndexType,
        -- existing stuff --
        vplsPwType                      INTEGER, -- new
        vplsPwBindRowStatus             RowStatus
    }

vplsPwType   OBJECT-TYPE
     SYNTAX          INTEGER {
                             mesh  (1),
                             spoke (2)
                     }
     MAX-ACCESS      read-create
     STATUS          current
     DESCRIPTION
          "The value of this object indicates
           whether the Pseudo Wire is of type mesh or spoke."
     DEFVAL       { 0 }
    ::= { vplsPwBindEntry 2 }

Regards,
Anil

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Tue, 25 Jul 2006 14:24:04 -0400

>     vplsMtu                          Unsigned32, -- new

	This is the configuration section. Why would we
put status-related objects in this section?

>     ::= { vplsPwBindEntry 2 }

	This was originally in one of the MIBs we merged in, but
was removed because it was felt that this was more of a
convenience than anything else.  Also, how do you describe
a partial-mesh?

	--Tom