Subject: Fwd: [L2VPN] comments on VPLS MIB

From: Shane Amante <[email-masked]>
Date: Sat, 8 Jul 2006 08:12:27 -0600

Forwarding to the list on behalf of Anil.

-shane

Begin forwarded message:
> From: [email-masked]
> Date: July 7, 2006 10:52:55 AM MDT
> To: Shane Amante <[email-masked]>, [email-masked]
> Subject: Fwd: [L2VPN] comments on VPLS MIB
>
> Shane, Tom,
>
> For some reason, my mail bounces off the l2vpn list.
>
> Please forward it if you could, for consideration at the meeting.
>
> Regards,
> Anil
>
> ----- Forwarded by Anil Rijhsinghani/AcctonUS on 07/07/2006 12:39  
> PM -----
>
>                     Anil
>                     Rijhsinghani         To:     [email-masked]
>                                          cc:     [email-masked]
>                     07/05/2006           Subject:     comments on  
> VPLS MIB(Document link: Anil Rijhsinghani)
>                     01:27 PM
>
>
>
>
>
> Tom,
>
> I was preparing to send in a contribution for VPLS MIB, before I  
> saw yours
> on the agenda.
>
> Some initial comments/questions on the MIB:
>
> - table of contents either not updated, or some piece of the MIB  
> missing?
> (page numbers)
> - I assume this only convers the LDP method; if so perhaps mention in
> abstract
> - need an optional static table to manually configure VPLS peers
> - what forms of auto-discovery in vplsPwBindBindType, can these be  
> listed
> as types?
> - vplsMacLearning: why is this needed? (corresponding function not
> described in VPLS document)
> - vplsDiscardUnknownDest: why needed? (ditto)
> - vplMacAging: why needed? (ditto)
> - object needed for VPLS MTU
> - object needed for information on HVPLS Spoke connection (eg,  
> correlation
> to Q-in-Q)
> - object to correlate the interface on which a VPLS instance is  
> running
> would be useful, which in turn ties into MAC address based on ifTable
> - up-front text to describe relationship to ifTable (in addition to  
> Bridge
> MIB and PW MIB)
> - traps for high-water and low-mater mark: suggest removing these  
> (there
> isn't such a thing in Bridge MIB either)
>
> Regards,
> Anil
>
>
>
>
>
>                     Shane Amante
>                     <shane@castlep       To:     [email-masked]
>                     oint.net>            cc:
>                                          Subject:     L2VPN Agenda  
> for IETF 66
>                     07/05/2006
>                     11:17 AM
>
>
>
>
>
>
> The agenda for the upcoming meeting in Montreal is located here, (and
> in-line below):
> http://www3.ietf.org/proceedings/06jul/agenda/l2vpn.txt
>
> For those who are presenting at the upcoming meeting, please e-mail  
> your
> slides to Vach & I by no later than noon EST on July 12.
>
> Thanks,
>
> -shane & Vach
>
>
> ---cut here---
>
> IETF 66: Layer 2 Virtual Private Network WG (l2vpn) Agenda
>
> Thursday, July 13, 2006, 1510-1610
> ==================================
>
> Chairs: Vach Kompella
>          Shane Amante
>
> 1) Administrivia
>     - Mailing list: http://www.ietf.org/mail-archive/web/l2vpn/ 
> index.html
>     - Scribe?
>     - Blue Sheets
>     - Agenda Bashing
>
> 2) WG Status and Update
>     Chairs
>     10 mins
>
> 3) Virtual Private Lan Services (VPLS) Management Information Base
> http://www.ietf.org/internet-drafts/draft-nadeau-l2vpn-vpls-mib-00.txt
>     Tom Nadeau ([email-masked])
>     10 mins
>
> 4) PIM Snooping over VPLS
> http://www.ietf.org/internet-drafts/draft-hemige-serbest-l2vpn-vpls- 
> pim-snooping-01.txt
>
>     Venu Hemige ([email-masked])
>     10 mins
>
> 5) Meeting Closes
>
>
>
>
>
>

---

From: Jayanta Tewari <[email-masked]>
Date: Sat, 8 Jul 2006 23:06:45 +0530

Should not there be objects to distinguish between qualified and unqualified
learning methods for Virtual switch instances ?

Refering to 4.2,will it be possible to keep label information through BRIDGE
MIB with respect to learning processes (as it might map to interfaces or
label.Right ?)What about a table related to Mac learning in this MIB itself
?

Pls. see other comments below starting with JT.

rgds,
--Jayanta

-----Original Message-----
From: Shane Amante [mailto:[email-masked]]
Sent: Saturday, July 08, 2006 7:42 PM
To: [email-masked]
Subject: Fwd: [L2VPN] comments on VPLS MIB

-shane

> - vplMacAging: why needed? (ditto)

JT:I guess these correspond to sections 4.2,6.2,9.1 etc.
draft-ietf-l2vpn-vpls-ldp-08.txt.

> - object needed for information on HVPLS Spoke connection (eg,
JT:Is there anything special  needed for HVPLS architecure as the spokes
will follow normal L2 technoligies and will keep the related information in
already developed MIBs for them ?
>                     <shane@castlep       To:     [email-masked]

The information contained in this electronic message and any attachments to this message are intended for the exclusive use of the addressee(s)and may contain confidential or privileged information. If you are not the intended recipient, please notify the sender or [email-masked]

---

From: [email-masked]
Date: Sun, 9 Jul 2006 09:31:04 +0800

It may be more optimized to merge VPWS and VPLS to one MIB.

Pls. see my comments below starting with Jin.lizhong.

Jayanta Tewari <[email-masked]>

2006-07-09 01:36
 
        收件人：        "'Shane Amante'" <[email-masked]>, 
<[email-masked]>
        抄送： 
        主题：  RE: [L2VPN] comments on VPLS MIB

Should not there be objects to distinguish between qualified and 
unqualified
learning methods for Virtual switch instances ?

Refering to 4.2,will it be possible to keep label information through 
BRIDGE
MIB with respect to learning processes (as it might map to interfaces or
label.Right ?)What about a table related to Mac learning in this MIB 
itself
?

Jin.lizhong: Mac learning parameters can be put in the BRIDGE MIB, for 
bridge
module performs the Mac learning capabilities. While label information can 
be
put in the pwTable described in [PW-MIB]. Maybe BRIDGE MIB can be changed 
to 
a bridge table in [VPLS-MIB], and is not necessary to be a seperate MIB.

rgds,
--Jayanta

-----Original Message-----
From: Shane Amante [mailto:[email-masked]]
Sent: Saturday, July 08, 2006 7:42 PM
To: [email-masked]
Subject: Fwd: [L2VPN] comments on VPLS MIB

-shane

JT:Is there anything special  needed for HVPLS architecure as the spokes
will follow normal L2 technoligies and will keep the related information 
in
already developed MIBs for them ?

Jin.lizhong:It is necessary to add SPOKE property to the MIB. There are 
some
other properties that special for VPLS and can not be described in 
[PW-MIB]. For
instance, pw backup information, pw STP information, pw SNOOPING 
information, etc.
So in [VPLS-MIB], additional pw information should be added, and a 
l2vpnPwTable
may be needed.

>                     <shane@castlep       To:     [email-masked]

The information contained in this electronic message and any attachments 
to this message are intended for the exclusive use of the addressee(s)and 
may contain confidential or privileged information. If you are not the 
intended recipient, please notify the sender or 
[email-masked]

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is 
solely property of the sender's organization. This mail communication is 
confidential. Recipients named above are obligated to maintain secrecy and 
are not permitted to disclose the contents of this communication to 
others.
This email and any files transmitted with it are confidential and intended 
solely for the use of the individual or entity to whom they are addressed. 
If you have received this email in error please notify the originator of 
the message. Any views expressed in this message are those of the 
individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam 
system.

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: "Rohit Mediratta" <[email-masked]>
Date: Tue, 11 Jul 2006 17:27:26 -0700

Hi,
 Please find my comments inline starting with "Rohit:"

Regards,
Rohit

> - need an optional static table to manually configure VPLS peers
Rohit: Why would this configuration not be in the PWE3 MIB ?

> - vplMacAging: why needed? (ditto)
Rohit: I believe the above should be included as pointed out in the previous
email.

> (there isn't such a thing in Bridge MIB either)
Rohit: This is a useful notification feature from a provider perspective.
Does anyone disagree ?

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 13 Jul 2006 09:19:19 -0400

> Jayanta Tewari <[email-masked]>

	Why do we need to add this?  There are already MAC tables in the native
Ethernet MIBs.  I would prefer to keep the l2vpn MIB as complicated  
as possible,
and no more.

> Jin.lizhong: Mac learning parameters can be put in the BRIDGE MIB,  
> for bridge
> module performs the Mac learning capabilities. While label  
> information can be
> put in the pwTable described in [PW-MIB].

	This should actually go in the PW-MPLS-MIIB (if anywhere).
L2TPv3 doesn't use labels.

> Maybe BRIDGE MIB can be changed to

	I don't understand what you are asking for here. Are you saying that
we add a bridge table into the l2vpn mib?

> > - need an optional static table to manually configure VPLS peers

	Please be specific about what you are proposing (i.e.: post SMI code  
please).

> > - what forms of auto-discovery in vplsPwBindBindType, can these be

	The assumption that is a box will do more than one type.
I don't know of any boxes that support two methods simultaneously.
OTOH, I suppose it is informational to list the specific type here.

> > - vplMacAging: why needed? (ditto)

	These were in one or both (can't remember) of the early proposed
l2vpn mibs that I looked at.   I am ok with removing these.

> > - object needed for VPLS MTU

	OK.

> > correlation to Q-in-Q)

	Can you be more specific on what this is?

	--Tom

> Jin.lizhong:It is necessary to add SPOKE property to the MIB. There  
> are some
> The information contained in this electronic message and any  
> attachments to this message are intended for the exclusive use of  
> the addressee(s)and may contain confidential or privileged  
> information. If you are not the intended recipient, please notify  
> the sender or [email-masked]
>
>
>
> ZTE Information Security Notice: The information contained in this  
> mail is solely property of the sender's organization. This mail  
> communication is confidential. Recipients named above are obligated  
> to maintain secrecy and are not permitted to disclose the contents  
> of this communication to others.
> This email and any files transmitted with it are confidential and  
> intended solely for the use of the individual or entity to whom  
> they are addressed. If you have received this email in error please  
> notify the originator of the message. Any views expressed in this  
> message are those of the individual sender.
> ZTE Information Security Notice: The information contained in this  
> mail is solely property of the sender's organization. This mail  
> communication is confidential. Recipients named above are obligated  
> to maintain secrecy and are not permitted to disclose the contents  
> of this communication to others.
>
> This email and any files transmitted with it are confidential and  
> intended solely for the use of the individual or entity to whom  
> they are addressed. If you have received this email in error please  
> notify the originator of the message. Any views expressed in this  
> message are those of the individual sender.
>