Subject: draft-kompella-l2vpn-l2vpn-02

From: Shane Amante <[email-masked]>
Date: Wed, 21 Mar 2007 17:27:10 +0100

I was approached by several people outside the hallway just after the 
L2VPN WG meeting expressing confusion over a poll in the room about 
making this draft a WG document, in particular over the 'Intended 
Status' of this WG draft, e.g.: Informational or Standards Track. 
Unfortunately, we were abruptly cut off after running over our time at 
the end of the meeting, in order so they could convert the room over for 
the IETF plenary session, so I didn't have time to clarify it.  So, my 
apologies for the confusion.

Let me now ask a hopefully more precise question here: How many people 
are in favor of making the aforementioned draft a WG draft *if* the 
'Intended Status' is Standards Track?

Thanks,

-shane

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 21 Mar 2007 09:46:04 -0700

Shane,

> 'Intended Status' is Standards Track?

Yes.

Yakov.

---

From: Rahul Aggarwal <[email-masked]>
Date: Wed, 21 Mar 2007 09:49:53 -0700 (PDT)

Hi Shane,

Yes.

rahul

---

From: "Ananth Nagarajan" <[email-masked]>
Date: Thu, 22 Mar 2007 00:55:51 +0800

> 
> I was approached by several people outside the hallway just 
> after the L2VPN WG meeting expressing confusion over a poll 
> in the room about making this draft a WG document, in 
> particular over the 'Intended Status' of this WG draft, e.g.: 
> Informational or Standards Track. 
> Unfortunately, we were abruptly cut off after running over 
> our time at the end of the meeting, in order so they could 
> convert the room over for the IETF plenary session, so I 
> didn't have time to clarify it.  So, my apologies for the confusion.
> 
> Let me now ask a hopefully more precise question here: How 
> many people are in favor of making the aforementioned draft a 
> WG draft *if* the 'Intended Status' is Standards Track?
> 

Yes

Ananth

---

From: "Guy Davies" <[email-masked]>
Date: Wed, 21 Mar 2007 17:13:37 +0000

Yes

Guy

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 21 Mar 2007 14:14:40 -0400

...in favor

> -----Original Message-----
> From: Shane Amante [mailto:[email-masked]]
> Sent: Wednesday, March 21, 2007 12:27 PM
> To: [email-masked]
> Subject: draft-kompella-l2vpn-l2vpn-02
> 
> 
> our time at 
> many people

---

From: Kireeti Kompella <[email-masked]>
Date: Wed, 21 Mar 2007 15:54:10 -0700 (PDT)

On Wed, 21 Mar 2007, Shane Amante wrote:

> I was approached by several people outside the hallway just after the L2VPN 
> WG meeting expressing confusion over a poll in the room about making this 
> draft a WG document, in particular over the 'Intended Status' of this WG 
> draft, e.g.: Informational or Standards Track. Unfortunately, we were 
> abruptly cut off after running over our time at the end of the meeting, in 
> order so they could convert the room over for the IETF plenary session, so I 

My fault as well, for not being clear (it being obvious to me).  This 
draft is intended as Proposed Standard.

Here's the situation: this draft specifies small but NORMATIVE 
extensions to RFC 4761 (which is PS); it has several (>= 2) 
independent implementations, and it is reasonably widely deployed.

Wouldn't an impartial view recommend Proposed Standard?

Kireeti.
-------

---

From: Ina Minei <[email-masked]>
Date: Wed, 21 Mar 2007 16:07:20 -0700 (PDT)

> Let me now ask a hopefully more precise question here: How many people are in 
> favor of making the aforementioned draft a WG draft *if* the 'Intended 
> Status' is Standards Track?
>

 	In favor.

 		Ina

---

From: Julian Lucek <[email-masked]>
Date: Thu, 22 Mar 2007 13:34:57 +0000

Yes

---

From: "Lasserre, Marc \(Marc\)" <[email-masked]>
Date: Thu, 22 Mar 2007 16:18:22 +0100

Informational RFC would be my preference.

Cheers,
Marc

-----Original Message-----
From: Shane Amante [mailto:[email-masked]] 
Sent: mercredi 21 mars 2007 17:27
To: [email-masked]
Subject: draft-kompella-l2vpn-l2vpn-02

Thanks,

-shane

---

From: Luca Martini <[email-masked]>
Date: Thu, 22 Mar 2007 09:28:37 -0600

Shane,

As I said on a different thread, I believe that if anything this 
document could become an informational RFC.
I also believe that since this document has been sitting around for 
almost 3 years ... for which 2 years it was expired.
So I have to question if there is any real interest in ever publishing 
this document.

Luca

Shane Amante wrote:
> the end of the meeting, in order so they could convert the room over 
> for the IETF plenary session, so I didn't have time to clarify it.  
> So, my apologies for the confusion.
>

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Thu, 22 Mar 2007 14:03:06 -0400

You rase a good point.  Would it not be more
appropriate to move this forward as an individual
informational?

	--Tom

> So I have to question if there is any real interest in ever  
> publishing this document.
>
> Luca
>
>
> Shane Amante wrote:
>> I was approached by several people outside the hallway just after  
>> the L2VPN WG meeting expressing confusion over a poll in the room  
>> about making this draft a WG document, in particular over the  
>> 'Intended Status' of this WG draft, e.g.: Informational or  
>> Standards Track. Unfortunately, we were abruptly cut off after  
>> running over our time at the end of the meeting, in order so they  
>> could convert the room over for the IETF plenary session, so I  
>> Let me now ask a hopefully more precise question here: How many  
>> people are in favor of making the aforementioned draft a WG draft  
>> *if* the 'Intended Status' is Standards Track?
>>
>> Thanks,
>>
>> -shane

---

From: "Dutta, Pranjal \(Pranjal\)" <[email-masked]>
Date: Fri, 23 Mar 2007 00:02:32 +0530

I would prefer this to be an *Informational* document.

Thanks,
Pranjal

-----Original Message-----
From: Shane Amante [mailto:[email-masked]] 
Sent: Wednesday, 21 March, 2007 9:57 PM
To: [email-masked]
Subject: draft-kompella-l2vpn-l2vpn-02

Thanks,

-shane

---

From: "Vinit Bansal \(vbansal\)" <[email-masked]>
Date: Thu, 22 Mar 2007 11:41:16 -0700

-Vinit

> Sent: Wednesday, March 21, 2007 9:27 AM
> To: [email-masked]

---

From: George Swallow <[email-masked]>
Date: Thu, 22 Mar 2007 19:14:35 -0400

> document could become an informational RFC.

An individual info RFC would be just fine.  

...George

========================================================================
George Swallow             Cisco Systems                  (978) 936-1398
                           1414 Massachusetts Avenue
                           Boxborough, MA 01719

---

From: [email-masked]
Date: Fri, 23 Mar 2007 10:49:55 +0000

Shane,

I would oppose this as as a standards track document.

IMO it should be informational.

Best regards,

Matthew

             Shane Amante                                                  
             <shane@castlepoin                                             
             t.net>                                                     To 
                                       [email-masked]                      
             21/03/2007 16:27                                           cc 
                                                                           
                                                                   Subject 
                                       draft-kompella-l2vpn-l2vpn-02       

                                                                           

Thanks,

-shane

---

From: "BRUNGARD, DEBORAH A, ATTLABS" <[email-masked]>
Date: Fri, 23 Mar 2007 11:02:39 -0500

Support *Standards Track*-
Deborah 

-----Original Message-----
From: Shane Amante [mailto:[email-masked]] 
Sent: Wednesday, March 21, 2007 12:27 PM
To: [email-masked]
Subject: draft-kompella-l2vpn-l2vpn-02

Thanks,

-shane

---

From: Eric Rosen <[email-masked]>
Date: Thu, 29 Mar 2007 08:11:00 -0500

I'm sorry to see this document come back to life after several years of much
deserved retirement. 

I oppose its adoption  as a WG document, but have no  objection to its being
published as an individual informational RFC.

---

From: "DECRAENE Bruno RD-CORE-ISS" <[email-masked]>
Date: Thu, 29 Mar 2007 15:19:12 +0200

Shane,

I support (for Standards Track).

Bruno

> -----Message d'origine-----
> De : Shane Amante [mailto:[email-masked]]
> Envoyé : mercredi 21 mars 2007 17:27
> À : [email-masked]
> Objet : draft-kompella-l2vpn-l2vpn-02
>

---

From: Kireeti Kompella <[email-masked]>
Date: Thu, 29 Mar 2007 07:38:54 -0700 (PDT)

> I'm sorry to see this document come back to life after several years of much

:-)

Kireeti.
-------

---

From: Loa Andersson <[email-masked]>
Date: Thu, 29 Mar 2007 17:28:17 +0200

All,

it is my take that the decision tree here is:

                        start
                          |
              +------------------------+
              |                        |
          individual             working group doc
            (done)                     |
                            +------------------------+
                            |                        |
                      standards track           informational
                         (done)                    (doc)

1. we decide first whether this will become a working group document
   or not

2. if we say *no* we don't need to bother if it is
   informational or standards track

3. if we say *yes* we need to decide whether it is
    informational or standards track

4. if we say standards track we are

5. if we say inforamational we are also done

However, sending a working group document using the 2119 language
to the IESG, will result in rather pointed questions from a very
reluctant IESG. If we go there a document revision to re-write it
infaormational language be better.

Also, if we decide not making it a working group document, Kireeti
can do whatever he want with it, so sugestions like *individual and
informational* maght be viewed as good advice by Kireeti, but nothing
the wg can decide.

/Loa

-- 
Loa Andersson

Principal Networking Architect
Acreo AB                           phone:  +46 8 632 77 14
Isafjordsgatan 22                  mobile: +46 739 81 21 64
Kista, Sweden                      email:  [email-masked]
                                           [email-masked]

---

From: "Bruno De Troch" <[email-masked]>
Date: Thu, 29 Mar 2007 21:16:48 +0100

I know multiple networks where this is already deployed, so I prefer it
to become a standard.

Cheers,

Bruno

> Sent: Wednesday, March 21, 2007 17:27
> To: [email-masked]
for

---

From: Ian Stanley <[email-masked]>
Date: Fri, 30 Mar 2007 06:52:26 +1000

Agree fully, the market needs this resolved

Cheers
Ian

On 30/3/07 6:16 AM, "Bruno De Troch" <[email-masked]> wrote:Bruno De
Troch

>> > 'Intended Status' is Standards Track?

Regards,
Ian Stanley
National Manager
Architecture & Design
IP & Data
Core Networks | Engineering
02 9396 8508
0419 257221

This communication may contain CONFIDENTIAL or copyright information of
Telstra Corporation Limited (ABN 33 051 775 556). If you are not an intended
recipient, you MUST NOT keep, forward, copy, use, save or rely on this
communication, and any such action is unauthorised and prohibited. If you
have received this communication in error, please reply to this email to
notify the sender of its incorrect delivery, and then delete both it and
your reply. Thank you.

---

From: "Ali Sajassi \(sajassi\)" <[email-masked]>
Date: Thu, 29 Mar 2007 15:30:35 -0700

... And I know many more networks that don't have such deployment and
some of them plan to do theirs based on the standard-track solution
specified in the l2vpn-signaling draft. So, as I have said previously,
given that we have a comprehensive solution which is standard-track,
there is no need for another one. However, as mentioned before, I
wouldn't mind this draft to become informational RFC.

-Ali 

> From: Bruno De Troch [mailto:[email-masked]] 
> Sent: Thursday, March 29, 2007 1:17 PM
> To: Shane Amante; [email-masked]
> Subject: RE: draft-kompella-l2vpn-l2vpn-02
> 
> I know multiple networks where this is already deployed, so I 
> prefer it to become a standard.
> 
> 
> Cheers,
> 
> Bruno
> 
> after the

---

From: "Renwei Li" <[email-masked]>
Date: Thu, 29 Mar 2007 18:36:32 -0700

When we decide something to be a standard track RFC or informational
RFC, do we need to take into account how many deployments there are? If
so, I see more implementations and deployments based on
pwe3-control-protocol draft.

On the other hand, a standard should be unique unless it is intended to
potentially obsolete the other ones. Do we intend to obsolete other
drafts using this new one?

Just some quick thoughts...

Renwei 

-----Original Message-----
From: Ali Sajassi (sajassi) [mailto:[email-masked]] 
Sent: Thursday, March 29, 2007 3:31 PM
To: Bruno De Troch; Shane Amante; [email-masked]
Subject: RE: draft-kompella-l2vpn-l2vpn-02

-Ali

---

From: "Andrew G. Malis" <[email-masked]>
Date: Thu, 29 Mar 2007 23:59:30 -0400

Since there's obviously no consensus on the list to make this
standards-track, I think informational is the obvious way to go.

Cheers,
Andy

---

From: "Ali Sajassi \(sajassi\)" <[email-masked]>
Date: Thu, 29 Mar 2007 22:40:46 -0700

And the current standard-track solution is based on the PWE3 control
protocol (RFC 4447).

-Ali 

> From: Renwei Li [mailto:[email-masked]] 
> Sent: Thursday, March 29, 2007 6:37 PM
> To: Ali Sajassi (sajassi); 'Bruno De Troch'; 'Shane Amante'; 
> [email-masked]
> When we decide something to be a standard track RFC or 
> informational RFC, do we need to take into account how many 
> deployments there are? If so, I see more implementations and 
> deployments based on pwe3-control-protocol draft.
> 
> On the other hand, a standard should be unique unless it is 
> intended to potentially obsolete the other ones. Do we intend 
> to obsolete other drafts using this new one?
> 
> ... And I know many more networks that don't have such 
> deployment and some of them plan to do theirs based on the 
> standard-track solution specified in the l2vpn-signaling 
> draft. So, as I have said previously, given that we have a 
> comprehensive solution which is standard-track, there is no 
> need for another one. However, as mentioned before, I 
> > I know multiple networks where this is already deployed, so 
> I prefer 
> > it to become a standard.
> > 
> > 
> > Cheers,
> > 
> > Bruno
> >

---

From: "Dutta, Pranjal \(Pranjal\)" <[email-masked]>
Date: Fri, 30 Mar 2007 12:10:56 +0530

Completely support this. The l2vpn-sig already adopted for LDP based
method.
We have wide deployments for both SS-PW and MS-PW with LDP signaling for
PWE3.

-Pranjal

-----Original Message-----
From: Ali Sajassi (sajassi) [mailto:[email-masked]] 
Sent: Friday, 30 March, 2007 11:11 AM
To: [email-masked]; Bruno De Troch; Shane Amante; [email-masked]
Subject: RE: draft-kompella-l2vpn-l2vpn-02

-Ali

---

From: "Yaakov Stein" <[email-masked]>
Date: Fri, 30 Mar 2007 16:11:06 +0300

prefer it
	to become a standard.
	
	This is precisely why I asked for it to be issued as an
informational RFC.
	Since it is deployed, we need it documented.
	 
	But, I prefer NOT to have 2 "standard" signaling mechanisms.
	 
	Y(J)S