Subject: RE: Raising of hands ...

From: "Sasha Vainshtein" <[email-masked]>
Date: Thu, 22 Mar 2007 19:12:23 +0200

Luca and all,
I am not sure the PWE3 precedent you quote is applicable.
 
In that case we had TWO competing proposals solving essentially the same
problem.
Not being able to reach a consensus, the PWE3 WG has opted to publish
both as Informational RFCs.
 
IF there were an alternative proposal, the L2VPN WG would have several
options:

*	Publish one as  a Standards Track document and the other one as
Informational
*	Publish both as Standards Track documents if the differences in
the applicability justify that (this is how this WG has published both
RFC 4761 and RFC 4762 as PS)
*	Publish both as Informational if the differences in the
applicability are not substantial and consensus cannot be reached
*	Drop all (well, this is always an option and does not really
require alternative proposals:-)

BUT I have not seen any alternative proposals so far. 
 
Simply stating that all the PWs in a PVWS are set using LDP is not
enough IMHO. 
You would need something close to the control plane sections of RFC
4762, only more complicated. 
 
Regards,
            Sasha
________________________________

From: Luca Martini [mailto:[email-masked]] 
Sent: Thursday, March 22, 2007 5:16 PM
To: Loa Andersson
Cc: Kireeti Kompella; [email-masked]
Subject: Re: Raising of hands ...

Loa Andersson wrote: 

	Loa Andersson wrote:

		Yakov,
		
		not sure here, but I think the draft specifies protocol
and uses
		the normative IETF language (MUST, SHOULD, etc ...)
(though Kireeti
		as usual is to lazy to capitalize.
		
		So, short of major rewriting this can be
"informational".

	So, short of major rewriting this can't be "informational".

Loa,
We have several documents from PWE3 that are informational RFCs yet they
have the same characteristics as this document.
So I do not agree that just because of the language of the document or
what it defines , this is going to be a standard recommendation of the
IETF.
I believe it is standard IETF policy to standardize a single common
method. However it is also common practice to permit additional
informational RFCs when needed.
I believe that we settled on an LDP PW , and the use of BGP for
autodiscovery.

Luca 

h

	sorry about that
	
	/Loa

		/Loa
		
		Yaakov Stein wrote:

			I just wanted to clarify that I raised my hand
for making
			draft-kompella-l2vpn-l2vpn a WG document,
			but prefer it to be informational, not
standards-track.
			
			Y(J)S

---

From: "Ali Sajassi \(sajassi\)" <[email-masked]>
Date: Thu, 22 Mar 2007 11:48:17 -0700

I am changing the "subject" to reflect the important fact that a
standard-track solution already exist for general L2VPN and VPWS
signaling which is specified in section 3.3 of
http://www.ietf.org/internet-drafts/draft-ietf-l2vpn-signaling-08.txt
<http://www.ietf.org/internet-drafts/draft-ietf-l2vpn-signaling-08.txt>
(sitting in RFC-Editor queue). Therefore, I think, at most the l2vpn
draft using BGP signaling (draft-kompella-l2vpn-l2vpn-02.txt) should be
just an informational RFC if we want to move it forward given that it
suffers from the issue I mention during the WG meeting where the
standard-track solution does NOT suffer.
 
-Ali

	From: Sasha Vainshtein [mailto:[email-masked]] 
	Sent: Thursday, March 22, 2007 10:12 AM
	To: Luca Martini (lmartini)
	Cc: Kireeti Kompella; [email-masked]; Loa Andersson
	Subject: RE: Raising of hands ...

	Luca and all,
	 
	In that case we had TWO competing proposals solving essentially
the same problem.
	Not being able to reach a consensus, the PWE3 WG has opted to
publish both as Informational RFCs.
	 
	IF there were an alternative proposal, the L2VPN WG would have
several options:

	*	Publish one as  a Standards Track document and the other
one as Informational 
	*	Publish both as Standards Track documents if the
differences in the applicability justify that (this is how this WG has
published both RFC 4761 and RFC 4762 as PS) 
	*	Publish both as Informational if the differences in the
applicability are not substantial and consensus cannot be reached 
	*	Drop all (well, this is always an option and does not
really require alternative proposals:-)

	Simply stating that all the PWs in a PVWS are set using LDP is
not enough IMHO. 
	You would need something close to the control plane sections of
RFC 4762, only more complicated. 
	 
	Regards,
	            Sasha

	Loa Andersson wrote: 

		Loa Andersson wrote:

			Yakov,
			
			not sure here, but I think the draft specifies
protocol and uses
			the normative IETF language (MUST, SHOULD, etc
...) (though Kireeti
			as usual is to lazy to capitalize.

		So, short of major rewriting this can't be
"informational".

	Loa,
	We have several documents from PWE3 that are informational RFCs
yet they have the same characteristics as this document.
	So I do not agree that just because of the language of the
document or what it defines , this is going to be a standard
recommendation of the IETF.
	I believe it is standard IETF policy to standardize a single
common method. However it is also common practice to permit additional
informational RFCs when needed.
	I believe that we settled on an LDP PW , and the use of BGP for
autodiscovery.
	
	Luca 

	h

		sorry about that
		
		/Loa

			/Loa
			
			Yaakov Stein wrote:

				I just wanted to clarify that I raised
my hand for making
				draft-kompella-l2vpn-l2vpn a WG
document,
				but prefer it to be informational, not
standards-track.
				
				Y(J)S