Subject: RE: draft-pdutta-l2vpn-vpls-ldp-mac-opt-04 WG draft?

From: "BOCCI Matthew" <[email-masked]>
Date: Thu, 2 Apr 2009 16:55:56 +0200

support 

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] 
> On Behalf Of Shane Amante
> Sent: 30 March 2009 03:40
> To: [email-masked]
> Subject: draft-pdutta-l2vpn-vpls-ldp-mac-opt-04 WG draft?
> 
> Hi All,
> 
> At the L2VPN WG meeting at IETF 74 in San Francisco, there 
> was a request by the authors to make this a WG draft.  Please 
> indicate to  
> the list if you do or don't support making this draft a WG 
> document.   
> The following is a URL for this draft:
> http://tools.ietf.org/html/draft-pdutta-l2vpn-vpls-ldp-mac-opt-04
> 
> The deadline for comments will be 3 weeks: Friday, April 17.  
> Silence will not be counted as acceptance.
> 
> -shane
>

---

From: [email-masked]
Date: Sun, 05 Apr 2009 22:31:11 +0800 (SGT)

Support
--- Shane Amante <[email-masked]> wrote:

> Hi All,
> 
> At the L2VPN WG meeting at IETF 74 in San Francisco, there was a  
> request by the authors to make this a WG draft.  Please indicate to 
> 
> the list if you do or don't support making this draft a WG document.
>

---

From: "Yuji KAMITE" <[email-masked]>
Date: Mon, 06 Apr 2009 21:45:42 +0900

Hi Pranjal,

I have some minor comments and questions.
Best regards,
Yuji

---
- I think it is better to clarify the relathionship between
VSI-IDs, PW IDs/AGI&AIIs, VPLS-id and PE-ID TLV encoding.
The current draft only says "PE-ID TLV carries sufficient
information for identifying the VPLS instance and the unique
VSI Identifier", this is ambigous because the proposed PE-ID
format encodes PW IDs/AIIs and PE address only --
not place VSI ID directly.   I'm not sure how PE-ID
content tells correctly which VSI-ID is targeted.

VSI-ID is assigned locally by each PE, 
(even in auto-discovery case, it is derived from
 concatenating its VPLS-id with an PE IP address)
so, in my guess there might be cases where they are
not always uniquely allocated in all PEs in one H-VPLS.
So ihow to interpret the received PE-ID content and recognize
VPLS instance/VSI ID correctly needs to be elaborated.

- Section.5  2nd paragraph
>The PE-ID TLV SHOULD carry the unique VSI identifier in the
> VPLS instance (specified in the FEC TLV). 
I am not sure why SHOULD is used.  "MUST carry" would be better,
to avoid non-interoperable solution.  Otherwise are there any reason to
allow other implementations?  And it is not yet clear how it
uniquely identifies VSI anyway.

- Section 5.1.  1st paragraph
>...  In such a case the PE-ID TLV in MAC flush message
>   MAY identify its own VSI in the VPLS instance.
Similarly, I am not sure why MAY is applied here.  If PE-ID is used,
this should be MUST?

- Section 4. / Figure 3. 
>Endpoint Address
> 32-bit LSR-ID from the LDP-ID used in LDP signaling session
>by a PW endpoint.
This explanation might not be clear because it doesn't say
which side's PE is pointed at (i.e., either of two PEs of PW).

---

> > From: [email-masked] 
> [mailto:[email-masked]] On Behalf 
> > Of Shane Amante
> > Sent: Sunday, March 29, 2009 10:40 PM
> > To: [email-masked]

---

From: "Dutta, Pranjal K (Pranjal)" <[email-masked]>
Date: Wed, 8 Apr 2009 08:30:02 +0530

Hi Yuji,
           Thanks for reviewing the I-D. Please refer my answers inline
to your comments.

Regards,
Pranjal

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Yuji KAMITE
Sent: Monday, April 06, 2009 5:46 AM
To: [email-masked]
Subject: RE: draft-pdutta-l2vpn-vpls-ldp-mac-opt-04 WG draft?

Hi Pranjal,

---

[Pranjal] 
In FEC 128, the PE-ID carries the PW-ID + 4 byte LDP LSR-ID. From the PW-ID, 
the termination points of a PW can indentify the vpls instance to which 
the PW is provisioned for. The LSR-ID indentifies one specific termination point of the PW. So, the combination identifies the unique VSI (VPLS forwarder) in a PE device.

In FEC 129, the PE-ID carries the AGI + AII. From the AGI, the termination
points of a PW can indentify the vpls instance to which the PW belongs to. The AII indentifies one specific termination point of the PW. So, the combination indentifies the unique VSI (VPLS forwarder) in a PE device. 

I would clarify in detail in next revision.

[Pranjal] Didn't get exactly. In BGP-AD, the AGI distribution would be 
unique across all n-PEs/u-PEs participating in H-VPLS. AGI would be 
generated by BGP.

[Pranjal] Thanks for pointing this out. Noted for correction in next revision.

[Pranjal] Noted for correction.

- Section 4. / Figure 3. 

[Pranjal] I would clarify this in next version. It is the LSR-ID of the 
          PE of the sender of the MAC flush.

---

---

From: <[email-masked]>
Date: Tue, 14 Apr 2009 11:22:32 +0200

Support.

BR,
Manuel

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Shane Amante
Sent: Monday, March 30, 2009 4:40 AM
To: [email-masked]
Subject: draft-pdutta-l2vpn-vpls-ldp-mac-opt-04 WG draft?

Hi All,

The deadline for comments will be 3 weeks: Friday, April 17.  Silence  
will not be counted as acceptance.

-shane

---

From: "Yuji KAMITE" <[email-masked]>
Date: Tue, 14 Apr 2009 20:11:13 +0900

Hi Pranjal,

> From: Dutta, Pranjal K (Pranjal) [mailto:[email-masked]] 
> Sent: Wednesday, April 08, 2009 12:00 PM
> To: Yuji KAMITE; [email-masked]
>            Thanks for reviewing the I-D. Please refer my 
> answers inline to your comments.
> 
> Regards,
> Pranjal
> 
> On Behalf Of Yuji KAMITE
> In FEC 128, the PE-ID carries the PW-ID + 4 byte LDP LSR-ID. 
> From the PW-ID, the termination points of a PW can indentify 
> the vpls instance to which the PW is provisioned for. The 
> LSR-ID indentifies one specific termination point of the PW. 
> So, the combination identifies the unique VSI (VPLS 
> forwarder) in a PE device.
> 
> In FEC 129, the PE-ID carries the AGI + AII. From the AGI, 
> the termination points of a PW can indentify the vpls 
> instance to which the PW belongs to. The AII indentifies one 
> specific termination point of the PW. So, the combination 
> indentifies the unique VSI (VPLS forwarder) in a PE device. 
> 

Thank you for clarification.
> concatenating its VPLS-id with an PE IP address) so, in my 
> guess there might be cases where they are not always uniquely 
> allocated in all PEs in one H-VPLS.

I might have been confused.  It makes sense to me now.
AGI is considered VPN Identifier,
so its meaning is equal to VPLS-id, not VSI ID.
But PE-Id tells AII as well as AGI, so I understand
it works well toally.

> [Pranjal] Thanks for pointing this out. Noted for correction 

All right.

>           PE of the sender of the MAC flush.

OK.  Thank you.

Best reagrds,
Yuji

---

From: "Yuji KAMITE" <[email-masked]>
Date: Tue, 14 Apr 2009 20:12:49 +0900

Support.

-Yuji

> Sent: Monday, March 30, 2009 11:40 AM
> To: [email-masked]

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 15 Apr 2009 14:23:48 -0400

support..

/himanshu 

-----Original Message-----

Hi All,

At the L2VPN WG meeting at IETF 74 in San Francisco, there was a request
by the authors to make this a WG draft.  Please indicate to  
the list if you do or don't support making this draft a WG document.   
The following is a URL for this draft:
http://tools.ietf.org/html/draft-pdutta-l2vpn-vpls-ldp-mac-opt-04

-shane

---

From: Shane Amante <[email-masked]>
Date: Sat, 18 Apr 2009 10:37:06 -0600

Hi Everyone,

This concludes the call to made this a WG draft.  There appears to be  
very good support to make this a WG draft.  Would the authors please  
re-publish the current -04 version as follows:
draft-ietf-l2vpn-vpls-ldp-opt-mac-flush-00

... please incorporate changes suggested by Yuji, and any others, into  
the next revision of the WG draft (-01).

Thanks,

-shane

On Mar 29, 2009, at 8:39 PM, Shane Amante wrote:
> document.  The following is a URL for this draft:

---

From: <[email-masked]>
Date: Mon, 20 Apr 2009 10:32:19 +0200

Support.

Fred