Subject: FW: Protocol Action: 'ARP Mediation for IP Interworking of Layer 2 VPN' to Proposed Standard (draft-ietf-l2vpn-arp-mediation-19.txt)

From: Alexander Vainshtein <[email-masked]>
Date: Wed, 8 Feb 2012 07:20:15 +0200

Himanshu hi,
Congratulations! 

I believe (may be wrong here) that this sets an absolute record of all times:
- To the best of my recollection, the -00 version of draft-shah has been posted some time in 2001 
- It has garnered immediate support in the community with multiple implementations 
- And, in spite of all that, it took 12 (twelve!) years to get the -19 version of the WG draft to be approved for publication.

They say that late is better than never - how true!

Again, congratulations! Hopefully your next one will take somewhat less time...

Sasha

________________________________________
From: [email-masked] [[email-masked]] On Behalf Of The IESG [[email-masked]]
Sent: Wednesday, February 08, 2012 1:10 AM
To: IETF-Announce
Cc: l2vpn mailing list; l2vpn chair; RFC Editor
Subject: Protocol Action: 'ARP Mediation for IP Interworking of Layer 2 VPN'    to Proposed Standard (draft-ietf-l2vpn-arp-mediation-19.txt)

The IESG has approved the following document:
- 'ARP Mediation for IP Interworking of Layer 2 VPN'
  (draft-ietf-l2vpn-arp-mediation-19.txt) as a Proposed Standard

This document is the product of the Layer 2 Virtual Private Networks
Working Group.

The IESG contact persons are Stewart Bryant and Adrian Farrel.

A URL of this Internet Draft is:
http://datatracker.ietf.org/doc/draft-ietf-l2vpn-arp-mediation/

Technical Summary

A Virtual Private Wire Service (VPWS) provides a point-to-point
connection service between a pair of Customer Edge (CE) devices
over an IP/MPLS packet switched network using Pseudowire
Emulation Edge to Edge (PWE3) technology.  It does so by
binding two Attachment Circuits (ACs), each connecting a CE
device with a Provider Edge (PE) device, to a Pseudowire (PW)
extended between the two PEs. PWE3 defines PW types
that interconnect ACs of the same technology (homogeneous ACs),
e.g., both ACs being Ethernet. In general, a VPWS provides
connectivity between homogeneous ACs using the existing
PWE3 technology. However, if the ACs are layer2 attachment
circuits of heterogeneous types (e.g., one AC is Ethernet and
the other one is a Fame Relay DLCI), and solely carry IP
datagrams in the corresponding packet data units' payload,
it is possible to provide a VPWS that interconnects these
ACs using IP Layer2 Transport PWs often referred to simply
as IP PWs. This requires the PEs to perform a function known
as "ARP Mediation".  ARP Mediation refers to the process of
resolving IP addresses to Layer 2 addresses when different
address resolution protocols are used on either Attachment
Circuit.  The methods described in this document are applicable
even when the CEs run a routing protocol between them
as long as the routing protocol runs over IP.

Working Group Summary

This document has been in existence since the very beginning
of the PPVPN and L2VPN WG's.  At first, it only included
support for IPv4, but subsequently was updated to include
support for IPv6. Ultimately, this document provides a means
of interworking IPv4-enabled ACs, IPv6-enabled ACs and
dual-stack IPv4/IPv6-enabled ACs whereby the ACs are of
disparate Layer2 technologies.

Document Quality
There are no concerns about document quality.
Several implementations of  this draft have existed in
the field for several years.

Personnel
Nabil Bitar ([email-masked]) is the Document Shepherd.
Stewart Bryant ([email-masked]) is the Responsible
Area Director.

RFC Editor Note

In section 2

OLD
A PE that is to perform ARP Mediation for IPv6 packets SHOULD
perform the following logical steps:
NEW
A PE that is to perform ARP Mediation for IPv6 packets MUST
perform the following logical steps:
END
=====
In section 4.3.3 - two places
- end of list item 2
- end of first sentence list item 3
In section 4.3.4 second para

OLD
link-layer address of the local AC
NEW
link layer address of the PE interface attached to local AC
END

This e-mail message is intended for the recipient only and contains information which is CONFIDENTIAL and which may be proprietary to ECI Telecom. If you have received this transmission in error, please inform us by e-mail, phone or fax, and then delete the original and all copies thereof.

---

From: "Shah, Himanshu" <[email-masked]>
Date: Wed, 8 Feb 2012 09:52:34 -0500

Thanks for the compliments Sasha..

The initial few years were definitely challenging with 'upper' management
(especially the PPVPN group) due its nature of Layer2 service interworking.

There is LONG list of PEOPLE (including you, of course) have helped making this 
document a success, thanks to you all.

And yes, hope the next document does not take this long (unfortunately, we already
have one on the deck, IPLS, with same lineage.. :-)

thanks again..
/himanshu

-----Original Message-----
From: Alexander Vainshtein [mailto:[email-masked]] 
Sent: Wednesday, February 08, 2012 12:20 AM
To: Shah, Himanshu
Cc: [email-masked]
Subject: FW: Protocol Action: 'ARP Mediation for IP Interworking of Layer 2 VPN' to Proposed Standard (draft-ietf-l2vpn-arp-mediation-19.txt)

Himanshu hi,
Congratulations! 

Sasha

Technical Summary

Working Group Summary

Document Quality

Personnel

RFC Editor Note

In section 2

OLD

OLD

---

From: Ping Pan <[email-masked]>
Date: Wed, 8 Feb 2012 10:13:29 -0800

> document a success, thanks to you all.
Look on the bright side, this draft has out-lived some of the companies
that actually implemented parts of it... Oh, the things we have done for
those ARP's... ;-)

Congrat!

Ping

> Subject: FW: Protocol Action: 'ARP Mediation for IP Interworking of Layer
> 2 VPN' to Proposed Standard (draft-ietf-l2vpn-arp-mediation-19.txt)
>
> Himanshu hi,
> Congratulations!
>
> - And, in spite of all that, it took 12 (twelve!) years to get the -19
> version of the WG draft to be approved for publication.
>
> Subject: Protocol Action: 'ARP Mediation for IP Interworking of Layer 2
> VPN'    to Proposed Standard (draft-ietf-l2vpn-arp-mediation-19.txt)
>
> This e-mail message is intended for the recipient only and contains
> information which is CONFIDENTIAL and which may be proprietary to ECI
> Telecom. If you have received this transmission in error, please inform us
> by e-mail, phone or fax, and then delete the original and all copies
> thereof.
>
>