Subject: E-Tree requirement discussion

From: Lizhong Jin<[email-masked]>
Date: Thu, 9 Feb 2012 20:00:39 +0800

Hi all,
Since VPLS E-tree provide standard MEF E-Tree capabilities, the 
cummnication between root and leaf is allowed, and communication between 
leaf and leaf is isolated. Does any provider has requirement to allow some 
part of leafs to be communicated, and some part of leafs to be isolated?
Such kind of communication model is a bit like the private VLAN in 
RFC5517, and of course, different with E-Tree.

Thanks
Lizhong

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: "Rogers, Josh" <[email-masked]>
Date: Thu, 9 Feb 2012 10:01:44 -0500

Lizhong,

I'm not following how RFC5517 is similar to allowing 'some part of leafs to communicate'?  Do you mean leaf-leaf communication?  I don't think Private VLAN's are intended to do that, however the way Private VLAN's behave is very similar to what the ETREE req doc outlines.

Today, we use BGP-VPLS to accomplish ETREE (or as close as we can get anyhow) by importing/exporting inversed vrf-targets between root and leaf sites:

root sites
import target:123:1
export target:123:2

leaf sites
import target:123:2
export target:123:1

We really enjoy/prefer BGP-VPLS for many reasons, however shortcomings of our vendor's implementation presents some challenges:
1. root-root communication is not allowed, since the root site cannot 'import' more than one target.
2. controlling PW creation using vrf-targets this way is based on PE to PE communication, not AC to AC communication, so it is not granular enough.  We control this with some unique knobs that allow local switching on the PE but not communication between AC and VSI, and/or disallow local switching, but only communicate between AC and VSI.  There are still topological use cases that we cannot solve, however, which leaves us intently following the handful of proposed ETREE methods that could solve this challenge.

Regarding your question about whether we need to allow 'some' leaf-leaf communication, the answer for us is 'no', generally we do not, and if that ever comes up, we'd let our customer know that was not part of the product offering, and they would be encouraged to use a basic any to any VPLS service, and then use their own edge equipment to control which sites communicate to which sites (routing policy for instance), or sell them additional service(s) that could be used to communicate between the leaf sites they are interested in.

Hope that helps,
Josh

On 02/09/2012 06:00 AM, Lizhong Jin wrote:

Hi all,
Since VPLS E-tree provide standard MEF E-Tree capabilities, the cummnication between root and leaf is allowed, and communication between leaf and leaf is isolated. Does any provider has requirement to allow some part of leafs to be communicated, and some part of leafs to be isolated?
Such kind of communication model is a bit like the private VLAN in RFC5517, and of course, different with E-Tree.

Thanks
Lizhong

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Phil <[email-masked]>
Date: Thu, 9 Feb 2012 15:17:11 -0500

There are times when some leaf to leaf communication is necessary without those sites being root nodes.  Similar to the community VLAN concept from pvlans.  Most deployments have a single root and many leaves but I have seen instances where people want a backend connection between two leaf sites.  Usually these days it means creating a new p2p service between the sites. 

Phil

---

From: "Mallette, Edwin" <[email-masked]>
Date: Thu, 9 Feb 2012 20:40:02 +0000

Lizhong,

So I can see how such a capability could be useful for some corner case deployments, however, I wouldn't associate that capability to E-Tree.  In general,  I'm comfortable with constructing multiple services to support the need, similar to what Phil suggested in a previous response.

Ed

From: Lizhong Jin <[email-masked]<mailto:[email-masked]>>
Date: Thu, 9 Feb 2012 20:00:39 +0800
To: <[email-masked]<mailto:[email-masked]>>
Subject: E-Tree requirement discussion

Hi all,

Thanks
Lizhong

CONFIDENTIALITY NOTICE: This e-mail may contain information that is privileged, confidential or otherwise protected from disclosure. If you are not the intended recipient of this e-mail, please notify the sender immediately by return e-mail, purge it and do not disseminate or copy it.

---

From: Lizhong Jin<[email-masked]>
Date: Fri, 10 Feb 2012 10:37:50 +0800

Josh, Phil, Edwin,
Thank you very much for the discussion. It seems all prefer to using 
additional service to provide leaf-to-leaf communication, and let VPLS 
ETree as defined in MEF. Any other opinions from the list?
BTW, as Phil pointed out, community VLAN concept in PVLAN in RFC5517 
provides similar leaf-to-leaf communication.

Regards
Lizhong

> cummnication between root and leaf is allowed, and communication 
> between leaf and leaf is isolated. Does any provider has requirement
> to allow some part of leafs to be communicated, and some part of 
> leafs to be isolated?

---

From: HUANG Feng F <[email-masked]>
Date: Fri, 10 Feb 2012 05:22:40 +0000

Dear all,
     For E-Tree defined in MEF and EVPRM in ITU-T G.8011.4, leaf to leaf message is prohibited, asymmetrical VLAN can be used, propose not define new service type and behavior, it make the industry confusion.
B.R.
Feng Huang

From: [email-masked] [mailto:[email-masked]] On Behalf Of Lizhong Jin
Sent: 2012年2月10日 10:38
To: Rogers, Josh; [email-masked]; [email-masked]
Cc: [email-masked]
Subject: Re: E-Tree requirement discussion

Josh, Phil, Edwin,
Thank you very much for the discussion. It seems all prefer to using additional service to provide leaf-to-leaf communication, and let VPLS ETree as defined in MEF. Any other opinions from the list?
BTW, as Phil pointed out, community VLAN concept in PVLAN in RFC5517 provides similar leaf-to-leaf communication.

Regards
Lizhong