Subject: Response to some comments on IS-IS VPLS

From: Xuxiaohu <[email-masked]>
Date: Thu, 29 Mar 2012 12:58:35 +0000

Hi all,

VPLS (Virtual Private LAN Service) has different understandings for different people, some people think it as a service while others  think it as a concrete technology, especially using PWs. Here, the "VPLS" is deemed as a VPLS service. If the WG consensus is that "VPLS" should be taken as a concrete technology,  I have no objection to using another term.

As said in the IS-IS VPLS draft, IS-IS VPLS is intended to be a light-weight VPLS solution which can meet some DC operators' requirements for simplicity. I don't want to argue in this mailing-list whether BGP-based L2VPN solutions could meet well the requirements from all DC operators. I personally believe that it would be better to ask this question to NVo3. In addition, according to today's presentation of E-VPN, I think E-VPN co-authors also admit that the exiting EVPN solution seems complex to some DC operators. If my understanding is wrong, pls correct me.

If I remembered correctly, L1VPN also has two RFCs using IS-IS and OSPF for L1VPN auto-discovery, although there has been one solution using BGP. Hence I don't know why can't we have a light-weight L2VPN using IS-IS.

Best regards,

Xiaohu

---

From: sajassi <[email-masked]>
Date: Thu, 29 Mar 2012 10:55:21 -0700

It seems like this draft keeps reincarnating itself. Last rev. of this draft
was at least consistent in terms of vpls-data plane operation, this rev of
the draft has no resemblance to VPLS (RFC 4761 or 4762). It uses neither
control-plane specified in those RFCs nor data-plane specified in those RFCs
!!

If you remember a year and half ago, we had the same situation when we
proposed E-VPN family of solutions and that¹s why L2VPN went through the
re-chartering to allow  specifically this new kind of solution.

I think if this draft needs to be pursued in L2VPN WG, then L2VPN WG needs
to go through the same re-chartering exercise to call out this family of
solution explicitly.

BTW, a year and half ago, when the chairs poll the group regarding how many
have read the drafts and how many think it should be pursued in this WG,
AFAI recall the number was around 30 in both cases. Today, when the chairs
poll the group on these questions, there were a dozen of hands on reading
the draft but only couple of hands in support the draft.

-Ali

On 3/29/12 5:58 AM, "Xuxiaohu" <[email-masked]> wrote:

> Hi all,
> 
>  
> 
> VPLS (Virtual Private LAN Service) has different understandings for different
> people, some people think it as a service while others  think it as a concrete
> technology, especially using PWs. Here, the "VPLS" is deemed as a VPLS
> service. If the WG consensus is that "VPLS" should be taken as a concrete
> technology,  I have no objection to using another term.
> 
>  
> 
> As said in the IS-IS VPLS draft, IS-IS VPLS is intended to be a light-weight
> VPLS solution which can meet some DC operators' requirements for simplicity. I
> don't want to argue in this mailing-list whether BGP-based L2VPN solutions
> could meet well the requirements from all DC operators. I personally believe
> that it would be better to ask this question to NVo3. In addition, according
> to today's presentation of E-VPN, I think E-VPN co-authors also admit that the
> exiting EVPN solution seems complex to some DC operators. If my understanding
> is wrong, pls correct me.
> 
>  
> 
> If I remembered correctly, L1VPN also has two RFCs using IS-IS and OSPF for
> L1VPN auto-discovery, although there has been one solution using BGP. Hence I
> don't know why can't we have a light-weight L2VPN using IS-IS.
> 
>  
> 
> Best regards,
> 
> Xiaohu
> 
>  
>

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Thu, 29 Mar 2012 18:29:38 +0000

IMHO... I am at a bit of a loss as to the notion that BGP is so overwhelmingly difficult to deal with in a data center environment.. Why is that??  BGP is being used across a wide spectrum of applications and is proven. I believe that the data center is becoming more and more a dynamic extension of a customer's network. I also think it would be wise to anticipate the world of tomorrow where customers may expect their network may span multiple operators DCs.  The right approach is to leverage what has been done BGP and extend it where needed.. This provides maximum flexibility and simplicity..

To build solutions based on the notion that "I don't like protocol X" is invalid..

Jim Uttaro

From: [email-masked] [mailto:[email-masked]] On Behalf Of Xuxiaohu
Sent: Thursday, March 29, 2012 2:59 PM
To: [email-masked]
Subject: Response to some comments on IS-IS VPLS

Hi all,

Best regards,

Xiaohu

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 29 Mar 2012 18:58:30 +0000

As for whether the BGP-based L2VPN solution is acceptable for most cloud DC operators, I think different people would have different opinions.

Since the above topic may be interesting to NVo3 BoF and be worthwhile for further discussion before the IESG approval of NVo3, I copy this email to NVo3 for further discussion.

Best regards,
Xiaohu
________________________________
发件人: UTTARO, JAMES [[email-masked]]
发送时间: 2012年3月30日 2:29
到: Xuxiaohu; [email-masked]
主题: RE: Response to some comments on IS-IS VPLS

IMHO… I am at a bit of a loss as to the notion that BGP is so overwhelmingly difficult to deal with in a data center environment.. Why is that??  BGP is being used across a wide spectrum of applications and is proven. I believe that the data center is becoming more and more a dynamic extension of a customer’s network. I also think it would be wise to anticipate the world of tomorrow where customers may expect their network may span multiple operators DCs.  The right approach is to leverage what has been done BGP and extend it where needed.. This provides maximum flexibility and simplicity..

To build solutions based on the notion that “I don’t like protocol X” is invalid..

Jim Uttaro

Hi all,

Best regards,

Xiaohu

---

From: John E Drake <[email-masked]>
Date: Thu, 29 Mar 2012 12:50:36 -0700

Jim,

You are completely correct , but let's not overlook the fun factor.  I.e., it's *fun* to say that everything that has gone before sucks and that the current initiative will be  "practically perfect" (c.f. 'Mary Poppins').

Thanks,

John

Sent from my iPhone

From: [email-masked] [mailto:[email-masked]] On Behalf Of UTTARO, JAMES
Sent: Thursday, March 29, 2012 11:30 AM
To: 'Xuxiaohu'; [email-masked]
Subject: RE: Response to some comments on IS-IS VPLS

Jim Uttaro

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Xuxiaohu
Sent: Thursday, March 29, 2012 2:59 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Response to some comments on IS-IS VPLS

Hi all,

Best regards,

Xiaohu

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 29 Mar 2012 23:33:59 +0200

Hi John,

I think you took it a little bit too far.

I have not heard anyone stating that current VPLS solutions suck. I also 
did not hear anyone claiming that BGP is difficult. The claim I have 
heard is that in some environments one may not like to use BGP for VPLS.

Ali's point is that current PEs will have problem supporting it as this 
is effectively TRILL over IP is valid from Ali's point of view.

However one could ask a question if IETF is still an organization to 
promote open innovation and consider new ideas (even if only in 
experimental mode) or is it just a forum to lock customers to limited 
set of solutions ? If it is the latter the trend to seek alternatives to 
IETF standardization process will continue to evolve. Especially now 
when control plane separation from data plane becomes reality.

I see nothing wrong to allocate perhaps in experimental mode VPLS Info 
TLV codepoint for VPLS over ISIS or for that matter well known 
destination port for STT from IANA and let companies who are asking for 
it develop the solutions, deploy it then report back the results to the 
community.

Best,
R.

> Jim,
>
> You are completely correct , but let’s not overlook the fun factor.
> I.e., it’s **fun** to say that everything that has gone before sucks and
> that the current initiative will be “practically perfect” (c.f. ‘Mary
> Poppins’).
>
> Thanks,
>
> John
>
> Sent from my iPhone
>
> *From:[email-masked] [mailto:[email-masked]] *On Behalf
> Of *UTTARO, JAMES
> *Sent:* Thursday, March 29, 2012 11:30 AM
> *To:* 'Xuxiaohu'; [email-masked]
> *Subject:* RE: Response to some comments on IS-IS VPLS
>
> IMHO… I am at a bit of a loss as to the notion that BGP is so
> overwhelmingly difficult to deal with in a data center environment.. Why
> is that?? BGP is being used across a wide spectrum of applications and
> is proven. I believe that the data center is becoming more and more a
> dynamic extension of a customer’s network. I also think it would be wise
> to anticipate the world of tomorrow where customers may expect their
> network may span multiple operators DCs. The right approach is to
> leverage what has been done BGP and extend it where needed.. This
> provides maximum flexibility and simplicity..
>
> *From:[email-masked] <mailto:[email-masked]>
> [mailto:[email-masked]] *On Behalf Of *Xuxiaohu
> *Sent:* Thursday, March 29, 2012 2:59 PM
> *To:* [email-masked] <mailto:[email-masked]>
> *Subject:* Response to some comments on IS-IS VPLS
>
> Hi all,
>
> VPLS (Virtual Private LAN Service) has different understandings for
> different people, some people think it as a service while others think
> it as a concrete technology, especially using PWs. Here, the "VPLS" is
> deemed as a VPLS service. If the WG consensus is that "VPLS" should be
> taken as a concrete technology, I have no objection to using another term.
>
> As said in the IS-IS VPLS draft, IS-IS VPLS is intended to be a
> light-weight VPLS solution which can meet some DC operators'
> requirements for simplicity. I don't want to argue in this mailing-list
> whether BGP-based L2VPN solutions could meet well the requirements from
> all DC operators. I personally believe that it would be better to ask
> this question to NVo3. In addition, according to today's presentation of
> E-VPN, I think E-VPN co-authors also admit that the exiting EVPN
> solution seems complex to some DC operators. If my understanding is
> wrong, pls correct me.
>
> If I remembered correctly, L1VPN also has two RFCs using IS-IS and OSPF
> for L1VPN auto-discovery, although there has been one solution using
> BGP. Hence I don't know why can't we have a light-weight L2VPN using IS-IS.
>
> Best regards,
>
> Xiaohu
>

---

From: "Shah, Himanshu" <[email-masked]>
Date: Thu, 29 Mar 2012 18:24:31 -0400

I agree completely.

BGP based solution has its application but by no means that
translates to "why everybody in the world would not want to use it"?

Perhaps there is thinking that by strongly opposing/ridiculing 
any solution other than BGP will somehow stop those who desire a 
non-BGP based solution?

/himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Thursday, March 29, 2012 5:34 PM
To: John E Drake
Cc: [email-masked]; UTTARO, JAMES
Subject: Re: Response to some comments on IS-IS VPLS

Hi John,

Best,
R.

> Jim,
>
> You are completely correct , but let's not overlook the fun factor.
> I.e., it's **fun** to say that everything that has gone before sucks and
> that the current initiative will be "practically perfect" (c.f. 'Mary
> Poppins').
>
> Thanks,
>
> John
>
> Sent from my iPhone
>
> IMHO... I am at a bit of a loss as to the notion that BGP is so
> dynamic extension of a customer's network. I also think it would be wise

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Thu, 29 Mar 2012 22:32:43 +0000

Hmmm.. You still haven't said why the BGP solution does not meet your reqs. I believe BGP is fundamental in terms of a) Proven Technology, b) Well known Interface with customer VPNs etc.... I have no issue if this is a science project more power but I don't think you are making a good case with the statement "I Don't Like Protocol X" so I am creating a different paradigm.. If there are other reasons to consider this approach I would like to see/understand them..

Jim Uttaro

-----Original Message-----
From: Shah, Himanshu [mailto:[email-masked]] 
Sent: Thursday, March 29, 2012 6:25 PM
To: [email-masked]; John E Drake
Cc: [email-masked]; UTTARO, JAMES
Subject: RE: Response to some comments on IS-IS VPLS

I agree completely.

/himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Thursday, March 29, 2012 5:34 PM
To: John E Drake
Cc: [email-masked]; UTTARO, JAMES
Subject: Re: Response to some comments on IS-IS VPLS

Hi John,

Best,
R.

---

From: "Shah, Himanshu" <[email-masked]>
Date: Thu, 29 Mar 2012 18:38:58 -0400

Perhaps it would have benefited if you attended the NVO3 BoF where sentiments from Data Center Operators (first or secondhand) were
expressed who clearly is looking for a solution. BGP based VPLS did not appear to be the winning choice.

/himanshu 

-----Original Message-----
From: UTTARO, JAMES [mailto:[email-masked]] 
Sent: Thursday, March 29, 2012 6:33 PM
To: Shah, Himanshu; [email-masked]; John E Drake
Cc: [email-masked]
Subject: RE: Response to some comments on IS-IS VPLS

Jim Uttaro

-----Original Message-----
From: Shah, Himanshu [mailto:[email-masked]] 
Sent: Thursday, March 29, 2012 6:25 PM
To: [email-masked]; John E Drake
Cc: [email-masked]; UTTARO, JAMES
Subject: RE: Response to some comments on IS-IS VPLS

I agree completely.

/himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Thursday, March 29, 2012 5:34 PM
To: John E Drake
Cc: [email-masked]; UTTARO, JAMES
Subject: Re: Response to some comments on IS-IS VPLS

Hi John,

Best,
R.

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Thu, 29 Mar 2012 22:42:14 +0000

Ok. Can you expand on why that is? If not you, can anyone explain why L2VPN Family of services VPLS, EVPN etc..it is not being considered?

Jim Uttaro

BTW.. I did attend and thus my e-mails.. The first few slides said something to the effect " We don't like BGP". Ok, so can you or someone share why that is..

-----Original Message-----
From: Shah, Himanshu [mailto:[email-masked]] 
Sent: Thursday, March 29, 2012 6:39 PM
To: UTTARO, JAMES; [email-masked]; John E Drake
Cc: [email-masked]
Subject: RE: Response to some comments on IS-IS VPLS

/himanshu 

-----Original Message-----
From: UTTARO, JAMES [mailto:[email-masked]] 
Sent: Thursday, March 29, 2012 6:33 PM
To: Shah, Himanshu; [email-masked]; John E Drake
Cc: [email-masked]
Subject: RE: Response to some comments on IS-IS VPLS

Jim Uttaro

-----Original Message-----
From: Shah, Himanshu [mailto:[email-masked]] 
Sent: Thursday, March 29, 2012 6:25 PM
To: [email-masked]; John E Drake
Cc: [email-masked]; UTTARO, JAMES
Subject: RE: Response to some comments on IS-IS VPLS

I agree completely.

/himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Thursday, March 29, 2012 5:34 PM
To: John E Drake
Cc: [email-masked]; UTTARO, JAMES
Subject: Re: Response to some comments on IS-IS VPLS

Hi John,

Best,
R.

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Thu, 29 Mar 2012 22:46:08 +0000

BTW... I am looking for a solution too.. This is a firsthand request

-----Original Message-----
From: UTTARO, JAMES 
Sent: Thursday, March 29, 2012 6:42 PM
To: 'Shah, Himanshu'; [email-masked]; John E Drake
Cc: [email-masked]
Subject: RE: Response to some comments on IS-IS VPLS

Jim Uttaro

-----Original Message-----
From: Shah, Himanshu [mailto:[email-masked]] 
Sent: Thursday, March 29, 2012 6:39 PM
To: UTTARO, JAMES; [email-masked]; John E Drake
Cc: [email-masked]
Subject: RE: Response to some comments on IS-IS VPLS

/himanshu 

-----Original Message-----
From: UTTARO, JAMES [mailto:[email-masked]] 
Sent: Thursday, March 29, 2012 6:33 PM
To: Shah, Himanshu; [email-masked]; John E Drake
Cc: [email-masked]
Subject: RE: Response to some comments on IS-IS VPLS

Jim Uttaro

-----Original Message-----
From: Shah, Himanshu [mailto:[email-masked]] 
Sent: Thursday, March 29, 2012 6:25 PM
To: [email-masked]; John E Drake
Cc: [email-masked]; UTTARO, JAMES
Subject: RE: Response to some comments on IS-IS VPLS

I agree completely.

/himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Robert Raszuk
Sent: Thursday, March 29, 2012 5:34 PM
To: John E Drake
Cc: [email-masked]; UTTARO, JAMES
Subject: Re: Response to some comments on IS-IS VPLS

Hi John,

Best,
R.

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 30 Mar 2012 06:52:09 +0000

________________________________________
发件人: Robert Raszuk [[email-masked]]
发送时间: 2012年3月30日 5:33
到: John E Drake
Cc: UTTARO, JAMES; Xuxiaohu; [email-masked]
主题: Re: Response to some comments on IS-IS VPLS

Hi John,

[Xiaohu] I fully agree with Robert's points. There are two BGP-based VPLS (as a service): BGP/PW-based VPLS [RFC4761] and E-VPN. If somebody wonders why BGP/PW-based VPLS is not suitable for cloud data center networks, I suggest you read some related BBF tutorials talking about cloud data center network interconnect. If somebody wonders why not E-VPN, I think it'd better to ask this question to NVo3 and also ask E-VPN co-authors why they want to simplify E-VPN.

Best regards,
Xiaohu

Best,
R.

---

From: <[email-masked]>
Date: Fri, 30 Mar 2012 09:49:14 +0200

Ok. VPLS, BGP or LDP based does not appear to be the winning choice for 
the DC, and so some people look for another solution than these (e.g. 
NVO3).

Among these people some may "dislike" BGP options, but until we 
formulate precisely why, we won't be able to progress (besides, it of 
course does not mean that they necessarily want ISIS-based VPLS).

-Thomas

Shah, Himanshu  :
>> *From:[email-masked]<mailto:[email-masked]>
>> *To:* [email-masked]<mailto:[email-masked]>

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 30 Mar 2012 08:11:58 +0000

Hi Thomas,

Please see my question inline.

Best regards,
Xiaohu

________________________________________
发件人: [email-masked] [[email-masked]] 代表 [email-masked] [[email-masked]]
发送时间: 2012年3月30日 15:49
到: [email-masked]
主题: Re: Response to some comments on IS-IS VPLS

[Xiaohu] ...we won't be able to progress what? NVo3?

-Thomas

---

From: <[email-masked]>
Date: Fri, 30 Mar 2012 10:19:30 +0200

>TM:

I think it particularly applies to NVO3, but, well, the need to develop 
/why/ option XYZ is not liked, applies to any IETF discussion.

-Thomas

---

From: "Shah, Himanshu" <[email-masked]>
Date: Fri, 30 Mar 2012 04:21:52 -0400

Agree. ISIS based solution is a proposal, once we dive into understanding the requirements better,
ISIS based solution may appeal more.. (note dropping the word VPLS... :-)
/himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, March 30, 2012 3:49 AM
To: [email-masked]
Subject: Re: Response to some comments on IS-IS VPLS

-Thomas

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Fri, 30 Mar 2012 10:30:38 +0200

Have you looked at spbm and see what is wring with this? You can run it over ip pw if you want.

Cheers,
Wim
_________________
sent from blackberry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, March 30, 2012 3:49 AM
To: [email-masked]
Subject: Re: Response to some comments on IS-IS VPLS

-Thomas

---

From: sajassi <[email-masked]>
Date: Fri, 30 Mar 2012 01:43:13 -0700

Hi Robert,

I won't get into the argument of whether this kind of solution is innovation
or permutation. My point is that it is clearly outside of current L2VPN
charter and if this kind of solution is to be pursued in L2VPN WG, then it
needs to be re-chartered.

Also, if we are talking about VPLS service over IP and doing MAC learning
against IP addresses (as what this draft is talking about), I had a draft 10
years ago that cover this subject !!

http://tools.ietf.org/id/draft-sajassi-mvpls-00.txt

Cheers,
Ali

On 3/29/12 2:33 PM, "Robert Raszuk" <[email-masked]> wrote:

>> You are completely correct , but let¹s not overlook the fun factor.
>> I.e., it¹s **fun** to say that everything that has gone before sucks and
>> that the current initiative will be ³practically perfect² (c.f. ŒMary
>> Poppins¹).
>> 
>> Thanks,
>> 
>> John
>> 
>> Sent from my iPhone
>> 
>> IMHOŠ I am at a bit of a loss as to the notion that BGP is so
>> dynamic extension of a customer¹s network. I also think it would be wise
>> To build solutions based on the notion that ³I don¹t like protocol X² is
>> invalid..
>> 
>> Jim Uttaro
>>

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 30 Mar 2012 08:42:48 +0000

Hi Wim,

Would you please share a pointer to that meterial describing runing SPB-M over IP? I think that would be interesting to most of us.

Best regards,
Xiaohu
________________________________________
发件人: [email-masked] [[email-masked]] 代表 Henderickx, Wim (Wim) [[email-masked]]
发送时间: 2012年3月30日 16:30
到: [email-masked]'; [email-masked]'; [email-masked]'
主题: Re: Response to some comments on IS-IS VPLS

Cheers,
Wim
_________________
sent from blackberry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, March 30, 2012 3:49 AM
To: [email-masked]
Subject: Re: Response to some comments on IS-IS VPLS

-Thomas

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Fri, 30 Mar 2012 08:46:03 +0000

+1

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, March 30, 2012 4:20 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: Response to some comments on IS-IS VPLS

-Thomas

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Fri, 30 Mar 2012 10:47:29 +0200

There is no IETF draft on this but basically how it works is replace and ETH link with a ETH PWoIP and you can have native SPB as defined by IEEE. 

-----Original Message-----
From: Xuxiaohu [mailto:[email-masked]] 
Sent: vrijdag 30 maart 2012 10:43
To: Henderickx, Wim (Wim); [email-masked]'; [email-masked]'; [email-masked]'
Subject: re: Response to some comments on IS-IS VPLS

Hi Wim,

Best regards,
Xiaohu

Cheers,
Wim
_________________
sent from blackberry

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, March 30, 2012 3:49 AM
To: [email-masked]
Subject: Re: Response to some comments on IS-IS VPLS

-Thomas

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 30 Mar 2012 08:55:49 +0000

Hi Ali,

What's your attitude to your own draft as mentioned below from today's point of view? good or bad?

Best regards,
Xiaohu

________________________________________
发件人: [email-masked] [[email-masked]] 代表 sajassi [[email-masked]]
发送时间: 2012年3月30日 16:43
到: [email-masked]; John E Drake
Cc: [email-masked]; UTTARO, JAMES
主题: Re: Response to some comments on IS-IS VPLS

Hi Robert,

Cheers,
Ali

---

From: sajassi <[email-masked]>
Date: Fri, 30 Mar 2012 02:01:44 -0700

Xiaohu,

First, thanks for enlightening us on the definition of VPLS! I wrote the RFC
that describes the differences between VPLS as a service, VPLS as a network,
and VPLS as a LAN emulation (RFC 6136)

Second, Before talking about why BGP is not suitable for DC, I would
recommend you differentiate between different types of DC and their
requirements (e.g., EDC v.s. SPDC v.s. MSDC). Jim Uttaro is from ATT and he
is very much involved in their SPDC project.

Third, before bashing E-VPN/PBB-EVPN, I would recommend that you understand
what it is. The reason for simplification is not because of BGP !! As I
explained during the session, the reason is because when Rahul and I did the
merge between R-VPLS and MAC-VPN, the resultant draft had multiple options
of doing the same thing and we decided that over time, we will do our
due-diligence and narrow it down.

Cheers,
Ali

On 3/29/12 11:52 PM, "Xuxiaohu" <[email-masked]> wrote:

> 
> [Xiaohu] I fully agree with Robert's points. There are two BGP-based VPLS (as
> a service): BGP/PW-based VPLS [RFC4761] and E-VPN. If somebody wonders why
> BGP/PW-based VPLS is not suitable for cloud data center networks, I suggest
> you read some related BBF tutorials talking about cloud data center network
> interconnect. If somebody wonders why not E-VPN, I think it'd better to ask
> this question to NVo3 and also ask E-VPN co-authors why they want to simplify
> E-VPN.
> 
> Best regards,
> Xiaohu
> 
>

---

From: Robert Raszuk <[email-masked]>
Date: Fri, 30 Mar 2012 11:48:25 +0200

Ali,

> Third, before bashing E-VPN/PBB-EVPN, I would recommend that you
> understand what it is.

Great point indeed.

Could you share a pointer to the list which describes VM 1 on Host A's 
hypervisor to VM 2 on host B's hypervisor interconnect model for both 
above solutions just assuming that you have IP or MPLS reachability 
between such hosts ?

The requirement of my question is that any encapsulation/decapsulation 
required for such interconnection should happen on the end hosts 
(kernel, OVS, NIC etc ...) and not on the "network".

Best regards,
R.

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 30 Mar 2012 09:53:02 +0000

Hi Ali,

please see my comments inline.

________________________________________
发件人: sajassi [[email-masked]]
发送时间: 2012年3月30日 17:01
到: Xuxiaohu; [email-masked]; John E Drake
Cc: [email-masked]; [email-masked]; UTTARO, JAMES
主题: Re: Response to some comments on IS-IS VPLS

Xiaohu,

[Xiaohu] IS-IS VPLS is intended to be used in multi-tenant data centers, IMHO, which can be run either by traditional service providers or those cloud providers such as Amazon. BTW, could you please explain what MSDC means? thanks.

Xiaohu

Cheers,
Ali