Subject: PBB E-VPN and TRILL

From: Giles Heron <[email-masked]>
Date: Wed, 09 May 2012 13:34:16 +0100

Ali presented the PBB-EVPN draft at IETF83 in Paris:

http://tools.ietf.org/html/draft-ietf-l2vpn-pbb-evpn-01

This has since been updated:

http://tools.ietf.org/html/draft-ietf-l2vpn-pbb-evpn-02

During our discussions Ali mentioned that the authors would like the TRILL
section of the draft to be separated out into a separate draft.  In response
Stewart questioned whether interconnecting TRILL islands is in-scope for
L2VPN.

Stewart, Nabil and I have just been discussing these issues.  Whilst TRILL
interconnect is not explicitly in-charter for L2VPN it would appear to be
implicitly in-charter - our decision to standardise solutions for PBB VPLS
and PBB E-VPN probably sets a precedent (since PBB is also unmentioned by
the charter).

On this basis we would like to ask the WG the following three questions:

1) is the WG happy for us to pursue interconnection of TRILL islands over
L2VPN?

2) is the WG happy for the authors to split the TRILL section of the PBB
E-VPN draft into a separate draft?

3) is the WG happy for the TRILL draft to be a WG doc?

Please respond by May 22nd if you are unhappy with any of these 3 actions
(I'll take no response to mean the WG is in agreement with us proceeding...)

Giles

---

From: Lucy yong <[email-masked]>
Date: Wed, 9 May 2012 22:34:20 +0000

Here is my input.

[[LY]] Yes.

2) is the WG happy for the authors to split the TRILL section of the PBB
E-VPN draft into a separate draft?
[[LY]] Yes. So we can also consider other L2VPN solution for TRILL islands interconnection. We should consider PBB/SPB island interconnection as well.

3) is the WG happy for the TRILL draft to be a WG doc?
[[LY]] Not for TRILL technology related drafts, they belong to TRILL WG. If the draft is about interconnecting TRILL island by using L2VPN, then yes.

Regards,
Lucy

---

From: Xuxiaohu <[email-masked]>
Date: Thu, 10 May 2012 01:28:32 +0000

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Lucy
> yong
> 发送时间: 2012年5月10日 6:34
> 收件人: Giles Heron; [email-masked]
> 抄送: Ali Sajassi (sajassi); Stewart Bryant
> 主题: RE: PBB E-VPN and TRILL
> 
> Here is my input.
> 
> [[LY]] Yes. So we can also consider other L2VPN solution for TRILL islands
> interconnection. We should consider PBB/SPB island interconnection as well.
> 
> [[LY]] Not for TRILL technology related drafts, they belong to TRILL WG. If the
> draft is about interconnecting TRILL island by using L2VPN, then yes.

+1.  Based on the assumption that L2 in the context of L2VPN means MAC, rather than TRILL nickname, the draft about TRILL+PBB-EVPN may belong to a to-be-formed WG called TRILL-VPN or the existing TRILL WG if it's to be rechartered so as to include that work.

Xiaohu

---

From: Ali Sajassi <[email-masked]>
Date: Wed, 09 May 2012 23:20:40 -0700

> 1) is the WG happy for us to pursue interconnection of TRILL islands over

Yes.

> E-VPN draft into a separate draft?

Yes.

> 3) is the WG happy for the TRILL draft to be a WG doc?

Yes.

---

From: Sami Boutros <[email-masked]>
Date: Wed, 9 May 2012 23:43:20 -0700

> 1) is the WG happy for us to pursue interconnection of TRILL islands over

Sami: Yes.

> E-VPN draft into a separate draft?

Sami: Yes.

> 3) is the WG happy for the TRILL draft to be a WG doc?

Sami: Yes.

Thanks,

Sami

---

From: Mingui Zhang <[email-masked]>
Date: Thu, 10 May 2012 07:48:22 +0000

We may further separate the interconnection into two parts: communication part and TRILL part. The communication part answers what information should be exchanged among MESes and what is the encapsulation format when TRILL data is tunneled through evpn. While the TRILL part tell us how MESes (or Border RBridges) participate in TRILL. IMO, the TRILL part should be conducted in TRILL WG, since it's highly tied up to TRILL. 

The interaction between these two parts can be handled through liaison. After some liaisons, we might find it is necessary to modify the communication part due to the TRILL part. For example, I concern about the interested VLANs information propagated in LSPs in TRILL. Without this information, how can an RBridge in VLAN-x build the entries in its multicast FIB for remote RBridges in VLAN-x but in a different island? 

I am OK with the three actions if its scope is limited to the communication part.

My 2 cents,
Mingui

   > -----Original Message-----
   > From: [email-masked] [mailto:[email-masked]] On Behalf Of
   > Giles Heron
   > Sent: Wednesday, May 09, 2012 8:34 PM
   > To: [email-masked]
   > Cc: Ali Sajassi (sajassi); Stewart Bryant
   > Subject: PBB E-VPN and TRILL
   >

---

From: John E Drake <[email-masked]>
Date: Thu, 10 May 2012 05:06:02 -0700

Inline

Sent from my iPhone

>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Giles Heron
>Sent: Wednesday, May 09, 2012 5:34 AM
>To: [email-masked]
>During our discussions Ali mentioned that the authors would like the
>TRILL section of the draft to be separated out into a separate draft.
>In response Stewart questioned whether interconnecting TRILL islands is
>in-scope for L2VPN.
>
>Stewart, Nabil and I have just been discussing these issues.  Whilst
>TRILL interconnect is not explicitly in-charter for L2VPN it would
>appear to be implicitly in-charter - our decision to standardise
>solutions for PBB VPLS and PBB E-VPN probably sets a precedent (since
>PBB is also unmentioned by the charter).
>
>1) is the WG happy for us to pursue interconnection of TRILL islands
>over L2VPN?

JD:  Yes

>E-VPN draft into a separate draft?

JD:  Yes

>3) is the WG happy for the TRILL draft to be a WG doc?

JD:  Yes

>
>Please respond by May 22nd if you are unhappy with any of these 3
>actions (I'll take no response to mean the WG is in agreement with us
>proceeding...)
>
>Giles
>

---

From: "Dennis Cai (dcai)" <[email-masked]>
Date: Thu, 10 May 2012 09:02:20 -0700

Yes
Yes
Yes

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf
Of Giles Heron
Sent: Wednesday, May 09, 2012 5:34 AM
To: [email-masked]
Cc: Ali Sajassi (sajassi); Stewart Bryant (stbryant)
Subject: PBB E-VPN and TRILL

During our discussions Ali mentioned that the authors would like the
TRILL
section of the draft to be separated out into a separate draft.  In
response
Stewart questioned whether interconnecting TRILL islands is in-scope for
L2VPN.

Stewart, Nabil and I have just been discussing these issues.  Whilst
TRILL
interconnect is not explicitly in-charter for L2VPN it would appear to
be
implicitly in-charter - our decision to standardise solutions for PBB
VPLS
and PBB E-VPN probably sets a precedent (since PBB is also unmentioned
by
the charter).

over
L2VPN?

Please respond by May 22nd if you are unhappy with any of these 3
actions
(I'll take no response to mean the WG is in agreement with us
proceeding...)

Giles

---

From: "Santiago Alvarez (saalvare)" <[email-masked]>
Date: Thu, 10 May 2012 09:25:57 -0700

Yes to all three.

SA
--

> From: [email-masked] [mailto:[email-masked]] On Behalf
Of
TRILL
response
TRILL
be
VPLS
by
over
> L2VPN?
> 
> 2) is the WG happy for the authors to split the TRILL section of the
PBB E-
> VPN draft into a separate draft?
> 
actions
proceeding...)

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Thu, 10 May 2012 18:27:04 +0200

Same, yes to all 3

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Santiago Alvarez (saalvare)
Sent: donderdag 10 mei 2012 18:26
To: Giles Heron; [email-masked]
Cc: Ali Sajassi (sajassi); Stewart Bryant (stbryant)
Subject: RE: PBB E-VPN and TRILL

Yes to all three.

SA
--

Of
TRILL
response
TRILL
be
VPLS
by
over
PBB E-
actions
proceeding...)

---

From: "Shah, Himanshu" <[email-masked]>
Date: Thu, 10 May 2012 12:38:09 -0400

Yes to first 2.

As for 3rd, before we induct the stated draft as WG doc, we should consider other two proposals
mentioned in the mailing list, as part of due diligence. This is the only fair way, and in fact,
consideration to responses to third question be postponed until other proposals have been given
chance to be reviewed at the WG, IMO.

/himanshu

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Henderickx, Wim (Wim)
Sent: Thursday, May 10, 2012 12:27 PM
To: Santiago Alvarez (saalvare); Giles Heron; [email-masked]
Cc: Ali Sajassi (sajassi); Stewart Bryant (stbryant)
Subject: RE: PBB E-VPN and TRILL

Same, yes to all 3

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Santiago Alvarez (saalvare)
Sent: donderdag 10 mei 2012 18:26
To: Giles Heron; [email-masked]
Cc: Ali Sajassi (sajassi); Stewart Bryant (stbryant)
Subject: RE: PBB E-VPN and TRILL

Yes to all three.

SA
--

Of
TRILL
response
TRILL
be
VPLS
by
over
PBB E-
actions
proceeding...)

---

From: Ali Sajassi <[email-masked]>
Date: Thu, 10 May 2012 09:46:49 -0700

Himanshu,

PBB-EVPN is already a WG draft! And the TRILL portion of it has been
presented to L2VPN WG and has been in discussions for quite some time. All
we are doing is separating SPB/PBB from TRILL - nothing new is getting
added. Whereas, the other drafts are all new and they came about during last
IETF meeting.

-Ali

On 5/10/12 9:38 AM, "Shah, Himanshu" <[email-masked]> wrote:

> Henderickx, Wim (Wim)
> Santiago Alvarez (saalvare)

---

From: "Shah, Himanshu" <[email-masked]>
Date: Thu, 10 May 2012 13:03:36 -0400

Hi Ali -

Correct. 

But within the context of previous two, which questions whether to 
consider interconnecting TRILL islands via L2VPN as part of WG charter, I think you
would agree that once TRILL portion is split from your base document, 
it might be worth to check if other proposals has merits.

Saying differently, if your split TRILL doc becomes WG doc at the same time we
include this work in the charter, other proposals would have no chance to be even considered..:-(

IMHO - himanshu

-----Original Message-----
From: Ali Sajassi [mailto:[email-masked]] 
Sent: Thursday, May 10, 2012 12:47 PM
To: Shah, Himanshu; Henderickx, Wim (Wim); Santiago Alvarez (saalvare); Giles Heron; [email-masked]
Cc: Stewart Bryant (stbryant)
Subject: Re: PBB E-VPN and TRILL

Himanshu,

-Ali

---

From: Ali Sajassi <[email-masked]>
Date: Thu, 10 May 2012 10:28:23 -0700

Hi Himanshu,

I think every draft should be evaluated based on its own merits and if it is
warranted there can be several drafts on this space.

Cheers,
Ali 

On 5/10/12 10:03 AM, "Shah, Himanshu" <[email-masked]> wrote:

>> mentioned in the mailing list, as part of due diligence. This is the only
>> fair
>> way, and in fact,

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 10 May 2012 10:30:37 -0700

Giles, Nabil and Stewart,

I have couple of questions regarding the questions you posted.
Please see inline with %SAM.

-sam

1) is the WG happy for us to pursue interconnection of TRILL islands over
L2VPN?
%SAM - Connecting TRILL islands is not necessary L2 all the time. It could be IP or MPLS or something else. So, if the L2 WG charter includes connecting TRILL islands, and should be dealt in L2 WG, where should interconnecting TRILL islands over IP etc should be handled? Also, if the interconnection doesn't involve any L2VPN enhancements, but purely TRILL enhancements, should it still be in L2VPN WG scope? 
2) is the WG happy for the authors to split the TRILL section of the PBB
E-VPN draft into a separate draft?
%SAM - Yes.

3) is the WG happy for the TRILL draft to be a WG doc?
%SAM - I do not think, split document should be WG doc automatically. Both L2VPN and TRILL WG should be requested for adoption. Without the document out there, how can we consider a document to be WG document?

Giles

---

From: "Shah, Himanshu" <[email-masked]>
Date: Thu, 10 May 2012 13:45:28 -0400

I think you are partially agreeing with me :-)
We only need to give a chance for other docs to stand on its own merit.

Based on my understanding, all the proposals are considered BEFORE
one is picked (with or without consolidation) for WG doc.

Thanks,
himanshu

-----Original Message-----
From: Ali Sajassi [mailto:[email-masked]] 
Sent: Thursday, May 10, 2012 1:28 PM
To: Shah, Himanshu; Henderickx, Wim (Wim); Santiago Alvarez (saalvare); Giles Heron; [email-masked]
Cc: Stewart Bryant (stbryant)
Subject: Re: PBB E-VPN and TRILL

Hi Himanshu,

Cheers,
Ali

---

From: Ali Sajassi <[email-masked]>
Date: Thu, 10 May 2012 10:52:43 -0700

> one is picked (with or without consolidation) for WG doc.

One proposal is already part of WG draft. Would you please read the draft
and then comment.

Cheers,
Ali

---

From: "Shah, Himanshu" <[email-masked]>
Date: Thu, 10 May 2012 13:59:32 -0400

Followings are the questions...

2) is the WG happy for the authors to split the TRILL section of the PBB E-VPN draft into a separate draft?

I think we are discussing splitting the trill section as a separate draft and making it a WG doc.

What am I missing?

/himanshu

-----Original Message-----
From: Ali Sajassi [mailto:[email-masked]] 
Sent: Thursday, May 10, 2012 1:53 PM
To: Shah, Himanshu; Henderickx, Wim (Wim); Santiago Alvarez (saalvare); Giles Heron; [email-masked]
Cc: Stewart Bryant (stbryant)
Subject: Re: PBB E-VPN and TRILL

Cheers,
Ali

---

From: Ali Sajassi <[email-masked]>
Date: Thu, 10 May 2012 11:06:13 -0700

> I think we are discussing splitting the trill section as a separate draft and

Just maybe the fact that the portion that we are talking about is already
part of PBB-EVPN WG draft and has been reviewed and discussed at several
IETF meetings :-)

Cheers,
Ali

>>> To: Shah, Himanshu; Henderickx, Wim (Wim); Santiago Alvarez (saalvare);
>>> Giles
>>> Heron; [email-masked]

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 10 May 2012 11:12:43 -0700

As I mentioned in my other email, the split document should be asked for WG adoption. It may not be for pbb content but for the TRILL content it should be done. When the doc was adopted as WG doc, trill content was minimal.

Sam

Sent from my iPhone

---

From: Ali Sajassi <[email-masked]>
Date: Thu, 10 May 2012 12:41:00 -0700

When the doc was adopted as WG draft over 14 months ago, BGP route
definition and procedures for TRILL DCI were already in place.

It seems like we are having all these email exchanges for a name change of a
WG doc !!

-Ali

On 5/10/12 11:12 AM, "Sam Aldrin" <[email-masked]> wrote:

> As I mentioned in my other email, the split document should be asked for WG
> adoption. It may not be for pbb content but for the TRILL content it should be
> done. When the doc was adopted as WG doc, trill content was minimal.
> 
> Sam
> 
> Sent from my iPhone
> 
>>>> include this work in the charter, other proposals would have no chance to
>>>> be
>>>> even considered..:-(
>>>> 
>>>> IMHO - himanshu
>>>> 
>>>> 
>>>>> As for 3rd, before we induct the stated draft as WG doc, we should
>>>>> consider
>>>>> other two proposals

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 10 May 2012 12:57:55 -0700

I do not agree that It is just a name change of the document.

As far as the content goes, there is lot more to just BGP route.
All the content w.r.t unicast forwarding, multicast forwarding etc was added recently. Atleast it was not present when the document was adopted as WG one.

So, without taking groups consensus for WG adoption is not right, IMO. As the content is more TRILL specific, it should be polled within that WG as well.

-sam

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 10 May 2012 14:48:58 -0700

I withdraw my objection and support it to be a WG doc.

Misunderstood that the new document will be under TRILL WG and objected for procedural reasons. As the document is already under L2vPN and is a WG, splitting into trill specific WG doc is fine as well. In fact I am in support of most of the trill specific content, as it is the outcome of our offline discussions for a while.

Cheers
Sam

Sent from my iPad

---

From: Samer Salam <[email-masked]>
Date: Thu, 10 May 2012 17:45:12 -0700

Yes, to all three questions.

Regards,
Samer

---

From: Shishio Tsuchiya <[email-masked]>
Date: Fri, 11 May 2012 10:42:16 +0900

1)Yes.
2)Yes.
3)Yes.

Regards,
-Shishio

---

From: "Luyuan Fang (lufang)" <[email-masked]>
Date: Thu, 10 May 2012 21:04:57 -0500

Yes to all three.
Luyuan

> PBB

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 11 May 2012 02:08:07 +0000

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Ali
> Sajassi
> 发送时间: 2012年5月11日 3:41
> 收件人: Sam Aldrin; Shah, Himanshu
> 抄送: [email-masked]; Stewart Bryant (stbryant)
> 主题: Re: PBB E-VPN and TRILL
> 
> 

Maybe seldom people have paid attentions to that part at that time:) 

Now this question has been raised by the co-chairs and has obtained more attentions, whether or not this to-be-separated part belongs to L2VPN should be evaluated seriously at this time IMHO.

Xiaohu

---

From: Luay Jalil <[email-masked]>
Date: Fri, 11 May 2012 21:51:51 -0500

Yes to all 3

Regards,
Luay