Subject: PBB E-VPN and TRILL

From: Balaji Venkat Venkataswami <[email-masked]>
Date: Thu, 10 May 2012 13:03:58 +0530

Hi  Giles,

I totally agree on this point. We have a solution that was presented to the TRILL
working group as well on the interconnection of TRILL islands. We would like to 
concur with this and request for entering our draft as well into the solution space.

The URL for the TRILL draft is as follows.
http://tools.ietf.org/html/draft-balaji-trill-over-ip-multi-level-05

thanks and regards,
balaji venkat

Sent: Wednesday, May 09, 2012 6:04 PM	
To: [email-masked]
Cc: Ali Sajassi (sajassi); Stewart Bryant
Subject: PBB E-VPN and TRILL

Ali presented the PBB-EVPN draft at IETF83 in Paris:

http://tools.ietf.org/html/draft-ietf-l2vpn-pbb-evpn-01

This has since been updated:

http://tools.ietf.org/html/draft-ietf-l2vpn-pbb-evpn-02

During our discussions Ali mentioned that the authors would like the TRILL section of the draft to be separated out into a separate draft.  In response Stewart questioned whether interconnecting TRILL islands is in-scope for L2VPN.

Stewart, Nabil and I have just been discussing these issues.  Whilst TRILL interconnect is not explicitly in-charter for L2VPN it would appear to be implicitly in-charter - our decision to standardise solutions for PBB VPLS and PBB E-VPN probably sets a precedent (since PBB is also unmentioned by the charter).

On this basis we would like to ask the WG the following three questions:

1) is the WG happy for us to pursue interconnection of TRILL islands over L2VPN?

2) is the WG happy for the authors to split the TRILL section of the PBB E-VPN draft into a separate draft?

3) is the WG happy for the TRILL draft to be a WG doc?

Please respond by May 22nd if you are unhappy with any of these 3 actions (I'll take no response to mean the WG is in agreement with us proceeding...)

Giles

---

From: Lucy yong <[email-masked]>
Date: Thu, 10 May 2012 14:35:48 +0000

There is another draft to be considered.

http://tools.ietf.org/html/draft-yong-trill-trill-o-mpls-01.txt

Lucy

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Balaji Venkat Venkataswami
Sent: Thursday, May 10, 2012 2:34 AM
To: [email-masked]; [email-masked]
Cc: [email-masked]; [email-masked]
Subject: PBB E-VPN and TRILL

Hi  Giles,

thanks and regards,
balaji venkat

Giles

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 10 May 2012 13:56:56 -0400

> http://tools.ietf.org/html/draft-yong-trill-trill-o-mpls-01.txt

There are a number of drafts but I think it is useful to make a
distinction between drafts that provide full connectivity between
TRILL switches (RBridges), so that they merge into a single TRILL
campus, and drafts that provide for data plane connectivity but
limited control plane connectivity for fault isolation, etc.

TRILL switches are routers. Like IP routers they logically strip the
link envelope from TRILL frames they receive and add a new, possible
different technology, link envelope on TRILL frames they send. Just as
it is possible to have an IP routed region where none of the
connections between IP routers is Ethernet but could be, for example,
PPP, it is possible to have a TRILL campus where none of the
connections between the RBridges is Ethernet but they are all some
other technology X, such as PPP. So, drafts that are "TRILL over X"
that are talking about full TRILL data and control plan connectivity
don't really seem to me to have much to do with L2VPN. Such drafts
should be done in either the TRILL WG or in the WG that does
technology X.

It seems to me that L2VPN has to do with method that provide limited
data plane interconnection for better fault isolation.

Thanks,
Donald
=============================
 Donald E. Eastlake 3rd   +1-508-333-2270 (cell)
 155 Beaver Street, Milford, MA 01757 USA
 [email-masked]

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 10 May 2012 11:18:11 -0700

Donald, 

At the WG session it was asked whether interconnecting TRILL was in TRILL charter of not. The answer was no. So, will the charter be edited to reflect what you are eluding to below?

Sam

Sent from my iPhone

---

From: John E Drake <[email-masked]>
Date: Thu, 10 May 2012 12:06:30 -0700

Sam,

I think all that Donald is saying is that TRILL can use a multiplicity of trunking technologies (from the current charter: "but also additional ways to extend and optimize TRILL for the properties of the networks on which it is deployed.").

Thanks,

John  

Sent from my iPhone

>From: [email-masked] [mailto:[email-masked]] On Behalf
>Of Sam Aldrin
>Sent: Thursday, May 10, 2012 11:18 AM
>To: Donald Eastlake
>Cc: [email-masked]; [email-masked]
>Subject: Re: PBB E-VPN and TRILL
>
>Donald,
>
>At the WG session it was asked whether interconnecting TRILL was in
>TRILL charter of not. The answer was no. So, will the charter be edited
>to reflect what you are eluding to below?
>
>Sam
>
>Sent from my iPhone
>
>>  155 Beaver Street, Milford, MA 01757 USA  [email-masked]
>>
>>> Lucy
>>>
>>> I totally agree on this point. We have a solution that was presented
>>> to the TRILL working group as well on the interconnection of TRILL
>>> islands. We would like to concur with this and request for entering
>our draft as well into the solution space.
>>>
>>> During our discussions Ali mentioned that the authors would like the
>TRILL section of the draft to be separated out into a separate draft.
>In response Stewart questioned whether interconnecting TRILL islands is
>in-scope for L2VPN.
>>>
>>> Stewart, Nabil and I have just been discussing these issues.  Whilst
>TRILL interconnect is not explicitly in-charter for L2VPN it would
>appear to be implicitly in-charter - our decision to standardise
>solutions for PBB VPLS and PBB E-VPN probably sets a precedent (since
>PBB is also unmentioned by the charter).
>>>
>>> Please respond by May 22nd if you are unhappy with any of these 3
>>> actions (I'll take no response to mean the WG is in agreement with us
>>> proceeding...)
>>>
>>> Giles
>>>
>>>

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 10 May 2012 12:25:00 -0700

Hi John,

Thanks for the reply.

The way I understood the below sentence from the charter, when I first read, was that it includes extending TRILL by interconnecting TRILL campuses or sites. But during last WG session, it wasn't so and was contentious topic. As TRILL is L2 technology and interconnecting them falls into L2VPN charter/territory.
Which WG owns the charter for TRILL interconnect is not a major point, IMO (others may differ)
As long it is clear to the TRILL WG on where to publish the drafts related to interconnect and get reviewed/adopted, it is good. As of now, it is not clear.

cheers
-sam

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 10 May 2012 15:28:41 -0400

Hi Sam,

> At the WG session it was asked whether interconnecting TRILL was in TRILL charter of not. The answer was no. So, will the charter be edited to reflect what you are eluding to below?

I don't believe there is a charter change currently in the works. I
believe the question was more like "interconnecting TRILL islands". I
interpreted this to be the sort of limited interconnection, which
allows the islands to continue as separate islands, that is in the
current L2VPN draft.

Thanks,
Donald

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 10 May 2012 15:38:08 -0400

> The way I understood the below sentence from the charter, when I first read, was that it includes extending TRILL by interconnecting TRILL campuses or sites. But during last WG session, it wasn't s…

I do not agree that TRILL is L2 technology.

> As long it is clear to the TRILL WG on where to publish the drafts related to interconnect and get reviewed/adopted, it is good. As of now, it is not clear.

So what was wrong with my statement that "TRILL over X" drafts should
be in the TRILL WG or the X WG while it is OK for drafts that provide
limited control plane interaction between TRILL islands, like the
current L2VPN draft, to be in L2VPN? ("TRILL over X" drafts are drafts
that pretty much just tell you how to encode any TRILL Data or TRILL
Control packet over a technology X link, along with whatever security
or other precautions you should take, so as to obtain full peering and
cause the RBridges on that link, and any other fully connected
RBridges, to be part of one unified TRILL campus.)

Thanks,
Donald

---

From: John E Drake <[email-masked]>
Date: Thu, 10 May 2012 13:27:37 -0700

Don,

I was composing an email along the lines of yours, but then I realized that there are some cases which break this distinction.  Specifically, in L3VPN when the interface between CE and PE is OSPF (V2 & v3), it is possible to extend an OSPF area across an L3VPN;  i.e., the L3VPN is providing 'trunking' for a single OSPF network.  The same, in principle, could be done for IS-IS and TRILL.

So, perhaps we should add a qualifier that X can include 'L2VPN' and 'L3VPN'.

Thanks,

John

Sent from my iPhone

>From: Donald Eastlake [mailto:[email-masked]]
>Sent: Thursday, May 10, 2012 12:38 PM
>To: Sam Aldrin
>Cc: John E Drake; [email-masked]; [email-masked]
>> The way I understood the below sentence from the charter, when I first
>read, was that it includes extending TRILL by interconnecting TRILL
>campuses or sites. But during last WG session, it wasn't so and was
>contentious topic. As TRILL is L2 technology and interconnecting them
>falls into L2VPN charter/territory.
>
>> Which WG owns the charter for TRILL interconnect is not a major point,
>> IMO (others may differ) As long it is clear to the TRILL WG on where
>to publish the drafts related to interconnect and get reviewed/adopted,
>it is good. As of now, it is not clear.
>
>So what was wrong with my statement that "TRILL over X" drafts should be
>in the TRILL WG or the X WG while it is OK for drafts that provide
>Control packet over a technology X link, along with whatever security or
>other precautions you should take, so as to obtain full peering and
>cause the RBridges on that link, and any other fully connected RBridges,
>to be part of one unified TRILL campus.)
>
>Thanks,
>Donald
>>> I think all that Donald is saying is that TRILL can use a
>multiplicity of trunking technologies (from the current charter: "but
>also additional ways to extend and optimize TRILL for the properties of
>the networks on which it is deployed.").
>>>
>>> Thanks,
>>>
>>> John
>>>
>>> Sent from my iPhone
>>>
>>>> From: [email-masked] [mailto:[email-masked]] On
>>>> Behalf Of Sam Aldrin
>>>> TRILL charter of not. The answer was no. So, will the charter be
>>>> edited to reflect what you are eluding to below?
>>>>
>>>> Sam
>>>>
>>>> Sent from my iPhone
>>>>
>>>>> TRILL switches are routers. Like IP routers they logically strip
>>>>> the link envelope from TRILL frames they receive and add a new,
>>>>> possible different technology, link envelope on TRILL frames they
>>>>> send. Just as it is possible to have an IP routed region where none
>>>>> of the connections between IP routers is Ethernet but could be, for
>>>>> example, PPP, it is possible to have a TRILL campus where none of
>>>>> the connections between the RBridges is Ethernet but they are all
>>>>> some other technology X, such as PPP. So, drafts that are "TRILL
>over X"
>>>>> that are talking about full TRILL data and control plan
>>>>> connectivity don't really seem to me to have much to do with L2VPN.
>>>>> Such drafts should be done in either the TRILL WG or in the WG that
>>>>> does technology X.
>>>>>
>>>>> It seems to me that L2VPN has to do with method that provide
>>>>> limited data plane interconnection for better fault isolation.
>>>>>
>>>>> Thanks,
>>>>> Donald
>>>>>> I totally agree on this point. We have a solution that was
>>>>>> presented to the TRILL working group as well on the
>>>>>> interconnection of TRILL islands. We would like to concur with
>>>>>> this and request for entering
>>>> In response Stewart questioned whether interconnecting TRILL islands
>>>> is in-scope for L2VPN.
>>>>>>
>>>> solutions for PBB VPLS and PBB E-VPN probably sets a precedent
>>>> (since PBB is also unmentioned by the charter).
>>>>>>
>>>>>> 1) is the WG happy for us to pursue interconnection of TRILL
>>>>>> islands
>>>> over L2VPN?
>>>>>>
>>>>>> 2) is the WG happy for the authors to split the TRILL section of
>>>>>> the
>>>> PBB E-VPN draft into a separate draft?
>>>>>>

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 10 May 2012 13:59:37 -0700

Donald,

Comment inline.

Sent from my iPad

> data plane interconnection for better fault isolation.
That is incorrect. The draft specifies interconnecting trill islands. But after interconnection, it will be one big trill campus, where RBridges are apart (which is your first case). Otherwise the concept of nickname uniqueness doesn't arise. 

Sam

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 10 May 2012 14:04:27 -0700

AFAIK, there's no TRILL interconnect draft which specifies (apologies in advance if it already exists) which keeps islands separate after interconnection. Each of them requires nickname uniqueness after interconnection because it will be one big trill cloud. As I said in my other response, same with pbb-evpn draft as well.

Sam

Sent from my iPad

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 10 May 2012 14:14:21 -0700

Donald,

From what I remember, at the WG session, the question of Trill interconnect is part of the charter for trill WG session or not, arose. The answer was, no, it was not part of the charter. (I do not see minutes to reference to, so basing it on my memory). We did not split hairs whether it is trill over x or trill campus extension, at that time. If you say, interconnect of Trill(ex: draft-aldrin-trill-data-center-interconnect)  is  ok to to be part of trill WG or dependent underlying technology group, then I am fine. Just wanted to get clarified.

Sam

Sent from my iPad

On May 10, 2012, at 12:38 PM, Donald Eastlake <[email-masked]> wrote:

>>>>>> Behalf Of Balaji Venkat Venkataswami

---

From: Donald Eastlake <[email-masked]>
Date: Thu, 10 May 2012 17:54:14 -0400

Hi Sam,

On Thu, May 10, 2012 at 4:59 PM, Sam Aldrin <[email-masked]> wrote:
>> ...

Sorry, should say "control plane" immediately above.

> That is incorrect. The draft specifies interconnecting trill islands. But after interconnection, it will be one big trill campus, where RBridges are apart (which is your first case). Otherwise the…

I don't see why you think control plane interconnection is binary.
There is a spectrum of possible interconnection.

A TRILL campus is defined in the current TRILL standard as a set of
RBridges and the links between them, bounded by end stations and Layer
3 routers, over which the TRILL protocol runs. Such a set of RBridges
share the same link state database. That's an awfully long way from a
set of islands that are, for example statically configured as to what
range of nickname each can use and, at the control level, mostly just
exchange those ranges of nicknames. Just because it is a spectrum and
you can find cases in the middle does not eliminate the utility of
distinguishing between tightly coupled RBridges and more loosely
coupled islands.

Thanks,
Donald

---

From: Sam Aldrin <[email-masked]>
Date: Thu, 10 May 2012 17:31:50 -0700

Hi Donald,

See my replies inline.

Sam

Sent from my iPad

> There is a spectrum of possible interconnection.
%sam- it is because you categorized drafts into two areas. One which expands trill campus and another set to keep independent. 
> distinguishing between tightly coupled RBridges and more loosely
Spectrum type allocation is network design and trill doesn't specify or mandates any, from protocol perspective, right? If so, any solution being proposed need to consider that there could exist a trill islands which have nickname overlap. So, if they get interconnected, either they have to be resolved or maintained independently. So, the issue is not with how tight they are coupled, but rather how the end topology will be when they get interconnected. That is what I was eluding to.

Sam

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 11 May 2012 02:00:30 +0000

> -----邮件原件-----
> 发件人: [email-masked] [mailto:[email-masked]] 代表 Donald
> Eastlake
> 发送时间: 2012年5月11日 3:38
> 收件人: Sam Aldrin
> 抄送: [email-masked]; [email-masked]
> 主题: Re: PBB E-VPN and TRILL
> 
> > The way I understood the below sentence from the charter, when I first read,
> was that it includes extending TRILL by interconnecting TRILL campuses or sites.
> But during last WG session, it wasn't so and was contentious topic. As TRILL is L2
> technology and interconnecting them falls into L2VPN charter/territory.
> 

Full agree. To some extent, TRILL can be looked as IPvx in which the address is shorter than that of IPv4 and the only application over such IPvx is L2VPN services till now. Maybe it could later be extended to support L3VPN services just as what SPB did (see http://tools.ietf.org/html/draft-unbehagen-spbb-ip-ipvpn-00).  If I remembered correctly, one of the PBB-EVPN co-authors had ever claimed that "TRILL is an IP-based solution" on the L2VPN session of IETF82 (see the meeting minutes at http://tools.ietf.org/wg/l2vpn/minutes?item=minutes82.html ).

IMHO, it's incorrect to determine whether a given underlying technology is L2 or L3 just according to its upper applications, especially just according to its current applications.

I guess nobody will object that the "L2" in the context of L2VPN represents "MAC or Ethernet", especially according to the current L2VPN charter. On basis of this consensus, if the trill interconnection solution is just to use the exiting L2VPN technologies to interconnect trill RBs located in different trill islands, just like the method of using L2VPN to interconnect multiple IP routers located in different sites, it belongs to the L2VPN scope and just needs to be informational. As for the method defined in the existing PBB-EVPN draft, if I understood it correctly, it uses BGP to advertise TRILL nickname reachability info between PE routers and use TRILL nicknames, rather than MAC addresses for routing and forwarding decision on PE routers. Hence it should not belong to the L2VPN scope. By the way, I didn't see why PBB is mentioned here since PBB isn't used at all in this method. IMHO, maybe it would be better to specify that method in the E-VPN draft or more accurately in a separate draft titled like TRILL-VPN.

Best regards,
Xiaohu