Subject: Re: Minor nit with draft-jiang-l2vpn-vpls-pe-etree-05

From: Jiangyuanlong <[email-masked]>
Date: Wed, 2 May 2012 07:46:33 +0000

Hi Dave,

The document is trying to capture the generic E-Tree solution for the whole 802.1Q, rather than for 802.1aq specifically.
As you know, IEEE 802.1 can revise the general aspects of 802.1Q in any specific sub-task project (such as 802.1aq).
I must say I am somewhat puzzled at how to properly reference their E-Tree work myself...

With regard to asymmetric VLAN, I will add a note with its publishing details (It seems published as early as 2003, or did I miss something?).  

Thanks,
Yuanlong

________________________________
From: [email-masked] [mailto:[email-masked]] On Behalf Of David Allan I
Sent: Monday, April 30, 2012 2:27 PM
To: [email-masked]
Subject: Minor nit with draft-jiang-l2vpn-vpls-pe-etree-05

HI:

There is a few inaccuracies in the description of ETREE with 802.1aq SPB on page 2 of the document.

1) Asymmetic VLAN was introduced with 802.1ad, long ago.

2) It refers to 802.1ad assymetric VLAN behavior but the description associates it and its artifacts with 802.1aq.  It suggests that the VLANs are used as a filtering mechanism at root and leaf nodes (which would be true for 802.1ad), suggesting frames are delivered to a superset of the intended recipients as an artifact of the ETREE implementation. This is not true for 802.1aq, the forwarding tree construction in SPB ensures frames are only delivered to intended recipients... leaves to roots and roots to all.

I'd suggest changing the paragraph:

IEEE 802.1 originally specified a generic E-Tree solution in 802.1ad(2005). In the solution, VLANs are used to indicate root/leaf source of a packet: one VLAN ID is used to indicate the frames originated from the roots and another VLAN ID is used to indicate the frames originated from the leaves. At a leaf port, the bridge can then filter out all the frames from other leaf ports based on the VLAN ID. 802.1aq(2012) improved upon this by eliminating the filtering requirement and associated discard by properly scoping the forwarding trees for an ETREE from leaf to root and from root to all. It would be desirable that any VPLS solution reflected this improvement.

Cheers Dave

---

From: David Allan I <[email-masked]>
Date: Wed, 2 May 2012 11:47:51 -0400

Hi Yuanlong: 

> The document is trying to capture the generic E-Tree solution for the whole 802.1Q, rather than for 802.1aq specifically.

Understood, that is why I seggested the change to avoid confusion between the attributes of how ETREE is achieved in the various revisions to 802.1Q.

> As you know, IEEE 802.1 can revise the general aspects of 802.1Q in any specific sub-task project (such as 802.1aq).

Yep...

> I must say I am somewhat puzzled at how to properly reference their E-Tree work myself...

These days most of the recent amendments got rolled up in Q-rev so 802.1Q(2011) jst about covers the waterfront. 802.1aq did not complete in time.

> With regard to asymmetric VLAN, I will add a note with its publishing details (It seems published as early as 2003, or did I miss something?). 

You're right, I checked, I thought it was in an annex of 802.1ad, but it is earlier: IEEE standard 802.1Q-2003, Annex B.1.3

Cheers
Dave 

HI:

Cheers Dave