Subject: RE: EVPN: withdrawing the alias

From: Jie Dong <[email-masked]>
Date: Thu, 6 Dec 2012 03:36:20 +0000

Hi Ali, Jakob,

Here is one comment about scenario 2:

2.       If the remote PE (e.g., PE3) receives Ether AD (mass withdraw) message from PE1 first (before MAC1 route withdraw), then because of aliasing, PE3 forwards traffic to PE2 till it receives MAC1 withdraw from PE1. In which case, it removes MAC1 entry from its table and starts flooding traffic toward MAC1. This covers link/port failure scenario.
When PE2 receives the traffic to MAC1 before it advertises the MAC1 route, will it treat the traffic as unknown unicast? If so, since PE2 may not become the DF for the segment, it can not flood the traffic to the segment and the traffic will get dropped. Is this understanding correct?

Regards,
Jie

From: [email-masked] [mailto:[email-masked]] On Behalf Of Ali Sajassi (sajassi)
Sent: Friday, November 30, 2012 3:19 AM
To: Jakob Heitz
Cc: [email-masked]
Subject: Re: EVPN: withdrawing the alias

Let me summarize the operation as follow:

  1.  if the remote PE (e.g., PE3) only receives MAC1 advertisement from only one of the PE in the Multi-homing group (e.g., from PE1), then upon receiving withdraw message for this MAC1,  PE3 will flood subsequent traffic toward MAC1. This covers the scenario in which MAC1 ages out on PE1.
  2.  If the remote PE (e.g., PE3) receives Ether AD (mass withdraw) message from PE1 first (before MAC1 route withdraw), then because of aliasing, PE3 forwards traffic to PE2 till it receives MAC1 withdraw from PE1. In which case, it removes MAC1 entry from its table and starts flooding traffic toward MAC1. This covers link/port failure scenario.

More comments in line ...

From: Jakob Heitz <[email-masked]<mailto:[email-masked]>>
Date: Thursday, November 29, 2012 5:02 AM
To: Cisco Employee <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Re: EVPN: withdrawing the alias

In case of (1), PE2 will advertise MAC1 *only* if there is traffic from MAC1. This is by no means assured. In that case, if PE2 does not advertise MAC1 before PE1 withdraws it, does PE3 consider MAC1 as unknown?

Ali> yes, PE3 consider MAC1 as unknown and starts flooding traffic toward MAC1 till it learns it from PE2.

Perhaps PE1 could delay its withdrawal, or not send it at all. PE1 withdraws the Ethernet A-D. That could trigger an aging timer on PE3 for the alias.

Ali> No need to delay the withdraw. Ether AD mass-withdraw message will cause PE3 to remove aliasing and thus traffic gets forwarded to PE2 for MAC1. If MAC1 is advertised by PE2 before  MAC1 is withdrawn by PE1, then there is no flooding; otherwise, there will be little bit of flooding till PE3 learns MAC1 from PE2.

Cheers,
Ali

I propose:

If a PE has advertised an Ethernet A-D route and has advertised a MAC route covered by that Ethernet A-D route and this PE subsequently withdraws the Ethernet A-D route, then it shall not withdraw the MAC route.

If a first PE has received an Ethernet A-D route and a MAC route covered by that Ethernet A-D route from a second PE and has an alias for that MAC route from a third PE and subsequently receives a withdrawal of the Ethernet A-D route from the second PE, then the first PE shall immediately delete its MAC route to the second PE and start an aging timer to delete its alias.

--
Jakob Heitz.

On Nov 29, 2012, at 12:21 AM, "Ali Sajassi (sajassi)" <[email-masked]<mailto:[email-masked]>> wrote:

Good question! The reason that PE1 withdraws MAC1 can be:

  1.  there is a failure between MHD and PE1 (e.g., a link or port failure)
  2.  MAC1 ages out on PE1
In case of (1), PE2 will advertise MAC1 and PE3 will set its adjacency for MAC1 to PE2.
In case of (2), PE1 withdraws MAC1 but there is no advertisement by PE2. In this case, MAC1 is not reachable via either PE1 or PE2.

I think we can elaborate this on the next rev. of the draft.

Cheers,
Ali

From: Jakob Heitz <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, November 28, 2012 2:49 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: EVPN: withdrawing the alias

   Consider a CE (CE1) that is dual-homed to two PEs (PE1 and PE2) on a

   LAG interface (ES1), and is sending packets with MAC address MAC1 on

   VLAN1. MAC1 is advertised only by PE1. Both PE1 and PE2 advertise a Ethernet A-D

   route per ESI for ESI1 as well as an Ethernet A-D route per EVI for

   <ESI1, VLAN1>. A remote PE, PE3 considers MAC1 as reachable

   via both PE1 and PE2.

Now, suppose PE1 withdraws its advertisement of MAC1.
Does PE3 still consider MAC1 as reachable via PE2?
I would think not, but it's not stated in the draft.

--
Jakob Heitz. x25475. 510-566-2901

---

From: Jakob Heitz <[email-masked]>
Date: Thu, 6 Dec 2012 03:49:55 +0000

I understand the same.
Hopefully, PE2 would also receive the the withdrawal of the Ethernet Segment route
from PE1 in a timely manner and recalculate the DF.

--
Jakob Heitz.

________________________________
From: Jie Dong [mailto:[email-masked]]
Sent: Wednesday, December 05, 2012 7:36 PM
To: Ali Sajassi (sajassi); Jakob Heitz
Cc: [email-masked]
Subject: RE: EVPN: withdrawing the alias

Hi Ali, Jakob,

Regards,
Jie

Cheers,
Ali

I propose:

--
Jakob Heitz.

Cheers,
Ali

   via both PE1 and PE2.

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Thu, 6 Dec 2012 08:25:10 +0000

PE2 can receive both unicast traffic as well as flooded traffic for MAC1. If it receives unicast packets for MAC1 (via unicast LSP), then it simply forwards them to its segment. However, if it receives flooded traffic for MAC1 (via mcast LSP) and it is not DF for it, then it drops them.

Cheers,
Ali

From: Jie Dong <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 5, 2012 7:36 PM
To: Cisco Employee <[email-masked]<mailto:[email-masked]>>, Jakob Heitz <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: RE: EVPN: withdrawing the alias

Hi Ali, Jakob,

Regards,
Jie

From: [email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Ali Sajassi (sajassi)
Sent: Friday, November 30, 2012 3:19 AM
To: Jakob Heitz
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: EVPN: withdrawing the alias

More comments in line …

Cheers,
Ali

I propose:

--
Jakob Heitz.

Cheers,
Ali

   via both PE1 and PE2.

---

From: Jie Dong <[email-masked]>
Date: Thu, 6 Dec 2012 09:18:01 +0000

Hi Ali,

Thanks for your prompt response. Just want to further confirm my understanding :

If PE2 receives packets for MAC1 via unicast LSP, it can be

1)       the remote PE sends unicast packets to PE2.

2)       the remote PE floods unknown unicast packets using ingress replication.

Since the flooded traffic with ingress replication would carry the downstream assigned label which PE2 advertised in PMSI Tunnel attribute, PE2 can tell whether the packets are unicast or flooded unknown unicast, and will only forward the unicast traffic to the segment. The flooded traffic for MAC1 using ingress replication will be dropped by PE2 if it is not DF.

Regards,
Jie

From: Ali Sajassi (sajassi) [mailto:[email-masked]]
Sent: Thursday, December 06, 2012 4:25 PM
To: Jie Dong; Jakob Heitz
Cc: [email-masked]
Subject: Re: EVPN: withdrawing the alias

Cheers,
Ali

Hi Ali, Jakob,

Regards,
Jie

Cheers,
Ali

I propose:

--
Jakob Heitz.

Cheers,
Ali

   via both PE1 and PE2.

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Thu, 6 Dec 2012 17:32:06 +0000

Exactly!

Cheers
Ali

Date: Thursday, December 6, 2012 1:18 AM

Hi Ali,

Regards,
Jie

Cheers,
Ali

Hi Ali, Jakob,

Regards,
Jie

From:[email-masked]<mailto:[email-masked]> [mailto:[email-masked]] On Behalf Of Ali Sajassi (sajassi)
Sent: Friday, November 30, 2012 3:19 AM
To: Jakob Heitz
Cc: [email-masked]<mailto:[email-masked]>
Subject: Re: EVPN: withdrawing the alias

More comments in line …

Cheers,
Ali

I propose:

--
Jakob Heitz.

Cheers,
Ali

   via both PE1 and PE2.