Subject: Extended communities in EVPN

From: Jie Dong <[email-masked]>
Date: Thu, 6 Dec 2012 06:42:39 +0000

Hi,

Here are some comments about the extended communities in EVPN draft.

1.       The EVPN draft defines 4 new extended communities, all of which are defined as transitive extended communities. But I noticed that in ESI MPLS Label Extended Community, ES-Import Extended Community and MAC Mobility Extended Community, the high-order octet of the Type field is 0x44, which means non-transitive. Besides, according to IANA's registry, the type code 0x44 has been assigned to "QoS Marking" which is a regular non-transitive extended community, thus it cannot be reused as the high-order octet of an extended type.

Thus I would propose to change the type value 0x44 in evpn draft to TBA.

2.       In section 8.8,
"The value of the second octet (Sub-Type) is 0x030d (Default Gateway) as defined by IANA."

should be

"The value of the second octet (Sub-Type) is 0x0d as defined by IANA."

Best regards,
Jie

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Thu, 6 Dec 2012 08:30:02 +0000

Noted.

Thanks,
Ali

From: Jie Dong <[email-masked]<mailto:[email-masked]>>
Date: Wednesday, December 5, 2012 10:42 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Extended communities in EVPN

Hi,

1.       The EVPN draft defines 4 new extended communities, all of which are defined as transitive extended communities. But I noticed that in ESI MPLS Label Extended Community, ES-Import Extended Community and MAC Mobility Extended Community, the high-order octet of the Type field is 0x44, which means non-transitive. Besides, according to IANA’s registry, the type code 0x44 has been assigned to “QoS Marking” which is a regular non-transitive extended community, thus it cannot be reused as the high-order octet of an extended type.

2.       In section 8.8,
“The value of the second octet (Sub-Type) is 0x030d (Default Gateway) as defined by IANA.”

should be

“The value of the second octet (Sub-Type) is 0x0d as defined by IANA.”

Best regards,
Jie