Subject: RE: EVPN: ES-Import and RT-Constrain

From: Jakob Heitz <[email-masked]>
Date: Wed, 5 Dec 2012 04:38:28 +0000

Is this wrong or a good idea?
Is there a better way for ES-Import to take advantage of RT-Constrain?
Should this be a question to IDR?

--
Jakob Heitz.

________________________________
From: Jakob Heitz
Sent: Saturday, December 01, 2012 10:42 PM
To: [email-masked]
Subject: EVPN: ES-Import and RT-Constrain

Just like a route-target, the ES-Import Extended Community is used
to filter the routes that contain them. As such, they should be
able to take advantage of RT-Constrain (rfc4684).

The RT-Constrain NLRI needs no modification. All that is needed
is for an RT-Constrain implementation to add the ES-Import
as a filter criteria. A sentence in the EVPN draft as follows
should ensure that:

A BGP speaker that includes both the (AFI, SAFI) of RT-Constrain (rfc4684)
as well as of EVPN in the capabilitiy advertisement MUST apply
the RT-Constrain procedures to any ES-import extended community
it receives in the RT-Constrain Route Target Membership NLRI.

--
Jakob Heitz.

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Thu, 6 Dec 2012 08:53:15 +0000

Yes, that's the basic idea but it should be vetted in IDR.

Cheers,
Ali
________________________________
From: Jakob Heitz
Sent: Saturday, December 01, 2012 10:42 PM
To: [email-masked]<mailto:[email-masked]>
Subject: EVPN: ES-Import and RT-Constrain

--
Jakob Heitz.