Subject: Ask for comments on "draft-zhang-l2vpn-vpls-bd-tagging-01.txt"

From: Mingui Zhang <[email-masked]>
Date: Fri, 21 Feb 2014 08:39:22 +0000

Hi,

Service providers are facing a heavy provisioning overhead in VPLS since a mass of PWs need to be maintained. If PEs can use Customer VLAN ID as a service discriminator in VPLS, the required number of PWs will be greatly reduced. Therefore, the provision overhead can be significantly relieved.

Authors compose the draft to justify the solutions on recognizing Customer VLAN IDs in VPLS. We wish to receive your comments and suggestions. 

Thanks,
Mingui

>-----Original Message-----
>From: I-D-Announce [mailto:[email-masked]] On Behalf Of 
>[email-masked]
>Sent: Friday, February 14, 2014 5:10 PM
>To: [email-masked]
>Subject: I-D Action: draft-zhang-l2vpn-vpls-bd-tagging-01.txt
>
>
>A New Internet-Draft is available from the on-line Internet-Drafts directories.
>
>
>        Title           : Tagging Customer Bridge Domains in VPLS
>        Authors         : Mingui Zhang
>                          Bin Wang
>                          Liang Xia
>                          Jie Hu
>	Filename        : draft-zhang-l2vpn-vpls-bd-tagging-01.txt
>	Pages           : 8
>	Date            : 2014-02-14
>
>Abstract:
>   This document proposes to use Customer VLAN ID as a identifier for
>   traffic isolation in Virtual Private LAN Service (VPLS). In this way,
>   multiple bridge domains of customers can share a single VPLS instance
>   while their traffic are separated. With this proposal, Service
>   Providers can be relieved from the heavy provisioning overhead of
>   large number of pseudowires in the environment where a mass of bridge
>   domains need be connected.
>
>
>The IETF datatracker status page for this draft is:
>https://datatracker.ietf.org/doc/draft-zhang-l2vpn-vpls-bd-tagging/
>
>There's also a htmlized version available at:
>http://tools.ietf.org/html/draft-zhang-l2vpn-vpls-bd-tagging-01
>
>A diff from the previous version is available at:
>http://www.ietf.org/rfcdiff?url2=draft-zhang-l2vpn-vpls-bd-tagging-01
>
>
>Please note that it may take a couple of minutes from the time of 
>submission until the htmlized version and diff are available at tools.ietf.org.
>
>Internet-Drafts are also available by anonymous FTP at:
>ftp://ftp.ietf.org/internet-drafts/
>
>_______________________________________________
>I-D-Announce mailing list
>[email-masked]
>https://www.ietf.org/mailman/listinfo/i-d-announce
>Internet-Draft directories: http://www.ietf.org/shadow.html or 
>ftp://ftp.ietf.org/ietf/1shadow-sites.txt

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Fri, 21 Feb 2014 11:27:19 +0000

The assumption being that the majority of customer are building more than a two or three point VPLS domain.. My experience does not indicate that VPLS is a service that supports many endpoints per VPLS VPN. Anyway why not simply use EVPN for this purpose? There are no PWs,  traffic traverses the same LSPs used for any other service. 

Jim Uttaro

-----Original Message-----
From: L2vpn [mailto:[email-masked]] On Behalf Of Mingui Zhang
Sent: Friday, February 21, 2014 3:39 AM
To: [email-masked]
Subject: Ask for comments on "draft-zhang-l2vpn-vpls-bd-tagging-01.txt"

Hi,

Thanks,
Mingui

---

From: Jeff Tantsura <[email-masked]>
Date: Fri, 21 Feb 2014 16:19:42 +0000

I fully subscribe to Jim's point of view.

Cheers,
Jeff

-----Original Message-----
From: <UTTARO>, JAMES <[email-masked]>
Date: Friday, February 21, 2014 3:27 AM
To: Mingui Zhang <[email-masked]>, "[email-masked]"
<[email-masked]>
Subject: RE: Ask for comments on "draft-zhang-l2vpn-vpls-bd-tagging-01.txt"

>The assumption being that the majority of customer are building more than
>a two or three point VPLS domain.. My experience does not indicate that
>VPLS is a service that supports many endpoints per VPLS VPN. Anyway why
>not simply use EVPN for this purpose? There are no PWs,  traffic
>traverses the same LSPs used for any other service.
>
>Jim Uttaro
>
>Service providers are facing a heavy provisioning overhead in VPLS since
>a mass of PWs need to be maintained. If PEs can use Customer VLAN ID as a
>service discriminator in VPLS, the required number of PWs will be greatly
>reduced. Therefore, the provision overhead can be significantly relieved.
>
>Authors compose the draft to justify the solutions on recognizing
>Customer VLAN IDs in VPLS. We wish to receive your comments and
>suggestions. 
>
>Thanks,
>Mingui
>

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Fri, 21 Feb 2014 16:29:23 +0000

Two points:

1) First vlan-aware bundle service is already supported in EVPN and per
Jim's suggestion "why not simply use EVPN".

2) Second, there is already a draft published about a year and half ago to
address this issue for VPLS :-)
http://tools.ietf.org/id/draft-cai-l2vpn-vpls-vlan-aware-bundling-00.txt

Cheers,
Ali

On 2/21/14 8:19 AM, "Jeff Tantsura" <[email-masked]> wrote:

>Subject: RE: Ask for comments on
>"draft-zhang-l2vpn-vpls-bd-tagging-01.txt"
>

---

From: Mingui Zhang <[email-masked]>
Date: Sat, 22 Feb 2014 02:38:28 +0000

Hi Jim, Jeff and Ali,

Thanks for your comments! Please let me reply all your comments in this email.

1) First, I approve EVPN is a good choice. However, we cannot let all service providers wait for its coming out. The bd-tagging approach can serve as the transitional technique. Since VPLS networks are widely deployed in practice, a mass of such devices will act as legacy devices for years. So this proposal is still valid for those legacy networks. 

2) Second, I knew the draft on vlan-aware-bundling. If you read through our draft, you will find the vlan-aware-bundling proposal was included as an enabling technique. In other words, our draft is proposed to justify that kind of proposals. As you may know, besides LDP extension, some vendors also implemented the U-tag recognizing feature in VPLS utilizing VLAN Registration Protocols, such as MVRP.

The U-tag recognizing feature is required by lots of VPLS service providers. And I know vendors have already provided this feature in their VPLS products.

Thanks,
Mingui 

>From: Ali Sajassi (sajassi) [mailto:[email-masked]]
>Sent: Saturday, February 22, 2014 12:29 AM
>To: Jeff Tantsura; UTTARO, JAMES; Mingui Zhang; [email-masked]
>Subject: Re: Ask for comments on "draft-zhang-l2vpn-vpls-bd-tagging-01.txt"
>
>
>Two points:
>
>1) First vlan-aware bundle service is already supported in EVPN and per Jim's
>suggestion "why not simply use EVPN".
>
>>>The assumption being that the majority of customer are building more
>>>than a two or three point VPLS domain.. My experience does not
>>>indicate that VPLS is a service that supports many endpoints per VPLS
>>>VPN. Anyway why not simply use EVPN for this purpose? There are no
>>>PWs,  traffic traverses the same LSPs used for any other service.
>>>
>>>Jim Uttaro
>>>
>>>Service providers are facing a heavy provisioning overhead in VPLS
>>>since a mass of PWs need to be maintained. If PEs can use Customer
>>>VLAN ID as a service discriminator in VPLS, the required number of PWs
>>>will be greatly reduced. Therefore, the provision overhead can be significantly
>relieved.
>>>
>>>>From: I-D-Announce [mailto:[email-masked]] On Behalf
>>>>Of [email-masked]