Subject: Fwd: [netmod] [OPS-AREA] configuration: writable MIB modules versus NETCONF/YANG modules

From: Giles Heron <[email-masked]>
Date: Fri, 14 Feb 2014 14:49:26 +0000

Worth noting.

Giles

Begin forwarded message:

> From: Thomas Nadeau <[email-masked]>
> Subject: [netmod] Fwd: [OPS-AREA] configuration: writable MIB modules versus NETCONF/YANG modules
> Date: 14 February 2014 01:41:34 GMT
> To: [email-masked]
> 
> 
> 	FYI in case you are not on the ops dir list...
> 
> 	--Tom
> 
> 
> Begin forwarded message:
> 
>> From: Benoit Claise <[email-masked]>
>> Subject: [OPS-AREA] configuration: writable MIB modules versus NETCONF/YANG modules
>> Date: February 13, 2014 at 7:39:57 PM EST
>> To: "[email-masked]" <[email-masked]>
>> 
>> Dear all,
>> 
>> We occasionally see read-write MIB module proposals within the IETF.
>> However, the write capabilities of those MIB modules are rarely implemented.
>> 
>> While discussing this issue with the MIB doctors, we arrive to the conclusion that it's now time to set the direction for future MIB developments within the IETF. Basically, let's not specify read-write MIB modules unless we have a good reason. Read-only MIB modules are still fine though, as SNMP is clearly used for monitoring purposes.
>> 
>> Here is the statement we came up with:
>> The OPS area recommends the use of NETCONF/YANG standards for configuration. IETF working groups are therefore encouraged to use the NETCONF/YANG standards for configuration, specifically in new charters. SNMP MIB modules modifying persistent configuration state should only be produced by working groups in cases of clear utility 
>> and consensus to use SNMP write operations for configuration.
>> Ideally, this should become an IESG statement.
>> Your feedback is most welcome.
>> 
>> Regards, the MIB doctors & Benoit
>> 
>> _______________________________________________
>> OPS-AREA mailing list
>> [email-masked]
>> https://www.ietf.org/mailman/listinfo/ops-area
> 
> _______________________________________________
> netmod mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/netmod

---

From: "Rogers, Josh" <[email-masked]>
Date: Fri, 14 Feb 2014 09:58:17 -0500

It is unfortunate to see RW abandoned.  I believe that SNMP R/W is not adopted more because of poor documentation, than because SNMP is not a good configuration vehicle.  I know of one vendor that provides a "CLI to SNMP" dictionary that provides OID's for every CLI command in their cli guide.  I think if everyone did something similar,  tools that leverage SNMP R/W would be more prolific.

Honestly, I don't see netconf adopted much better (although I wish it was, its an excellent configuration vehicle).

-Josh

From: Giles Heron <[email-masked]<mailto:[email-masked]>>
Date: Friday, February 14, 2014 8:49 AM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Fwd: [netmod] [OPS-AREA] configuration: writable MIB modules versus NETCONF/YANG modules

Worth noting.

Giles

Begin forwarded message:

From: Thomas Nadeau <[email-masked]<mailto:[email-masked]>>
Subject: [netmod] Fwd: [OPS-AREA] configuration: writable MIB modules versus NETCONF/YANG modules
Date: 14 February 2014 01:41:34 GMT
To: [email-masked]<mailto:[email-masked]>

--Tom

Begin forwarded message:

From: Benoit Claise <[email-masked]<mailto:[email-masked]>>
Subject: [OPS-AREA] configuration: writable MIB modules versus NETCONF/YANG modules
Date: February 13, 2014 at 7:39:57 PM EST
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>

Dear all,

_______________________________________________
OPS-AREA mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/ops-area

_______________________________________________
netmod mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/netmod

________________________________
This E-mail and any of its attachments may contain Time Warner Cable proprietary information, which is privileged, confidential, or subject to copyright belonging to Time Warner Cable. This E-mail is intended solely for the use of the individual or entity to which it is addressed. If you are not the intended recipient of this E-mail, you are hereby notified that any dissemination, distribution, copying, or action taken in relation to the contents of and attachments to this E-mail is strictly prohibited and may be unlawful. If you have received this E-mail in error, please notify the sender immediately and permanently delete the original and any copy of this E-mail and any printout.

---

From: Giles Heron <[email-masked]>
Date: Fri, 14 Feb 2014 15:48:12 +0000

Hi Josh,

Fair comment.

I have to say though that the vast majority of the pain in shepherding the VPLS MIB has been in read-write.  IIRC the main issue was around references from one table to another where there's an implied order of creation (so if X points to Y you have to either create Y before X, or allow a "dangling reference").  NETCONF resolves a lot of that by wrapping changes into a single edit-config operation which either succeeds or fails.

Giles

On 14 Feb 2014, at 14:58, "Rogers, Josh" <[email-masked]> wrote:

> From: Giles Heron <[email-masked]>
> To: "[email-masked]" <[email-masked]>