Subject: Representation of VPLS attachment circuits in the VPLS MIB draft

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 19 May 2014 09:34:00 +0000

Hi all,
I've looked up the current version of draft-ietf-l2vpn-vpls-mib<https://datatracker.ietf.org/doc/draft-ietf-l2vpn-vpls-mib/?include_text=1> and I did not find there any explicit reference to (local) attachment circuits of VPLS. (Neither the term "attachment circuit" nor its common abbreviation "AC" appear in the text.)

At the same time, to the best of my understanding, attachment circuits form a substantial component of any VPLS instance.

Did I miss something?

If yes, could somebody please explain how one could indicate that, say, a specific VLAN on a specific Ethernet port belongs to a given VPLS instance as defined in the draft?

If not, could somebody please explain why presenting such functionality is considered unnecessary in the VPLS MIB?

Regards, lots of thanks in advance,
       Sasha
Email: [email-masked]
Mobile: 054-9266302

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 19 May 2014 10:11:13 -0400

ACs are attached to the VPLS instances and are represented as IfMIB entries. 

	--Tom

On May 19, 2014:5:34 AM, at 5:34 AM, Alexander Vainshtein <[email-masked]> wrote:

> Hi all,
> I’ve looked up the current version of draft-ietf-l2vpn-vpls-mib and I did not find there any explicit reference to (local) attachment circuits of VPLS. (Neither the term “attachment circuit” nor its common abbreviation “AC” appear in the text.)
>

---

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 19 May 2014 14:40:11 +0000

Tom,
Lots of thanks for a prompt response.

Unfortunately ACs as IfMIB entries are not mentioned anywhere in the draft.
I would expect something similar to the PW Binding table for binding ACs to a VPLS instance, but there is no such thing there.

And while the draft mentions that it uses the definitions for RFC 2863 in the text, the actual  IMPORT clauses do not list this RFC at all!

Could you please elaborate?

Regards, and lots of thanks in advance,
       Sasha
Email: [email-masked]
Mobile: 054-9266302

From: Thomas Nadeau [mailto:[email-masked]]
Sent: Monday, May 19, 2014 5:11 PM
To: Alexander Vainshtein
Cc: [email-masked]; [email-masked]; [email-masked]; Gideon Agmon; Rotem Cohen
Subject: Re: Representation of VPLS attachment circuits in the VPLS MIB draft

          --Tom

On May 19, 2014:5:34 AM, at 5:34 AM, Alexander Vainshtein <[email-masked]<mailto:[email-masked]>> wrote:

Hi all,

Did I miss something?

Regards, lots of thanks in advance,
       Sasha
Email: [email-masked]<mailto:[email-masked]>
Mobile: 054-9266302

---

From: Alexander Vainshtein <[email-masked]>
Date: Tue, 20 May 2014 15:46:30 +0000

Hi all,
This is a gentle reminder that I still have not seen any answers to my question - or, to be more specific, an answer that refers to specific objects defined in the VPLS MIB draft.
I am adding Giles (who was the shepherd of this document) and Nabil to this thread.

For the reference, the L3VPN MIB (RFC 4382<http://www.rfc-editor.org/rfc/rfc4382.txt>) defines a dedicated table (mplsL3VpnIfConfTable) that performs this functionality.

I would expect something similar in this draft, but could not find it in there.

Regards,
       Sasha

From: Alexander Vainshtein
Sent: Monday, May 19, 2014 5:40 PM
To: 'Thomas Nadeau'
Cc: [email-masked]; [email-masked]; [email-masked]; Gideon Agmon; Rotem Cohen
Subject: RE: Representation of VPLS attachment circuits in the VPLS MIB draft

Tom,

From: Thomas Nadeau [mailto:[email-masked]]
Sent: Monday, May 19, 2014 5:11 PM
To: Alexander Vainshtein
Cc: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>; Gideon Agmon; Rotem Cohen
Subject: Re: Representation of VPLS attachment circuits in the VPLS MIB draft

          --Tom

Hi all,

Did I miss something?