Subject: IPLS

From: Giles Heron <[email-masked]>
Date: Mon, 14 Jul 2014 13:08:04 +0100

Hi all,

the IPLS draft (probably the oldest draft ever to attempt to progress to RFC) was recently re-published as "historic" rather than "informational":

http://tools.ietf.org/html/draft-ietf-l2vpn-ipls-14

To that end the IANA assignments requested in the draft were also withdrawn - though they could be re-instated if the draft were ever to progress.

Based on these changes we now intend to progress this draft to RFC.

Giles

---

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 14 Jul 2014 12:09:32 +0000

Giles,
Do you intend to progress it directly to Historic RFC?

Regards,
       Sasha 
Email: [email-masked]
Mobile: 054-9266302

> -----Original Message-----
> From: L2vpn [mailto:[email-masked]] On Behalf Of Giles Heron
> Sent: Monday, July 14, 2014 3:08 PM
> To: [email-masked]
> Subject: IPLS
> 
> Hi all,
> 
> the IPLS draft (probably the oldest draft ever to attempt to progress to RFC)
> was recently re-published as "historic" rather than "informational":
> 
> To that end the IANA assignments requested in the draft were also
> withdrawn - though they could be re-instated if the draft were ever to
> progress.
>

---

From: Giles Heron <[email-masked]>
Date: Mon, 14 Jul 2014 13:10:21 +0100

Hi Sasha,

yes - I believe that's the plan.

Giles

---

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 14 Jul 2014 12:27:13 +0000

Hi Giles,
Lots of thanks for a prompt response.

I have always thought that Historic RFCs describe something that has been implemented and deployed, but new standards are now in force.
E.g., original Martini drafts (which definitely have been implemented and deployed)  have been published as Historic RFCs.

For the sake of curiosity, is this the case with IPLS?

Regards,
       Sasha 

> From: Giles Heron [mailto:[email-masked]]
> Sent: Monday, July 14, 2014 3:10 PM
> To: Alexander Vainshtein
> Cc: [email-masked]
> Subject: Re: IPLS
> 
> Hi Sasha,
> 
> On 14 Jul 2014, at 13:09, Alexander Vainshtein
> <[email-masked]> wrote:
> 
> > Giles,
> >> the IPLS draft (probably the oldest draft ever to attempt to progress
> >> to RFC) was recently re-published as "historic" rather than
> "informational":
> >>
> >> withdrawn - though they could be re-instated if the draft were ever
> >> to progress.
> >>

---

From: Loa Andersson <[email-masked]>
Date: Mon, 14 Jul 2014 15:07:38 +0200

Sasha,

hmmm - the MPLS wg pubished RFC 6348, that is a requirement document,
so in itself it has not been implemented or deployed; even if you can
problably make the argument that specification fulfilling the
requirements has.

I think that making a document is because we want it to available in
the future.

/Loa

-- 

Loa Andersson                        email: [email-masked]
Senior MPLS Expert                          [email-masked]
Huawei Technologies (consultant)     phone: +46 739 81 21 64

---

From: Alexander Vainshtein <[email-masked]>
Date: Mon, 14 Jul 2014 13:14:44 +0000

Loa,

I agree that making a document permanently available  (for some degree of permanence:-) is a valid reason for publishing it as a Historic RFC.

Regards,
       Sasha 

> From: Loa Andersson [mailto:[email-masked]]
> Sent: Monday, July 14, 2014 4:08 PM
> To: Alexander Vainshtein; Giles Heron
> Cc: [email-masked]
> Subject: Re: IPLS
> 
> Sasha,
> 
> problably make the argument that specification fulfilling the requirements
> has.
> 
> I think that making a document is because we want it to available in the
> future.
> 
> /Loa
> 
> > I have always thought that Historic RFCs describe something that has been
> implemented and deployed, but new standards are now in force.
> > E.g., original Martini drafts (which definitely have been implemented and
> deployed)  have been published as Historic RFCs.
> >
> >>>> the IPLS draft (probably the oldest draft ever to attempt to
> >>>> progress to RFC) was recently re-published as "historic" rather
> >>>> than
> >> "informational":
> >>>>

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 20 Jul 2014 14:09:48 +0100

Sasha,

Just an update...

The IESG is in the process of updating its statement on "Designating RFCs as
Historic". It includes the following text:

   An RFC may be published directly as Historic, with no earlier status to
change
   (see, for example, RFC 4870). This is usually done to document ideas that
were
   considered and discarded, or protocols that were already historic when it was
   decided to document them. Those publications are handled as are any other 
   RFCs.

Adrian

> From: L2vpn [mailto:[email-masked]] On Behalf Of Alexander Vainshtein
> Sent: 14 July 2014 14:15
> To: Loa Andersson
> Cc: [email-masked]
> Subject: RE: IPLS
> 
> Loa,
> I agree that making a document permanently available  (for some degree of
> permanence:-) is a valid reason for publishing it as a Historic RFC.
> 
> Regards,
>        Sasha

---

From: Alexander Vainshtein <[email-masked]>
Date: Sun, 20 Jul 2014 13:15:39 +0000

Adrian,
Lots of thanks for a clarification. 
Just to make it clear - I do not have any technical issues with the IPLS draft.
Publishing it as a Historic RFC in order " to document ideas that were  considered and discarded"  sounds quite reasonable to me.

Regards,
       Sasha 

> From: Adrian Farrel [mailto:[email-masked]]
> Sent: Sunday, July 20, 2014 4:10 PM
> To: Alexander Vainshtein; 'Loa Andersson'
> Cc: [email-masked]
> Subject: RE: IPLS
> 
> Sasha,
> 
> Just an update...
> 
> > > hmmm - the MPLS wg pubished RFC 6348, that is a requirement
> > > document, so in itself it has not been implemented or deployed; even
> > > if you can problably make the argument that specification fulfilling
> > > the requirements has.
> > >
> > > >>>> To that end the IANA assignments requested in the draft were
> > > >>>> also withdrawn - though they could be re-instated if the draft
> > > >>>> were ever to progress.
> > > >>>>