Subject: Two comments about draft-rabadan-l2vpn-evpn-optimized-ir-00

From: Haoweiguo <[email-masked]>
Date: Thu, 24 Jul 2014 18:25:41 +0000

Hi Jorge,

I have two comments:
1. More than one REPLICATOR scenario:
In a service where there is more than one or more REPLICATORs,
In per-flow loadbalancing mode:
Relies on LEAF’s local traffic HASH algorithm, a packet can be sent to any one of the REPLICATOR and replicated to destinations.Multicast traffic can be fully dispersed among all REPLICATORs.
In per-VNI mode:
To ensure traffic loadbalancing among multiple REPLICATORs,each REPLICATOR should announce VNI List or multicast group range to all leafs, the VN List or multicast group on each REPLICATOR is configured by operators in beforehand. For example if there are two REPLICATORs and 100 VN in NVO3 network, REPLICATOR1 can be responsible for VNI 1-50 multicast traffic forwarding, REPLICATOR2 is responsible for VNI 51-100. When a leaf receives multicast traffic from local connecting TS, if the TS belongs to VNI 1-50, the traffic will be sent to REPLICATOR1;If the TS belongs to VNI 51-100, the traffic will be sent to REPLICATOR2.
EVPN protocol should be extended to support VNI List or multicast group range advertisement.

2. Hierarchical REPLICATOR-LEAF:
Hierarchical REPLICATOR-LEAF should be supported, i.e, a device can be REPLICATOR and LEAF at the same time, for lower LAYER network, its REPLICATOR;For upper layer network, its LEAF.

Thanks

weiguo

---

From: "Rabadan, Jorge (Jorge)" <[email-masked]>
Date: Fri, 25 Jul 2014 20:19:48 +0000

Hi Weiguo,

Thank you for your comments.
Please see in-line.

From: Haoweiguo <[email-masked]<mailto:[email-masked]>>
Date: Thursday, July 24, 2014 at 11:25 AM
To: Jorge Rabadan <[email-masked]<mailto:[email-masked]>>
Cc: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>
Subject: Two comments about draft-rabadan-l2vpn-evpn-optimized-ir-00

Hi Jorge,

I have two comments:

OK. This is implementation-specific and compatible with the current draft.

In per-VNI mode:

The per-VNI mode is already possible with the current revision of the draft. The LEAF can already build a list of AR-REPLICATORs for each <evi, eth-tag> and decide how to balance. As for the multicast groups, if you refer to IP multicast streams, this is possible in the per-flow balancing mode.

We are already working in a revision that will take care of that.

Thanks

weiguo