Subject: About inter-as option-B solution between NVO3 network and EVPN network

From: Haoweiguo <[email-masked]>
Date: Tue, 22 Jul 2014 02:58:58 +0000

Hi Ali,

I think the inter-as option-B solution in our draft is different from current EVPN inter-as solution. The procedures are described as follows:

Assuming ASBR in NVO3 network is called ASBR-d, ASBR in EVPN network is called ASBR-w.

Control plane process:

1. From DC to WAN side:

MPLS VPN Label is allocated on ASBR-d per ESI per VN, the usage of the VN has no change from traditional NVO3 network,the VN has global significance; For single-homed scenario, it is allocated per NVE per VN. Incoming forwarding table is generated on ASBR-d. ASBR-d advertises the MAC/IP advertisement route with new allocated MPLS VPN Label to peer ASBR-w.

2.From WAN to DC side:

VN ID is allocated per MPLS VPN Label, the VN ID has local significance on ASBR-d.  Outgoing forwarding table is generated on ASBR-d. ASBR-d advertises the MAC/IP advertisement route with new VN ID to local NVE.

Data plane process:

1.From DC to WAN side:

When a NVE receives traffic from local TS, the NVE performs MAC lookup in local VN, then it sends the traffic to ASBR-d using NVO3 encapsulation, VN ID is the new allocated VN ID on ASBR-d, It can only have local significance on ASBR-d. ASBR-d performs NVO3 decapsulation, switch VN ID to MPLS VPN Label, then performs MPLS encapsulation and sends to peer ASBR-w.

2. From WAN to DC side:

When ASBR-d receives traffic from peer ASBR-w, ASBR-d switches MPLS VPN Label to local NVE+ VN ID and sends it to local NVE using NVO3 encapsulation. The VN ID in the NVO3 header has global significance on all NVEs.

In option-B solution, only VN ID and MPLS VPN Label switching is supported on ASBR-d, ASBR-d doesn't need to perform MAC look up, ASBR-d has more scalability.

Thanks

weiguo

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Tue, 22 Jul 2014 12:36:26 +0000

Not sure I understand what is the problem being solved by this draft?? Is it scalability??

From: L2vpn [mailto:[email-masked]] On Behalf Of Haoweiguo
Sent: Monday, July 21, 2014 10:59 PM
To: [email-masked]; [email-masked]
Cc: Vic Liu; Frank xu
Subject: About inter-as option-B solution between NVO3 network and EVPN network

Hi Ali,

Control plane process:

1. From DC to WAN side:

2.From WAN to DC side:

Data plane process:

1.From DC to WAN side:

2. From WAN to DC side:

Thanks

weiguo

---

From: Haoweiguo <[email-masked]>
Date: Tue, 22 Jul 2014 12:53:17 +0000

Yes, it is for scalability. NVO3 network and EVPN network can be inter-connected through option-A or option-B method. Option-A is back-to-back connection method, sub-interfaces associated with each MAC-VRF are created to connect two ASBRs. If there are huge number of tenants and end systems in data center,  it will impose big burden on ASBRs.

In option-B solution, only VN ID and MPLS VPN Label switching is needed on ASBR, no need to create huge number of sub-interfaces and MAC-VRFs.

EVPN base protocol provides homogenous network inter-as option-B connection method, for heterogeneous network, new technical points should be introduced, this draft describes inter-as option-B for heterogeneous network interconnection.

weiguo

________________________________
发件人: UTTARO, JAMES [[email-masked]]
发送时间: 2014年7月22日 20:36
收件人: Haoweiguo; [email-masked]'; [email-masked]'
抄送: 'Vic Liu'; Frank xu
主题: RE: About inter-as option-B solution between NVO3 network and EVPN network

Hi Ali,

Control plane process:

1. From DC to WAN side:

2.From WAN to DC side:

Data plane process:

1.From DC to WAN side:

2. From WAN to DC side:

Thanks

weiguo

---

From: "UTTARO, JAMES" <[email-masked]>
Date: Tue, 22 Jul 2014 12:59:36 +0000

I am familiar with the two existing methods Opt A and Opt B.. This already is well known and exists what does this draft do differently from what exists already?

From: Haoweiguo [mailto:[email-masked]]
Sent: Tuesday, July 22, 2014 8:53 AM
To: UTTARO, JAMES; [email-masked]'; [email-masked]'
Cc: 'Vic Liu'; Frank xu
Subject: 答复: About inter-as option-B solution between NVO3 network and EVPN network

weiguo

From: L2vpn [mailto:[email-masked]] On Behalf Of Haoweiguo
Sent: Monday, July 21, 2014 10:59 PM
To: [email-masked]<mailto:[email-masked]>; [email-masked]<mailto:[email-masked]>
Cc: Vic Liu; Frank xu
Subject: About inter-as option-B solution between NVO3 network and EVPN network

Hi Ali,

Control plane process:

1. From DC to WAN side:

2.From WAN to DC side:

Data plane process:

1.From DC to WAN side:

2. From WAN to DC side:

Thanks

weiguo

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Wed, 23 Jul 2014 05:23:39 +0000

Hi Weiguo,

As discussed in person, there is a considerable overlap between this draft and what already exist in evpn-overlay and dci-evpn-overlay. Locally-significant VNID is covered in the former and the globally-significant VNID is covered in the latter draft. If additional clarification is need, we welcome your contribution in that.

Cheers,
Ali

From: Haoweiguo <[email-masked]<mailto:[email-masked]>>
Date: Monday, July 21, 2014 10:58 PM
To: "[email-masked]<mailto:[email-masked]>" <[email-masked]<mailto:[email-masked]>>, Cisco Employee <[email-masked]<mailto:[email-masked]>>
Cc: Frank xu <[email-masked]<mailto:[email-masked]>>, Zhuangshunwan <[email-masked]<mailto:[email-masked]>>, Vic Liu <[email-masked]<mailto:[email-masked]>>
Subject: About inter-as option-B solution between NVO3 network and EVPN network

Hi Ali,

Control plane process:

1. From DC to WAN side:

2.From WAN to DC side:

Data plane process:

1.From DC to WAN side:

2. From WAN to DC side:

Thanks

weiguo