Subject: [L3sm] Considering the OAM details in draft-ietf-l3sm-l3vpn-service-model-03.txt

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 11 Mar 2016 08:43:06 -0000

Hi,

I was just reading the model and found the following fragment:

                        container oam {
                                container bfd {
                                        leaf bfd-enabled {
                                                type boolean;
                                                description
                                                 "BFD activation";
                                        }
                                        choice holdtime {
                                                case profile {
                                                        leaf profile-name {
                                                                type string;
                                                                description
                                                                 "Service
provider well
                                                                 known
profile.";
                                                        }
                                                        description
                                                                 "Service
provider well
                                                                 known
profile.";
                                                }
                                                case fixed {
                                                        leaf fixed-value {
                                                                type uint32;
                                                                units msec;
                                                                description
                                                                 "Expected
holdtime
                                                                 expressed
                                                                 in msec.";
                                                        }
                                                }
                                                description
                                                 "Choice for holdtime flavor.";
                                        }
                                        description
                                         "Container for BFD.";
                                }
                                description
                                 "Define the OAM used on the connection.";
                        }

I think that we discussed having our model not reference specific OAM
mechanisms, but that it would include generic client requirements on OAM
function.

My proposal, therefore, is to strip the mentions of BFD and end up with the
following fragment:

                        container oam {
                                leaf oam-enabled {
                                        type boolean;
                                        description
                                         "OAM activation";
                                }
                                choice holdtime {
                                        case profile {
                                                leaf profile-name {
                                                        type string;
                                                        description
                                                         "Service provider well
                                                         known profile.";
                                                }
                                                description
                                                         "Service provider well
                                                         known profile.";
                                        }
                                        case fixed {
                                                leaf fixed-value {
                                                        type uint32;
                                                        units msec;
                                                        description
                                                         "Expected holdtime
                                                         expressed
                                                         in msec.";
                                                }
                                        }
                                        description
                                         "Choice for holdtime flavor.";
                                }
                                description
                                 "Define the OAM used on the connection.";

What do you think?

Thanks,
Adrian

---

From: <[email-masked]>
Date: Fri, 11 Mar 2016 11:09:10 +0000

Hi Adrian,

As this OAM will run at the customer/provider demarcation, we need the information from the customer on the OAM technology to be used. Currently BFD was the only possibility proposed, but this can be extended to new mechanism (Ethernet OAM ...).

Brgds,

Stephane

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Friday, March 11, 2016 09:43
To: [email-masked]
Subject: [L3sm] Considering the OAM details in draft-ietf-l3sm-l3vpn-service-model-03.txt

Hi,

                        container oam {
                                container bfd {
                                        leaf bfd-enabled {
                                                type boolean;
                                                description
                                                 "BFD activation";
                                        }
                                        choice holdtime {
                                                case profile {
                                                        leaf profile-name {
                                                                type string;
                                                                description
                                                                 "Service provider well
                                                                 known profile.";
                                                        }
                                                        description
                                                                 "Service provider well
                                                                 known profile.";
                                                }
                                                case fixed {
                                                        leaf fixed-value {
                                                                type uint32;
                                                                units msec;
                                                                description
                                                                 "Expected holdtime
                                                                 expressed
                                                                 in msec.";
                                                        }
                                                }
                                                description

I think that we discussed having our model not reference specific OAM mechanisms, but that it would include generic client requirements on OAM function.

My proposal, therefore, is to strip the mentions of BFD and end up with the following fragment:

                        container oam {
                                leaf oam-enabled {
                                        type boolean;
                                        description
                                         "OAM activation";
                                }
                                choice holdtime {
                                        case profile {
                                                leaf profile-name {
                                                        type string;
                                                        description
                                                         "Service provider well
                                                         known profile.";
                                                }
                                                description
                                                         "Service provider well
                                                         known profile.";
                                        }
                                        case fixed {
                                                leaf fixed-value {
                                                        type uint32;
                                                        units msec;
                                                        description
                                                         "Expected holdtime
                                                         expressed
                                                         in msec.";
                                                }
                                        }
                                        description

What do you think?

Thanks,
Adrian

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Adrian Farrel" <[email-masked]>
Date: Sun, 13 Mar 2016 08:03:29 -0000

Yeah, I see your point which I read as "it's the customer's equipment so they
must have some say about what function it runs." 

Thanks,
Adrian

> From: [email-masked] [mailto:[email-masked]]
> Sent: 11 March 2016 11:09
> To: [email-masked]; [email-masked]
> Subject: RE: [L3sm] Considering the OAM details in
draft-ietf-l3sm-l3vpn-service-
> model-03.txt
> 
> Hi Adrian,
> 
> As this OAM will run at the customer/provider demarcation, we need the
> information from the customer on the OAM technology to be used. Currently
> BFD was the only possibility proposed, but this can be extended to new
> mechanism (Ethernet OAM ...).
> 
> Brgds,
> 
> Stephane
> 
provider well
profile.";
provider well
profile.";
holdtime
>                                                          "Service provider
well
>                                                          "Service provider
well
> ______________________________________________________________
> ___________________________________________________________
> 
> Ce message et ses pieces jointes peuvent contenir des informations
> confidentielles ou privilegiees et ne doivent donc
> a l'expediteur et le detruire ainsi que les pieces jointes. Les messages
> electroniques etant susceptibles d'alteration,
> This message and its attachments may contain confidential or privileged
> information that may be protected by law;
> If you have received this email in error, please notify the sender and delete
this
> message and its attachments.

---

From: <[email-masked]>
Date: Mon, 14 Mar 2016 08:58:31 +0000

Right,

Maybe we can rename the container to link-oam to differentiate with service-oam (end to end) which are not in the scope.

-----Original Message-----
From: Adrian Farrel [mailto:[email-masked]] 
Sent: Sunday, March 13, 2016 09:03
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: [L3sm] Considering the OAM details in draft-ietf-l3sm-l3vpn-service-model-03.txt

Yeah, I see your point which I read as "it's the customer's equipment so they must have some say about what function it runs." 

Thanks,
Adrian

> information from the customer on the OAM technology to be used. 
> Currently BFD was the only possibility proposed, but this can be 
> extended to new mechanism (Ethernet OAM ...).
> 
> Brgds,
> 
> Stephane
> 
> Subject: [L3sm] Considering the OAM details in 
> draft-ietf-l3sm-l3vpn-service- model-03.txt
> 
> Hi,
> 
provider well
profile.";
provider well
profile.";
holdtime
> mechanisms, but that it would include generic client requirements on 
> OAM function.
> 
> provider
well
> provider
well
> confidentielles ou privilegiees et ne doivent donc pas etre diffuses, 
> exploites ou copies sans autorisation. Si vous avez recu ce message 
> par erreur, veuillez le signaler a l'expediteur et le detruire ainsi 
> que les pieces jointes. Les messages electroniques etant susceptibles 
> d'alteration, Orange decline toute responsabilite si ce message a ete 
> altere, deforme ou falsifie. Merci.
> 
> This message and its attachments may contain confidential or 
> privileged information that may be protected by law; they should not 
> be distributed, used or copied without authorisation.
this