Subject: [L3sm] L3SM pending question : do we remove templates ?

From: <[email-masked]>
Date: Fri, 10 Jun 2016 07:17:46 +0000

Hi,

Concerns were raised on the list of having a template mechanism in L3SM which is orthogonal to L3SM : templates may be useful in YANG modeling globally. Moreover there may be a need to express exact rules of template application.

So the question is : is there a consensus to remove site-templates from L3SM ?

Thanks,

[Orange logo]<http://www.orange.com/>

Stephane Litkowski
Network Architect
Orange/SCE/EQUANT/OINIS/NET
Orange Expert Future Networks
phone: +33 2 23 28 49 83 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%202%2023%2028%2049%2083%20>
mobile: +33 6 37 86 97 52 <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%206%2037%2086%2097%2052%20>
[email-masked]<mailto:[email-masked]>

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Tue, 14 Jun 2016 11:31:27 +0000

As mentioned before, I fully agree that this is orthogonal.

If there was no consensus to remove site templates, perhaps the templates could be made optional, for instance by moving site-template a separate YANG data model within the I-D (e.g., by import/include)?

Michael

From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Friday, June 10, 2016 9:18 AM
To: [email-masked]
Subject: [L3sm] L3SM pending question : do we remove templates ?

Hi,

Thanks,

Stephane Litkowski
Network Architect

Thank you.

---

From: <[email-masked]>
Date: Tue, 14 Jun 2016 12:39:24 +0000

Thanks Michael,

Let's wait for other feedbacks to determine consensus.

From: Scharf, Michael (Nokia - DE) [mailto:[email-masked]]
Sent: Tuesday, June 14, 2016 13:31
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: L3SM pending question : do we remove templates ?

Michael

From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Friday, June 10, 2016 9:18 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [L3sm] L3SM pending question : do we remove templates ?

Hi,

Thanks,

Stephane Litkowski
Network Architect

Thank you.

---

From: David Ball <[email-masked]>
Date: Tue, 14 Jun 2016 13:51:36 +0100

I support removing them.

     David

On 10/06/2016 08:17, [email-masked] wrote:
>
> Hi,
>
> Concerns were raised on the list of having a template mechanism in 
> L3SM which is orthogonal to L3SM : templates may be useful in YANG 
> modeling globally. Moreover there may be a need to express exact rules 
> of template application.
>
> Orange logo <http://www.orange.com/>
>
> *Stephane Litkowski *
> Network Architect
> phone: +33 2 23 28 49 83 
> <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%202%2023%2028%2049%2083%20>
> mobile: +33 6 37 86 97 52 
> <https://monsi.sso.francetelecom.fr/index.asp?target=http%3A%2F%2Fclicvoice.sso.francetelecom.fr%2FClicvoiceV2%2FToolBar.do%3Faction%3Ddefault%26rootservice%3DSIGNATURE%26to%3D+33%206%2037%2086%2097%2052%20>
> [email-masked] <mailto:[email-masked]>
>
> _______________________________________________
> L3sm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/l3sm

-- 
David Ball
<[email-masked]>

---

From: "Tomotaki, Luis M" <[email-masked]>
Date: Tue, 14 Jun 2016 10:22:45 -0400

Stephane,
I also agree to remove the site templates.

Luis

From: L3sm [mailto:[email-masked]] On Behalf Of David Ball
Sent: Tuesday, June 14, 2016 7:52 AM
To: [email-masked]
Subject: [E] Re: [L3sm] L3SM pending question : do we remove templates ?

I support removing them.

    David

On 10/06/2016 08:17, [email-masked]<mailto:[email-masked]> wrote:
Hi,

Thanks,

<http://www.orange.com/>

Stephane Litkowski
Network Architect

Thank you.

L3sm mailing list

[email-masked]<mailto:[email-masked]>

--

David Ball

<[email-masked]><mailto:[email-masked]>