Subject: [L3sm] actual-site-start / actual-site-stop

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Wed, 1 Jun 2016 09:25:14 +0000

Hi,

Is "actual-site-start" and "actual-site-stop" indeed meant to tagged by "config true"?

If so, what is the expected behavior if this is set, either directly or by template?

Thanks

Michael

---

From: <[email-masked]>
Date: Wed, 1 Jun 2016 09:30:26 +0000

Hi Michael,

This is a mistake, these are ops state that needs to be config false.

Thanks for the catch.

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Scharf, Michael (Nokia - DE)
Sent: Wednesday, June 01, 2016 11:25
To: [email-masked]
Subject: [L3sm] actual-site-start / actual-site-stop

Hi,

Thanks

Michael

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Tue, 7 Jun 2016 10:00:55 +0000

Hi Stephane,

I see that this has been fixed in -07. Thanks. However, is ops state indeed useful in the subtree "site-templates"?

The more fundamental question is whether the template mechanism may require some further thinking. For instance:

* According to Section 5.15, "If a site has some particular parameters, specific parameters within the site MUST always override parameters derived from template." Now, what happens if the template defines a list (e.g., "cascaded-lan-prefixes")? If a requester would want to add something to a pre-defined list, does this mean that first the template list entries have to be read, then list entries have to be added by the requester, and then the merged list has to be used in the service request?

* Another example that comes into my mind is the error handling if a site cannot be added, because some parameter in the template cannot be deployed. Is this a problem of the service request or of the template?

At first sight, this sort of question may be quite independent of the modeling of a L3VPN. It seems to me that templates may have some implications on a system implementing the YANG model. 

Thanks

Michael

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, June 01, 2016 11:30 AM
To: Scharf, Michael (Nokia - DE); [email-masked]
Subject: RE: actual-site-start / actual-site-stop

Hi Michael,

Thanks for the catch.

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Scharf, Michael (Nokia - DE)
Sent: Wednesday, June 01, 2016 11:25
To: [email-masked]
Subject: [L3sm] actual-site-start / actual-site-stop

Hi,

Thanks

Michael

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Wed, 8 Jun 2016 13:42:31 +0000

Hi Michael

Pls find some inline comments.

Best Regards,

-----Original Message-----
From: Scharf, Michael (Nokia - DE) [mailto:[email-masked]] 
Sent: Tuesday, June 07, 2016 12:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: Ops state in templates?

Hi Stephane,

* According to Section 5.15, "If a site has some particular parameters, specific parameters within the site MUST always override parameters derived from template." Now, what happens if the template defines a list (e.g., "cascaded-lan-prefixes")? If a requester would want to add something to a pre-defined list, does this mean that first the template list entries have to be read, then list entries have to be added by the requester, and then the merged list has to be used in the service request?
[SLI] As override is needed, I would say that the list in the template will not be used and the local list will be.

* Another example that comes into my mind is the error handling if a site cannot be added, because some parameter in the template cannot be deployed. Is this a problem of the service request or of the template?
[SLI] Yes, but it's inherent to any template use case, it's not specific to this service model.

At first sight, this sort of question may be quite independent of the modeling of a L3VPN. It seems to me that templates may have some implications on a system implementing the YANG model. 
[SLI] I agree that defining templates at YANG level would be helpful. Do you think we should remove the template in L3VPN SM ?

Thanks

Michael

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, June 01, 2016 11:30 AM
To: Scharf, Michael (Nokia - DE); [email-masked]
Subject: RE: actual-site-start / actual-site-stop

Hi Michael,

Thanks for the catch.

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Scharf, Michael (Nokia - DE)
Sent: Wednesday, June 01, 2016 11:25
To: [email-masked]
Subject: [L3sm] actual-site-start / actual-site-stop

Hi,

Thanks

Michael

---

From: "Scharf, Michael (Nokia - DE)" <[email-masked]>
Date: Wed, 8 Jun 2016 14:45:49 +0000

As I said already, I believe that the modeling of a L3VPN and the handling of templates are by and large orthogonal problems.

And, sure, I would prefer a generic solution for the latter, since templates could have a much wider applicability. But maybe that question could be raised on the NETMOD list?

Michael

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, June 08, 2016 3:43 PM
To: Scharf, Michael (Nokia - DE); [email-masked]
Subject: RE: Ops state in templates?

Hi Michael

Best Regards,

-----Original Message-----
From: Scharf, Michael (Nokia - DE) [mailto:[email-masked]]
Sent: Tuesday, June 07, 2016 12:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: Ops state in templates?

Hi Stephane,

Thanks

Michael

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, June 01, 2016 11:30 AM
To: Scharf, Michael (Nokia - DE); [email-masked]
Subject: RE: actual-site-start / actual-site-stop

Hi Michael,

Thanks for the catch.

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Scharf, Michael (Nokia - DE)
Sent: Wednesday, June 01, 2016 11:25
To: [email-masked]
Subject: [L3sm] actual-site-start / actual-site-stop

Hi,

Thanks

Michael

---

From: <[email-masked]>
Date: Thu, 9 Jun 2016 08:34:29 +0000

I agree that they are orthogonal.

Please raise the question to netmod.

-----Original Message-----
From: Scharf, Michael (Nokia - DE) [mailto:[email-masked]] 
Sent: Wednesday, June 08, 2016 16:46
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: Ops state in templates?

Michael

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] 
Sent: Wednesday, June 08, 2016 3:43 PM
To: Scharf, Michael (Nokia - DE); [email-masked]
Subject: RE: Ops state in templates?

Hi Michael

Best Regards,

-----Original Message-----
From: Scharf, Michael (Nokia - DE) [mailto:[email-masked]]
Sent: Tuesday, June 07, 2016 12:01
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: Ops state in templates?

Hi Stephane,

Thanks

Michael

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]
Sent: Wednesday, June 01, 2016 11:30 AM
To: Scharf, Michael (Nokia - DE); [email-masked]
Subject: RE: actual-site-start / actual-site-stop

Hi Michael,

Thanks for the catch.

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Scharf, Michael (Nokia - DE)
Sent: Wednesday, June 01, 2016 11:25
To: [email-masked]
Subject: [L3sm] actual-site-start / actual-site-stop

Hi,

Thanks

Michael