Subject: [L3sm] FW: I-D Action: draft-ietf-l3sm-l3vpn-service-model-08.txt

From: Lucy yong <[email-masked]>
Date: Thu, 9 Jun 2016 17:21:11 +0000

Hi Stephane,

Thank you to address my comments/suggestions in these version.

Sn 5.1.2, The usage of cloud-access is targeted for
   public cloud.  Internet access can also be considered as a public
   cloud access service. The cloud-access container provides parameters
   for network address translation and authorization rules.

Need cloud-access container for Internet access but no need a cloud identifier for Internet access, right? Good to state out it.

One Caveat: you forget a description about the new figure under Sn 5.14.

Sn 5.14.1
   The cloud service provider or the customer itself may use our L3VPN
   service model exposed by service provider B to create the VPN
   connectivity.  We could consider that, as the NNI is shared, the
   physical connection (bearer) between CSP A and SP B already exists.
   CSPA may so request through a service model a new site creation with
   a single site-network-access (single homing used in the diagram).  As
   placement constraint, CSP A may use the existing bearer reference it
   has from SP A to force the placement of the VPN NNI on the existing
   link.

This is the case that multiple sites to share the same bearer between CSPA and SP A. This is different from subVPN case where it is related to a single site. It is important to point that out in Sn 5.2.1.1.

On page 83,
 <site>
    <site-id>CSP_B_attachment</site-id>

Should it be CSP_A to align with the example?

May consider add some description for cloud provider and SP interworking using option B and C as well. 

Thanks,
Lucy

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, June 09, 2016 3:33 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] I-D Action: draft-ietf-l3sm-l3vpn-service-model-08.txt

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the L3VPN Service Model  of the IETF.

        Title           : YANG Data Model for L3VPN service delivery
        Authors         : Stephane Litkowski
                          Rob Shakir
                          Luis Tomotaki
                          Kenichi Ogaki
                          Kevin D'Souza
	Filename        : draft-ietf-l3sm-l3vpn-service-model-08.txt
	Pages           : 156
	Date            : 2016-06-09

Abstract:
   This document defines a YANG data model that can be used to deliver a
   Layer 3 Provider Provisioned VPN service.  The document is limited to
   the BGP PE-based VPNs as described in RFC4110 and RFC4364.  This
   model is intended to be instantiated at management system to deliver
   the overall service.  This model is not a configuration model to be
   used directly on network elements.  This model provides an abstracted
   view of the Layer 3 IPVPN service configuration components.  It will
   be up to a management system to take this as an input and use
   specific configurations models to configure the different network
   elements to deliver the service.  How configuration of network
   elements is done is out of scope of the document.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-l3sm-l3vpn-service-model/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-l3sm-l3vpn-service-model-08

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-l3sm-l3vpn-service-model-08

Please note that it may take a couple of minutes from the time of submission until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

---

From: <[email-masked]>
Date: Fri, 10 Jun 2016 06:58:09 +0000

Hi Lucy,

Please find some inline comments.

-----Original Message-----
From: Lucy yong [mailto:[email-masked]] 
Sent: Thursday, June 09, 2016 19:21
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: FW: [L3sm] I-D Action: draft-ietf-l3sm-l3vpn-service-model-08.txt

Hi Stephane,

Need cloud-access container for Internet access but no need a cloud identifier for Internet access, right? Good to state out it.
[SLI] You also need to cloud-id for Internet, the SP needs to allocate a particular ID to identify an access to Internet (as for any other cloud)

One Caveat: you forget a description about the new figure under Sn 5.14.
[SLI] I added the description

Sn 5.14.1

This is the case that multiple sites to share the same bearer between CSPA and SP A. This is different from subVPN case where it is related to a single site. It is important to point that out in Sn 5.2.1.1.
[SLI] I added a new flavor site-vpn-flavor-nni and added a text for this to differentiate from regular sites.

On page 83,
 <site>

Should it be CSP_A to align with the example?
[SLI] That was a mistake, thanks.

May consider add some description for cloud provider and SP interworking using option B and C as well. 
[SLI] I added it for option B. Option C is exactly the same as option B from a service point of view, so I would like to avoid duplication.
Now the question is : do we add the appropriate modeling for option B/C ? and how ?

Thanks,
Lucy

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Thursday, June 09, 2016 3:33 AM
To: [email-masked]
Cc: [email-masked]
Subject: [L3sm] I-D Action: draft-ietf-l3sm-l3vpn-service-model-08.txt

Abstract:

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.