Subject: [L3sm] Site composed of multiple provider managed CEs

From: <[email-masked]>
Date: Wed, 7 Sep 2016 08:44:39 +0000

Hi,

We currently have an issue to handle sites composed of multiple CEs. It is at least not explained in the draft.
Without touching the model, we can assume that one site (as we have today) corresponds to one CE (in case of provider managed), so if customer wants dual CE, it should request two sites with single site network access. The issue is that provider loose information that this is a multihomed site.
Moreover in case of customer managed CE, such site could be modeled using single site and multiple site network accesses which brings some inconsistency.

If we want to be able to track multihoming, all accesses must be under the same container or having a common reference (ID or sort of .).
We also need to track the number of requested CEs and their locations, because a site could be splitted in two locations (with intra city fibers between them at customer side).
 As described in a previous email we could have :

Customer site (single location), single CE
+-----------------+
|                            |
|          CE   --------------  PE
|                 --------------- PE
|                            |
+-----------------+

Customer site (single location),Dual CE
+-----------------+ 
|                            |
|          CE   --------------  PE
|                            |
|          CE   --------------- PE
|                            |
+-----------------+

Customer site (Dual location), Dual CE
+-----------------+ 
|                            |
|          CE   --------------  PE
|                            |
+-----------------+

+-----------------+ 
|                            |
|          CE   --------------  PE
|                            |
+-----------------+

The interresting info for the SP is where to send CEs and where to terminate the bearers.
Today location information is a site information, and there is a single location per site.

One proposal could be :
- to have a list of location per site with an associated ID
- a list of requested CEs with associated location ID
- a list a site-network-accesses (that we have today) and that we map to location and requested CE ID (in case of provider managed or comanaged)

In addition to this, we created "requested-site-start" ... parameters, I wondering if it would be better to have such parameter per site-network-access rather than at site level, as customer may request control on activation per site-network-access.

Any feedback on this issue ?
 
Stephane Litkowski 
Network Architect 
Orange/SCE/EQUANT/OINIS/NET
Orange Expert Future Networks
phone: +33 2 23 28 49 83 
mobile: +33 6 37 86 97 52 
[email-masked] 

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: "Landry, Jean-Philippe" <[email-masked]>
Date: Thu, 8 Sep 2016 20:37:23 +0000

I support the suggestion being made here.

A site may be associated to a single physical location (such as a building) or may actually correspond to a more logical location (such as a campus). The relevance for the site when it comes to VPN modeling has more to do with a way to group what accesses are meant to work together to implement the connection to the VPN(s) of a given customer (primary, backup or loadsharing arrangements) as well as what user communities are getting served from that site. The exact physical locations are really relevant when we need to identify precisely where the site network accesses are terminated and help a technician find the CE routers for instance. This could mean saying what floor and what room the different CEs are located within a unique building or within different buildings on a campus site. The bottom line is there could be as many individual locations as there are site network accesses to a given logical site. Listing these potential locations under each sites and then further listing CEs and tying them to these locations works very well. In the end everything comes together when the model ties explicitly each site network access to one of the CEs. This makes it completely unambiguous whether the multiple site network accesses are connected to a single or multiple CEs.

Many thanks for the suggestion, I think it works very well.

JPL

Ps for customer managed CEs one could say tracking down sub site locations is less important but considering the SP often has to perform the physical access wiring down to the Customer managed CEs, the info could still be very relevant.

________________________
Jean-Philippe Landry, Senior Technical Architect/Architecte technique principal,
New Technology Introduction, Bell Canada
1 Alexander-Graham-Bell, E2
Verdun, QC, H3E 3B3
téléphone: (514) 391-3494
<<mailto:[email-masked]>>
https://session.collaboration.bell.ca/join/krcwz

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]
Sent: Wednesday, September 07, 2016 4:45 AM
To: [email-masked]
Subject: [L3sm] Site composed of multiple provider managed CEs

Hi,

+-----------------+
| |
| CE -------------- PE
| |
+-----------------+

One proposal could be :

Stephane Litkowski
Network Architect
Orange/SCE/EQUANT/OINIS/NET
Orange Expert Future Networks
phone: +33 2 23 28 49 83
mobile: +33 6 37 86 97 52
[email-masked]<mailto:[email-masked]>

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration, Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law; they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

_______________________________________________
L3sm mailing list
[email-masked]<mailto:[email-masked]>
https://www.ietf.org/mailman/listinfo/l3sm

---

From: <[email-masked]>
Date: Mon, 12 Sep 2016 11:20:59 +0000

Thanks Jean Philippe,

Any objection on this proposal ? If no, I will update the model and draft accordingly.

"One proposal could be :
"

From: Landry, Jean-Philippe [mailto:[email-masked]]
Sent: Thursday, September 08, 2016 22:37
To: LITKOWSKI Stephane OBS/OINIS; [email-masked]
Subject: RE: Site composed of multiple provider managed CEs

JPL

________________________

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of [email-masked]<mailto:[email-masked]>
Sent: Wednesday, September 07, 2016 4:45 AM
To: [email-masked]<mailto:[email-masked]>
Subject: [L3sm] Site composed of multiple provider managed CEs

Hi,

+-----------------+
| |
| CE -------------- PE
| |
+-----------------+

One proposal could be :

Stephane Litkowski
Network Architect