Subject: [L3sm] I-D Action: draft-ietf-l3sm-l3vpn-service-model-14.txt

From: [email-masked]
Date: Tue, 13 Sep 2016 04:05:18 -0700

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the L3VPN Service Model  of the IETF.

        Title           : YANG Data Model for L3VPN service delivery
        Authors         : Stephane Litkowski
                          Rob Shakir
                          Luis Tomotaki
                          Kenichi Ogaki
                          Kevin D'Souza
	Filename        : draft-ietf-l3sm-l3vpn-service-model-14.txt
	Pages           : 157
	Date            : 2016-09-13

Abstract:
   This document defines a YANG data model that can be used to deliver a
   Layer 3 Provider Provisioned VPN service.  The document is limited to
   the BGP PE-based VPNs as described in RFC4110 and RFC4364.  This
   model is intended to be instantiated at management system to deliver
   the overall service.  This model is not a configuration model to be
   used directly on network elements.  This model provides an abstracted
   view of the Layer 3 IPVPN service configuration components.  It will
   be up to a management system to take this as an input and use
   specific configurations models to configure the different network
   elements to deliver the service.  How configuration of network
   elements is done is out of scope of the document.

The IETF datatracker status page for this draft is:
https://datatracker.ietf.org/doc/draft-ietf-l3sm-l3vpn-service-model/

There's also a htmlized version available at:
https://tools.ietf.org/html/draft-ietf-l3sm-l3vpn-service-model-14

A diff from the previous version is available at:
https://www.ietf.org/rfcdiff?url2=draft-ietf-l3sm-l3vpn-service-model-14

Please note that it may take a couple of minutes from the time of submission
until the htmlized version and diff are available at tools.ietf.org.

Internet-Drafts are also available by anonymous FTP at:
ftp://ftp.ietf.org/internet-drafts/

---

From: Benoit Claise <[email-masked]>
Date: Wed, 14 Sep 2016 12:02:48 +0200

FYI.

http://www.claise.be/IETFYANGPageCompilation.html
[email-masked]:2178: error: XPath error: XPath syntax error
[email-masked]:2203: error: XPath error: XPath syntax error
[email-masked]:2676: error: XPath error: XPath syntax error
[email-masked]:2691: error: XPath error: XPath syntax error

To match the lines in the YANG model, click on Download the YANG model 
<http://www.claise.be/YANG-modules/[email-masked]>

Regards, B.

-------- Forwarded Message --------
Subject: 	[L3sm] I-D Action: draft-ietf-l3sm-l3vpn-service-model-14.txt
Date: 	Tue, 13 Sep 2016 04:05:18 -0700
From: 	[email-masked]
To: 	[email-masked]
CC: 	[email-masked]

Abstract:

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm
.

---

From: <[email-masked]>
Date: Wed, 14 Sep 2016 13:22:10 +0000

Thanks Benoit,

I will fix it with some other issues people mentioned to me.

It would be good to add confd validation when a YANG model draft is submitted in addition to PYANG. I don't know if it's an easy change or not ... (still not installed confd on my server :( ).

From: L3sm [mailto:[email-masked]] On Behalf Of Benoit Claise
Sent: Wednesday, September 14, 2016 12:03
To: [email-masked]
Subject: [L3sm] Fwd: I-D Action: draft-ietf-l3sm-l3vpn-service-model-14.txt

FYI.
http://www.claise.be/IETFYANGPageCompilation.html
[email-masked]:2178<mailto:[email-masked]:2178>: error: XPath error: XPath syntax error
[email-masked]:2203<mailto:[email-masked]:2203>: error: XPath error: XPath syntax error
[email-masked]:2676<mailto:[email-masked]:2676>: error: XPath error: XPath syntax error
[email-masked]:2691<mailto:[email-masked]:2691>: error: XPath error: XPath syntax error

To match the lines in the YANG model, click on Download the YANG model<http://www.claise.be/YANG-modules/[email-masked]>

Regards, B.

-------- Forwarded Message --------
Subject:

[L3sm] I-D Action: draft-ietf-l3sm-l3vpn-service-model-14.txt

Date:

Tue, 13 Sep 2016 04:05:18 -0700

From:

[email-masked]<mailto:[email-masked]>

To:

[email-masked]<mailto:[email-masked]>

CC:

[email-masked]<mailto:[email-masked]>

                          Rob Shakir

                          Luis Tomotaki

                          Kenichi Ogaki

                          Kevin D'Souza

        Pages           : 157

        Date            : 2016-09-13

Abstract:

L3sm mailing list

[email-masked]<mailto:[email-masked]>

.

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Benoit Claise <[email-masked]>
Date: Wed, 14 Sep 2016 15:38:01 +0200

On 9/14/2016 3:22 PM, [email-masked] wrote:
> It would be good to add confd validation when a YANG model draft is 
> submitted in addition to PYANG. I don’t know if it’s an easy change or 
> not … (still not installed confd on my server L).
>
I know. So many things to do, so little time.

Regards, Benoit
>
> *From:*L3sm [mailto:[email-masked]] *On Behalf Of *Benoit Claise
> *Sent:* Wednesday, September 14, 2016 12:03
> *To:* [email-masked]
> *Subject:* [L3sm] Fwd: I-D Action: 
> draft-ietf-l3sm-l3vpn-service-model-14.txt
>
> FYI.
>
> [email-masked]:2178 
> <mailto:[email-masked]:2178>: error: XPath error: 
> XPath syntax error
> [email-masked]:2203 
> <mailto:[email-masked]:2203>: error: XPath error: 
> XPath syntax error
> [email-masked]:2676 
> <mailto:[email-masked]:2676>: error: XPath error: 
> XPath syntax error
> [email-masked]:2691 
> <mailto:[email-masked]:2691>: error: XPath error: 
> XPath syntax error
>
> *Subject: *
> *Date: *
> *From: *
> [email-masked] <mailto:[email-masked]>
>
> *To: *
>
> 	
>
> [email-masked] <mailto:[email-masked]>
>
> *CC: *
>
> 	
>
> [email-masked] <mailto:[email-masked]>
>
> [email-masked] <mailto:[email-masked]>

---

From: Benoit Claise <[email-masked]>
Date: Wed, 14 Sep 2016 15:41:51 +0200

On 9/14/2016 3:38 PM, Benoit Claise wrote:
>> submitted in addition to PYANG. I don’t know if it’s an easy change 
>> or not … (still not installed confd on my server L).
>>
Forgot to mention: confdc is part of http://www.yangvalidator.com/

Regards, Benoit
>> To match the lines in the YANG model, click on Download the YANG 
>> model <http://www.claise.be/YANG-modules/[email-masked]>
>>
>> Regards, B.
>>