Subject: [L3sm] [l3sm] #23 (draft-ltsd-l3sm-l3vpn-service-model): rip-ng and direct routing protocol omissions

From: "l3sm issue tracker" <[email-masked]>
Date: Fri, 02 Sep 2016 18:32:16 -0000

#23: rip-ng  and  direct routing  protocol omissions

 The document refers to “direct” and “rip-ng” routing protocol but their
 entry is missing from the routing protocols container

 container routing-protocols {
  list routing-protocol {
  key type;

  leaf type {
   type identityref {
   base routing-protocol-type;
   }
   description
   "Type of routing protocol.";
  }

  Container …

 The base definition does list them  however.

  identity rip-ng {
  base routing-protocol-type;
  description
  "Identity for RIPng protocol type.";
  }
 .
 .
 .
  identity direct {
  base routing-protocol-type;
  description
  "Identity for direct protocol type.
  .";
  }

-- 
-------------------------------------+-------------------------------------
 Reporter:  [email-masked]         |      Owner:  draft-ltsd-l3sm-l3vpn-
     Type:  defect                   |  [email-masked]
 Priority:  trivial                  |     Status:  new
Component:  draft-ltsd-l3sm-l3vpn-   |  Milestone:
  service-model                      |    Version:
 Severity:  -                        |   Keywords:
-------------------------------------+-------------------------------------

Ticket URL: <https://trac.tools.ietf.org/wg/l3sm/trac/ticket/23>
l3sm <https://tools.ietf.org/l3sm/>

---

From: <[email-masked]>
Date: Mon, 5 Sep 2016 07:20:15 +0000

Hi,

Thanks for the catch, for rip-ng that a mistake and we need to remove the identity. Both IPv4 and IPv6 RIP instances are managed under rip identity as the rip container has AFI/SAFI information.

For protocol direct, we do not need any parameter specific container, referring to the type is enough that explains why there is no container.

I will so remove rip-ng identity.

Brgds,

-----Original Message-----
From: l3sm issue tracker [mailto:[email-masked]] 
Sent: Friday, September 02, 2016 20:32
To: [email-masked]; [email-masked]
Cc: [email-masked]
Subject: [l3sm] #23 (draft-ltsd-l3sm-l3vpn-service-model): rip-ng and direct routing protocol omissions

 The document refers to “direct” and “rip-ng” routing protocol but their  entry is missing from the routing protocols container

  leaf type {
   type identityref {

  Container …

  identity rip-ng {

-- 
-------------------------------------+----------------------------------
-------------------------------------+---
 Reporter:  [email-masked]         |      Owner:  draft-ltsd-l3sm-l3vpn-
     Type:  defect                   |  [email-masked]
 Priority:  trivial                  |     Status:  new
Component:  draft-ltsd-l3sm-l3vpn-   |  Milestone:
  service-model                      |    Version:
 Severity:  -                        |   Keywords:
-------------------------------------+----------------------------------
-------------------------------------+---

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.