Subject: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

From: Brian E Carpenter <[email-masked]>
Date: Sat, 8 Oct 2016 11:34:39 +1300

-------- Forwarded Message --------
Subject: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery
Date: Fri, 7 Oct 2016 10:55:11 +0000
From: [email-masked]
To: [email-masked]
CC: [email-masked]

Hi Brian,

I've had a look at the QoS section.

Page 72 top is related to classification:

   The order of rules is really important.  The management system
   responsible for translating those rules in network element
   configuration MUST keep the same processing order in element
   configuration.  The order of rule is defined by the "id" leaf.  The
   lowest "id" MUST be processed first.

This makes sense. I noted that there seems to be a "default" classification in the draft example, which is rule <ID>4</4> (the
final rule). I'm not a YANG expert. "Default" here is indicated by - "no classification rule" prior to assigning  a "target
class". - last rule by processing order
If that's how YANG handles a default rule, I got no comment. Otherwise my question is, whether "default" or "terminal rule"
should be indicated explicitely.

Page 72
      guaranteed-bw-percent : used to define a guaranteed amount of
      bandwidth for the class of service.  It is expressed as a
      percentage.  The guaranteed-bw-percent uses available bandwidth at
      the priority-level of the class.

This links priority levels to rate queues. I doubt that this is a general configuration. I suggest to differ between classes
based on rate queues and classes based on priority queues by a separate indicator. Only the queues based on priority queuing
need to be ranked.

Maybe, I'm worried here also because it is somewhat hard to differ what is customized and what's SP standard configuration.
Neither queue-depth nor burst sizes appear - these seem to be based on an SP standard configuration. The question to me is,
whether classes as such aren't following an SP standard and by a given class name it is set already, whether that class is
produced by priority queuing or by a rate queue. If the classes are customer defined, additional parameters like queue-depth and
policer burst sizes need to be defined (maybe WRED too).

It further may be useful to indicate a layer to which a rate refers, especially if QoS is fully customized.

This text doesn't mention metering / accounting of QoS traffic. I think it should, if classes are completely customized.

Minors

Page 72:
a device scheduling policy may be implemented both at PE and CE side on the WAN link.
                         ^^^^^^^^
"WAN link" is standard terminology for the interface of the PE to CE? "WAN access" was used on page 69. Using the same
terminology may be helpful.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: tsvwg [mailto:[email-masked]] Im Auftrag von Brian E Carpenter
Gesendet: Donnerstag, 6. Oktober 2016 21:59
An: [email-masked]
Betreff: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

Hi,

As a Gen-ART reviewer, I drew the short straw for:

https://tools.ietf.org/html/draft-ietf-l3sm-l3vpn-service-model-16

which is in IETF Last Call ending 2016-10-11:
https://mailarchive.ietf.org/arch/msg/ietf-announce/L5feYhXtLXWe-HYIZqJrBXRbNDo

I'd like to suggest that people here take a look at sections 5.12.2
(QoS) and 5.13.2 (Transport constraints) and respond to the Last Call (not to me!) if they have any concerns.

Regards
   Brian Carpenter

---

From: Qin Wu <[email-masked]>
Date: Sun, 9 Oct 2016 08:24:19 +0000

-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 Brian E Carpenter
发送时间: 2016年10月8日 6:35
收件人: [email-masked]
主题: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

-------- Forwarded Message --------
Subject: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery
Date: Fri, 7 Oct 2016 10:55:11 +0000
From: [email-masked]
To: [email-masked]
CC: [email-masked]

Hi Brian,

This makes sense. I noted that there seems to be a "default" classification in the draft example, which is rule <ID>4</4> (the final rule). I'm not a YANG expert. "Default" here is indicated by - "no classification rule" prior to assigning  a "target class". - last rule by processing order If that's how YANG handles a default rule, I got no comment. Otherwise my question is, whether "default" or "terminal rule"
should be indicated explicitely.

[Qin]: I think the rule with rule ID 4 is the last rule and doesn't need to be seen as applying default classification, if any traffic doesn't match any application or flow with 3 tuple or 5 tuples, this traffic will be classified as one traffic class with specific traffic-id, qos-classification defined in service model allows a rule with assigned target class not match either any application or any flow.

Page 72

This links priority levels to rate queues. I doubt that this is a general configuration. I suggest to differ between classes based on rate queues and classes based on priority queues by a separate indicator. Only the queues based on priority queuing need to be ranked.

Maybe, I'm worried here also because it is somewhat hard to differ what is customized and what's SP standard configuration.
Neither queue-depth nor burst sizes appear - these seem to be based on an SP standard configuration. The question to me is, whether classes as such aren't following an SP standard and by a given class name it is set already, whether that class is produced by priority queuing or by a rate queue. If the classes are customer defined, additional parameters like queue-depth and policer burst sizes need to be defined (maybe WRED too).

[Qin]: I think we have consensus to not touch full device configuration details now.
https://www.ietf.org/mail-archive/web/l3sm/current/msg00607.html

Minors

Page 72:
a device scheduling policy may be implemented both at PE and CE side on the WAN link.
                         ^^^^^^^^
"WAN link" is standard terminology for the interface of the PE to CE? "WAN access" was used on page 69. Using the same terminology may be helpful.

[Qin]: Good catch.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: tsvwg [mailto:[email-masked]] Im Auftrag von Brian E Carpenter
Gesendet: Donnerstag, 6. Oktober 2016 21:59
An: [email-masked]
Betreff: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

Hi,

Regards
   Brian Carpenter

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

---

From: <[email-masked]>
Date: Mon, 10 Oct 2016 07:29:01 +0000

Hi Qin,

Thanks. The text on QoS doesn't have to contain all details. Some questions are still open:

- the text proposes to assign a priority level to a rate queue. Why 
  are priority levels not limited to priority queues?

- Leaving out service details makes sense, if traffic classes are pre-defined.
  # if a class of service is pre-defined, no priority is required - the priority is part of 
    the class definition. I can imagine that all missing configuration details are defined 
    elsewhere within the SP domain and QoS can be configured.
  # if a class of service is customized, there's currently no text informing the reader 
    where to find the required configuration details of the customized class. 
    That could of course be out of scope, but the document should express that explicitly in 
    the text. Such a statement is missing. 

Regards, Ruediger

-----Ursprüngliche Nachricht-----
Von: Qin Wu [mailto:[email-masked]] 
Gesendet: Sonntag, 9. Oktober 2016 10:24
An: Geib, Rüdiger; [email-masked]
Cc: [email-masked]; [email-masked]
Betreff: RE: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 Brian E Carpenter
发送时间: 2016年10月8日 6:35
收件人: [email-masked]
主题: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

-------- Forwarded Message --------
Subject: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery
Date: Fri, 7 Oct 2016 10:55:11 +0000
From: [email-masked]
To: [email-masked]
CC: [email-masked]

Hi Brian,

Page 72

Minors

Page 72:

[Qin]: Good catch.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: tsvwg [mailto:[email-masked]] Im Auftrag von Brian E Carpenter
Gesendet: Donnerstag, 6. Oktober 2016 21:59
An: [email-masked]
Betreff: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

Hi,

Regards
   Brian Carpenter

---

From: <[email-masked]>
Date: Mon, 10 Oct 2016 08:22:45 +0000

Hi,

Please find some comments inline

Brgds,

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Brian E Carpenter
Sent: Saturday, October 08, 2016 00:35
To: [email-masked]
Subject: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

-------- Forwarded Message --------
Subject: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery
Date: Fri, 7 Oct 2016 10:55:11 +0000
From: [email-masked]
To: [email-masked]
CC: [email-masked]

Hi Brian,

[SLI] Customer can provide a terminal rule otherwise SP may implement a default rule that is up to its implementation. I will add a sentence for this.

Page 72

[SLI] The model enables to perform guaranteed BW at multiple priority levels.
So you can have for example a :
Q1 : priority 1
Q2 : priority 2 , bw 70%
Q3 : priority 2, bw 20%
Q4 : priority 3, bw 5%
Q5 : priority 3, bw 5%

So "WRR-like" mechanism is applied at each priority level.

Maybe, I'm worried here also because it is somewhat hard to differ what is customized and what's SP standard configuration.
Neither queue-depth nor burst sizes appear - these seem to be based on an SP standard configuration. 
[SLI] queue-depth or burst size are too low level parameters and really HW dependent. If really necessary , if we can express a maximum latency as a customer requirement for BW queues that then can be converted in queue-depth ...  but I would prefer let it for augmentation.

The question to me is, whether classes as such aren't following an SP standard and by a given class name it is set already, whether that class is produced by priority queuing or by a rate queue. If the classes are customer defined, additional parameters like queue-depth and policer burst sizes need to be defined (maybe WRED too).

Minors

Page 72:

[SLI] Fixed to WAN link everywhere.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: tsvwg [mailto:[email-masked]] Im Auftrag von Brian E Carpenter
Gesendet: Donnerstag, 6. Oktober 2016 21:59
An: [email-masked]
Betreff: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

Hi,

Regards
   Brian Carpenter

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: Qin Wu <[email-masked]>
Date: Mon, 10 Oct 2016 08:44:13 +0000

Hiya:
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2016年10月10日 15:29
收件人: Qin Wu
抄送: [email-masked]; [email-masked]; [email-masked]
主题: AW: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

Hi Qin,

[Qin]: The idea is to make traffic classes(e.g., DATA1, DATA2) with different priority have different treatment. Yes, this links to priority queues, but talking detail on priority queue touches device configuration details, which is not scope of this document, in my opinion. I do see a statement in the draft to say:
"
Priority-level can be used to define strict priority queueing.
"

[Qin]: This is exactly what standard profile is, we have PLATINUM service, GOLDEN service, BRONZE service without requiring priority.

[Qin]: I understand your concern, but we have charter said:
"
A separate process is responsible for mapping this service model onto the protocols and 
network elements depending on how the network operator chooses to realise the service.
"

Regards, Ruediger

-----Ursprüngliche Nachricht-----
Von: Qin Wu [mailto:[email-masked]] 
Gesendet: Sonntag, 9. Oktober 2016 10:24
An: Geib, Rüdiger; [email-masked]
Cc: [email-masked]; [email-masked]
Betreff: RE: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 Brian E Carpenter
发送时间: 2016年10月8日 6:35
收件人: [email-masked]
主题: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

-------- Forwarded Message --------
Subject: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery
Date: Fri, 7 Oct 2016 10:55:11 +0000
From: [email-masked]
To: [email-masked]
CC: [email-masked]

Hi Brian,

Page 72

Minors

Page 72:

[Qin]: Good catch.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: tsvwg [mailto:[email-masked]] Im Auftrag von Brian E Carpenter
Gesendet: Donnerstag, 6. Oktober 2016 21:59
An: [email-masked]
Betreff: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

Hi,

Regards
   Brian Carpenter

---

From: <[email-masked]>
Date: Mon, 10 Oct 2016 08:45:12 +0000

Hi Stephane,

Thanks for your response. I'll focus on one aspect, picking up the bandwidth share and priority of your example:

Assume Q1, Q2 and Q5 not to carry any traffic. Q4 is a rate Queue carrying 3% traffic. Q3 is a rate queue carrying 100% traffic. That means in your example that all traffic of Q4 is dropped, because Q3 has a higher priority?

If yes - if possible at all, a lot of knobs are required to configure that by rate queues, especially if you have many different priority levels for them. 

Should the answer be that Q4 will see 3% throughput and Q3 97%, that's straightforward in configuration with rate queues. Should this hold, the priority is meaningless for the rate queues.

I'd like to understand if special equipment or sophisticated configuration experience is required to set up the services specified by the document.

Regards,

Ruediger

#######################

Page 72

[RG] This links priority levels to rate queues. I doubt that this is a 
general configuration. I suggest to differ between classes based on rate
queues and classes based on priority queues by a separate indicator. 
Only the queues based on priority queuing need to be ranked.

[SLI] So "WRR-like" mechanism is applied at each priority level.

---

From: <[email-masked]>
Date: Mon, 10 Oct 2016 09:00:14 +0000

Hi Qin,

I've replied to Stephane related to priority combined with rate queues.

Your document mentions many times that details are out of scope in different chapters, but doesn't do so in the QoS and service section. Please maintain your philosophy in the same way throughout the document:

- there's no need to mention that details are out of scope, because the reader 
  of your document is aware of the WG charter. Then remove the "out of scope" 
  statements related to missing details elsewhere.

- or add an "out of scope" statement wherever it is clear that the information 
  of the model is insufficient for service configuration. Such a statement is 
  missing in the QoS section.

I prefer the latter.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: Qin Wu [mailto:[email-masked]] 
Gesendet: Montag, 10. Oktober 2016 10:44
An: Geib, Rüdiger
Cc: [email-masked]; [email-masked]; [email-masked]
Betreff: RE: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

Hiya:
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2016年10月10日 15:29
收件人: Qin Wu
抄送: [email-masked]; [email-masked]; [email-masked]
主题: AW: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

Hi Qin,

[Qin]: I understand your concern, but we have charter said:
"
A separate process is responsible for mapping this service model onto the protocols and network elements depending on how the network operator chooses to realise the service.
"

Regards, Ruediger

-----Ursprüngliche Nachricht-----
Von: Qin Wu [mailto:[email-masked]]
Gesendet: Sonntag, 9. Oktober 2016 10:24
An: Geib, Rüdiger; [email-masked]
Cc: [email-masked]; [email-masked]
Betreff: RE: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 Brian E Carpenter
发送时间: 2016年10月8日 6:35
收件人: [email-masked]
主题: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

-------- Forwarded Message --------
Subject: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery
Date: Fri, 7 Oct 2016 10:55:11 +0000
From: [email-masked]
To: [email-masked]
CC: [email-masked]

Hi Brian,

Page 72

Minors

Page 72:

[Qin]: Good catch.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: tsvwg [mailto:[email-masked]] Im Auftrag von Brian E Carpenter
Gesendet: Donnerstag, 6. Oktober 2016 21:59
An: [email-masked]
Betreff: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

Hi,

Regards
   Brian Carpenter

---

From: Qin Wu <[email-masked]>
Date: Mon, 10 Oct 2016 09:22:08 +0000

Ruediger:
Thank for your response and proposal. I tend to agree with you. This is a very good discussion.

-Qin
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]] 
发送时间: 2016年10月10日 17:00
收件人: Qin Wu
抄送: [email-masked]; [email-masked]; [email-masked]
主题: AW: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

Hi Qin,

- or add an "out of scope" statement wherever it is clear that the information 
  of the model is insufficient for configuration. Such a statement is 
  missing in the QoS section.

I prefer the latter.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: Qin Wu [mailto:[email-masked]] 
Gesendet: Montag, 10. Oktober 2016 10:44
An: Geib, Rüdiger
Cc: [email-masked]; [email-masked]; [email-masked]
Betreff: RE: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

Hiya:
-----邮件原件-----
发件人: [email-masked] [mailto:[email-masked]]
发送时间: 2016年10月10日 15:29
收件人: Qin Wu
抄送: [email-masked]; [email-masked]; [email-masked]
主题: AW: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

Hi Qin,

Regards, Ruediger

-----Ursprüngliche Nachricht-----
Von: Qin Wu [mailto:[email-masked]]
Gesendet: Sonntag, 9. Oktober 2016 10:24
An: Geib, Rüdiger; [email-masked]
Cc: [email-masked]; [email-masked]
Betreff: RE: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

-----邮件原件-----
发件人: L3sm [mailto:[email-masked]] 代表 Brian E Carpenter
发送时间: 2016年10月8日 6:35
收件人: [email-masked]
主题: [L3sm] Fwd: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

-------- Forwarded Message --------
Subject: AW: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery
Date: Fri, 7 Oct 2016 10:55:11 +0000
From: [email-masked]
To: [email-masked]
CC: [email-masked]

Hi Brian,

Page 72

Minors

Page 72:

[Qin]: Good catch.

Regards,

Ruediger

-----Ursprüngliche Nachricht-----
Von: tsvwg [mailto:[email-masked]] Im Auftrag von Brian E Carpenter
Gesendet: Donnerstag, 6. Oktober 2016 21:59
An: [email-masked]
Betreff: [tsvwg] draft-ietf-l3sm-l3vpn-service-model-16 - YANG Data Model for L3VPN service delivery

Hi,

Regards
   Brian Carpenter