Subject: [L3sm] Alexey Melnikov's No Objection on draft-ietf-l3sm-l3vpn-service-model-18: (with COMMENT)

From: "Alexey Melnikov" <[email-masked]>
Date: Tue, 25 Oct 2016 07:24:58 -0700

Alexey Melnikov has entered the following ballot position for
draft-ietf-l3sm-l3vpn-service-model-18: No Objection

When responding, please keep the subject line intact and reply to all
email addresses included in the To and CC lines. (Feel free to cut this
introductory paragraph, however.)

Please refer to https://www.ietf.org/iesg/statement/discuss-criteria.html
for more information about IESG DISCUSS and COMMENT positions.

The document, along with other ballot positions, can be found here:
https://datatracker.ietf.org/doc/draft-ietf-l3sm-l3vpn-service-model/

----------------------------------------------------------------------
COMMENT:
----------------------------------------------------------------------

This is generally a well written document, so only a couple of nits:

leaf country-code {
        type string;
        description
         "Country of the site.";
       }

2 letter country codes? 3 letted country codes? Please add a normative
reference. (I think you meant 2-letter ISO country codes.)

14.2.  Informative References

   [I-D.ietf-netconf-restconf]
              Bierman, A., Bjorklund, M., and K. Watsen, "RESTCONF
              Protocol", draft-ietf-netconf-restconf-17 (work in
              progress), September 2016.

This should be Normative due to RFC 2119 language used when mentioning
RESTCONF. However it doesn't look like RESTCONF needs any normative
language when mentioned. For example:

The configuration of network elements MAY be done by CLI,
   or by NETCONF ([RFC6241])/RESTCONF ([I-D.ietf-netconf-restconf])
   coupled with specific configuration YANG data models (BGP, VRF, BFD
   ...) or any other way.

I don't think use of MAY is correct here, because it is not an
implementation choice that affects use of your document. I would just
change "MAY" to "can".

There is another similar use later in the document.

---

From: <[email-masked]>
Date: Tue, 25 Oct 2016 15:05:18 +0000

Hi, 

I agree with your comments and I will take them into account in the next revision.

Best Regards,

-----Original Message-----
From: Alexey Melnikov [mailto:[email-masked]] 
Sent: Tuesday, October 25, 2016 16:25
To: The IESG
Cc: [email-masked]; Qin Wu; [email-masked]; [email-masked]; [email-masked]
Subject: Alexey Melnikov's No Objection on draft-ietf-l3sm-l3vpn-service-model-18: (with COMMENT)

When responding, please keep the subject line intact and reply to all email addresses included in the To and CC lines. (Feel free to cut this introductory paragraph, however.)

leaf country-code {
        type string;
        description
         "Country of the site.";
       }

2 letter country codes? 3 letted country codes? Please add a normative reference. (I think you meant 2-letter ISO country codes.)

This should be Normative due to RFC 2119 language used when mentioning RESTCONF. However it doesn't look like RESTCONF needs any normative language when mentioned. For example:

I don't think use of MAY is correct here, because it is not an implementation choice that affects use of your document. I would just change "MAY" to "can".

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, Orange is not liable for messages that have been modified, changed or falsified.
Thank you.