Subject: [L3sm] RFC 8049 on YANG Data Model for L3VPN Service Delivery

From: "Adrian Farrel" <[email-masked]>
Date: Thu, 23 Feb 2017 10:15:53 -0000

Thanks to all of you for helping to complete this work.
Special thanks (of course) to the authors and contributors.
And massive thanks to Stephane who was relentless in making the minor edits for
the many different phases of "final" review.

Adrian

> -----Original Message-----
> From: L3sm [mailto:[email-masked]] On Behalf Of rfc-editor@rfc-
> editor.org
> Sent: 23 February 2017 00:26
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: [L3sm] RFC 8049 on YANG Data Model for L3VPN Service Delivery
> 
> A new Request for Comments is now available in online RFC libraries.
> 
> 
>         RFC 8049
> 
>         Title:      YANG Data Model for L3VPN
>                     Service Delivery
>         Author:     S. Litkowski, L. Tomotaki, K. Ogaki
>         Status:     Standards Track
>         Stream:     IETF
>         Date:       February 2017
>         Mailbox:    [email-masked],
>                     [email-masked],
>                     [email-masked]
>         Pages:      157
>         Characters: 272974
>         Updates/Obsoletes/SeeAlso:   None
> 
>         I-D Tag:    draft-ietf-l3sm-l3vpn-service-model-19.txt
> 
>         URL:        https://www.rfc-editor.org/info/rfc8049
> 
>         DOI:        10.17487/RFC8049
> 
> This document defines a YANG data model that can be used for
> communication between customers and network operators and to deliver
> a Layer 3 provider-provisioned VPN service.  This document is limited
> to BGP PE-based VPNs as described in RFCs 4026, 4110, and 4364.  This
> model is intended to be instantiated at the management system to
> deliver the overall service.  It is not a configuration model to be
> used directly on network elements.  This model provides an abstracted
> view of the Layer 3 IP VPN service configuration components.  It will
> be up to the management system to take this model as input and use
> specific configuration models to configure the different network
> elements to deliver the service.  How the configuration of network
> elements is done is out of scope for this document.
> 
> This document is a product of the L3VPN Service Model Working Group of the
> IETF.
> 
> This is now a Proposed Standard.
> 
> STANDARDS TRACK: This document specifies an Internet Standards Track
> protocol for the Internet community, and requests discussion and suggestions
> for improvements.  Please refer to the current edition of the Official
> Internet Protocol Standards (https://www.rfc-editor.org/standards) for the
> standardization state and status of this protocol.  Distribution of this
> memo is unlimited.
> 
> This announcement is sent to the IETF-Announce and rfc-dist lists.
> To subscribe or unsubscribe, see
>   https://www.ietf.org/mailman/listinfo/ietf-announce
>   https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist
> 
> For searching the RFC series, see https://www.rfc-editor.org/search
> For downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk
> 
> Requests for special distribution should be addressed to either the
> author of the RFC in question, or to [email-masked].  Unless
> specifically noted otherwise on the RFC itself, all RFCs are for
> unlimited distribution.
> 
> 
> The RFC Editor Team
> Association Management Solutions, LLC
> 
> 
> _______________________________________________
> L3sm mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/l3sm

---

From: Qin Wu <[email-masked]>
Date: Thu, 23 Feb 2017 14:39:29 +0000

Congratulations on authors and thank you to all involved to help achieve this milestone.

-Qin
_____________________________________
发件人: L3sm [[email-masked]] 代表 Adrian Farrel [[email-masked]]
发送时间: 2017年2月23日 18:15
收件人: [email-masked]
主题: [L3sm] RFC 8049 on YANG Data Model for L3VPN Service Delivery

Adrian

---

From: Jan Lindblad <[email-masked]>
Date: Tue, 28 Feb 2017 11:49:36 +0100

A great achievement that I have long awaited, for sure!

I have some concerns with the resulting model, however, and I now (obviously) regret not looking at this earlier and taking part in the review process.

At ietf-l3vpn-svc.yang:2053 I find:

grouping site-devices {
  container devices {
   must "/l3vpn-svc/sites/site/management/type = "+
    "'provider-managed' or "+
    "/l3vpn-svc/sites/site/management/type = "+
    "'co-managed'" {
     description
      "Applicable only for provider-managed or co-managed device.";
    }

To me, it appears that the author intended to say that the "container device" configuration is only applicable when the current site management type is 'provider-managed' or 'co-managed'. That would make sense. 

The use of "must" and the use of the absolute paths above changes the meaning in YANG to "as soon as any l3vpn is configured, there must be at least one l3vpn (not necessarily the current one) that is 'provider-managed' or 'co-managed'." One implication would be that it would not be legal to have a collection of only 'customer-managed' vpns. What would be legal, though, is to have one 'provider-managed' l3vpn with no device configuration and another 'customer-managed' with devices configured. I expect this was not the intention.

This was something I noticed after spending a few minutes reading the model. Perhaps a YANG doctor review would be appropriate?

Best Regards,
/jan

> On 23 Feb 2017, at 11:15, Adrian Farrel <[email-masked]> wrote:
>