Subject: [L3sm] FW: RFC 8299 on YANG Data Model for L3VPN Service Delivery

From: "Adrian Farrel" <[email-masked]>
Date: Sat, 20 Jan 2018 14:05:33 -0000

Thanks to Qin and the other authors for their tireless (?) work to get this revision out.

Thanks, too, to Jan for his excellent and helpful reviews, and thanks to our two ADs (yes, it took two ADs!) for pushing to get this published this year.

We hope to apply all the lessons learned to the L2SM work that is approaching WG last call in the L2SM working group.

Best,
Adrian

> -----Original Message-----
> From: IETF-Announce [mailto:[email-masked]] On Behalf Of rfc-
> [email-masked]
> Sent: 20 January 2018 00:35
> To: [email-masked]; [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: RFC 8299 on YANG Data Model for L3VPN Service Delivery
> 
> A new Request for Comments is now available in online RFC libraries.
> 
> 
>         RFC 8299
> 
>         Title:      YANG Data Model for L3VPN
>                     Service Delivery
>         Author:     Q. Wu, Ed.,
>                     S. Litkowski,
>                     L. Tomotaki,
>                     K. Ogaki
>         Status:     Standards Track
>         Stream:     IETF
>         Date:       January 2018
>         Mailbox:    [email-masked],
>                     [email-masked],
>                     [email-masked],
>                     [email-masked]
>         Pages:      188
>         Characters: 344738
>         Obsoletes:  RFC 8049
> 
>         I-D Tag:    draft-wu-l3sm-rfc8049bis-11.txt
> 
>         URL:        https://www.rfc-editor.org/info/rfc8299
> 
>         DOI:        10.17487/RFC8299
> 
> This document defines a YANG data model that can be used for
> communication between customers and network operators and to deliver
> a Layer 3 provider-provisioned VPN service.  This document is limited
> to BGP PE-based VPNs as described in RFCs 4026, 4110, and 4364.  This
> model is intended to be instantiated at the management system to
> deliver the overall service.  It is not a configuration model to be
> used directly on network elements.  This model provides an abstracted
> view of the Layer 3 IP VPN service configuration components.  It will
> be up to the management system to take this model as input and use
> specific configuration models to configure the different network
> elements to deliver the service.  How the configuration of network
> elements is done is out of scope for this document.
> 
> This document obsoletes RFC 8049; it replaces the unimplementable
> module in that RFC with a new module with the same name that is not
> backward compatible.  The changes are a series of small fixes to the
> YANG module and some clarifications to the text.
> 
> This is now a Proposed Standard.
> 
> STANDARDS TRACK: This document specifies an Internet Standards Track
> protocol for the Internet community, and requests discussion and suggestions
> for improvements.  Please refer to the current edition of the Official
> Internet Protocol Standards (https://www.rfc-editor.org/standards) for the
> standardization state and status of this protocol.  Distribution of this
> memo is unlimited.
> 
> This announcement is sent to the IETF-Announce and rfc-dist lists.
> To subscribe or unsubscribe, see
>   https://www.ietf.org/mailman/listinfo/ietf-announce
>   https://mailman.rfc-editor.org/mailman/listinfo/rfc-dist
> 
> For searching the RFC series, see https://www.rfc-editor.org/search
> For downloading RFCs, see https://www.rfc-editor.org/retrieve/bulk
> 
> Requests for special distribution should be addressed to either the
> author of the RFC in question, or to [email-masked].  Unless
> specifically noted otherwise on the RFC itself, all RFCs are for
> unlimited distribution.
> 
> 
> The RFC Editor Team
> Association Management Solutions, LLC

---

From: Benoit Claise <[email-masked]>
Date: Sat, 20 Jan 2018 17:33:59 +0100

Yes, thanks to all.
Glad this one is finally delivered.

Regards, Benoit
> .

---

From: "Susan Hares" <[email-masked]>
Date: Sun, 21 Jan 2018 17:26:24 -0500

+ 1 
Congratulations to Qin and the other others for getting this important work
to RFC. 
Thanks Adrian for all your hard work. 
Thanks to Benoit, Joel and Warren for all the hard work!

Sue 

-----Original Message-----
From: L3sm [mailto:[email-masked]] On Behalf Of Adrian Farrel
Sent: Saturday, January 20, 2018 9:06 AM
To: 'l3sm'
Cc: [email-masked]; 'Jan Lindblad'; Alissa Cooper
Subject: [L3sm] FW: RFC 8299 on YANG Data Model for L3VPN Service Delivery

Thanks to Qin and the other authors for their tireless (?) work to get this
revision out.

Thanks, too, to Jan for his excellent and helpful reviews, and thanks to our
two ADs (yes, it took two ADs!) for pushing to get this published this year.

We hope to apply all the lessons learned to the L2SM work that is
approaching WG last call in the L2SM working group.

Best,
Adrian

> From: IETF-Announce [mailto:[email-masked]] On Behalf 
> Of rfc- [email-masked]
> communication between customers and network operators and to deliver a 
> Layer 3 provider-provisioned VPN service.  This document is limited to 
> BGP PE-based VPNs as described in RFCs 4026, 4110, and 4364.  This 
> protocol for the Internet community, and requests discussion and 
> suggestions for improvements.  Please refer to the current edition of 
> the Official Internet Protocol Standards 
> (https://www.rfc-editor.org/standards) for the standardization state 
> and status of this protocol.  Distribution of this memo is unlimited.
> 
> author of the RFC in question, or to [email-masked].  
> Unless specifically noted otherwise on the RFC itself, all RFCs are 
> for unlimited distribution.
> 
> 
> The RFC Editor Team

_______________________________________________
L3sm mailing list
[email-masked]
https://www.ietf.org/mailman/listinfo/l3sm

---

From: "[email-masked]" <[email-masked]>
Date: Mon, 22 Jan 2018 15:13:44 +0800

Congratulations to the team of RFC8299. :-)

Chongfeng

[email-masked]
 
From: Benoit Claise
Date: 2018-01-21 00:33
To: adrian; 'l3sm'
CC: 'Jan Lindblad'; Alissa Cooper
Subject: Re: [L3sm] FW: RFC 8299 on YANG Data Model for L3VPN Service Delivery
Yes, thanks to all.
Glad this one is finally delivered.
 
Regards, Benoit