Subject: Re: L3VPN charter rev 02 (final?)

From: Alex Zinin <[email-masked]>
Date: Thu, 12 Jun 2003 19:24:01 -0400

Cliff,

> Just a minor question/clarification.

> I assume that VPN deployment scenarios 4 will involve the case of
> multiple SPs with either single AS VPN or multi-AS VPN, right?

Correct.

> For example, a company's intranet VPN is supported by several
> regional SPs or an extranet VPN supported by several SPs.

Yes.
 
Alex

> Or it is meant for something else.
> Anyway, I assume this is an important WG scope question.

> Thanks,
> cliff

---

From: cliff wang <[email-masked]>
Date: Thu, 12 Jun 2003 06:33:20 -0700 (PDT)

Alex,

I assume that VPN deployment scenarios 4 will involve the case of multiple SPs with either single AS VPN or multi-AS VPN, right?

For example, a company's intranet VPN is supported by several regional SPs or an extranet VPN supported by several SPs.

Thanks,

cliff

-----Original Message-----
From: Alex Zinin [mailto:[email-masked]] 
Sent: Thursday, June 12, 2003 8:24 AM
To: [email-masked]
Subject: L3VPN charter rev 02 (final?)

Folks

 Links to the updated charter and diff below.

 http://psg.com/~zinin/ietf/ppvpn/l3vpn-02.txt

 http://psg.com/~zinin/ietf/ppvpn/l3vpn-diff-01-02.html

 I am taking this to the IESG telechat today, and hoping

 this is the final rev.

-- 

Alex

Layer 3 Virtual Private Networks (l3vpn)

Chair(s): <under discussion>

Area Director(s):

   Thomas Narten <[email-masked]>

   Erik Nordmark <[email-masked]>

Area Advisor:

   Thomas Narten <[email-masked]>

Technical Advisor:

   Alex Zinin <[email-masked]>

Mailing Lists:

   General Discussion: [email-masked]

   To Subscribe: https://www1.ietf.org/mailman/listinfo/l3vpn

   Archive: https://www1.ietf.org/mail-archive/working-groups/l3vpn/current/maillist.html

Description of Working Group:

Alex is the routing advisor.

This working group is responsible for defining and specifying a

limited number of solutions for supporting provider-provisioned 

Layer-3 (routed) Virtual Private Networks (L3VPNs).

The WG is responsible for standardization of the following solutions:

   1. BGP/MPLS IP VPNs (based on RFC 2547)

   2. IP VPNs using Virtual Routers

   3. CE-based VPNs using IPSEC

The following VPN deployment scenarios will be considered by the WG:

   1. Internet-wide: VPN sites attached to arbitratry points in

      the Internet

   2. Single SP/single AS: VPN sites attached to the network of a

      single provider within the scope of a single AS

   3. Single SP/multiple AS'es: VPN sites attached to the network

      of a single provider consisting of multiple AS'es

   4. Cooperating SPs: VPN sites attached to networks of different

      providers that cooperate with each other to provide VPN service

As part of this effort the WG will work on the following tasks

(additional work items will require rechartering):

   1. Requirements and framework for Layer 3 VPNs

   2. Solution documents for each approach listed above (including

      applicability statements)

   3. MIB definitions for each approach

   4. Security mechanisms for each approach

As a general rule, the WG will not create new protocols, but will provide 

functional requirements for extensions of the existing protocols that will 

be discussed in the protocol-specific WGs. L3VPN WG will review proposed 

protocol extensions for L3VPNs before they are recommended to appropriate 

protocol-specific WGs.

Multicast and QoS support are excluded from the charter at this time. 

They may be considered for inclusion in an updated charter 

at a later time. Future work items may also include OAM support.

WG Milestones (optimistic):

Dec 2002  Submit L3 VPN Requirements Document to IESG for publication as Info

          (completed)

Dec 2002 Submit Generic Requirements Document to IESG for publication as Info

          (completed)

Dec 2002  Submit L3 VPN Framework Document to IESG for publication as Info

          (completed)

Dec 2003  Submit VPN Security Analysis to IESG for publication as Info

          (draft-fang-ppvpn-security-framework-00)

Dec 2003  Submit BGP/MPLS VPNs specification and AS to IESG for 

          publication as PS

         (draft-ietf-ppvpn-rfc2547bis-03, draft-ietf-ppvpn-as2547-01)

Dec 2003 Submit CE-based specification and AS to IESG for publication as PS

         (draft-ietf-ppvpn-ce-based-03)

         (draft-declercq-ppvpn-ce-based-sol-00)

         (draft-declercq-ppvpn-ce-based-as-01)

Dec 2003 Submit Virtual Router specification and AS to IESG for publication as PS

         (draft-ietf-ppvpn-vpn-vr-03, draft-ietf-ppvpn-as-vr-01)

Jan 2004 Submit VPN MIB Textual Conventions to IESG for publication as PS

         (draft-ietf-ppvpn-tc-mib-02)

Jan 2004 Submit MPLS/BGP VPN MIB to IESG for publication as PS

         (draft-ietf-ppvpn-mpls-vpn-mib-05)

Jan 2004 Submit VR MIB to IESG for publication as PS

         (draft-ietf-ppvpn-vr-mib-04)

Jan 2004 Submit BGP as an Auto-Discovery Mechanism for publication as PS.

         (draft-ietf-ppvpn-bgpvpn-auto-05.txt)

March 2004 Submit specification of using IPSEC for PE-PE encapsulation in BGP/MPLS VPNs to IESG

         for publication as PS

         (draft-ietf-ppvpn-ipsec-2547-03)

March 2004 Submit specification of using GRE for PE-PE encapsulation in BGP/MPLS VPNs to IESG

         for publication as PS

         (draft-ietf-ppvpn-gre-ip-2547-02)

March 2004 Submit specification of CE Route Authentication to IESG for publication as PS

         (draft-ietf-ppvpn-l3vpn-auth-03)

March 2004 Submit specification of OSPF as the PE/CE Protocol in BGP/MPLS VPNs for publication. 

          (draft-rosen-vpns-ospf-bgp-mpls-06.txt)

March 2004 Submit specification of BGP-MPLS VPN extension for IPv6 VPN to IESG for publication as PS

             (draft-ietf-ppvpn-bgp-ipv6-vpn-03)

---------------------------------
Do you Yahoo!?
Free online calendar with sync to Outlook(TM).