Subject: RE: Updated WG charter

From: "Francois Le Faucheur (flefauch)" <[email-masked]>
Date: Tue, 10 Jun 2003 13:28:31 +0100

Alex and all,

I noticed there does not seem to be any milestone in the proposed
charter regarding IPv6 VPNs. Is this something you've already discussed
and agreed to take out (sorry, I couldn't keep up with the whole thread
so I may have missed that discussion) or is it more of an omission?

While IPv6 need not be explicitely mentioned in the body of the charter
(since the text is generic and thus applies equally to IPv4 and IPv6),
specifying a solution for IPv6 VPNs would call for a milestone.

For memory, the current PPVPN Working Group has developed a Working
Group document for IPv6 VPNs (draft-ietf-ppvpn-bgp-ipv6-vpn-03.txt,
"BGP-MPLS VPN extension for IPv6 VPN"). The status for that document was
that its finalisation and submission to IESG was on hold, pending
2547bis publication since it is based on it.

Considering the proposed milestone for 2547bis ("Dec 2003  Submit
BGP/MPLS VPNs specification and AS to IESG for publication as PS"), we
could perhaps include something like:
"
March 2004   Submit specification of BGP-MPLS VPN extension for IPv6 VPN
to IESG for publication as PS
             (draft-ietf-ppvpn-bgp-ipv6-vpn-03)
"

Thanks

Francois

>> -----Original Message-----
>> From: Alex Zinin [mailto:[email-masked]] 
>> Sent: 06 June 2003 01:24
>> To: [email-masked]
>> Subject: Updated WG charter
>> 
>> 
>> Folks-
>> 
>>  I believe the updated rev of the charter below should reflect the
>>  discussion on the list. The diff from the previously posted version
>>  can be found here:
>>  
>>    http://psg.com/~zinin/ietf/ppvpn/l3vpn-diff-00-01.html
>> 
>>  Note that QoS is in the list of for-now-excluded items. I'd like us
>>  to finish current work items before taking on new work, and
>>  especially such broad topic as QoS.
>> 
>>  Regards.
>>  
>> -- 
>> Alex
>> http://www.psg.com/~zinin/
>> 
>> 
>> Layer 3 Virtual Private Networks (l3vpn)
>> 
>> Chair(s): <under discussion>
>> 
>> Area Director(s):
>>    Thomas Narten <[email-masked]>
>>    Erik Nordmark <[email-masked]>
>> 
>> Area Advisor:
>>    Thomas Narten <[email-masked]>
>> 
>> Technical Advisor:
>>    Alex Zinin <[email-masked]>
>> 
>> Description of Working Group:
>> 
>> This working group is responsible for defining and specifying a
>> limited number of solutions for supporting provider-provisioned 
>> Layer-3 (routed) Virtual Private Networks (L3VPNs).
>> 
>> The WG is responsible for standardization of the following solutions:
>> 
>>    1. BGP/MPLS IP VPNs (based on RFC 2547)
>>    2. IP VPNs using Virtual Routers
>>    3. CE-based VPNs using IPSEC
>> 
>> The following VPN deployment scenarios will be considered by the WG:
>> 
>>    1. Internet-wide: VPN sites attached to arbitratry points in
>>       the Internet
>> 
>>    2. Single SP/single AS: VPN sites attached to the network of a
>>       single provider within the scope of a single AS
>> 
>>    3. Single SP/multiple AS'es: VPN sites attached to the network
>>       of a single provider consisting of multiple AS'es
>> 
>>    4. Cooperating SPs: VPN sites attached to networks of different
>>       providers that cooperate with each other to provide VPN service
>> 
>> As part of this effort the WG will work on the following tasks
>> (additional work items will require rechartering):
>> 
>>    1. Requirements and framework for Layer 3 VPNs
>>    2. Solution documents for each approach listed above (including
>>       applicability statements)
>>    3. MIB definitions for each approach
>>    4. Security mechanisms for each approach
>> 
>> As a general rule, the WG will not create new protocols, but 
>> will provide 
>> functional requirements for extensions of the existing 
>> protocols that will 
>> be discussed in the protocol-specific WGs. The group will 
>> review proposed 
>> protocol extensions for L3VPNs before they are recommended 
>> to appropriate 
>> protocol-specific WGs.
>> 
>> Multicast and QoS support are excluded from the charter at 
>> this time. 
>> They may be considered for inclusion in an updated charter 
>> at a later time. Future work items may also include OAM support.
>> 
>> WG Milestones (optimistic):
>> 
>> Dec 2002  Submit L3 VPN Requirements Document to IESG for 
>> publication as Info
>>           (completed)
>> Dec 2002 Submit Generic Requirements Document to IESG for 
>> publication as Info
>>           (completed)
>> Dec 2002  Submit L3 VPN Framework Document to IESG for 
>> publication as Info
>>           (completed)
>> 
>> Dec 2003  Submit VPN Security Analysis to IESG for 
>> publication as Info
>>           (draft-fang-ppvpn-security-framework-00)
>> Dec 2003  Submit BGP/MPLS VPNs specification and AS to IESG for 
>>           publication as PS
>>          (draft-ietf-ppvpn-rfc2547bis-03, draft-ietf-ppvpn-as2547-01)
>> Dec 2003 Submit CE-based specification and AS to IESG for 
>> publication as PS
>>          (draft-ietf-ppvpn-ce-based-03)
>>          (draft-declercq-ppvpn-ce-based-sol-00)
>>          (draft-declercq-ppvpn-ce-based-as-01)
>> Dec 2003 Submit Virtual Router specification and AS to IESG 
>> for publication as PS
>>          (draft-ietf-ppvpn-vpn-vr-03, draft-ietf-ppvpn-as-vr-01)
>> 
>> Jan 2004 Submit VPN MIB Textual Conventions to IESG for 
>> publication as PS
>>          (draft-ietf-ppvpn-tc-mib-02)
>> Jan 2004 Submit MPLS/BGP VPN MIB to IESG for publication as PS
>>          (draft-ietf-ppvpn-mpls-vpn-mib-05)
>> Jan 2004 Submit VR MIB to IESG for publication as PS
>>          (draft-ietf-ppvpn-vr-mib-04)
>> Jan 2004 Submit BGP as an Auto-Discovery Mechanism for 
>> publication as PS.
>>          (draft-ietf-ppvpn-bgpvpn-auto-05.txt)
>> 
>> March 2004 Submit specification of using IPSEC for PE-PE 
>> encapsulation in BGP/MPLS VPNs to IESG
>>          for publication as PS
>>          (draft-ietf-ppvpn-ipsec-2547-03)
>> March 2004 Submit specification of using GRE for PE-PE 
>> encapsulation in BGP/MPLS VPNs to IESG
>>          for publication as PS
>>          (draft-ietf-ppvpn-gre-ip-2547-02)
>> March 2004 Submit specification of CE Route Authentication 
>> to IESG for publication as PS
>>          (draft-ietf-ppvpn-l3vpn-auth-03)
>> March 2004 Submit specification of OSPF as the PE/CE 
>> Protocol in BGP/MPLS VPNs for publication. 
>>           (draft-rosen-vpns-ospf-bgp-mpls-06.txt)
>> 
>>

---

From: Alex Zinin <[email-masked]>
Date: Tue, 10 Jun 2003 15:03:12 -0700

Francois,

> so I may have missed that discussion) or is it more of an omission?

It is an omission. Thanks for reminding.
I will put it in.

---

From: Alex Zinin <[email-masked]>
Date: Thu, 12 Jun 2003 08:23:40 -0400

Folks

 Links to the updated charter and diff below.

 http://psg.com/~zinin/ietf/ppvpn/l3vpn-02.txt
 http://psg.com/~zinin/ietf/ppvpn/l3vpn-diff-01-02.html

 I am taking this to the IESG telechat today, and hoping
 this is the final rev.

-- 
Alex

Area Director(s):

Area Advisor:

Technical Advisor:

Mailing Lists:

   General Discussion: [email-masked]
   To Subscribe: https://www1.ietf.org/mailman/listinfo/l3vpn
   Archive: https://www1.ietf.org/mail-archive/working-groups/l3vpn/current/maillist.html

Alex is the routing advisor.

As a general rule, the WG will not create new protocols, but will provide 
functional requirements for extensions of the existing protocols that will 
be discussed in the protocol-specific WGs. L3VPN WG will review proposed 
protocol extensions for L3VPNs before they are recommended to appropriate 
protocol-specific WGs.

Multicast and QoS support are excluded from the charter at this time. 
They may be considered for inclusion in an updated charter 
at a later time. Future work items may also include OAM support.

Dec 2002  Submit L3 VPN Requirements Document to IESG for publication as Info
          (completed)
Dec 2002 Submit Generic Requirements Document to IESG for publication as Info
          (completed)
Dec 2002  Submit L3 VPN Framework Document to IESG for publication as Info
          (completed)

Dec 2003  Submit VPN Security Analysis to IESG for publication as Info
          (draft-fang-ppvpn-security-framework-00)
Dec 2003  Submit BGP/MPLS VPNs specification and AS to IESG for 
          publication as PS
         (draft-ietf-ppvpn-rfc2547bis-03, draft-ietf-ppvpn-as2547-01)
Dec 2003 Submit CE-based specification and AS to IESG for publication as PS
         (draft-ietf-ppvpn-ce-based-03)
         (draft-declercq-ppvpn-ce-based-sol-00)
         (draft-declercq-ppvpn-ce-based-as-01)
Dec 2003 Submit Virtual Router specification and AS to IESG for publication as PS
         (draft-ietf-ppvpn-vpn-vr-03, draft-ietf-ppvpn-as-vr-01)

Jan 2004 Submit VPN MIB Textual Conventions to IESG for publication as PS
         (draft-ietf-ppvpn-tc-mib-02)
Jan 2004 Submit MPLS/BGP VPN MIB to IESG for publication as PS
         (draft-ietf-ppvpn-mpls-vpn-mib-05)
Jan 2004 Submit VR MIB to IESG for publication as PS
         (draft-ietf-ppvpn-vr-mib-04)
Jan 2004 Submit BGP as an Auto-Discovery Mechanism for publication as PS.
         (draft-ietf-ppvpn-bgpvpn-auto-05.txt)

March 2004 Submit specification of using IPSEC for PE-PE encapsulation in BGP/MPLS VPNs to IESG
         for publication as PS
         (draft-ietf-ppvpn-ipsec-2547-03)
March 2004 Submit specification of using GRE for PE-PE encapsulation in BGP/MPLS VPNs to IESG
         for publication as PS
         (draft-ietf-ppvpn-gre-ip-2547-02)
March 2004 Submit specification of CE Route Authentication to IESG for publication as PS
         (draft-ietf-ppvpn-l3vpn-auth-03)
March 2004 Submit specification of OSPF as the PE/CE Protocol in BGP/MPLS VPNs for publication. 
          (draft-rosen-vpns-ospf-bgp-mpls-06.txt)
March 2004 Submit specification of BGP-MPLS VPN extension for IPv6 VPN to IESG for publication as PS
             (draft-ietf-ppvpn-bgp-ipv6-vpn-03)

---

From: Junichi Sumimoto <[email-masked]>
Date: Fri, 13 Jun 2003 13:49:40 +0900

Hi Alex,

draft-ietf-ppvpn-applicability-guidelines-01.txt is not 
addressed in the milestones.
I (and Co-authors of the draft) think that it should become 
an Informational RFC, and we hope it is addressed in the 
milestones.

Thanks,
Junichi.

> I am taking this to the IESG telechat today, and hoping

(snip)

--------
Junichi Sumimoto
NTT Corporation

E-mail: [email-masked]
Tel: +81 422 59 3293

---

From: Eric Rosen <[email-masked]>
Date: Fri, 13 Jun 2003 10:37:55 -0400

> addressed in the milestones. 

Hasn't this  document already  served its purpose?   I don't really  see the
point of making it an RFC.

---

From: Junichi Sumimoto <[email-masked]>
Date: Mon, 16 Jun 2003 10:57:57 +0900

Eric,

>point of making it an RFC. 

Current version of this document has not cover l2 material completely.
I'm going to revise this document before Vienna meeting incorporating recent
progress of major l2 document.
And I hope that I will make final revision of this document after these items 

  Alex Zinin wrote:
  >JUL 2003  Submit L2 requirements to IESG for publication as Informational RFC
  >JUL 2003  Submit L2 framework to IESG for publication as Informational RFC
  >JUL 2003  Identify VPLS and VPWS solutions for the WG

are completed.

Thanks,
Junichi.

--------
Junichi Sumimoto
NTT Corporation

---

From: Alex Zinin <[email-masked]>
Date: Tue, 17 Jun 2003 11:21:30 -0700

Junichi,

  Wrt L2, it would seem to be useful to think about a separate
  document for L2.

  However, on the question of the draft below becoming an RFC, I am
  with Eric here, but I will leave this discussion and decision to
  the chairs of the new WG.

---

From: Junichi Sumimoto <[email-masked]>
Date: Wed, 18 Jun 2003 19:24:52 +0900

Alex,
Thanks for your reply.

>  Wrt L2, it would seem to be useful to think about a separate

I have no objection.

Anyway, I will try to revise the draft soon, since the current 
version expires in this month.

>  the chairs of the new WG.

Best regards,
Junichi Sumimoto.