Subject: RE: Advertising Routes to a PE

From: John Smith <[email-masked]>
Date: Thu, 31 Jul 2003 12:17:45 +0100 (BST)

Makes sense. But this goes against what Tappan and Enke have been saying all along.

----- Original Message ----- 
From: <[email-masked]>
To: <[email-masked]>; <[email-masked]>
Sent: Thursday, July 31, 2003 4:00 PM
Subject: RE: Advertising Routes to a PE

I think that conceptually the route distribution should be similar than 
it would be if VRF B resides in different PE. In that case the given 
route would not end up into VRFs that have import RT 45:64.

So, I think that route should be advertised only with RT 100:100.

Marko

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 31. heinäkuuta 2003 13:19
> To: [email-masked]; [email-masked]
> Subject: RE: Advertising Routes to a PE
> 
> 
> Robert,
>  
> > What are the reasons that make you think that explicitely exporting
> > routes from vrf A with RT 45:64 will not address the need 
> in much more
> > clean and obvious way ? 
> 
> I just want to clear it conceptually. 
> 
> Moreover i am sure we can have a configuration wherein this 
> could be possible.
> 
> So what will be done finally? Will we announce just 
> 1:1:10.0.0.0/8 with RT 100:100 or
> would the RT be 100:100 45:64
> 
> Regards,
> John

________________________________________________________________________
Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://uk.messenger.yahoo.com/

---

From: Dan Tappan <[email-masked]>
Date: Thu, 31 Jul 2003 08:49:31 -0400

>Makes sense. But this goes against what Tappan and Enke have been saying 

I think you may be misinterpreting what I said - and maybe it's my fault 
for not being more explicit. When I said (several messages back):

>1:1:x/x,  Label=L1, RT={ 100:100}
>2:2:x/x, Label=L1, RT={100:100, 100:200}
>
>will produce exactly the same effect on a remote PE as advertising
>
>1:1:x/x, Label=L1, RT={100:100, 100:200}

I was _not_ trying to imply that an implementation should scan the 
importing VRFs and apply the union of all export RTs to the advertised 
routes. That behavior would have some of the same faults as recursive export.

_All_ I'm saying is that:
- architecturally 2547 never requires advertising more than one route to 
achieve a desired connectivity (considering only the RT mechanism). ALl it 
requires is that routes be associated with an appropriate set of RTs.

- an implementation should provide a mechanism to apply the appropriate set 
of RTs to a route. VRF export lists are not the only acceptable mechanism. 
In fact if you read rfc2547 carefully you'll find that it doesn't even 
mention VRF export lists.

- recursive export is neither necessary or sufficient, and can be actively 
harmful.

So, if we get back to the original question, the answer is: "No. An 
implementation which does not do recursive export is not behaving incorrectly".

I'm continually amazed at how much effort it takes to answer a simple 
question on an IETF list.

---

From: John Smith <[email-masked]>
Date: Thu, 31 Jul 2003 14:10:17 +0100 (BST)

> routes. That behavior would have some of the same faults as recursive export.

This makes it very clear :-)

> requires is that routes be associated with an appropriate set of RTs.

Very True.

> implementation which does not do recursive export is not behaving incorrectly".

This is what i wanted to know !!

> question on an IETF list.

:-)

Thanks,
John