Subject: Re: RFC2547bis doubt

From: Eric Rosen <[email-masked]>
Date: Mon, 28 Jul 2003 13:53:05 -0400

(Switched mailing lists.) 

> Can IP address of CE routers, over which they establish BGP session with PE,
> overlap? 

> Means two CEs, say CE1 (in VPN A) and CE2 (in VPN B), having same IP
> addresses, can have bgp session to same PE. 

Certainly the architecture allows  this.  It's an implementation issue, your
BGP implementation just has to be able  to cope with it.  I know of at least
one implementation which does allow this.

---

From: "Naidu, Venkata" <[email-masked]>
Date: Mon, 28 Jul 2003 18:02:08 -0400

-> > Can IP address of CE routers, over which they establish 
-> BGP session with PE,
-> > overlap? 
-> 
-> > Means two CEs, say CE1 (in VPN A) and CE2 (in VPN B), 
-> having same IP
-> > addresses, can have bgp session to same PE. 
-> 
-> Certainly the architecture allows  this.  It's an 
-> implementation issue, your
-> BGP implementation just has to be able  to cope with it.  I 
-> know of at least one implementation which does allow this. 

  More precisely, your IP stack has to support this. This is
  nothing to do with BGP. To complicate, PE interface addresses 
  over different VRFs (in the above case, to CE1 and CE2) can 
  also overlap. So, in some cases, "CE1 to PE" and "CE2 to PE" 
  IP datagrams can look very similar (including the TCP header 
  ephemeral port numbers, IP source and destination addresses etc). 
  If possible, distinguish the packets at the port (interface) 
  of entry at PE.

Venkata.