Subject: Re: Advertising Routes to a PE

From: John Smith <[email-masked]>
Date: Thu, 31 Jul 2003 11:05:08 +0100 (BST)

Hi,

> It seems to me that there is a difference if there exists a customer on the
> remote PE with the following attributes:
> 
>         vrf C:  rd 3:3,  import 100:200, export 100:200
> 
> (In that case vrf B probably should have import: 100:100 100:200.)

Well i tried it a little differently. I made the configuration on the router attached to
the VRF like this.

!
ip vrf A
 rd 1:1
 route-target both 100:100
!
 ip vrf B
 rd 2:2
 route-target export 45:64
 route-target both 100:100
!
router bgp X
 bgp router-id x.y.z.w
 neighbor <IP_ADDR_PEER> remote-as X
!
 address-family vpnv4 unicast
 neighbor <IP_ADDR_PEER> activate
 exit-address-family
!

This router learns from VRF A and i see it importing these routes in its VRF B. But when
it needs to advertise to its PE router it only advertises (say 10.0.0.0/8)
1:1::10.0.0.0/8
with Route Targets 100:100

As per the discussion which i follow it should do it with the RTs 100:100 45:64

Isnt the current behaviour improper?

Regards,
John

________________________________________________________________________
Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://uk.messenger.yahoo.com/

---

From: Robert Raszuk <[email-masked]>
Date: Thu, 31 Jul 2003 12:11:00 +0200

John,

What are the reasons that make you think that explicitely exporting
routes from vrf A with RT 45:64 will not address the need in much more
clean and obvious way ? 

R.

> John Smith wrote: