Subject: RE: Re: Advertising Routes to a PE

From: [email-masked]
Date: Wed, 30 Jul 2003 17:02:33 +0300

Thanks for explaining that.

You wrote:  "This would both be a violation of iBGP procedures ..."

So, one could think so that the route distribution in a single PE is 
kind of logical MP-iBGP session, right ? and that is why it is not 
distributed further by MP-iBGP to other PEs. 
But the route is distributed to the CEs that are associated to VRF B 
(via eBGP or OSPF..).

-Marko

> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]]
> Sent: 30. heinäkuuta 2003 16:36
> To: Kulmala, Marko
> Cc: [email-masked]; [email-masked]; [email-masked]
> Subject: RE: Re: Advertising Routes to a PE
> 
> 
> At 03:46 PM 7/30/2003 +0300, [email-masked] wrote:
> >I think that below configuration works even if route 
> 2:2::10.0.0.0/8 is
> >not advertised since export RTs in the VRF A and B are the same.
> >
> >But what if VRF B has different export RTs than VRF A ?
> 
> In the scenario you've described the route in VRF B is not 
> exported, so 
> export RTs do not apply.
> 
> In this context 'exported' means "redistributed from a VRF 
> RIB into BGP, 
> for purposes of producing a vpnv4 route for advertisement to 
> other PEs". 
> So, as you can see, the route in VRF B is _imported_ 
> (installed into the 
> proper RIB by BGP based on the RTs associated with the route) 
> but there is 
> no reason to export it.
> 
> At an architectural level, the BGP advertisement needs to be 
> based on which 
> vpnv4 routes are produced on a given PE, which is a separate 
> issue from 
> what VRF RIB a route is installed into. The vpnv4 route is 
> based on the RIB 
> entry which exported the route.  (the fact that some implementations 
> internally generate a vpnv4 route for VRF B, for purposes of 
> book-keeping, 
> is separate from the 2547 architecture).
> 
> If you have a need to control the RT set which is associated 
> with a vpnv4 
> route, then there are other mechanisms to do so.
> 
> If one followed your suggested model consistently then every 
> route received 
> by PE and imported into multiple VRFs would result in the 
> re-advertisement 
> of multiple vpnv4 routes. This would both be a violation of iBGP 
> procedures, and would result in an explosion of routing information.
> 
> >Then I think it is necessary to advertise route 
> 2:2::10.0.0.0/8 as well.
> >
> >Conceptually I think that both routes should be advertised.
> >What is reason not to do so ?
> >
> >Best Regards,
> >Marko Kulmala
> >
> > > -----Original Message-----
> > > From: [email-masked] [mailto:[email-masked]]
> > > Sent: 30. heinäkuuta 2003 12:35
> > > To: [email-masked]
> > > Cc: [email-masked]; [email-masked]
> > > Subject: Re: Advertising Routes to a PE
> > >
> > >
> > >
> > > Yes this is correct :). Advertising of locally imported 
> routes should
> > > not be allowed.
> > >
> > > R.
> > >
> > > > John Smith wrote:
> > > >
> > > > Hi,
> > > >
> > > > I have a conceptual doubt.
> > > >
> > > > I have two VRFs A and B defined on a PE router. Both of
> > > them have overlapping Route
> > > > Targets.
> > > >
> > > > My basic config goes something like this.
> > > >
> > > > !
> > > > ip vrf A
> > > >  rd 1:1
> > > >  route-target both 100:100
> > > > !
> > > > ip vrf B
> > > >  rd 2:2
> > > >  route-target both 100:100
> > > > !
> > > >
> > > > Now i learn a route (say 10.0.0.0/8) from VRF A. I
> > > redistribute it into VRF B too as they
> > > > have overlapping RTs.
> > > >
> > > > Now when this PE router peers up with another PE peer it
> > > will announce 1:1::10.0.0.0/8
> > > > along with the associated Route Targets. Should it also
> > > advertise 2:2::10.0.0.0/8 to the
> > > > remote PE router?
> > > >
> > > > I have a router from one major vendor which is not doing
> > > this. I see it only advertising
> > > > 1:1::10.0.0.0/8
> > > >
> > > > Is this correct?
> > > >
> > > > Regards,
> > > > Smith
> > > >
> > > >
> > > ______________________________________________________________
> > > __________
> > > > Want to chat instantly with your online friends?  Get the
> > > FREE Yahoo!
> > > > Messenger http://uk.messenger.yahoo.com/
> > >
> > >
> >
> >============================================================
> >The information contained in this message may be privileged
> >and confidential and protected from disclosure.  If the
> >reader of this message is not the intended recipient, or an
> >employee or agent responsible for delivering this message to
> >the intended recipient, you are hereby notified that any
> >reproduction, dissemination or distribution of this
> >communication is strictly prohibited. If you have received
> >this communication in error, please notify us immediately by
> >replying to the message and deleting it from your computer.
> >
> >Thank you.
> >Tellabs
> >============================================================
> 
> 
> 

============================================================
The information contained in this message may be privileged 
and confidential and protected from disclosure.  If the 
reader of this message is not the intended recipient, or an 
employee or agent responsible for delivering this message to 
the intended recipient, you are hereby notified that any 
reproduction, dissemination or distribution of this 
communication is strictly prohibited. If you have received 
this communication in error, please notify us immediately by 
replying to the message and deleting it from your computer.

Thank you.
Tellabs
============================================================

---

From: Dan Tappan <[email-masked]>
Date: Wed, 30 Jul 2003 10:17:18 -0400

At 05:02 PM 7/30/2003 +0300, [email-masked] wrote:
>kind of logical MP-iBGP session, right ?

Yes, that is one consistent model.

>and that is why it is not

Correct.