Subject: Advertising Routes to a PE

From: John Smith <[email-masked]>
Date: Wed, 30 Jul 2003 10:09:27 +0100 (BST)

Hi,

I have a conceptual doubt.

I have two VRFs A and B defined on a PE router. Both of them have overlapping Route
Targets.

My basic config goes something like this.

!
ip vrf A
 rd 1:1
 route-target both 100:100
!
ip vrf B
 rd 2:2
 route-target both 100:100
!

Now i learn a route (say 10.0.0.0/8) from VRF A. I redistribute it into VRF B too as they
have overlapping RTs.

Now when this PE router peers up with another PE peer it will announce 1:1::10.0.0.0/8
along with the associated Route Targets. Should it also advertise 2:2::10.0.0.0/8 to the
remote PE router?

I have a router from one major vendor which is not doing this. I see it only advertising
1:1::10.0.0.0/8

Is this correct?

Regards,
Smith

________________________________________________________________________
Want to chat instantly with your online friends?  Get the FREE Yahoo!
Messenger http://uk.messenger.yahoo.com/

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 30 Jul 2003 11:35:27 +0200

Yes this is correct :). Advertising of locally imported routes should
not be allowed.

R.

> John Smith wrote: