Subject: draft-ietf-l3vpn-mpls-vpn-mib-05 Syntax Error?

From: [email-masked]
Date: Tue, 26 Aug 2003 17:31:42 -0400

I was playing around with the MIB module in draft-ietf-l3vpn-mpls-vpn-mib-05 and got the following error when I tried to compile it:

"Item 'mplsVpnVrfBgpPAtrCalcLocalPref' in sequence 
'MplsVpnVrfBgpNbrPrefixEntry' has conflicting syntax specified."

In the sequence list 'mplsVpnVrfBgpPAtrCalcLocalPref' is shown as an INTEGER:

"MplsVpnVrfBgpNbrPrefixEntry ::= SEQUENCE {
        <list trimmed to save bandwidth>
     mplsVpnVrfBgpPAtrCalcLocalPref      INTEGER,
        <list trimmed to save bandwidth>
}"

But farther down in the module the sytax for this object is shown as 'Interger32':

"mplsVpnVrfBgpPAtrCalcLocalPref OBJECT-TYPE
     SYNTAX     Integer32 (-1..2147483647)"

I'd appreciate it if someone could let me know which it's actually supposed to be, INTEGER or Integer32.

Thanks,
Len Nieman

---

From: "Thomas D. Nadeau" <[email-masked]>
Date: Wed, 27 Aug 2003 11:26:29 -0400

The INTEGER is wrong; this should only be
used for enumerations.   Will fix in the next
version. Will also check compilation using
SmicNGPro in ultra-pedantic mode. :P

	--Tom

> I was playing around with the MIB module in 
> draft-ietf-l3vpn-mpls-vpn-mib-05 and got the following error 
> when I tried to compile it:
> 
> I'd appreciate it if someone could let me know which it's 
> actually supposed to be, INTEGER or Integer32.
> 
> Thanks,
> Len Nieman
> 
> 
>