Subject: RE: Route Reflector and VRFs

From: [email-masked]
Date: Tue, 28 Oct 2003 09:55:39 +0100

Hi there,

I'm not sure what you are trying to do, but as soon as you go beyond the basic architectures you may have multiple RTs for one route (still exactly one RD), and then neither #1 nor #2 make sense.

Cheers,

Juerg Fankhauser
www.swisscom.com

-----Original Message-----
From: John Smith [mailto:[email-masked]] 
Sent: Tuesday, October 28, 2003 8:52 AM
To: PamSri; Rajesh Potti; [email-masked]
Cc: [email-masked]
Subject: Re: Route Reflector and VRFs

just a clarification,

1. is there anything in the RFC which prevents from treating the RT:ipv4 and
not RD:ipv4 as the bases of the decision making algorithim
2. even if #1 is there, is there anything in the RFC which prevents the
following:
filter routes based on RT, tag each route with an RD=RT, run BGP decision on
the whole set of RD:ipv4 routes, put routes in RIBs_OUT tagged with their
export target attributes etc, and strip RD before sending out the route?

i believe both 1 and 2 are not possible based on the RFC, though it does say
one can make RD=RT.

please correct me if I am wrong.

-Smith

----- Original Message -----
From: "PamSri" <[email-masked]>
To: "Rajesh Potti" <[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, October 28, 2003 6:51 AM
Subject: RE: Route Reflector and VRFs

> Rajesh, refer to the Route Reflector v/s Router Server
> email thread. ORFs are used to get the specific routes
> by the PE from the RR. According to 2547 a RR need'nt
> store the VRF info if it does'nt interface any VRF
> site.
>
> sri
>
> --- Rajesh Potti <[email-masked]> wrote:
> > Nagananda,
> >
> >  For ipv4 routes, do Route Reflectors reflect routes
> > even if it is not
> > inserted into the FIB? RFC 2796 does not states
> >  this explicitly. Since the nexthop is unaltered by
> > the RR, i think it would
> > be sufficient if the RR clients have inserted the
> >  routes into its FIB.
> >
> > Since the RR selects the best route for reflecting,
> > from its view point,
> > this could result in suboptimality, as the RFC
> > points out. For vpnv4 routes, routes should be in
> > the FIB, as well as an LSP
> > should be established between the
> > clients.
> >
> > RR does not sound like a good way to handle this
> > case, since it only sends
> > the clients, only the best route for it.
> > Suppose,
> > 1. RRC A and RRC B sends a route to the RR,
> > 2. RR picks the route from RRC A, as the best, and
> > sends it to RRC C.
> > 3. RRC C might have an LSP to RRC B, and not to RRC
> > A --> In this case, RRC
> > C would have preferred the route
> > from RRC B, while it gets the route from RRC A,
> > which results in loss of
> > connectivity, when there is an alternate
> > path.
> >
> > Rajesh
> >
> > -----Original Message-----
> > From: Nagananda Anur [mailto:[email-masked]]
> > Sent: Monday, October 27, 2003 6:16 PM
> > To: Potti, Rajesh [BL60:SF40:EXCH]
> > Subject: RE: Route Reflector and VRFs
> >
> >
> > Rajesh,
> >
> > One doesn't need to have VRF to reflect VPN routes.
> > You don't install MBGP routes into you FIB but you
> > still reflect right -
> > it's the same way.
> >
> > It's the resposibility of PEs to make sure that LSP
> > is been established
> > before opening up for directing traffic. Also, RR
> > may not be in VPN traffic
> > forwarding path...hence it's not necessary to have
> > VRFs to reflect.
> >
> > Nagananda
> >
> > -----Original Message-----
> > From: [email-masked]
> > [mailto:[email-masked]]On Behalf Of Rajesh
> > Potti
> > Sent: Monday, October 27, 2003 4:56 PM
> > To: [email-masked]'
> > Subject: Route Reflector and VRFs
> >
> >
> >
> >
> > Hi,
> >
> >  Route Reflectors reflect routes only if it is
> > inserted into the Forwarding
> > Table.
> >   In that case, we need to have the VRFs activated,
> > and routes inserted into
> > the VRF,  before it can be advertised to the
> > clients?
> >
> >  Is an exception to this rule done, before
> > reflecting vpnv4 routes?
> >
> > Thanks,
> > Rajesh
> >
> >
>
>
> __________________________________
> Do you Yahoo!?
> Exclusive Video Premiere - Britney Spears
> http://launch.yahoo.com/promos/britneyspears/
>

---

From: "John Smith" <[email-masked]>
Date: Tue, 28 Oct 2003 14:42:27 +0530

In that case, would they not be the same customer V4 route destined to
different VPNs.

so one could still say :

#1 if there are multiple RTs, make multiple routes for the decision process:
for (loop=1;loop<=count(RT);loop++)
{
newroute_for_decision(RT:prefix);/*makes a new route for decision in the
incoming_routes_base*/
}

and while trasmitting routes, sort for RT and send all routes with the same
RT under one set of NLRI with the same attribute.

#2. if there are multiple RTs, and one still wishes to use the RD, make
multiple routes for the decision process:
 for (loop=1;loop<=count(RT);loop++)
{
RD=RT[loop];
newroute_for_decision(RD:prefix);/*makes a new route for decision in the
incoming_routes_base*/
}

Then run BGP decison process on the routes, and then strip the RD before
propogation etc, and retain the attributes.

eitherways, I believe that the next-hop may have to be the RR, but I was
referring to a case where one may not want to make multiple VRFs or have
multiple decision making instances.

-Smith

----- Original Message -----
From: <[email-masked]>
To: <[email-masked]>
Cc: <[email-masked]>
Sent: Tuesday, October 28, 2003 2:25 PM
Subject: RE: Route Reflector and VRFs

Hi there,

I'm not sure what you are trying to do, but as soon as you go beyond the
basic architectures you may have multiple RTs for one route (still exactly
one RD), and then neither #1 nor #2 make sense.

Cheers,

Juerg Fankhauser
www.swisscom.com

-----Original Message-----
From: John Smith [mailto:[email-masked]]
Sent: Tuesday, October 28, 2003 8:52 AM
To: PamSri; Rajesh Potti; [email-masked]
Cc: [email-masked]
Subject: Re: Route Reflector and VRFs

just a clarification,

-Smith