Subject: RE: Route Reflector and VRFs

From: "Rajesh Potti" <[email-masked]>
Date: Mon, 27 Oct 2003 18:40:48 -0500

Nagananda,
 
 For ipv4 routes, do Route Reflectors reflect routes even if it is not
inserted into the FIB? RFC 2796 does not states
 this explicitly. Since the nexthop is unaltered by the RR, i think it would
be sufficient if the RR clients have inserted the
 routes into its FIB. 
 
Since the RR selects the best route for reflecting, from its view point,
this could result in suboptimality, as the RFC 
points out. For vpnv4 routes, routes should be in the FIB, as well as an LSP
should be established between the
clients. 
 
RR does not sound like a good way to handle this case, since it only sends
the clients, only the best route for it. 
Suppose, 
1. RRC A and RRC B sends a route to the RR, 
2. RR picks the route from RRC A, as the best, and sends it to RRC C. 
3. RRC C might have an LSP to RRC B, and not to RRC A --> In this case, RRC
C would have preferred the route 
from RRC B, while it gets the route from RRC A, which results in loss of
connectivity, when there is an alternate
path.
 
Rajesh

-----Original Message-----
From: Nagananda Anur [mailto:[email-masked]] 
Sent: Monday, October 27, 2003 6:16 PM
To: Potti, Rajesh [BL60:SF40:EXCH]
Subject: RE: Route Reflector and VRFs

Rajesh,
 
One doesn't need to have VRF to reflect VPN routes. 
You don't install MBGP routes into you FIB but you still reflect right -
it's the same way.
 
It's the resposibility of PEs to make sure that LSP is been established
before opening up for directing traffic. Also, RR may not be in VPN traffic
forwarding path...hence it's not necessary to have VRFs to reflect.
 
Nagananda

-----Original Message-----
From: [email-masked] [mailto:[email-masked]]On Behalf Of Rajesh
Potti
Sent: Monday, October 27, 2003 4:56 PM
To: [email-masked]'
Subject: Route Reflector and VRFs

Hi, 

 Route Reflectors reflect routes only if it is inserted into the Forwarding
Table. 
  In that case, we need to have the VRFs activated, and routes inserted into
the VRF,  before it can be advertised to the clients? 

 Is an exception to this rule done, before reflecting vpnv4 routes? 

Thanks, 
Rajesh

---

From: PamSri <[email-masked]>
Date: Mon, 27 Oct 2003 17:21:56 -0800 (PST)

Rajesh, refer to the Route Reflector v/s Router Server
email thread. ORFs are used to get the specific routes
by the PE from the RR. According to 2547 a RR need'nt
store the VRF info if it does'nt interface any VRF
site. 

sri

--- Rajesh Potti <[email-masked]> wrote:
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Rajesh
> Potti

__________________________________
Do you Yahoo!?
Exclusive Video Premiere - Britney Spears
http://launch.yahoo.com/promos/britneyspears/

---

From: "John Smith" <[email-masked]>
Date: Tue, 28 Oct 2003 13:21:36 +0530

just a clarification,

1. is there anything in the RFC which prevents from treating the RT:ipv4 and
not RD:ipv4 as the bases of the decision making algorithim
2. even if #1 is there, is there anything in the RFC which prevents the
following:
filter routes based on RT, tag each route with an RD=RT, run BGP decision on
the whole set of RD:ipv4 routes, put routes in RIBs_OUT tagged with their
export target attributes etc, and strip RD before sending out the route?

i believe both 1 and 2 are not possible based on the RFC, though it does say
one can make RD=RT.

please correct me if I am wrong.

-Smith

---

From: Rajesh Potti <[email-masked]>
Date: Tue, 28 Oct 2003 09:55:01 -0500

I agree VRFs need not be activated for RR to reflect the VRF routes.
 The question was :- Is this an exception to RFC 2796 on RRs?  Or does
Route Reflectors generally
 reflect routes, even if they are not inserted into the FIB?

Rajesh

--
Rajesh Potti.

---

From: PamSri <[email-masked]>
Date: Tue, 28 Oct 2003 11:35:52 -0800 (PST)

>  reflect routes, even if they are not inserted into
Yes. From a VRF residing on a ingress LER's
perspective the egress LER for the LSP is the p2p
interface and the RR does'nt do a VRF route
forwarding. The only thing that RR would do is a
transport label switching.  

sri