Subject: (No Subject)

From: "Prem Chand" <[email-masked]>
Date: Fri, 12 Dec 2003 01:27:53 -0500

Hi i m giving sample VPN-IPv4 update message below. 

ff ff  ff ff ff ff ff ff ff ff ff ff ff ff ff ff
00 5b  02 00 00 00 44 40 01 01 02 40 02 00 80 04
04 00  00 00 00 40 05 04 00 00 00 64 c0 10 08 00
02 00  03 00 00 00 03 80 0e 21 00 01 80 0c 00 00
00 00  00 00 00 00 0a 0d 01 3e 00 76 00 01 71 00
00 00  01 00 00 00 01 c8 01 3e 04

Here, the total length = 0x5b = 91bytes
Withdrawn Length = 0x00 = 0 bytes
Path Attributes Length = 0x0044 = 68 bytes

MP_REACH_NLRI -- length = 0x21 = 33bytes
<AFI, SAFI> = <1, 128>
Nexthop Length = 0x0c = 12bytes
Nexthop = 0:10.13.1.62
Prefix+label length in bits = 0x76 = 118.
Label = 0x000171
Prefix -- RD=0x0000000100000001 IPv4 route = 200.1.62.4

This prefix+lable length in bits '118' is not divisible by 8 (i.e doent fall under octet boundary length). Can it be like this? or is it erroneous packet?

Label (3 octets) + RD (8 octets) + IPv4 prefix (4 octets) = 15 octets = 120 in bits. How it matches with 118???

Regards,
PREM

____________________________________________________________
Free Poetry Contest. Win $10,000. Submit your poem @ Poetry.com!
http://ad.doubleclick.net/clk;6750922;3807821;l?http://www.poetry.com/contest/contest.asp?Suite=A59101

---

From: Enke Chen <[email-masked]>
Date: Thu, 11 Dec 2003 22:48:58 -0800

The prefix length is /30 (and not /32) in this case.

-- Enke

> To: [email-masked]
> Date: Fri, 12 Dec 2003 01:27:53 -0500
> From: "Prem Chand" <[email-masked]>
> Message-ID: <[email-masked]>
> Mime-Version: 1.0
> Cc: [email-masked]
>