Subject: Clarification on the L3 framework draft

From: "Vishal Sharma" <[email-masked]>
Date: Tue, 30 Dec 2003 17:15:55 -0800

Folks,

I have the following question, and would appreciate someone
clarifying it.

On pp. 54, Sec. 4.4.4, the document states that using 
BGP's route reflectors, PE-PE adjacencies can be completely
eliminated, and furthermore that the no. of backbone adjacencies
can be made a small constant _independent_ of the number of
PEs involved.

I figure even if one is using RR's, each PE device would
have to have an adjacency to one (typcially two) RRs, so
the total adjacencies in the system or on any one RR will
be a function of the number of PEs? 

Or, is the statement talking merely of the adjacencies between 
the RRs themselves,
which I suppose would be independent of the number of PEs,
or of the adjacencies on a given PE, which also would be 
a constant in this case.

Any insights would be very helpful.

Thanks,
-Vishal

****************************************************************
Dr. Vishal Sharma
Metanoia, Inc.
1600 Villa Street, Unit 352
Mountain View, CA 94041-1174
Phone: +1 408-530-8313. Cell: +1 408-394-6321 
Email: [email-masked]. http://www.metanoia-inc.com
****************************************************************

---

From: "Vishal Sharma" <[email-masked]>
Date: Wed, 31 Dec 2003 09:55:59 -0800

Pam,

Thanks. I did understand that the aggregate
routing model is being talked about here. My
question, however, was focused more on how it
is possible to make the adjacencies with RRs
_independent_ of the no. of PEs, as stated in 
the draft.

As I explained in my email, at least from the
perspective of the network as a whole or from
that of the RRs, it appears that the no. of
adjacencies will, in fact, depend on the no. of
PEs (unless I misunderstood something).

Thanks,
-Vishal

> -----Original Message-----
> From: PamSri [mailto:[email-masked]]
> Sent: Wednesday, December 31, 2003 8:24 AM
> To: Vishal Sharma
> Subject: Re: Clarification on the L3 framework draft
> 
> 
> Vishal ,
> 
> "PE-PE adjacencies can be
> > completely
> > PEs involved."
> This is from the perspective of a single instance
> model that is being talked about, instead of a VFI
> model where one routing protocol is used per VFI in
> other words one PE-PE peering per VFI. 
> 
> sri
> 
> --- Vishal Sharma <[email-masked]> wrote:
> > Folks,
> > 
> __________________________________
> Do you Yahoo!?
> Find out what made the Top Yahoo! Searches of 2003
> http://search.yahoo.com/top2003

---

From: "Vishal Sharma" <[email-masked]>
Date: Wed, 31 Dec 2003 11:53:20 -0800

Sri,

Comments in-line.

> Sent: Wednesday, December 31, 2003 11:17 AM
> To: Vishal Sharma
> Subject: RE: Clarification on the L3 framework draft
> 
> 
> Vishal,
> The draft says PE-PE adjacencies are eliminated and
> the no. of adjacencies in the backbone can be reduced
> to a small constant which is independent of PEs when
> RRs are used. Seems pretty simple, straightforward and
> fair statement. 

Please look at my explanations more carefully. I have outlined
4 items for which adjacencies may be counted -- i) for the
RRs, ii) between the RRs, iii) for the PEs, and iv) for the network
as a whole.
Of these ii) and iii) may be made constant, and I'd already observed
this in my original email.
(RRs peer with each other, and this depends on the number of domains
that the network is split into, which is likely to be a (long-term)
constant. PE's peer with RR's, and typically with 2, so that is
also a constant.)

> What this is saying is if RRs are used then no matter
> how many PEs one adds it does'nt result in that many
> PE-PE peerings. In otherwords only PE(RRC) - RR
> peerings need to be added when RRs are used. 

That's right, and I think this fact was pretty clear
in my original email itself. But, that does not appear to me to be 
a case where adjacencies are _independent_ of the 
number of PEs.

(As you add more PE's the no. of adjacencies
at the RR's will grow (and thereby so will those in the network
as a whole), and moreover, these _will_ be a function of
the number of PEs.)

So, I was trying to determine the basis of the original statement
in the draft, and that question still stands.

-Vishal

> > > > eliminated, and furthermore that the no. of
> > backbone
> > > > adjacencies
> > > > can be made a small constant _independent_ of
> > the
> > > > number of
> > > > PEs involved."
> > > 
> > > > I have the following question, and would
> > appreciate
> > > > someone
> > > > clarifying it.
> > > > 
> > > > eliminated, and furthermore that the no. of
> > backbone
> > > > adjacencies
> > > > can be made a small constant _independent_ of
> > the
> > > > number of
> > > > PEs involved.
> > > > 
> > > > I figure even if one is using RR's, each PE
> > device
> > > > would
> > > > the total adjacencies in the system or on any
> > one RR
> > > > will
> > > > which I suppose would be independent of the
> > number
> > > > of PEs,