Subject: RE: FW: draft-touch-ipsec-vpn-06.txt

From: "Claudio Lordello" <[email-masked]>
Date: Tue, 27 Jan 2004 10:57:29 -0500

Mark Duffy wrote:
> 
> At 09:12 AM 1/27/2004 -0500, Lars Eggert wrote:
> 
> >Some 2401-compliant implementations *CAN* run dynamic 
> routing over IPsec
> >tunnels. Some 2401-compliant implementations *CANNOT*.
> >
> >I'd call that an issue in the spec with regard to supporting dynamic
> >routing. (I don't know how else to explain this any simpler.)
> 
> The authors of this draft have been making this sort of 
> argument all along 
> and to me it makes no sense.  Some ethernet-compliant devices 
> *CAN* support 
> IP and some *CANNOT*.  Does anyone think this is a problem with the 
> ethernet spec?
> 
> -Mark

You hit the nail on the head.

The fact is that IPsec is orthogonal to dynamic routing. It does not mandate nor restrict it, as it should.

Claudio.

---

From: Lars Eggert <[email-masked]>
Date: Tue, 27 Jan 2004 17:20:48 +0100

> mandate nor restrict it, as it should.

It does include a tunneling mechanism that provides some of the 
functionality of a virtual link. It leaves it up to implementors to 
decide how fully to implement related link characteristics. Hence the 
ambiguity.

The ID does NOT propose to change 2401 such that all IPsec 
implementations must support dynamic routing.

It describes one approach that carefully combines existing mechanisms 
such that dynamic routing works by default.

We're running in circles, and I'll stop now.

Lars
-- 
Lars Eggert                                     NEC Network Laboratories