Subject: Re: draft-touch-ipsec-vpn-06.txt

From: Joe Touch <[email-masked]>
Date: Mon, 26 Jan 2004 22:11:04 -0800

Claudio Lordello wrote:
>>...
>>
>>>OK. In summary: this WG is asking comments as to whether or not it
>>>should approve this draft,
>>
>>Actually, since it's not a WG doc, the 'approval' isn't the option.
>>
>>What's being asked is whether the WG has issues with the doc in its 
>>current for, notably issues central to L3VPN.
>>
> Well, hopefully is very clear by now that I do have an issue
 > with this draft on its current format, and I have clearly stated
 > what exactly my issue is on previous emails.
> 
>>>a draft which states that "IPsec tunnel mode
>>>conflict with routing and forwarding inside a VN", when in fact, the
>>>only mode that MUST be supported by SG's (i.e., routers), 
>>
>>as established
>>
>>>by the IPsec WG, is actually tunnel mode.
>>
>>That is an excellent point that has already been taken up 
>>with the IPsec 
>>WG. Your participation in that WG - notably on the update to RFC2401, 
>>would have been useful.
>>
>>Joe
> 
> Not at all! I am NOT the one saying that there are issues
 > with running routing protocols over an IPsec tunnel. You are
 > saying that. I am perfectly happy with the MUST's and
> MAY's currently specified in 2401bis regarding tunnel/transport
 > mode. Actually, I have clearly stated that the implementation
 > I work with does support dynamic routing over an IPsec tunnel,
 > without any of the issues you describe in your draft.
> 
> Claudio.

Claudio,

This thread is repeating itself. The IPsec WG has already decided on our 
draft on this specific issue. See especially the IPsec WG archives 
around the Salt Lake City IETF meeting in Dec. 2001.

Joe

---

From: "Claudio Lordello" <[email-masked]>
Date: Mon, 26 Jan 2004 16:36:13 -0500

> current for, notably issues central to L3VPN.

Well, hopefully is very clear by now that I do have an issue with this draft on its current format, and I have clearly stated what exactly my issue is on previous emails.

> WG. Your participation in that WG - notably on the update to RFC2401, 

Not at all! I am NOT the one saying that there are issues with running routing protocols over an IPsec tunnel. You are saying that. I am perfectly happy with the MUST's and MAY's currently specified in 2401bis regarding tunnel/transport mode. Actually, I have clearly stated that the implementation I work with does support dynamic routing over an IPsec tunnel, without any of the issues you describe in your draft. 

Claudio.