Subject: Re: Re: draft-ietf-l3vpn-ospf-2547-01.txt query

From: "Karthikeyan Subramaniam" <[email-masked]>
Date: 4 May 2004 13:09:35 -0000

Anand,

  Can you produce a scenario (in VPN) where and why do we need to distinguish real AS-external routes and external routes generated through standard BGP/OSPF interaction mechanism ?

with regards,
S.Karthikeyan

On Fri, 30 Apr 2004 Anand Oswal wrote :
>Karthikeyan,
>
>The remote CE routers of the same VPN, need to appear as if they are
>part of the same OSPF domain, that is why we carry Type 1,2,3 LSAs
>as Type 3.
>
>If you carry all your routes as AS External, how would you know which
>ones
>are the "real" Ext routes
>
>Thanks
>Anand
>
>Karthikeyan Subramaniam wrote:
> >
> > Hello,
> >
> >     As stated in the draft draft-ietf-l3vpn-ospf-2547-01.txt,
> >
> >    "Per [VPN], the VPN routes are distributed among the PE routers by
> >    BGP.  If the PE uses OSPF to distribute routes to the CE router, the
> >    standard procedures governing BGP/OSPF interactions [OSPF] would
> >    cause routes from one site to be delivered to another as AS-external
> >
> >    routes (in type 5 LSAs).  This is undesirable; it would be much
> >    better to deliver such routes in type 3 LSAs (as inter-area routes),
> >    so that they can be distinguished from any "real" AS-external routes
> >    that may be circulating in the VPN. (That is, so that they can be
> >    distinguished by OSPF from routes which really do not come from
> >    within the VPN.)"
> >
> >    So the query is why do we need to distinguish As-external routes from inter-area routes from VPN perspective??? (I guess Type-3 LSAs are generated for proper database synchronization from OSPF perspective, is there any other reason???)
> >
> > Thanks in advance
> > S.Karthikeyan

---

From: Eric Rosen <[email-masked]>
Date: Tue, 04 May 2004 10:28:48 -0400

> So the  query is  why do  we need to  distinguish As-external  routes from
> inter-area routes from VPN perspective???  

- to  ensure  that  the inter-area  routes  are  preferred  by OSPF  to  the
  AS-external routes, if some prefix can be reached either way;

- to  ensure that inter-area routes  via the VPN backbone  are comparable to
  inter-area routes via "backdoors".