Subject: Sham link query

From: "Karthikeyan Subramaniam" <[email-masked]>
Date: 13 May 2004 06:23:43 -0000

Hi,

    Can I configure more than one sham link between two PE's. For example 
  
area 120 sham-link 10.44.0.1 10.0.0.1 cost 1
area 100 sham-link 10.44.0.1 10.0.0.1 cost 1

with regards,
S.Karthikeyan.

On Wed, 05 May 2004 Anand Oswal wrote :
>Hi,
>
>The sham link end point will be  a  loopback interface (usually)
>associated with your VRF.
>For manual config you will need to explicitly specify the endpoint
>for the sham link.
>
>You can use BGP to carry this address to the remote PE VRF.
>
>So in your example below.
>on PE1, you will have a manual config to specify
>10.1.1.1 sham-source
>10.1.1.2 sham-endpoint
>
>Hope that helps.
>Thanks
>Anand
>
>
>
>On Wed, 5 May 2004, nabendu das wrote:
>
> >
> >
> > HI
> >
> > Cosidering the scenario below, how data packets will be forwarded
> > through sham link
> >
> >
> > H1
> > ------------CE1----------PE1-----------P---------------P-------------PE2--------------CE2
> >
> >
> > A) AUTO-configuration:
> > PE1 will distribute its sham link endpoint address(10.1.1.1) at PE1 as
> > VPN-IPV4 route through BGP along with BGP next-hop and label L1. So PE2 will
> > have a routing entry at its VRF for 10.1.1.1 with BGP next-hop and label. So
> > while forwarding packet to H1, it will find 10.1.1.1 as next-hop and for
> > 10.1.1.1 it will find the BGP next-hop and ..it will find the tunnel to that
> > BGP next-hop and packet can be forwarded through the tunnel after
> > encapsulating the packet with L1 and tunnel first next-hop label.
> >
> >
> > B) MANUAL configuration:
> > PE1 and PE2 both will be configured with sham link endpoint address as
> > 10.1.1.1 and 10.2.2.2 ..
> > But there will be no route at PE2 for PE1 endpoint address i.e 10.1.1. (as
> > we are manually configuring, VPN-IPV4 route for 10.1.1.1 will not be
> > advertised via BGP to PE2).... So when we do manual configuration for sham
> > link , how sham link will be up and how data packets will be forwarded
> > through sham link ???????
> >
> >
> > TIA
> > Nabendu
> >
> > _________________________________________________________________
> > Best of Indian handicrafts.
> > http://www.fabmall.com/affiliatehtml/redir/nl8.asp At MSN Shopping.
> >
> >
>
>

---

From: Anand Oswal <[email-masked]>
Date: Thu, 13 May 2004 10:48:11 -0700

A sham-link is required between any two VPN sites (VRF's) belonging 
to the same area and they also have a backdoor link between the CE
routers.
If a backdoor link is not present between the CE routers, sham-link is 
not required.

Sham Link source and endpoint are part of the VRF.
Sham link area is the same as the area towards the CE.

You could have more than one sham link between the same source
and endpoint in the same area, but dont think it would be very useful.

Hope that helps.
Thanks
Anand