Subject: question on l3vpn RT constraints draft

From: Spice Sylvia <[email-masked]>
Date: Wed, 24 Nov 2004 07:18:04 +0000 (GMT)

Hi,

In the framework of this draft, specifically when one
needs attachement identifiers for multihomed site in
L2VPN case,

If <as, RT> is the NLRI, could <as as , RT> constitute
a possible NLRI?

In other words (say for the L2VPN case), when a site
is advertised <as , RT> from one location and another
L2 circuit to the site is advertised as <as as, RT>
from another location, could one have something of the
form:

a. use the BGP decision process and collapse <as as,
RT> into <as , RT> due to the path length.

b. only the one selected in a is propogated to peers
from the peer at which it is collapsed (best is
chosen)

c. the fact that one has a path to <as, RT> implies
one can also have a path to <as as , RT> via the peer
from which is learns <as , RT> and specifically setup
and LSP when needed?

d. the other option ofcourse, for the L2VPN case is to
use different as numbers for each of the end points
attachement identifiers which makes things easy.

I have also read some documents by some vendors who
claim that the same AS number can be used at 2
different sites in the L3VPN case. I would like to
know how such vendors plan to handle backdoor links
running BGP between these sites?

-brgds
Sylvia

___________________________________________________________ 
Moving house? Beach bar in Thailand? New Wardrobe? Win £10k with Yahoo! Mail to make your dream a reality. 
Get Yahoo! Mail www.yahoo.co.uk/10k

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 24 Nov 2004 00:51:49 -0800

Hi,

 > is advertised <as , RT>

In rt-constrain spec we do not advertise sites. We advertise PE's import 
  policy. It does not really matter what sites are attached behind the 
PEs as route targets itself create an policy abstraction already for us 
not to have to consider the external sites connected to such PEs.

 > L2 circuit to the site is advertised as <as as, RT>

Further rt-constrain is not an autodiscovery proposal in any form and we 
do not intend to advertise circuits.

 > RT> into <as , RT> due to the path length.

BGP decision process does not modify NLRIs

 > from which is learns <as , RT> and specifically setup

That's exactly why sending <as:RT> should be sufficient.

 > running BGP between these sites?

Essentially that would be a multihomed site. In those cases (when 
AS_PATH has been altered) use of SOO is the solution to prevent routing 
loops.

Cheers,
R.

 > Spice Sylvia wrote:

---

From: Spice Sylvia <[email-masked]>
Date: Wed, 24 Nov 2004 09:52:53 +0000 (GMT)

> BGP decision process does not modify NLRIs

yes, i mixed up some terms, but 1st let me clarify
some points,

from the draft:

   In order to achieve this we will rely on ASa and
ASi generating a
   NLRI consisting of <as#, route-target> ( RT
membership information ).
   Receipt of such an advertisement by one of the ASes
in the network
   will signal the need to distribute VPN routes
containing this Route
   Target community to the peer that advertised this
route.

a. what is the AS# that ASa and ASi have to signal to
their peers?

b. will ASa and ASi not know the best path to get from
ASa to ASi? Hence they do not need to signal peers
which are not a part of the best path, correct?

c. in other words as far as i can see, ASa will send a
<asi,RT> along the best path it sees to AS-i, and ASi
will send a <asa,RT> along the best path it sees to
AS-a ? Is my understanding correct?

d. What if I wish to use a suboptimal
path/link/circuit to AS-i from AS-a (the path along
which the as,rt goes is the direction in which traffic
will flow for that RT from AS-a to AS-i, is that
correct)?

-brgds
Sylvia

___________________________________________________________ 
Win a castle for NYE with your mates and Yahoo! Messenger 
http://uk.messenger.yahoo.com

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 24 Nov 2004 05:43:41 -0800

> a. what is the AS# that ASa and ASi have to signal to

As number in the NLRI is the AS# of the PE which advertises such a NLRI. 
For ASa this is ASa's number and for ASi - ASi AS number.

> AS-a ? Is my understanding correct?

No ASa will send <asa,RT> and ASi will send <asi,RT> NLRIs.

> will flow for that RT from AS-a to AS-i, is that

You can use multipath and apply the received advertisement from any 
number of peer's ASBRs.

Cheers,
R.

---

From: Spice Sylvia <[email-masked]>
Date: Wed, 24 Nov 2004 14:15:29 +0000 (GMT)

> For ASa this is ASa's number and for ASi - ASi AS

fine seems I was right the 1st time then...
then why do you say that:

"Further rt-constrain is not an autodiscovery proposal
in any form ...."

seems to me that is exactly what you are doing here.
you are autodiscovering VPN members across ASes.

"   Receipt of such an advertisement by one of the
ASes in the network
   will signal the need to distribute VPN routes
containing this Route
   Target community to the peer that advertised this
route."

> No ASa will send <asa,RT> and ASi will send <asi,RT>

So in the given example, AS-a would receive multiple
paths to AS-i,RT via each of the paths and choose the
best path based on BGP decison process?

-brgds
Sylvia