Subject: Adding lo0 to a VRF

From: John Smith <[email-masked]>
Date: Thu, 23 Dec 2004 04:51:07 +0000 (GMT)

Hi,

Assume a PE (in RFC 2547 context) which has some 3 VRFs defined. Should it be possible
(or does this make any sense at all) to add the loopback IP address of this PE router in
one of the VRFs?

I understand advertising this loopback IP address to other BGP PE routers? But would
anyone want to advertise the loopback IP address in the remote PE's VRFs? That is,
advertise a loopback IP address as MP_REACH_NLRI with the NLRI as RD:lo0, etc.

Thanks,
John

___________________________________________________________ 
ALL-NEW Yahoo! Messenger - all new features - even more fun! http://uk.messenger.yahoo.com

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 22 Dec 2004 23:13:53 -0800

Hi John,

First you have to separate two things ..

One is the interface assignment to the vrf handling and the other IP 
address scope and IP address reuse.

In most implementations of 2547 I am aware of an interface can belong to 
only one vrf. So if your lo0 is already part of global table (aka VRF_0) 
you can't simply put it under any other vrf.

Now reg the IP address reuse ... sure. You can define the same IP 
address as for yr global loopback and configure it under some new loX 
interface then assign this new interface into a vrf. If you red 
connected it will get advertised with the format RD:IP_address_of_yr_loX.

Cheers,
R.

 > John Smith wrote: