Subject: Re: WG LAST CALL draft-ietf-l3vpn-vr-mib-03

From: Joseph Laria <[email-masked]>
Date: Mon, 4 Jul 2005 09:03:49 -0700 (PDT)

Hi Adrian,

Thanks for your thoughtful comments.  I've replied
in-line below.

Regards.

Joe Laria

--- Adrian Farrel <[email-masked]> wrote:

> Hi,
> 
> A few brief comments. Nothing very important.
> 
> I-D should indicate intended status.
> Since you have suggested that the OID is
> "experimental" perhaps this I-D
> is also Experimental?
I disagree.  Rather the I-D would be informational. 
The VR MIB would likely go under mib-2 as does the
vpnTcMIB.  This change would be incorporated in the
next version of the draft.

> 
> Most mentions of "MIB" should read "MIB module"
I agree and will encorporate your suggestion in the
next version of the draft.

> 
> Nice to indicate (in a comment and not using square
> brackets) the RFC
> number of imports.
> (e.g. see draft-ietf-ccamp-gmpls-te-mib-09.txt)
I agree, but I this follows the style of other drafts
in the WG.

> 
> vrName Description clause has spare period and line
> break.
I agree and will encorporate your suggestion in the
next version of the draft.

> 
> vrRpTrigger Description appears to repeat itself.
I agree and will encorporate your suggestion in the
next version of the draft.

> 
> vrRpTrigger
> "Bits 4-7 are reserved for future use."
> I think the BITS syntax is not constrained to be
> exactly 8 bits. So you
> don't need this sentence.
I agree and will encorporate your suggestion in the
next version of the draft.

> 
> vrActiveVRs
> "vrStatOperationalStatus" should read "vrOperStatus"
I agree and will encorporate your suggestion in the
next version of the draft.

> 
> vrRpStatus
> Shouldn't this have Syntax BITS and a back pointer
> to vrRpTrigger?
> Better still would be to define a Textual Convention
> for them both to use.
I agree and will encorporate your suggestion in the
next version of the draft.

> 
> vrRouterAddress
> Are you sure that this cannot be configured per VR?
The VR router addresses are indexed by VR.  They can
be configured per VR.

> 
> All Notifications return vrRowStatus. I would have
> expected vrOperStatus.
> Seems, however, to be unnecessary as the status can
> be deduced from the
> trap type.
I agree, but it seems unnecessary as the status can be
deduced from the trap type.

> 
> vrUp and vrDown
> The Description clauses should refer explicitly to
> vrOperStatus
I agree and will encorporate your suggestion in the
next version of the draft.

> 
> vrMaxRoutesExceeded
> Isn't there a danger of Notification storms with
> this Notification?
> The definition of vrMaxRoutes is such that
> vrStatRouteEntries could never
> exceed it. So when you reach vrMaxRoutes, each new
> attempt to add a route
> will cause a new Notification.
I agree and will encorporate your suggestion in the
next version of the draft.

> 
> You should probably reference as normative the RFCs
> from which you import
> things.
> That will include the new RFC4001.
> Also VPN-TC-STD-MIB in draft-ietf-l3vpn-tc-mib. This
> is pretty important
> as this I-D must not go to RFC before that one does.
I agree and will encorporate your suggestion in the
next version of the draft.

> 
> Cheers,
> Adrian
> 
> ----- Original Message ----- 
> From: "Ron Bonica" <[email-masked]>
> To: <[email-masked]>
> Sent: Wednesday, June 22, 2005 10:16 PM
> Subject: WG LAST CALL draft-ietf-l3vpn-vr-mib-03
> 
> 
> > Folks,
> >
> > This message begins a working group last call on
> > draft-ietf-l3vpn-vr-mib. The last call will end on
> > July 8.
> >
> >                            Ron
> >
> >
> > -------- Original Message --------
> > Subject: I-D ACTION:draft-ietf-l3vpn-vr-mib-03.txt
> > Date: Wed, 22 Jun 2005 15:50:01 -0400
> > From: [email-masked]
> > To: [email-masked]
> > CC: [email-masked]
> >
> > A New Internet-Draft is available from the on-line
> Internet-Drafts
> > directories.
> > This draft is a work item of the Layer 3 Virtual
> Private Networks
> > Working Group of the IETF.
> >
> > Title : Virtual Router Management Information Base
> Using SMIv2
> > Author(s) : E. Stelzer, et al.
> > Filename : draft-ietf-l3vpn-vr-mib-03.txt
> > Pages : 21
> > Date : 2005-6-22
> >
> > This memo defines a portion of the Management
> Information Base (MIB)
> > for use with network management protocols in
> TCP/IP based internets.
> > In particular, it defines objects for managing
> networks using Virtual
> > Routers (VR).
> >
> > A URL for this Internet-Draft is:
> >
>
http://www.ietf.org/internet-drafts/draft-ietf-l3vpn-vr-mib-03.txt

---

From: "Adrian Farrel" <[email-masked]>
Date: Tue, 5 Jul 2005 18:32:07 +0100

Hi Joseph,

Thanks for the response.
Cutting down to just a couple of points.

> The VR router addresses are indexed by VR.  They can

OK, but you are in the vrStatTable which is all read-only. That means that
you cannot configure this item.
This may be your intention, but if so, I'm not clear how you do set the
address.

> > be deduced from the trap type.

OK. So does that mean you will remove vrRowStatus and not include
vrOperStatus?

Regards,
Adrian

---

From: Sam Hancock <[email-masked]>
Date: Wed, 6 Jul 2005 22:04:25 -0700 (PDT)

Hello Adrian,
Please see my comments inline with the questions.
Cheers,
Sam>

> This may be your intention, but if so, I'm not clear how you do set the

The address is configured at the interface level, and then interfaces are
attached to the VR via the vrIfConfigTable.

> OK. So does that mean you will remove vrRowStatus and not include

All notifications return vrRowStatus to assist in finding the vrId.  Since the
vrId is a not-accessible, the vrRowStatus was added to the varbind list. The
vrOperStatus seemed redundant to the vrUp and vrDown notifications--although it
could serve similar role in deriving the vrId.

---

From: "Adrian Farrel" <[email-masked]>
Date: Fri, 8 Jul 2005 14:26:32 +0100

OK Sam,

Clear.

Adrian
----- Original Message ----- 
From: "Sam Hancock" <[email-masked]>
To: "Adrian Farrel" <[email-masked]>; "Joseph Laria"
<[email-masked]>; <[email-masked]>
Cc: <[email-masked]>
Sent: Thursday, July 07, 2005 6:04 AM
Subject: Re: WG LAST CALL draft-ietf-l3vpn-vr-mib-03