Subject: Question on NG MVPN

From: John Smith <[email-masked]>
Date: Wed, 11 May 2011 06:48:48 +0100 (BST)

Hi,

All the documents that explain the Next Generation (NG) MVPN mention using P2MP 
LSPs for transmitting the multicast vpn data across the network. My question is 
that is it mandatory to support P2MP LSPs for this or is it just an optimization 
that routers could use. Can we not set up multiple point-to-point RSVP tunnels 
to each remote PE and still get the NG solution to work?

While Sec 3.2.2 of draft-ietf-l3vpn-2547bis-mcast-10 does seem to allude to the 
possibility of using unicast p2p RSVP tunnels, the draft still keeps referring 
to P2MP tunnels.

Is it then fair to say that by using unicast p2p RSVP tunnels we cannot 
implement UI-PMSIs and S-PMSIs?

Thanks, John

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 11 May 2011 04:53:52 -0700

John,

> Hi,
> 
> All the documents that explain the Next Generation (NG) MVPN mention 
> using P2MP LSPs for transmitting the multicast vpn data across the network. 
> My question is that is it mandatory to support P2MP LSPs for this or is 
> it just an optimization that routers could use. Can we not set up 
> multiple point-to-point RSVP tunnels to each remote PE and still get 
> the NG solution to work?

One can certainly set up multiple point-to-point RSVP tunnels to
each remote PE and get the NG solution to work - this is ingress
replication.
  
> While Sec 3.2.2 of draft-ietf-l3vpn-2547bis-mcast-10 does seem to 
> allude to the possibility of using unicast p2p RSVP tunnels, the draft 
> still keeps referring to P2MP tunnels.

Please look at draft-ietf-l3vpn-2547bis-mcast-bgp-08.txt for
more on ingress replication. 

> implement UI-PMSIs and S-PMSIs?

No, this is incorrect. One can certainly implement both UI-PMSI
and S-PMSI with ingress replication using p2p RSVP tunnels.

Yakov.

---

From: John Smith <[email-masked]>
Date: Wed, 11 May 2011 13:36:46 +0100 (BST)

Thank You Yakov for your answers.

Then this really means that the data plane is exactly the same as L3 VPN for 
Unicasts. Is this correct?

The only difference being that the MPLS labelled packet that comes from the 
network side will undergo a (S,G, VRF) lookup after decapsulation instead of a 
normal L3 lookup thats done for regular L3 VPNs.

> more on ingress replication. 

I did and it actually confused me.

Sec 5 only seems to refer to P2MP LSPs and i was wondering if P2P LSPs are 
supported or not.

Thanks, John

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 11 May 2011 06:04:40 -0700

John,

> Thank You Yakov for your answers.

Welcome.

> Unicasts. Is this correct?

The data plane on all the P routers is exactly the same as L3VPN for
unicast. The data plane on the PE routers is not the same (you pointed
to the difference below).

> network side will undergo a (S,G, VRF) lookup after decapsulation instead of 
> a normal L3 lookup thats done for regular L3 VPNs.

Correct.

>From section 5:

     + 0 - No tunnel information present
     + 1 - RSVP-TE P2MP LSP
     + 2 - mLDP P2MP LSP
     + 3 - PIM-SSM Tree
     + 4 - PIM-SM Tree
     + 5 - PIM-Bidir Tree
     + 6 - Ingress Replication
     + 7 - mLDP MP2MP LSP
   ....

   When the type is set to Ingress Replication the Tunnel Identifier
   carries the unicast tunnel endpoint IP address of the local PE that
   is to be this PE's receiving endpoint address for the tunnel.

Ingress replication in the above uses unicast LSPs (either p2p with
RSVP-TE or mp2p with LDP).

Yakov.

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 11 May 2011 06:55:58 -0700

Saud,

> Yakov,
> 
> Regarding your last point. Isn't there a provision to have Ingress
> Replication using P2P LSPs with LDP?

I am not sure what you mean by "P2P LSPs with LDP". Could you please
elaborate.

Yakov.

> 
> Saud
> 
> -----Original Message-----
> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Yakov Rekhter
> Sent: Wednesday, May 11, 2011 9:05 AM
> To: John Smith
> Cc: [email-masked]
> Subject: Re: Question on NG MVPN 
> 
> John,
>

---

From: John Smith <[email-masked]>
Date: Wed, 11 May 2011 15:34:15 +0100 (BST)

Saud,

Thats probably because there is no tunnel to speak of with LDP.

Thanks, John

----- Original Message ----
From: "ASIF, SAUD (ATTSI)" <[email-masked]>
To: Yakov Rekhter <[email-masked]>
Cc: John Smith <[email-masked]>; [email-masked]
Sent: Wed, 11 May, 2011 19:50:47
Subject: RE: Question on NG MVPN 

Yakov,

You mentioned "Ingress replication in the above uses unicast LSPs
(either p2p with RSVP-TE or mp2p with LDP)". 

My question was can't we have IR using Unicast LSPs:

1. p2p with LDP  OR 
2. p2p with RSVP-TE

Saud

-----Original Message-----
From: Yakov Rekhter [mailto:[email-masked]] 
Sent: Wednesday, May 11, 2011 9:56 AM
To: ASIF, SAUD (ATTSI)
Cc: John Smith; [email-masked]
Subject: Re: Question on NG MVPN 

Saud,

Yakov.

> > Sec 5 only seems to refer to P2MP LSPs and i was wondering if P2P
LSPs
> are

---

From: Eric Rosen <[email-masked]>
Date: Wed, 11 May 2011 11:05:05 -0400

Saud> My question was can't we have IR using Unicast LSPs:

Saud> 1. p2p with LDP  OR 
Saud> 2. p2p with RSVP-TE

The unicast LSPs created by LDP are multipoint-to-point (mp2p), not
point-to-point.  Please don't confuse mp2p with p2mp!