Subject: RE: Poll to adopt draft-rosen-l3vpn-mvpn-bidir-03 as a L3VPN WG document

From: Jeff Tantsura <[email-masked]>
Date: Mon, 2 May 2011 01:14:00 -0400

Yes/support (in Maya calendar :))

Regards,
Jeff  

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Ben Niven-Jenkins
Sent: Saturday, April 30, 2011 02:02
To: L3VPN WG mailing list
Cc: [email-masked]
Subject: Poll to adopt draft-rosen-l3vpn-mvpn-bidir-03 as a L3VPN WG document

Colleagues,
 
This e-mail is to start a poll on whether the L3VPN WG should adopt draft-rosen-l3vpn-mvpn-bidir-03.txt as a L3VPN WG document.
 
Please indicate your support or otherwise by responding to this message (with yes/support or no/do not support) or e-mailing the WG chairs privately.

If you do not support the adoption of the document it would be useful if you could also state the reason for your objection.
 
Please send your responses by midnight August 15th May PDT.

FYI Eric has outlined his view on the need for this document on the mailing list previously which you can read here:
http://www.ietf.org/mail-archive/web/l3vpn/current/msg02901.html

Thanks
Ben

---

From: "NAPIERALA, MARIA H (ATTSI)" <[email-masked]>
Date: Mon, 2 May 2011 10:21:11 -0400

Yes/support

Maria

> Sent: Saturday, April 30, 2011 5:02 AM
> This e-mail is to start a poll on whether the L3VPN WG should adopt
> draft-rosen-l3vpn-mvpn-bidir-03.txt as a L3VPN WG document.
> 
> Please indicate your support or otherwise by responding to this
message
> (with yes/support or no/do not support) or e-mailing the WG chairs
> privately.
> 
> If you do not support the adoption of the document it would be useful
> if you could also state the reason for your objection.
> 
> FYI Eric has outlined his view on the need for this document on the
> mailing list previously which you can read here:

---

From: Ahmed Bashandy <[email-masked]>
Date: Mon, 02 May 2011 16:34:37 +0200

Yes,

Support

Thanks

Ahmed

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 4 May 2011 06:55:10 -0700

Ben,

> Please indicate your support or otherwise by responding to this message (with
> yes/support or no/do not support) or e-mailing the WG chairs privately.
> 
> If you do not support the adoption of the document it would be useful if you 
> could also state the reason for your objection.
>  

It is premature to discuss adoption of draft-rosen-l3vpn-mvpn-bidir-03.txt 
as a L3VPN WG document, and here is why.

There was already a discussion in L3VPN WG about adopting
draft-rosen-l3vpn-mvpn-bidir as an L3VPN WG document. From your
e-mail on 10/29/2010:

   To follow-up on this, from comments on the mailing list and private
   conversations between the chairs and some participants it would
   appear that for BiDir P-tunnels at least:
   
   - There is interest in the work and some loose agreement among the
   people that we spoke with that the existing specifications only
   minimally specify solutions using BiDir P-tunnels
   
   - But that there are some quite different views on what the scope
   of any work on BiDir P-tunnels should be.
   
   We already have draft-rosen-l3vpn-mvpn-bidir on the table which has
   received some debate. It would be useful if one or more of the
   people that are not happy with the scope of draft-rosen-l3vpn-mvpn-bidir
   were to make alternative proposal(s) for the scope of work required
   to address BiDir P-tunnels so we can see where the common ground
   may be as a start to see if we can progress a specification for
   BiDir P-tunnels.

In response to your request to put an alternative proposal for
the scope of the work required to address Bidir P-tunnels,
I proposed the following (in my e-mail on 11/22/2010):

   The scope of work in support of mp2mp P-tunnels should be guided by
   draft-ietf-l3vpn-mvpn-considerations.
   
   From draft-ietf-l3vpn-mvpn-considerations:
   
      The use of MP2MP P-tunnels may provide
      some scaling benefits to the service provider as only a single MP2MP
      P-tunnel need be deployed per VPN, thus reducing by an order of
      magnitude the amount of multicast state that needs to be maintained
      by P routers. 
   
   Therefore, the scope of work should be limited to the cases where
   mp2mp P-tunnels do provide scaling benefits in conjunction with
   the C-multicast routing schemes defined in [MVPN]. Specifically, the
   scope of work should be limited to (1) use of mp2mp P-tunnels for
   I-PMSI, and (2) support of C-bidir with the "Partitioned Sets of
   PEs" method using a partial mesh of mp2mp P-tunnels (as discussed in 
   section 11.2.3 of [MVPN]). 
   
   From draft-ietf-l3vpn-mvpn-considerations:
   
      5.  Avoiding duplicates
   
      It is recommended that implementations support the procedures
      described in section 9.1.1 of [I-D.ietf-l3vpn-2547bis-mcast]
      "Discarding Packets from Wrong PE", allowing fully avoiding
      duplicates.
   
   Therefore, use of mp2mp P-tunnels for I-PMSI must fully specify
   procedures to support 9.1.1 of [MVPN].
   
   New work must not change/modify the existing procedures specified
   in [MVPN] and [BGP-MVPN]. New work must not introduce new mechanisms
   and/or procedures unless it shows that the mechanisms/procedures
   specified in [MVPN] and [BGP-MVPN] are insufficient for the purpose
   of delivering what is within the scope (as described above).

There was some subsequent e-mails on the list, but the L3VPN WG
never reached a consensus on the scope of this work.

Therefore, before discussing adopting of draft-rosen-l3vpn-mvpn-bidir as 
an L3VPN WG document, the L3VPN WG must first reach a consensus
on the scope of the work related to the use of Bidir P-tunnels.

Yakov.

---

From: IJsbrand Wijnands <[email-masked]>
Date: Thu, 5 May 2011 08:59:03 +0200

yes/support

---

From: Thomas Morin <[email-masked]>
Date: Wed, 11 May 2011 18:21:37 +0200

Hi Ben, working group,

There have been on-list and off-list discussions in the past 10 months 
or so, and we still haven't a consensus what's needed for bidir-PIM 
tunnels.  Obviously, this is not the best starting point to gather 
consensus on a solution draft. I support the idea that a prerequisite 
for considering adopting a draft on bidir P-tunnels would be to clarify 
the exact things that needs to be solved and have a consensus on this.

A key reason why I would not support the adoption of this draft as-is, 
is specifically the lack of a clearly bounded scope.

-Thomas

---

From: Rahul Aggarwal <[email-masked]>
Date: Tue, 17 May 2011 15:05:26 -0700

Hi Ben, working group,

I oppose the adoption of this draft as a WG draft.

This is because despite several discussions in the past few months, there 
is no consensus on precisely what bidir-PIM tunnel specific issues need to 
be addressed by the WG.

rahul

On Wed, 11 May 2011, Thomas Morin wrote:

> Hi Ben, working group,
>
> There have been on-list and off-list discussions in the past 10 months or so, 
> and we still haven't a consensus what's needed for bidir-PIM tunnels. 
> Obviously, this is not the best starting point to gather consensus on a 
> solution draft. I support the idea that a prerequisite for considering 
> adopting a draft on bidir P-tunnels would be to clarify the exact things that 
> needs to be solved and have a consensus on this.
>
> A key reason why I would not support the adoption of this draft as-is, is 
> specifically the lack of a clearly bounded scope.
>
> -Thomas
>
>
>> Please indicate your support or otherwise by responding to this message 
>> If you do not support the adoption of the document it would be useful if 
>> you could also state the reason for your objection.
>>