Subject: Re: vpn4dc Q&A

From: [email-masked]
Date: Tue, 1 Nov 2011 16:14:55 +0800

Hi Luyuan,
Thanks for initiating this discussion. Please see my comments in line. 

Regards
Lizhong

> ------------------------------
> 
> Message: 3
> Date: Tue, 1 Nov 2011 00:05:49 -0500
> From: "Luyuan Fang (lufang)" <[email-masked]>
> To: "L3VPN" <[email-masked]>
> Subject: vpn4dc Q&A
> Message-ID:
>    <[email-masked]>
> Content-Type: text/plain; charset="us-ascii"
> 
> Hi all,
> 
> 
> 
> There are a few things around vpn4dc I'd like to kick off the
> discussion.
> 
> I put my simple answers to each question, very much like to hear yours.
> 
> 
> 
> 1 What are we trying to achieve in vpn4dc? 
> 
> -          DC Host-to-host connectivity through layer 3 signaling
> protocols.
> 
>        These hosts can be in SP DC, Enterprise DC, content provider's
> DC, any DC... The connection can be in the same DC, or different DCs
> within any admin domains.
> 
[Lizhong] I try to suggest to change "host-to-host connectivity" to "host 
connectivity". Host-to-host is a bit easy to misunderstand with 
point-to-point or end-to-end, while L3VPN will provide 
multipoint-to-multipoint IP connection for hosts.

> 
> 
> 2. What cannot be achieved through L3VPN today?
> 
>         - We don't have a stds way for host-to-host vpn connectivity
> through protocols signaling which easily work in DC. 
> 
>        - BGP/MPLS VPN is extremely successful in network environment.
> But it is normally not accepted in the computing community. I had
> discussion with folks working on DC directly or indirectly, including
> Google, Yahoo, Facebook, VZ, AT&T, CenturyLink, T-Systems, ... many
> folks think layer 3 is a scalable approach, but no BGP/MPLS VPN inside
> DC, into host... so we need to bridge the gap.
> 
>       - And this is no long SP provisioned vpns, it has wider scope.
[Lizhong] agree, and I think VPN4DC does not intend to achieve host 
connectivity only by L3VPN, and L3VPN is only deployed in some network 
segment, e.g, provider's network, part of DC network. L3VPN is not always 
BGP/MPLS VPN based, VRF-lite can also be deployed in DC network.

> 
> 
> 
> 3. What is missing?
> 
>      The missing piece is the segment in DC and
> inter-connection/auto-mapping of the DC segment to the network segment.
[Lizhong] I am not clear with the missing piece of segment in DC. I think 
VPN segment in DC is mixed with L2&L3 VPN. And I agree 
inter-connection/auto-mapping is the missing piece.

> 
> 
> 
> 4. Is this IETF problem?
> 
> - Yes. It is about IP protocols for establish connectivity.
[Lizhong] agree.

> 
> 
> 
> 5. Who wants this? 
> 
>     Please speak out if you do.
> 
> 
> 
> 6. What are not in scope for this initiative/charter?
> 
> - L2VPN for DC connectivity - that goes to L2VPN WG
> 
> - Encryption, key management, new authentication protocols - these go to
> Security Area.
> 
> - Multicast - the mcast use in DC need to be further studied. We like to
> start without mcast to make things simpler, be able to move.
> 
> 
> 
> Looking forward seeing  your comments to any of the questions.
> 
> 
> 
> Thanks,
> 
> Luyuan
> 
> 
> 
> 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail is solely property of the sender's organization. This mail communication is confidential. Recipients named above are obligated to maintain secrecy and are not permitted to disclose the contents of this communication to others.
This email and any files transmitted with it are confidential and intended solely for the use of the individual or entity to whom they are addressed. If you have received this email in error please notify the originator of the message. Any views expressed in this message are those of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam system.

---

From: "Luyuan Fang (lufang)" <[email-masked]>
Date: Tue, 1 Nov 2011 17:19:55 -0500

Lizhong,

Thanks for your comments. See in-line.

Luyuan

From: [email-masked] [mailto:[email-masked]] 
Sent: Tuesday, November 01, 2011 4:15 AM
To: Luyuan Fang (lufang)
Cc: [email-masked]
Subject: Re: vpn4dc Q&A

Hi Luyuan, 

Regards 
Lizhong 

[Lizhong] I try to suggest to change "host-to-host connectivity" to
"host connectivity". Host-to-host is a bit easy to misunderstand with
point-to-point or end-to-end, while L3VPN will provide
multipoint-to-multipoint IP connection for hosts. 

[Luyuan] I really meant any-to-any VPN connections. P2P, partial mesh
would be degenerated cases of any-to-any. May be I should change the
wording later.

[Lizhong] agree, and I think VPN4DC does not intend to achieve host
connectivity only by L3VPN, and L3VPN is only deployed in some network
segment, e.g, provider's network, part of DC network. L3VPN is not
always BGP/MPLS VPN based, VRF-lite can also be deployed in DC network. 

> inter-connection/auto-mapping of the DC segment to the network
segment. 
[Lizhong] I am not clear with the missing piece of segment in DC. I
think VPN segment in DC is mixed with L2&L3 VPN. And I agree
inter-connection/auto-mapping is the missing piece. 

[Luyuan] points taken. 

[Lizhong] agree. 

--------------------------------------------------------
ZTE Information Security Notice: The information contained in this mail
is solely property of the sender's organization. This mail communication
is confidential. Recipients named above are obligated to maintain
secrecy and are not permitted to disclose the contents of this
communication to others.
This email and any files transmitted with it are confidential and
intended solely for the use of the individual or entity to whom they are
addressed. If you have received this email in error please notify the
originator of the message. Any views expressed in this message are those
of the individual sender.
This message has been scanned for viruses and Spam by ZTE Anti-Spam
system.