Subject: Possible Shutdown of L3VPN

From: Marshall Eubanks <[email-masked]>
Date: Sat, 21 Jan 2012 08:37:32 -0500

Dear WG members;

With the Paris meeting coming up, we felt that you should know that
there has been serious discussion of shutting down the L3VPN working
group, both because of a decline of work in the group, and because of the
expected new work to come from the DC effort is likely to require a
new working group with a different focus.

If the WG were to be wound down, the basic choices for existing drafts are

- to go to last call with the drafts that are ready for it or

- to put outstanding WG drafts into another WG, such as MPLS, or

- to have the ADs sponsor "orphaned" drafts that don't fit in another
WG as individual submissions.

We have polled the current draft authors, and do not see any
insurmountable difficulties with this process.

There doesn't at present seem to be enough business to warrant another
L3VPN meeting in Paris. However, we feel that the future of the WG
(and of the work)
should be discussed in person, so we plan to request time on the
agenda to discuss this at
the RTGAREA meeting.

If anyone feels that closing L3VPN would be a mistake, now is the time
to speak up.

Regards
Marshall Eubanks / Ben Niven-Jenkins

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Sun, 22 Jan 2012 07:11:58 +0100

Why don't we keep the WG open until the WG drafts are finished?
We can probably do this on the mailing list and don't need a face2face meeting, but as such you keep the WG alive until the work is done.

-----Original Message-----
From: [email-masked] [mailto:[email-masked]] On Behalf Of Marshall Eubanks
Sent: zaterdag 21 januari 2012 14:38
To: L3VPN; Stewart Bryant (stbryant); [email-masked]
Subject: Possible Shutdown of L3VPN

Dear WG members;

Regards

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Sun, 22 Jan 2012 09:59:13 +0000

Wim,

> Why don't we keep the WG open until the WG drafts are finished?

Because there's nothing like a deadline to motivate people :-)

If it's decided to wind the WG down, what I would expect is that it wouldn't just happen overnight but that we would produce a 'plan' for closure within a reasonable timeframe (say 6 months) where we would aim to finish what we have on our plate first, if possible.

Regarding WG drafts, currently we have 3:
-> draft-ietf-l3vpn-mvpn-wildcards, which has just gone through WG LC and about to be sent to IESG for publication
-> draft-ietf-l3vpn-acceptown-community, which we will initiate a WG LC on shortly
-> draft-ietf-l3vpn-mvpn-bidir, which the authors say needs another revision before being ready for WG LC

So getting those finished relatively quickly before closure seems achievable.

I'd personally also like the combined extranet draft produced before closure but again I'd expect that should be possible relatively quickly too.

Ben

---

From: "Henderickx, Wim (Wim)" <[email-masked]>
Date: Sun, 22 Jan 2012 14:18:29 +0100

Ben, i just want to ensure we close the work as you pointed out before considering closing the WG

-----Original Message-----
From: Ben Niven-Jenkins [mailto:[email-masked]] 
Sent: zondag 22 januari 2012 10:59
To: Henderickx, Wim (Wim)
Cc: Marshall Eubanks; L3VPN; Stewart Bryant (stbryant)
Subject: Re: Possible Shutdown of L3VPN

Wim,

Ben

---

From: "NAPIERALA, MARIA H" <[email-masked]>
Date: Sun, 22 Jan 2012 17:01:40 +0000

Ben,

There are also drafts that there are no WG documents, for example: draft-rosen-l3vpn-mvpn-segments-02.txt.

Maria

> From: [email-masked] [mailto:[email-masked]] On Behalf
> Of Ben Niven-Jenkins
> Sent: Sunday, January 22, 2012 4:59 AM
> Cc: L3VPN; Stewart Bryant (stbryant)
> If it's decided to wind the WG down, what I would expect is that it
> wouldn't just happen overnight but that we would produce a 'plan' for
> closure within a reasonable timeframe (say 6 months) where we would aim
> to finish what we have on our plate first, if possible.
> 
> -> draft-ietf-l3vpn-mvpn-wildcards, which has just gone through WG LC
> and about to be sent to IESG for publication
> I'd personally also like the combined extranet draft produced before
> closure but again I'd expect that should be possible relatively quickly
> too.
> 
> Ben
> 
> > We can probably do this on the mailing list and don't need a
> face2face meeting, but as such you keep the WG alive until the work is
> done.
> >

---

From: <[email-masked]>
Date: Mon, 23 Jan 2012 10:07:08 +0100

Hello,

My opinion is that we should keep the WG open at least until the current 
active drafts and an mVPN extranet draft, are pushed to IESG. The 
alternatives mentioned below don't look to me as particularly appealing.

Thanks,

-Thomas

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 23 Jan 2012 20:10:32 +0000

Maria,

> There are also drafts that there are no WG documents, for example: draft-rosen-l3vpn-mvpn-segments-02.txt.

I guess the question is really whether there needs to be an L3VPN group in order to progress drafts such as the one you mention?

There's also an underlying question of whether L3VPN (at least in its current form) is actually providing anything other than document processing services. IMO the purpose of a WG is to foster technical debate, reach consensus where there are opposing views and provide quality technical reviews of documents.

Speaking frankly I do not think L3VPN is currently achieving any of those things as the level of traffic on the mailing list regarding technical debate or discussing/reviewing documents is practically non-existent. 

Therefore I think it could be argued that progressing documents through L3VPN  provides no value versus progressing them through the AD-sponsored route or through some other appropriate WG.

Ben

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 23 Jan 2012 20:12:25 +0000

Thomas,

> alternatives mentioned below don't look to me as particularly appealing.

Thanks for sharing your views. It would be useful if you could clarify whether by "current active drafts" you mean current WG drafts or current WG drafts and individual drafts listed against L3VPN in the datatracker.

Thanks
Ben

---

From: Thomas Nadeau <[email-masked]>
Date: Mon, 23 Jan 2012 15:54:37 -0500

If there are only a few drafts left, then the other option is to punt the remaining drafts over to MPLS too.

	--Tom

---

From: Linda Dunbar <[email-masked]>
Date: Mon, 23 Jan 2012 21:52:55 +0000

Does it mean that VPN4DC discussion which was held in L3VPN WG session at Taipei will be moved to a new WG? Should L3VPN wait until the new WG is established? 

Linda Dunbar

> Of Marshall Eubanks
> Sent: Saturday, January 21, 2012 7:38 AM

---

From: Marshall Eubanks <[email-masked]>
Date: Mon, 23 Jan 2012 16:59:01 -0500

> Does it mean that VPN4DC discussion which was held in L3VPN WG session at Taipei will be moved to a new WG? Should L3VPN wait until the new WG is established?

That is an entirely separate matter.  The VPN4DC discussion was held
in L3VPN, by request, partially to see if it should be included inside
L3VPN. I think it is fair to say that there is not consensus to do
that. Further discussion on this topic is underway in the DC mailing
list.

Marshall

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Mon, 23 Jan 2012 22:00:25 +0000

Linda,

On 23 Jan 2012, at 21:52, Linda Dunbar wrote:

> Does it mean that VPN4DC discussion which was held in L3VPN WG session at Taipei will be moved to a new WG?

VPN4DC discussions should happen on the [email-masked] mailing list as per my e-mail to the L3VPN list on 9th December.
 
> Should L3VPN wait until the new WG is established? 

Speaking personally, I don't believe closure of L3VPN (if that's what is decided) should be tied to waiting on the more general Data Center discussions reaching consensus. 

Ben

---

From: IJsbrand Wijnands <[email-masked]>
Date: Tue, 24 Jan 2012 09:32:01 +0100

Hi Ben,

I agree with Wim, Thomas and Maria.

Just keep the L3VPN WG active until the WG documents are done and the individual submissions have been sorted out. 

> I guess the question is really whether there needs to be an L3VPN group in order to progress drafts such as the one you mention?

Don't you think it helps to have a focused group to help process it?

Thx,

Ice.

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 24 Jan 2012 09:42:31 +0100

Hi Ben,

I agree with Wim, Thomas, Maria and Ice. It is clearly wise to address 
all L3VPN related documents in this working group rather then attempting 
to prematurely close this working group. And this is not only limited to 
documents accepted as WG docs, but also to new submission in this space 
... all should be worked on here.

As a matter of fact extending the L3VPN to also cover data centers 
tenants isolation IMHO fits very nicely in this working group rather 
then on some new dc alias.

It almost seems like that someone is just pushing to close this WG to 
make sure existing solutions stay sealed while no other ideas (even if 
better) have IETF room to evolve and progress to RFCs ;)

Best,
R.

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 24 Jan 2012 09:59:03 +0000

> Don't you think it helps to have a focused group to help process it?

<hat="individual">

Yes but one could argue that L3VPN isn't performing that role currently. For example I know of other WGs that follow a process where at least 5 people that aren't the authors must review a draft before it is progressed, if we were to instigate a similar rule in L3VPN I suspect few, if any, drafts would meet the criteria for progression. 

IMO L3VPN no longer has a critical mass of active participants that help review, reach consensus and process documents.

Ben

---

From: IJsbrand Wijnands <[email-masked]>
Date: Tue, 24 Jan 2012 12:04:41 +0100

Ben,

> IMO L3VPN no longer has a critical mass of active participants that help review, reach consensus and process documents.

And by moving it to a different WG you think it will get better?

Maybe there is also a role for the WG chairs to solicit input and help drive documents through the WG. But I get the impression the chairs are more interested in killing it.

Thx,

Ice.

---

From: "NAPIERALA, MARIA H" <[email-masked]>
Date: Tue, 24 Jan 2012 13:28:47 +0000

Ben,

> IMO L3VPN no longer has a critical mass of active participants that
> help review, reach consensus and process documents.

IMHO, I don't think that such a "critical mass" existed before, yet the group was able to progress the documents.

Maria

---

From: Robert Raszuk <[email-masked]>
Date: Tue, 24 Jan 2012 16:04:07 +0100

Ben,

> help review, reach consensus and process documents.

Just looking at number of responses along to this thread seems like a 
sufficient prove that there are folks interested in this area and in 
this WG.

As mentioned earlier there are also new incoming proposals which either 
extend existing L3VPN draft-marques-l3vpn-end-system or attempt to solve 
L3VPN without locking customers to the providers 
draft-ko-vaas-problem-statement. Both fit very nicely to overall L3VPN 
WG objective. However indeed they may not fit to BGP_ONLY_L3VPN WG.

Regards,
R.

---

From: Ben Niven-Jenkins <[email-masked]>
Date: Tue, 24 Jan 2012 19:28:28 +0000

Ice,

> And by moving it to a different WG you think it will get better?

<hat="individual">
I don't know if it will get better but I don't think it will be any worse.
</hat>

> Maybe there is also a role for the WG chairs to solicit input and help drive documents through the WG.

On one hand that's probably a reasonable criticism of the WG chairs.

> But I get the impression the chairs are more interested in killing it.

<hat ="individual">
I, personally, have no vested interest in whether L3VPN remains "alive" or gets "killed" and FWIW it wasn't the WG chairs that initiated the discussions on whether the WG should remain open, it was our Area Directors.

I do question whether the L3VPN WG is really providing what the community would generally expect from a WG beyond document processing services and if it isn't then IMO it's hard to justify keeping the WG open when there are other valid routes for progressing those documents.
</hat>

Ben

---

From: Thomas Narten <[email-masked]>
Date: Tue, 24 Jan 2012 21:36:18 -0500

IJsbrand Wijnands <[email-masked]> writes:

> > I guess the question is really whether there needs to be an L3VPN
> > group in order to progress drafts such as the one you mention?

> Don't you think it helps to have a focused group to help process it?

Not if the effort is basically out of steam. It's the author's job to
get a document finished. If they can't do that, and no one else wants
to take over, that's a pretty good indication that a document really
isn't important in the overall scheme of things.

Most WGs get to a point where they run out of steam. They almost
always have a few documents left. But there are two kinds:

1) documents that the WG believes are important, and the
ADs/chairs/etc. agree that an effort isn't complete without finishing
the documents.

2) documents that have been pushed by a small number of persons and
that aren't really all that important. The WG has gone along with the
documents (as they are related to the WGs technology), but really
doesn't care whether they get finished (i.e., not in the previous
category).

Documents in category 2 are for the authors to finish up or to just
drop. No WG is needed for that.

I see two official WG drafts left:

> draft-ietf-l3vpn-acceptown-community

version 00 was published back in October 2008. There was one revision
in 2009. One more revision in 2010. There were two revisions in 2011,
but looking at the diffs, the only change was an author affiliation.

The importance of this document would seem to obvious from the history.

draft-ietf-l3vpn-mvpn-bidir:

-00 as a WG document appeared in August. Has there been any movement
since then? (datatracker doesn't have any history on the predecessor
to this document, so I don't know how long it has been around.)

In Taipei, this WG only met to discuss VPN4DC. It did not discuss any
of its own drafts. Without VPN4DC, the WG presumably wouldn't have met
at all. Surely a sign of a WG that isn't really doing anything?

This sure smells to me like a textbook end-of-life WG that should be
shutdown. The mailing list would of course remain open for closing out
any drafts, assuming there really is interest in completing them.

Thomas

---

From: Marshall Eubanks <[email-masked]>
Date: Tue, 24 Jan 2012 21:36:34 -0500

> I, personally, have no vested interest in whether L3VPN remains "alive" or gets "killed" and FWIW it wasn't the WG chairs that initiated the discussions on whether the WG should remain open, it was…

Indeed it was. Speaking just for myself, I also have no vested
interest here. In my opinion, if people want it to continue, they need
to speak up, start commenting on drafts, and re-energize the group.

Regards
Marshall

---

From: <[email-masked]>
Date: Wed, 25 Jan 2012 09:34:32 +0100

Hi Ben

2012-01-23, Ben Niven-Jenkins:
>> Thomas:
> Thanks for sharing your views. It would be useful if you could
> clarify  whether by "current active drafts" you mean current WG drafts or current
 > WG drafts and individual drafts listed against L3VPN in the
 > datatracker.

Sorry, let me be more precise: the WG should progress (at least) the 
currently active _WG_ drafts and a merged mVPN extranet draft (there is 
active work there) before we may consider closing it.

As far as individual drafts are concerned, I would say this should be 
"business as usual": reaching WG consensus, matching the current charter 
or a revised one, etc.

-Thomas