Subject: draft-ymbk-l3vpn-origination-02

From: <[email-masked]>
Date: Mon, 12 Nov 2012 09:44:25 +0000

Arjun, all,

I confess that I don't know much about SIDR, but I guess that I'm not the only one in L3 VPN. Therefore clarification may be useful for the L3 VPN WG.

Let's assume that no RPKI is used.

1) Given that the goal is to protect from unintentional errors, can you elaborate on the added value brought by l3vpn-origination compared to the use of a (extended) community agreed upon the VPN sites (e.g. some kind of a shared password)?
The latter being available now, how much is it deployed/used now? (I would assume that l3vpn-origination would be used by a subset of such current users)

2) Can you elaborate on how l3vpn-origination protects from unintentional errors by the legitimate originator?
Seems to me that both correct and erroneous routes would be signed by the egress CE/PE and hence accepted by the ingress.

3) Given that a VPN may want to import routes from outside of the VPN (e.g. provider IP services (e.g. voice gateway), extranet), how does l3vpn-origination protect from unintentional errors from those partners?

Thanks for the clarifications,
Bruno

_________________________________________________________________________________________________________________________

Ce message et ses pieces jointes peuvent contenir des informations confidentielles ou privilegiees et ne doivent donc
pas etre diffuses, exploites ou copies sans autorisation. Si vous avez recu ce message par erreur, veuillez le signaler
a l'expediteur et le detruire ainsi que les pieces jointes. Les messages electroniques etant susceptibles d'alteration,
France Telecom - Orange decline toute responsabilite si ce message a ete altere, deforme ou falsifie. Merci.

This message and its attachments may contain confidential or privileged information that may be protected by law;
they should not be distributed, used or copied without authorisation.
If you have received this email in error, please notify the sender and delete this message and its attachments.
As emails may be altered, France Telecom - Orange is not liable for messages that have been modified, changed or falsified.
Thank you.

---

From: <[email-masked]>
Date: Mon, 12 Nov 2012 10:02:36 +0000

Arjun, all,

Given the number of routes in large L3 VPN networks (much higher than in the Internet), IMO the draft should elaborate on the scalability impact of this draft (signing, checking signatures, NLRI deaggregation).
e.g. try to quantify the reduction of capacity on RR and PE, and the increase in convergence time.

Thanks,
Regards,
Bruno