Subject: About ALL-ZERO-MAC's encapsulation in EVPN MAC/IP Advertisement route. //Re: Poll for adoption: draft-bonica-l3vpn-orf-covering-prefixes

From: Zhuangshunwan <[email-masked]>
Date: Wed, 2 Jul 2014 16:00:10 +0800

Dear all,

I have got into knots for presentment of ALL-ZERO-MAC's encapsulation in EVPN MAC/IP Advertisement route.

draft-bonica-l3vpn-orf-covering-prefixes-03 defines the "Default MAC Route ":

   o  Default MAC Route (DMR) - An EVPN MAC/IP Advertisement Route with
      MAC Address length equal to 0.

But draft-rabadan-l2vpn-dci-evpn-overlay-01 said:

2.5.1 Use of the Unknown MAC route to reduce unknown flooding 

      The solution suggested in this document is based on the use of an
      "Unknown MAC route" that is advertised by the Designated Forwarder
      DC GW. The Unknown MAC route is a regular EVPN MAC/IP
      Advertisement route where the MAC Address Length is set to 48 and
      the MAC address to 00:00:00:00:00:00 (IP length is set to 0).

Can we use a uniform way?

Regards,
Shunwan (Vincent)

-----邮件原件-----
发件人: L3VPN [mailto:[email-masked]] 代表 Thomas Morin
发送时间: 2014年6月27日 22:21
收件人: [email-masked]
抄送: [email-masked]
主题: Poll for adoption: draft-bonica-l3vpn-orf-covering-prefixes

Hello working group,

This email starts a two-week poll on adopting
draft-bonica-l3vpn-orf-covering-prefixes-03 [1] as a working group item.

Please send comments to the list and state if you support adoption or
not (in the later case, please also state the reasons).

This poll runs until July 12th.

*Coincidentally*, we are also polling for knowledge of any IPR that
applies to this draft, to ensure that IPR has been disclosed in
compliance with IETF IPR rules (see RFCs 3979, 4879, 3669
and 5378 for more details).

==> *If you are listed as a document author or contributor* please
respond to this email and indicate whether or not you are aware of any 
relevant IPR.

The draft will not be adopted until a response has been received from
each author and contributor.

If you are on the L3VPN WG mailing list but are not listed as an author
or contributor, then please explicitly respond only if you are aware of
any IPR that has not yet been disclosed in conformance with IETF rules.

Thank you,

Martin & Thomas
l3vpn chairs

[1] http://tools.ietf.org/html/draft-bonica-l3vpn-orf-covering-prefixes-03

---

From: "Rabadan, Jorge (Jorge)" <[email-masked]>
Date: Wed, 2 Jul 2014 10:31:54 +0000

Hi Shunwan,

That’s a good point. A couple of comments about it and why I think we
should use a length = 48.

- I don’t know about draft-bonica, but there is already at least one
shipping implementation using 00:..:00/48 as per
draft-rabadan-l2vpn-dci-evpn-overlay
- There are a few reasons why we decided to use length 48:

1) The EVPN base draft only allows a MAC length = 48 and says other length
is out of scope
2) In the IP world, there is subneting so a default route with length /0
makes sense. In the MAC world, there is no subnetting (at least in real
implementations where MACs are not managed) so some implementations might
have issues with lengths different than 48.
3) the meaning of 00:..:00/48 is a bit different than only a default
route. We actually decided to call it “unknown mac route” since you might
want to advertise it from different gateway devices to attract all the
unknown traffic to ONLY those devices. In
draft-rabadan-l2vpn-dci-evpn-overlay you can see that the ingress PE needs
to send unknown traffic to all the egress PEs advertising the
unknown-mac-route, as opposed to only one.

Thank you.
Jorge

-----Original Message-----
From: Zhuangshunwan <[email-masked]>
Date: Wednesday, July 2, 2014 at 1:00 AM
To: 'Thomas Morin' <[email-masked]>, "[email-masked]"
<[email-masked]>
Cc: "[email-masked]" <[email-masked]>,
"[email-masked]"
<[email-masked]>
Subject: About ALL-ZERO-MAC's encapsulation in EVPN MAC/IP Advertisement
route. //Re: Poll for adoption: draft-bonica-l3vpn-orf-covering-prefixes

---

From: Robert Raszuk <[email-masked]>
Date: Wed, 2 Jul 2014 12:35:41 +0200

Jorge,

I would highly agree with your suggestion.

Even if for nothing else then point #3 is a very reasonable and strong
argument to be able to differentiate "default MAC" from "unknown MAC":

3) the meaning of 00:..:00/48 is a bit different than only a default
route. We actually decided to call it “unknown mac route” since you might
want to advertise it from different gateway devices to attract all the
unknown traffic to ONLY those devices.

Thx,
R.

On Wed, Jul 2, 2014 at 12:31 PM, Rabadan, Jorge (Jorge) <
[email-masked]> wrote:

> >[1]
> http://tools.ietf.org/html/draft-bonica-l3vpn-orf-covering-prefixes-03
> >
>
>

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 2 Jul 2014 13:41:24 +0000

Shunwan,

> Can we use a uniform way?

Yes, we'll update draft-bonica-l3vpn-orf-covering-prefixes to use
00:00:00:00:00:00 MAC as the Default MAC Route.

Yakov.

> compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for
> more details).
>

---

From: Yakov Rekhter <[email-masked]>
Date: Wed, 2 Jul 2014 06:46:23 -0700

Thomas,

> This poll runs until July 12th.

Support (as a co-author).

Yakov.

---

From: John E Drake <[email-masked]>
Date: Wed, 2 Jul 2014 13:47:47 +0000

Support

Yours Irrespectively,

John

> From: L3VPN [mailto:[email-masked]] On Behalf Of Thomas Morin
> Sent: Friday, June 27, 2014 7:21 AM
> To: [email-masked]
> Cc: [email-masked]
> Subject: Poll for adoption: draft-bonica-l3vpn-orf-covering-prefixes
> 
> Hello working group,
> 
> Please send comments to the list and state if you support adoption or not (in
> the later case, please also state the reasons).
> 
> *Coincidentally*, we are also polling for knowledge of any IPR that applies to
> this draft, to ensure that IPR has been disclosed in compliance with IETF IPR
> rules (see RFCs 3979, 4879, 3669 and 5378 for more details).
> 
> ==> *If you are listed as a document author or contributor* please respond to
> this email and indicate whether or not you are aware of any relevant IPR.
> 
> The draft will not be adopted until a response has been received from each
> author and contributor.
> 
> If you are on the L3VPN WG mailing list but are not listed as an author or
> contributor, then please explicitly respond only if you are aware of any IPR that
> has not yet been disclosed in conformance with IETF rules.
> 
> Thank you,
> 
> Martin & Thomas
> l3vpn chairs
>

---

From: "Rabadan, Jorge (Jorge)" <[email-masked]>
Date: Wed, 2 Jul 2014 15:20:45 +0000

Support.

Jorge

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Wed, 2 Jul 2014 16:25:25 +0000

>00:00:00:00:00:00 MAC as the Default MAC Route.

Great! Since evpn draft only specifies MAC address w/ length 48.

Cheers,
Ali

---

From: "Ali Sajassi (sajassi)" <[email-masked]>
Date: Wed, 2 Jul 2014 16:29:38 +0000

Support

-Ali

---

From: Zhuangshunwan <[email-masked]>
Date: Thu, 3 Jul 2014 08:30:30 +0800

Support

-Shunwan

-----邮件原件-----
发件人: L3VPN [mailto:[email-masked]] 代表 Thomas Morin
发送时间: 2014年6月27日 22:21
收件人: [email-masked]
抄送: [email-masked]
主题: Poll for adoption: draft-bonica-l3vpn-orf-covering-prefixes

Hello working group,

Thank you,

Martin & Thomas
l3vpn chairs

---

From: "Keyur Patel (keyupate)" <[email-masked]>
Date: Thu, 3 Jul 2014 00:33:56 +0000

Regards,
Keyur

---

From: Zhuangshunwan <[email-masked]>
Date: Thu, 3 Jul 2014 08:52:06 +0800

Jorge,

I'm much obliged to you for your detailed comments. 

Thank you.
Shunwan

-----邮件原件-----
发件人: Rabadan, Jorge (Jorge) [mailto:[email-masked]] 
发送时间: 2014年7月2日 18:32
收件人: Zhuangshunwan; 'Thomas Morin'; [email-masked]
抄送: [email-masked]; [email-masked]
主题: Re: About ALL-ZERO-MAC's encapsulation in EVPN MAC/IP Advertisement route. //Re: Poll for adoption: draft-bonica-l3vpn-orf-covering-prefixes

Hi Shunwan,

Thank you.
Jorge

-----Original Message-----
From: Zhuangshunwan <[email-masked]>
Date: Wednesday, July 2, 2014 at 1:00 AM
To: 'Thomas Morin' <[email-masked]>, "[email-masked]"
<[email-masked]>

---

From: Ronald Bonica <[email-masked]>
Date: Thu, 3 Jul 2014 21:42:16 +0000

And support as co-author...

> Sent: Friday, June 27, 2014 10:21 AM
> To: [email-masked]
> ==> *If you are listed as a document author or contributor* please respond
> to this email and indicate whether or not you are aware of any relevant IPR.
> 
> contributor, then please explicitly respond only if you are aware of any IPR
> that has not yet been disclosed in conformance with IETF rules.
> 
> Thank you,
> 
> Martin & Thomas
> l3vpn chairs
>

---

From: Luay Jalil <[email-masked]>
Date: Thu, 3 Jul 2014 16:45:38 -0500

Support (co-author)

Luay

---

From: Xuxiaohu <[email-masked]>
Date: Fri, 4 Jul 2014 00:58:50 +0000

Support as co-author.

Xiaohu

> From: L3VPN [mailto:[email-masked]] On Behalf Of Ronald Bonica
> Sent: Friday, July 04, 2014 5:42 AM
> To: EXT - [email-masked]; [email-masked]
> Subject: RE: Poll for adoption: draft-bonica-l3vpn-orf-covering-prefixes
> 
> > compliance with IETF IPR rules (see RFCs 3979, 4879, 3669 and 5378 for more
> details).
> >
> > If you are on the L3VPN WG mailing list but are not listed as an
> > author or contributor, then please explicitly respond only if you are
> > aware of any IPR that has not yet been disclosed in conformance with IETF
> rules.
> >
> > Thank you,
> >
> > Martin & Thomas
> > l3vpn chairs
> >
> > [1]

---

From: Vero Zheng <[email-masked]>
Date: Fri, 4 Jul 2014 02:11:58 +0000

Support.

Regards,
Vero

> Sent: Friday, June 27, 2014 10:21 PM
> To: [email-masked]

---

From: Lucy yong <[email-masked]>
Date: Mon, 7 Jul 2014 16:23:19 +0000

Hi Thomas,

> This poll runs until July 12th.

Support as a co-author.

Lucy

---

From: Thomas Morin <[email-masked]>
Date: Wed, 23 Jul 2014 17:17:46 -0400

Hi,

This draft is now a working group document.
Can authors please repost as draft-ietf-l3vpn-orf-covering-prefixes-00  ?

Thank you,

-Thomas

---

From: Thomas Morin <[email-masked]>
Date: Wed, 23 Jul 2014 23:29:54 -0400

Hi,

Thank you,

-Thomas