Subject: Re: [Lager] Default Namespace

From: Asmus Freytag <[email-masked]>
Date: Sun, 18 Oct 2015 08:29:42 -0700

On 9/22/2015 12:14 PM, Hollenbeck, Scott wrote:
>
> You need to pick one of those namespace identifiers and use it 
> consistently throughout the document. I suggest changing 
> “http://www.iana.org/lgr/0.1” to “urn:ietf:params:xml:ns:lgr-1.0” in 
> the schema.
>

Not having heard from Kim, I'm in the process of making that change and 
pushing a new -04 before the document submission deadline. With that we 
should be clean as far as issues with _existing functionality_ are 
concerned.

The remaining issues in the tracker are all about new / additional 
features and are outside of what I can take care of.

A./
>
> Scott
>
> *From:*Lager [mailto:[email-masked]] *On Behalf Of *Asmus Freytag
> *Sent:* Tuesday, September 22, 2015 2:15 PM
> *To:* [email-masked]
> *Subject:* Re: [Lager] Default Namespace
>
> On 9/22/2015 5:06 AM, Hollenbeck, Scott wrote:
>
>     *From:*Lager [mailto:[email-masked]] *On Behalf Of *Asmus
>     Freytag
>     *Sent:* Monday, September 21, 2015 4:03 PM
>     *To:* [email-masked] <mailto:[email-masked]>
>     *Subject:* [Lager] Fwd: I-D Action:
>     draft-ietf-lager-specification-03.txt
>
>     I've rolled up the pending discussion into an -03 draft. People
>     should verify that this addresses their concerns.
>
>     At this point, it would be useful for someone more experienced
>     with schemas to check the schema for the <scope> element.
>
>     I just did some basic XML validation checking. One nit: the
>     default namespace used in the schema found in Appendix D is
>     http://www.iana.org/lgr/0.1. The namespace used in the examples
>     included in Appendix A is “urn:ietf:params:xml:ns:lgr-1.0”. These
>     should be consistent with the latter type being more commonly
>     used. Both of the examples appear to be otherwise valid per the
>     schema.
>
>
> Scott,
>
> can you phrase this more explicitly like "change x to y in paragraph z"
>
> Because I can't make heads or tails of your comment.
>
> A./
>
> Scott
>
>
>
>
> _______________________________________________
> Lager mailing list
> [email-masked] <mailto:[email-masked]>
> https://www.ietf.org/mailman/listinfo/lager
>
>
>
> _______________________________________________
> Lager mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lager

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Sun, 18 Oct 2015 16:34:12 +0000

Thanks for making the change.

Scott

From: Lager [mailto:[email-masked]] On Behalf Of Asmus Freytag
Sent: Sunday, October 18, 2015 11:30 AM
To: [email-masked]
Subject: Re: [Lager] Default Namespace

On 9/22/2015 12:14 PM, Hollenbeck, Scott wrote:
You need to pick one of those namespace identifiers and use it consistently throughout the document. I suggest changing “http://www.iana.org/lgr/0.1” to “urn:ietf:params:xml:ns:lgr-1.0” in the schema.

Not having heard from Kim, I'm in the process of making that change and pushing a new -04 before the document submission deadline. With that we should be clean as far as issues with existing functionality are concerned.

The remaining issues in the tracker are all about new / additional features and are outside of what I can take care of.

A./

Scott

From: Lager [mailto:[email-masked]] On Behalf Of Asmus Freytag
Sent: Tuesday, September 22, 2015 2:15 PM
To: [email-masked]<mailto:[email-masked]>
Subject: Re: [Lager] Default Namespace

On 9/22/2015 5:06 AM, Hollenbeck, Scott wrote:
From: Lager [mailto:[email-masked]] On Behalf Of Asmus Freytag
Sent: Monday, September 21, 2015 4:03 PM
To: [email-masked]<mailto:[email-masked]>
Subject: [Lager] Fwd: I-D Action: draft-ietf-lager-specification-03.txt

I've rolled up the pending discussion into an -03 draft. People should verify that this addresses their concerns.

At this point, it would be useful for someone more experienced with schemas to check the schema for the <scope> element.

I just did some basic XML validation checking. One nit: the default namespace used in the schema found in Appendix D is http://www.iana.org/lgr/0.1. The namespace used in the examples included in Appendix A is “urn:ietf:params:xml:ns:lgr-1.0”. These should be consistent with the latter type being more commonly used. Both of the examples appear to be otherwise valid per the schema.

Scott,

A./

Scott

Lager mailing list

[email-masked]<mailto:[email-masked]>

Lager mailing list

[email-masked]<mailto:[email-masked]>