Subject: [Lager] LAGER IETF-94 Meeting Minutes

From: "Hollenbeck, Scott" <[email-masked]>
Date: Thu, 5 Nov 2015 23:54:09 +0000

Here are the meeting minutes take by Paul Hoffman (thanks, Paul!). Does anyone see anything that needs to be edited?

Scott
----------
LAGER WG
IETF 94, Yokohama
Thursday November 5, 2015
Scott Hollenbeck and Marc Blanchet, chairs
Minutes by Paul Hoffman
	Things from the slides are not included here

draft-ietf-lager-specification remaining issues (Kim Davies)
	Trying to come to resolution on these
	Almost no changes to the major technical parts since taken into the WG
	{{ Registration of new dispositions }}
	Martin DÃ¼rst: Limiting the registration too much makes people use the private space instead
		Don't be too strict at the start
	Kim: Doesn't feel strongly about that, willing to take an alternative
	Barry Leiba: Standards document, IETF review, RFC required, specification required, expert review, first-come-first-serve
	Asmus Freitag: Another approach is used for the <scope> element
	Andrew Sullivan: Nervous about private disposition approach
		Weird to have a registristry that is not for interoperable
		Maybe have a high bar for the important ones
		Maybe have a middle level
		Marc: maybe the middle level is a bit more formal, specification required
	{{ Lots of people have read the document }}
		One person thinks it is ready
		Andrew: Specialized document, needs some specialized review

LAGER implementation report (Audric Schiltknecht)
	Yoshiro Yoneya: IDNA 2008 relies on Unicode 6.3, so there is also a dependency on IDNA version
	Variant generation is the big topic, very difficult to code
	Yoshiro: At APNIC meeting, people said that some Arabic labels could generate a million variants
		Will send URL of presentation to list
	Marc: Will you provide text for the LGR spec?
		Audric: Yes, from a technical side
	Asmus: Maybe add a line to the metadata indicating the minimum and maximum label length
		Or hack this up through a WLE rule
		Used to give zone policy
		Edmund Chung: WLE seems logical
	Andrew: Because this is supposed to be used with IDNA labels, there are technical limitations already
		There might be disagreements

LAGER use cases (Yoshiro Yoneya)
	TLDs (root zone)
	Second level
	Lager is intended to replace IANA tables?
	Maybe have an IANA registry?
	Need some integration mechanism
	Edmund: In the root zone LGR, are we expecting multiple LAGER LGRs, or just one?
		Marc: This is out of scope unless there is an impact on the specification
			There will be multiple LGR files
		Asmus: Integrated set of LGR files
			So no need to have integration mechanism
	Yoshiro: This question is about second level, so the integration might be required there
		Kim: Envisages that LGR files will replace tables as they exist today
		Paul Hoffman: Should consider this after we are finished
		Edmund: Might not want to call the metatag "language", but can also mean script
			Maybe call it "IDN LGR tag"
			This plus scope could form what we want to achieve
		Andrew: Thinks there is such an identifier there
			Take this to the list
			Marc: In there in 3.3.3
			Asmus: Sees no need to fiddle with this

Audric: What should he do with his earlier proposals?
	Scott: Take it to the list

---

From: Yoshiro YONEYA <[email-masked]>
Date: Fri, 6 Nov 2015 14:53:01 +0900

Dear co-chairs,

Thank you for the minutes.
One correction:
  Edmund -> Edmon

Regards,

-- 
Yoshiro YONEYA <[email-masked]>

On Thu, 5 Nov 2015 23:54:09 +0000 "Hollenbeck, Scott" <[email-masked]> wrote:

> _______________________________________________
> Lager mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lager
> 
>

---

From: "Hollenbeck, Scott" <[email-masked]>
Date: Fri, 6 Nov 2015 17:17:34 +0000

Will fix - thanks!

Scott

> -----Original Message-----
> From: Lager [mailto:[email-masked]] On Behalf Of Yoshiro YONEYA
> Sent: Friday, November 06, 2015 12:53 AM
> To: [email-masked]
> Subject: Re: [Lager] LAGER IETF-94 Meeting Minutes
> 
> Dear co-chairs,
> 
> > Here are the meeting minutes take by Paul Hoffman (thanks, Paul!).
> Does anyone see anything that needs to be edited?
> >
> > Scott
> > ----------
> > LAGER WG
> > IETF 94, Yokohama
> > 	Barry Leiba: Standards document, IETF review, RFC required,
> specification required, expert review, first-come-first-serve