Subject: Re: [Lager] Draft Agenda Posted - small suggestion

From: Kim Davies <[email-masked]>
Date: Wed, 4 Nov 2015 18:53:19 +0000

Hi all,

>> ** There's no way to define a scope that is "generic". ICANN has this project of defining reference LGRs for the second level, and those, by definition, are intended to be applicable to any zone on the second level.
>> The appropriate designation would therefore be a wildcard, something like ".*", or some other scope type altogether, that is not "domain" but something else. (Range of domains?, Level?).
>> 
>> What is being created really is a "template", rather than an actual LGR, but the template is, for example, not necessarily intended for all zones (for example, not the root).

It sounds like what is perhaps being called for is a statement in the metadata that it is an LGR that has no explicit claim to a specific zone, but is intended for usage with domain names. Since the root zone, which is technically a zero-length label in the DNS, is explicitly denoted to as “.” in the specification, perhaps an empty text node in the XML can be used to represent such templates, i.e.:

	<scope type=“domain”/>

If something more explicit is desirable, something along the lines of:

	<scope type=“domain”><none/></scope>

I guess I am not particularly concerned with the use case because I don’t think in practice reference LGRs benefit from machine identification in the same way a production LGR does. I can foresee a registry platform may have a set of LGRs in its configuration, and in the parsing process the application needs to identify which LGRs to apply to which zones. However, a reference LGR is going to be a starting point for a curation process whereby a registry operator tailors it to the needs of a given zone, and then later adds their own explicit <scope> tag(s) to turn it into a production LGR.

>> Is this a use case for having an LGR that can apply to any number of zones based on wild card, etc?
...
> The use case, as far as I understand it, is to have a model LGR, which can be adopted into any zone (or perhaps any zone on a particular level). Now, the easiest is to make a copy of the file with the scope replaced (and/or additional scopes added).

I don’t think a reference LGR can make any claim to apply at a certain level. I can see a wildcard being applicable in a private context (i.e. IETF could produce an LGR for all its children zones, thus has a scope like "*.ietf.org”.) However, if one is creating an LGR with an intended purpose for being useable at the “registration-level”, the level where third-parties can openly register domains, these don’t all happen at specific level of the DNS. Consider *.co.uk and *.com.au, for example. I think trying to wander down this path is probably overengineering, where a simple statement in the free-form text that this is a reference table intended for domain-related usage may be sufficient.

I guess a counter-question is, what is the risk if the metadata does not limit its usage to a general domain scope? If I used a reference LGR that was originally designed for domain registry usage for a different kind of non-domain application, is that a problem?

kim

---

From: Asmus Freytag <[email-masked]>
Date: Wed, 4 Nov 2015 11:21:00 -0800

On 11/4/2015 10:53 AM, Kim Davies wrote:
> Hi all,
>
>>>     ** There's no way to define a scope that is "generic". ICANN has
>>>     this project of defining reference LGRs for the second level,
>>>     and those, by definition, are intended to be applicable to any
>>>     zone on the second level.
>>>
>>>     The appropriate designation would therefore be a wildcard,
>>>     something like ".*", or some other scope type altogether, that
>>>     is not "domain" but something else. (Range of domains?, Level?).
>>>
>>>     What is being created really is a "template", rather than an
>>>     actual LGR, but the template is, for example, not necessarily
>>>     intended for all zones (for example, not the root).
>>>
>
> It sounds like what is perhaps being called for is a statement in the 
> metadata that it is an LGR that has no explicit claim to a specific 
> zone, but is intended for usage with domain names. Since the root 
> zone, which is technically a zero-length label in the DNS, is 
> explicitly denoted to as “.” in the specification, perhaps an empty 
> text node in the XML can be used to represent such templates, i.e.:
>
> <scope type=“domain”/>
>

An empty field (or "none") would go partway to a solution of identifying 
an LGR as pertaining to IDNs without localizing them in the tree.

Someone suggested ".example". That might be a workable convention as well.

>
> I guess I am not particularly concerned with the use case because I 
> don’t think in practice reference LGRs benefit from machine 
> identification in the same way a production LGR does.

Actually, you will want to run the same tools over them, and the tools 
for developing LGRs tend to "insist" that these have a valid scope. This 
is fine, because it allows the tools to know that, for example, it is OK 
to flag IDNA 2008 DISALLOWED code points, or to verify that IDNA 2008 
CONTEXTO/J code points are covered by context rules in the LGR. These 
kinds of QA support issues are potentially different for other scopes.

> I can foresee a registry platform may have a set of LGRs in its 
> configuration, and in the parsing process the application needs to 
> identify which LGRs to apply to which zones. However, a reference LGR 
> is going to be a starting point for a curation process whereby a 
> registry operator tailors it to the needs of a given zone, and then 
> later adds their own explicit <scope> tag(s) to turn it into a 
> production LGR.

There is a separate issue of selecting an LGR based on the metadata. 
That's not so much  a "validity" issue.
>> The use case, as far as I understand it, is to have a model LGR, 
>> which can be adopted into any zone (or perhaps any zone on a 
>> particular level). Now, the easiest is to make a copy of the file 
>> with the scope replaced (and/or additional scopes added).
>
> I don’t think a reference LGR can make any claim to apply at a certain 
> level. I can see a wildcard being applicable in a private context 
> (i.e. IETF could produce an LGR for all its children zones, thus has a 
> scope like "*.ietf.org <http://ietf.org>”.) However, if one is 
> creating an LGR with an intended purpose for being useable at the 
> “registration-level”, the level where third-parties can openly 
> register domains, these don’t all happen at specific level of the DNS. 
> Consider *.co.uk <http://co.uk> and *.com.au <http://com.au>, for 
> example. I think trying to wander down this path is probably 
> overengineering, where a simple statement in the free-form text that 
> this is a reference table intended for domain-related usage may be 
> sufficient.

I think there is something to your argument. So what we are looking for 
then, is a way (either a convention or a syntax option) that allows us 
to specify that an LGR intends to be applicable with (and valid for) a 
scope of type="domain" without having to select a specific domain.

If ".example" is a usable convention for this purpose, I could live with 
that. Alternatively, if leaving the scope blank is recognized as "DNS 
zone unspecificed, but LGR is of type domain", that would work for me as 
well.
>
> I guess a counter-question is, what is the risk if the metadata does 
> not limit its usage to a general domain scope? If I used a reference 
> LGR that was originally designed for domain registry usage for a 
> different kind of non-domain application, is that a problem?

I think I pointed out some useful validations that are possible if you 
know that the ruleset is for IDNs.

A./
>
> kim
>
>
>
> _______________________________________________
> Lager mailing list
> [email-masked]
> https://www.ietf.org/mailman/listinfo/lager