Subject: I-D ACTION:draft-ietf-ldapbis-protocol-00.txt

From: [email-masked]
Date: Wed, 10 Jan 2001 06:45:55 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the LDAP (v3) Revision Working Group of the IETF.

	Title		: Lightweight Directory Access Protocol (v3)
	Author(s)	: J. Sermersheim
	Filename	: draft-ietf-ldapbis-protocol-00.txt
	Pages		: 51
	Date		: 09-Jan-01
	
The protocol described in this document is designed to provide access
to directories supporting the [X.500] models, while not incurring the
resource requirements of the X.500 Directory Access Protocol (DAP).
This protocol is specifically targeted at management applications and
browser applications that provide read/write interactive access to
directories. When used with a directory supporting the X.500
protocols, it is intended to be a complement to the X.500 DAP.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ldapbis-protocol-00.txt

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-ldapbis-protocol-00.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-ldapbis-protocol-00.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 10 Jan 2001 17:57:57 -0700

This (draft in the subject line) will be the official first cut of the protocol draft. It differs from the "other" first cut (http://search.ietf.org/internet-drafts/draft-sermersheim-ldapbis-rfc2251-00.txt) in that it only has a minimal and very safe set of changes. Those changes are illustrated in Appendix B and repeated here:

B.1 Editorial
   - Bibliography References: Changed all bibliography references to
     use a long name form for readability.
   - Changed occurrences of "unsupportedCriticalExtension" to
     "unavailableCriticalExtension"
   - Fixed a small number of misspellings (mostly dropped letters).

B.2 Section 1
   - Removed IESG note.

B.3 Section 9
   - Added references to RFCs 1823, 2234, 2829 and 2830.

I pulled the previous changes out due to unease at their inclusion felt at the San Diego meeting. Please voice your opinion if you feel any of this is unacceptable. 

Going forward, I will post a handful of issues to the list to gain consensus before applying them to the draft. I'll try to keep it down to 3 or 4 outstanding issues at a time. I plan on resubmitting the draft periodically as changes are made so everyone can track the process in a more incremental way.

The current set of outstanding issues is listed in Appendix C. This is not a complete list, just a merge of the old Appendix C and all the pulled changes from my last attempt. If you have some time to kill, you can start forming your opinions today on issues to be talked about tomorrow, but I'd like to keep the number of issues being discussed at one time low.

Thanks. 

Jim