Subject: RE: When to not deref aliases

From: "Jim Sermersheim" <[email-masked]>
Date: Fri, 12 Jan 2001 10:38:20 -0700

My copy of X.511 (93) doesn't include a CommonArguments in the bind operation, thus you can't specify "dontDereferenceAliases". Also, the bind operation doesn't talk about alias dereferencing. I don't know if this is to be read as:
1) since you can't specify behavior, don't deref while binding or,
2) since you can't specify behavior, do deref while binding (since the implied default is to deref).

I feel like I'm overlooking something.

Jim

>>> "Jim Sermersheim" <[email-masked]> 1/12/01 10:08:25 AM >>>
So it sounds like we should state that Compare and ModDN do not deref the alias. Does X.500 deref the bind name (or equiv) if it's an alias?

Jim

>>> "Ramsay, Ron" <[email-masked]> 11/16/00 7:24:03 PM >>>
You're right, Compare should not dereference (as it has no way of saying not
to dereference).

As regards X.500, CommonArguments, ServiceControls contains
options:dontDereferenceAliases, and this is available to all operations
(where Bind is not an operation). Of course, it is ignored in update
operations.

Ron.

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]] 
Sent: Friday, 17 November 2000 13:05
To: Jim Sermersheim
Cc: [email-masked]; [email-masked] 
Subject: RE: When to not deref aliases

At 06:39 PM 11/16/00 -0700, Jim Sermersheim wrote:
>Well, I don't think we can do that for v3. I'm just trying to get
clarification on whether we should explicitly state that alias dereferencing
does not happen for those three op's.

I assume this is in X.500 somewhere, but I believe aliases
should be dereferenced during processing of the search operation.
Other operations should act upon the alias, not the aliased object.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 12 Jan 2001 10:49:27 -0800

IMO, aliases should only be dereferenced when there is a field
enabling the behavior (such as provided in the search request
or by a control).  I believe this is implicit in the specification.
This can be made explicit if necessary.