Subject: Re: AttributeTypeValue and binary

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 24 Jan 2001 17:52:20 -0700

My suggested change is the result of trying to keep the existing wording intact as much as possible, and also not address any issues other than the wrapper confusion. Another wordy possibility is:

A field of type AttributeValue is an OCTET STRING containing an encoding of the value syntax of the companion attribute type. When the syntax of an attribute type defines a string encoding, that encoding is used unless an option is present in the companion AttributeDescription which overrides the string-based encoding. For example, if the "binary" option is present, the value will be the binary encoding of the value.

This addresses the "wrapper" issue, the "default encoding" issue, and the "future encodings" issue.

Jim

>>> Mark Smith <[email-masked]> 1/24/01 4:01:54 PM >>>
Jim Sermersheim wrote:
> 
> I believe there is consensus regarding the first part of this message.
> That being that the first paragraph of section 4.1.6 is confusing, and
> leaves the reader unsure as to whether or not all binary encodings require
> an extra OCTET STRING wrapper.
> 
> Unless there are objections, I will make the following change to the protocol > document:
> 
> 4.1.6
> <A field of type AttributeValue takes on as its value either a string encoding of a AttributeValue data type, or an OCTET STRING containing an encoded binary value, depending on whether the "binary" option is present in the companion AttributeDescription to this AttributeValue.
> >A field of type AttributeValue is an OCTET STRING containing either a string encoding, or an encoded binary value of an AttributeValue data type, depending on whether the "binary" option is present in the companion AttributeDescription to this AttributeValue.

I think the revised text is better but still a little confusing and
awkward (although the OCTET STRING wrapper issue has been addressed). 
At the risk of being "wordy" I suggest:

 If the companion AttributeDescription to an AttributeValue does not
 contain the "binary" option, then the AttributeValue field is an
 OCTET STRING that contains a string encoded value.

 If the companion AttributeDescription to an AttributeValue contains the
 "binary" option, then the AttributeValue field is an OCTET STRING
 that contains an encoded binary value of the AttributeValue data type.

-Mark

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 24 Jan 2001 17:12:14 -0800

>This addresses the "wrapper" issue, the "default encoding" issue, and the "future encodings" issue.

This has the problem in that the default encoding for certificate
is binary.  That is, when all attributes are requested and the
entry contains a userCertificate attribute, the attribute should
be returned as userCertificate;binary.

---

From: "Steven Legg" <[email-masked]>
Date: Thu, 25 Jan 2001 13:40:55 +1100

Jim,

> -----Original Message-----
> From: [email-masked]
> [mailto:[email-masked]]On Behalf Of Jim Sermersheim
> Sent: Thursday, 25 January 2001 11:52
> To: [email-masked]
> Cc: [email-masked]; [email-masked]
> Subject: Re: AttributeTypeValue and binary
> 
> 
> My suggested change is the result of trying to keep the 
> existing wording intact as much as possible, and also not 
> address any issues other than the wrapper confusion. Another 
> wordy possibility is:
> 
> A field of type AttributeValue is an OCTET STRING containing 
> an encoding of the value syntax of the companion attribute 
> type. When the syntax of an attribute type defines a string 
> encoding, that encoding is used unless an option is present 
> in the companion AttributeDescription which overrides the 
> string-based encoding. For example, if the "binary" option is 
> present, the value will be the binary encoding of the value.

Can we say "BER encoding" instead of "binary encoding" ? The latter is
likely to cause confusion with arbitrary binary data, which should of
course be put in an attribute with Octet String syntax.

Regards,
Steven