Subject: RE: binary syntax suggestion (Was: AttributeTypeValue andbinary)

From: "Jim Sermersheim" <[email-masked]>
Date: Mon, 22 Jan 2001 19:09:25 -0700

What was wrong with the OCTET STRING wrapper comment (I assume you're referring to 2251: 4.1.6)? It made sense as an issue that should be cleared up.

>>> "Kurt D. Zeilenga" <[email-masked]> 1/21/01 8:17:12 PM >>>
I offer this revised suggestion.  I've dropped the ;binary
restriction as more discussion is needed regarding this and
the more general issues Steven has raised.  I've also dropped
the OCTET STRING wrapper comment as being misplaced and somewhat
confusing.

>I suggest 4.3.1 be stricken and 6.2 be replaced with:
>
>6.2. Binary
>
>   ( 1.3.6.1.4.1.1466.115.121.1.5 DESC 'Binary' )
>
>   Each value of this syntax is a BER-encoded instance of
>   an ASN.1 data type definition. 

I actually view the following paragraph as stating the obvious
(attribute types can state additional restrictions upon values,
but such enforcement of such restrictions is OPTIONAL), so I'm
not sure if adds value or not.  Maybe a more general (not
syntax specific) statement in this area would be more appropriate.

>   Attribute type, matching rule, and other specifications
>   which make use of this syntax MAY place further restrict
>   upon values of this syntax including restricting values to
>   instances of a specific ASN.1 data type or restricting
>   values to those produced by a subset of BER.  Enforcement
>   of additional restrictions is OPTIONAL.

comments?

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 22 Jan 2001 18:49:30 -0800

At 07:09 PM 1/22/01 -0700, Jim Sermersheim wrote:
>What was wrong with the OCTET STRING wrapper comment (I assume you're referring to 2251: 4.1.6)?

No RFC 2252, 4.3.1.

>It made sense as an issue that should be cleared up.

The issue, in terms of 2252 "binary" syntax, is that the syntax
itself does not have an OCTET STRING wrapper in all uses.
For example, the DN containing a RDN value 0x02024869 (hex) from
a binary syntax attribute type (1.1.0) should be represented as:
        1.1.0=#02024869

The wrapper statement could be confused as meaning there
should an OCTET STRING wrapper, that is:
        1.1.0=#040402024869

Kurt