Subject: Re: LDAPbis Acknowledgement Policy

From: [email-masked] (Mark C Smith)
Date: Thu, 11 Jan 2001 09:56:17 -0500

"Kurt D. Zeilenga" wrote:
> 
> To ensure WG documents appropriately and consistently
> give credit to WG document editors and authors, prior work
> document editors and authors, and individuals providing
> other significant contributions to WG documents, an
> acknowledge policy should be adopted.  The following
> policy statement is offered by this co-chair:
> 
>   Each WG I-D shall list in the header the name and
>   organization of the document editor and author(s)
>   of the WG (revision) document.  An author is an
>   individual who has made a direct major contribution
>   to the WG (revision) document.

I assume it is up to the document editor to determine what constitutes a
"major contribution."  For example, technical review of changes by an
expert could be viewed as a major contribution.

Also, I think it would be useful to ask editors to put the word "Editor"
after their name in the header, e.g.,

     Kurt D. Zeilenga, Editor
     Joe Smith
     Babs Jensen

>   The document editor and author(s) of prior work(s)
>   shall be credited in an Acknowledgement section.

Unless they are already listed in the new document in the header, etc.

>   Other significant contributors to the (revision)
>   document may be credited in the Acknowledgement
>   section.  Such credit should be in a separate
>   paragraph from prior work(s) acknowledgements.
> 
>   A request from a named individual to be credited
>   in the Acknowledgement section instead of the header
>   or not to be credited shall be honored.
> 
> This statement is based upon past LDAP revision/update
> acknowledge practices and is believed to be consistent
> with IETF policy and tradition.
> 
> The WG chairs plan to make a decision on an acknowledgement
> policy within the next few weeks and solicits WG comments
> on this action.  Please send your comments to this list
> or to the WG chairs by 10 January 2001.

Looks like I am one day late ;-)

-- 
Mark Smith
Directory Product Development / Netscape
My words are my own, not my employer's.            Got LDAP?

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 11 Jan 2001 09:41:34 -0800

At 09:56 AM 1/11/01 -0500, Mark C Smith wrote:
>"major contribution."

Yes.  It is the document editor who executes the policy
and should apply reasonable discretion.

>For example, technical review of changes by an

I guess it could be.  I'm more of the school that the
act of reviewing is different than the act of authoring.
However, reviewers do originate work which is included in
the document.  As an editor, I would try to judge whether
this work was 'major' or 'significant' and acknowledge
based upon this judgement. This, of course, is just my view.
There are other valid approaches to applying reasonable
discretion which an editor may take.

>after their name in the header, e.g.,

I concur.

>Unless they are already listed in the new document in the header, etc.

I would like to see the first paragraph of the acknowledgement
section of each I-D to state:

        This document is an update of RFC XXXX by John Doe
        and Mark Jones.  RFC XXXX was a product of the IETF
        XXXX Working Group.

The statement should name all the listed editors/authors of
the RFC(s) which is being updated.

Kurt

---

From: [email-masked] (Mark C Smith)
Date: Thu, 11 Jan 2001 13:35:26 -0500

> and should apply reasonable discretion.

Okay by me.

> discretion which an editor may take.

Right.  In most cases, I wouldn't consider technical review to produce a
major contribution -- but it might (that is, if a great idea is
contributed during such a review I might consider that a major
contribution, even though no document text was written by the
contributor, etc.).

> the RFC(s) which is being updated.

That sounds good to me.  I suggest you spell that out in the
Acknowledgement Policy / Guidelines so we are consistent.

-Mark