Subject: RE: AttributeTypeValue and binary

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 25 Jan 2001 21:16:16 -0700

I'm an idiot. And here it is again with Steven's change:

A field of type AttributeValue is an OCTET STRING containing an encoding of the value syntax of the companion attribute type. The syntax of each attribute type defines a default encoding, that encoding is used unless an option is present in the companion AttributeDescription which overrides the default encoding. For example, if the "binary" option is present, the value will be the BER encoding of the value. 

The definition of encodings for different syntaxes and types may be found in other documents, and in particular [RFC2252].
<<

We don't actually need the "For example" part, but it's useful. Is it useful enough to include?

Jim

>>> "Kurt D. Zeilenga" <[email-masked]> 1/25/01 5:18:55 PM >>>
At 04:56 PM 1/25/01 -0700, Jim Sermersheim wrote:
>Sounds good. Where do you suggest the statement go?

Well, I'm thinking the first part of my suggestion
belongs in 2251, it's clearly protocol semantics.
The second part needs to be part of the "syntax
profile" (what a syntax specification is required
to provide).  This likely should be in 2252.

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 25 Jan 2001 21:41:32 -0800

>The definition of encodings for different syntaxes and types may be found in other documents, and in particular [RFC2252].

Hmm... I'm not sure I'm happy with this.  I think you are now
confusing the relationship between the transfer encoding
and the attribute description (4.1.6) and issues dealing
with requested (implicit or explicit) attribute descriptions
v. returned attribute descriptions (which is what I did
previously).

Kurt