Subject: Re: search & extendedResponse implementation report quiz

From: "Jim Sermersheim" <[email-masked]>
Date: Mon, 22 Oct 2001 19:20:08 -0600

Thinking about this further... Say we have a need to send periodic "update" responses to a client that is waiting for a search request to complete. One could address this by periodically attaching a control to a search result entry, but if the period is time-based, and search result entries are not being returned when the time interval is reached, there is no other response mechanism available to convey the update information.

Without the availability of the ExtendedResponse, one would be forced to return "bogus" search result entries to convey this update information--which isn't exactly kosher.

Is there a different solution that I'm overlooking?

Jim 

>>> "Kurt D. Zeilenga" <[email-masked]> 3/29/01 8:48:55 AM >>>
Are you aware of any implementation which support returning
of extendedResponse PDU solicited by a searchRequest extended
by a control (rfc2251, section 4.5.2)?

If there is no affirmative response to this message within
a week, it shall be assumed that there are no implementations
of this feature and that the editor shall remove it.

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 22 Oct 2001 18:31:48 -0700

>Thinking about this further... Say we have a need to send periodic "update" responses to a client that is waiting for a search request to complete. One could address this by periodically attaching a…

One could want to do the same for any operation, consider
a subtree rename.

>Is there a different solution that I'm overlooking?

draft-rharrison-ldap-intermediate-resp-00.txt (which has
been recommended to the IESG for consideration as a
Proposed Standard.

Note as well that the IANA Considerations for LDAP I-D
provides a mechanism which would allow additional messages
to be added to LDAP without requiring their specification
as part the "core".

Kurt