Subject: Re: Teletex Terminal Identifier in draft-ietf-ldapbis-syntaxes-01

From: Kathy Dally <[email-masked]>
Date: Fri, 01 Mar 2002 00:06:26 -0500

Hi!

The -02 version of the syntaxes I-D that has just been submitted
includes:  octetstring = *OCTET   , where OCTET  =  %x00-FF (defined in
RFC 2234, ABNF).

Regards,
Kathy Dally

Steven Legg wrote:
> 
> Jim,
> 
> Jim Sermersheim wrote:
> > This syntax has the encoding:
> > teletex-id = ttx-term  0*("$" ttx-param)
> > where ttx-param ends in an octetstring.
> >
> > Some escapment policy must be noted regarding the occurance of %0x24 in
> > the octetstring (due to the $ delimiter). It probably would have been
> > easier if ttx-param was defined as:
> > ttx-param  = ttx-key ":" ttx-value-len ":" ttx-value
> >
> > but I think we're beyond going back and changing it.
> 
> The <octetstring> rule isn't actually defined anywhere so we're
> free to define it to be something sensible. I suggest we make
> it a hexadecimal string.
> 
> Note that the 4th edition of X.500 has deprecated this syntax.
> The X.500 working group has even gone to the extent of removing
> the teletexTerminalIdentifier attribute from every object class
> that used to reference it. An option for us is to throw it out too.
> 
> Regards,
> Steven

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 28 Feb 2002 21:29:01 -0800

At 08:13 AM 2002-02-28, Jim Sermersheim wrote:
>Some escapment policy must be noted

In general, the escapement policy is that defined in
RFC 2252, 4.3, pp3.