Subject: Re: Issues regarding LDAP Control

From: "Timothy Hahn" <[email-masked]>
Date: Wed, 13 Mar 2002 22:45:05 -0500

Kurt,

I agree with most everything you wrote except for one thing - see <TJH> ...
</TJH> below.

Regards,
Tim Hahn

Internet: [email-masked]
Internal: Timothy Hahn/Endicott/IBM@IBMUS or IBMUSM00(HAHNT)
phone: 607.752.6388     tie-line: 8/852.6388
fax: 607.752.3681

                      "Kurt D. Zeilenga"                                                                                                  
                      <[email-masked]>         To:       [email-masked]                                                     
                      Sent by:                    cc:                                                                                     
                      owner-ietf-ldapbis@O        Subject:  Issues regarding LDAP Control                                                 
                      penLDAP.org                                                                                                         

                      03/13/2002 12:11 PM                                                                                                 

Here are a few issues I've found in review 4.12 of [Protocol]
and past discussions (many on LDAPext) regarding controls.

>4.1.12. Controls
>
>   A control is a way to specify extension information. Controls which
>   are sent as part of a request apply only to that request and are not
>   saved.

This likely should be generalized to apply to both request
and response controls.  Maybe something like:
   Controls which are sent as part of a LDAP PDU apply
   only to that PDU and are not saved.
<TJH>
I guess I see this as "overly restrictive".  Why couldn't some control,
specified as a part of one request, have "semantics" that made the
effect of the control apply to other requests that come later in
the connection stream?  If I'm reading the clarification right,
it sounds like this would be DIS-allowed since the control that
was sent as part of one LDAP PDU would "apply" to other PDUs.
</TJH>

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 13 Mar 2002 21:37:03 -0800

>was sent as part of one LDAP PDU would "apply" to other PDUs.

Do you find the original text "overly restrictive" as well?

I don't think this or the original text was intended to
restrict the impact of an operation extended by zero or
more controls, but to restrict the impact of a control.

It can be said that a control only alters the semantics
of the message it is attached to.  This is not to say
that this operation may impact the processing of other
operations.

Maybe this sentence should be replaced with that, e.g.:
        A control only alters the semantics of the
        message it attached to.

Kurt