Subject: RE: I-D ACTION:draft-ietf-ldapbis-protocol-06.txt

From: "Ramsay, Ron" <[email-masked]>
Date: Tue, 5 Mar 2002 17:11:18 +1100

I don't follow

I note that ASN.1 provides only the data definition, not an
encoding.

If you specify ;binary, it certainly becomes an encoding (and therefore
always was an encoding).

Also, LDAP usually doesn't have an encoding based on the ASN.1. Unless you
mean loosely based. For example, StreetAddress is a SEQUNCE OF, but the LDAP
version is a collection of strings separated by '$' (is the '$' escaped in
the strings? - don't know, but it would also complicate the transformation).

So let's just say there are two encodings. I am not saying the ASN.1 form is
'native', I am simply saying that, as the ASN.1 form came first, and, as you
say below, the string encoding is based on the ASN.1, one can hardly call
the LDAP form 'native'. I would prefer a different adjective.

Ron.

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]]
Sent: Tuesday, 5 March 2002 15:11
To: Ramsay, Ron
Cc: [email-masked]; [email-masked]
Subject: RE: I-D ACTION:draft-ietf-ldapbis-protocol-06.txt

At 04:56 PM 2002-03-04, Ramsay, Ron wrote:
>This use of the term 'native' encoding is not good. I think we have already
>established that every syntax must have an ASN.1 encoding defined, and I
>would think that this is about as native as you can get. I can see
>difficulties with the term 'string' encoding, but I don't think 'native' is
>the way to go.

The WG consensus was use a different term. The only proposal
we have is use the term 'native'.

I note that ASN.1 provides only the data definition, not an
encoding.  LDAP currently has two possible encodings, both
defined in terms of the ASN.1 data definition.  Referring
to the "string" representation as a "native" encoding as
they were born in LDAP technical specifications for use
in LDAP.

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 04 Mar 2002 22:57:32 -0800

At 10:11 PM 2002-03-04, Ramsay, Ron wrote:
>the LDAP form 'native'.

Again, you imply that ASN.1 data type is an encoding.

Both LDAP encodings (string and binary) are based on the ASN.1
data type definitions, but the string representations were
not only the first encodings of the ASN.1 data type definitions
used in LDAP but are the encodings which originated in LDAP.
The binary transfer encodings were introduced subsequently
and are based on encodings used in DAP.

So, in the dictionary sense:
   native: adj 1: being such by origin.  [WordNet]

the term makes reasonable sense. 

> I would prefer a different adjective.

Such as?

Kurt