Subject: New DN name string please

From: David Chadwick <[email-masked]>
Date: Mon, 01 Apr 2002 17:11:11 +0100

Could we please define a name string for the serial number attribute
type and it to the table in dn-07. Serial number is a PKIX and X.509
recommended method for uniquely identifying certificate holders using a
dual attribute value RDN of the form

CN=David Chadwick + SerialNumber=123456789

I dont mind what name string we choose (SN - but could be confused with
surname - or SerialNumber) but it would be nice to recognise that one
can be used in DNs.

Thankyou

David

-- 
*****************************************************************

David W. Chadwick, BSc PhD
Professor of Information Systems Security
IS Institute, University of Salford, Salford M5 4WT
Tel: +44 161 295 5351  Fax +44 161 745 8169
Mobile: +44 77 96 44 7184
Email: [email-masked]
Home Page:  http://www.salford.ac.uk/its024/chadwick.htm
Research Projects: http://sec.isi.salford.ac.uk
Understanding X.500:  http://www.salford.ac.uk/its024/X500.htm
X.500/LDAP Seminars: http://www.salford.ac.uk/its024/seminars.htm
Entrust key validation string: MLJ9-DU5T-HV8J
PGP Key ID is 0xBC238DE5

*****************************************************************

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 04 Apr 2002 11:21:25 -0800

At 08:11 AM 2002-04-01, David Chadwick wrote:
>type and it to the table in dn-07.

No, the mapping table is purposely not extensible as that would
lead to interoperability problems.  Attributes which are not
listed in the table (or an alternative table, if so agreed
upon by protocols peers) need to be referred to by their OIDs.

The static v. extensible table issue was discussed previously
on the list and I (as editor) believe the I-D accurately reflects
WG consensus.

Kurt