Subject: Query about LDAPv3

From: Anurag Tiwari <[email-masked]>
Date: Mon, 24 Jun 2002 18:20:42 +0530

Sir
Does ldap v3 support `distinguished name searches' in the sense that can
I setup a filter that searches only for a dn like:
    (cn=Jo*,o=CMC,c=india)

Yours Sincerely
Anurag Tiwari

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 24 Jun 2002 14:53:38 -0700

>I setup a filter that searches only for a dn like:

No.  DNs are not attributes.  Filter assertions, even
extensible matching rule assertions, act upon attributes.

Note: some servers might maintain operational attributes
which contain a copy of the entry's DN.  Values of these
attributes can be matched using filters.  However, I'm
not sure how one would do substring matching against a
DN value.  While DN values have string representations,
the DN syntax is not a string data type.

Kurt

---

From: David Chadwick <[email-masked]>
Date: Thu, 27 Jun 2002 00:00:31 +0100

> I setup a filter that searches only for a dn like:

No, but you can achieve the same thing by doing a one level search below
o=cmc, c=india
searching for cn=jo*. It achieves the same result

David

-- 
*****************************************************************

David W. Chadwick, BSc PhD
Professor of Information Systems Security
IS Institute, University of Salford, Salford M5 4WT
Tel: +44 161 295 5351  Fax +44 01484 532930
Mobile: +44 77 96 44 7184
Email: [email-masked]
Home Page:  http://www.salford.ac.uk/its024/chadwick.htm
Research Projects: http://sec.isi.salford.ac.uk
Understanding X.500:  http://www.salford.ac.uk/its024/X500.htm
X.500/LDAP Seminars: http://www.salford.ac.uk/its024/seminars.htm
Entrust key validation string: MLJ9-DU5T-HV8J
PGP Key ID is 0xBC238DE5

*****************************************************************