Subject: Object class subschema

From: Michael Ströder <[email-masked]>
Date: Fri, 16 Aug 2002 08:35:52 +0200

HI!

Referring to section 6.2 of draft-ietf-ldapbis-syntaxes-02.txt:

---------------------- snip ---------------------
       ( 2.5.20.1 NAME 'subschema'
          AUXILIARY
          MAY ( dITStructureRules $
              nameForms $
              ditContentRules $
              objectClasses $
              attributeTypes $
              matchingRules $
              matchingRuleUse ) )

    The ldapSyntaxes operational attribute can also be present in
    subschema entries.
---------------------- snip ---------------------

What's the rationale behind not including attribute type 
ldapSyntaxes in MAY expression?

Ciao, Michael.

---

From: Mark Wahl <[email-masked]>
Date: Fri, 16 Aug 2002 10:56:44 -0500

> ldapSyntaxes in MAY expression?

2.5.20.1 sounds like an OID from the X.500 space.  But the ldapSyntaxes
and ldapSchemas attributes which can also be present in subschema entries
are not defined in X.500 and so cannot be added to their subschema class
without changing the definition.  In practice this should not matter 
because all of the attributes listed there are operational and so are not
governed by object class rules in most implementations.

Mark Wahl
Sun Microsystems Inc.