Subject: I-D ACTION:draft-ietf-ldapbis-iana-09.txt

From: [email-masked]
Date: Mon, 05 Aug 2002 07:44:08 -0400

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the LDAP (v3) Revision Working Group of the IETF.

	Title		: IANA Considerations for LDAP
	Author(s)	: K. Zeilenga
	Filename	: draft-ietf-ldapbis-iana-09.txt
	Pages		: 22
	Date		: 02-Aug-02
	
This document provides procedures for registering extensible elements
of LDAP (Lightweight Directory Access Protocol).  The document also
provides guidelines to IANA (Internet Assigned Numbers Authority)
describing conditions under which new values can be assigned

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ldapbis-iana-09.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-ldapbis-iana-09.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-ldapbis-iana-09.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 05 Aug 2002 07:26:25 -0700

This revision includes a discoverable "Protocol Mechanisms"
registry for Extended Operations, Controls, and such.  This
addition was requested by the IESG, so I suspect they will
approve -09 quickly (since -08 had been previously approved).

Kurt

At 04:44 AM 2002-08-05, [email-masked] wrote:
>Content-Type: text/plain
>Content-ID:     <[email-masked]>
>
>ENCODING mime
>FILE /internet-drafts/draft-ietf-ldapbis-iana-09.txt
>
><ftp://ftp.ietf.org/internet-drafts/draft-ietf-ldapbis-iana-09.txt>

---

From: David Chadwick <[email-masked]>
Date: Fri, 09 Aug 2002 20:41:44 +0100

Kurt

There is still the ongoing discussion about the registration and use of
further DN strings for use by PKIX. If iana-09 goes to RFC, saying that
the Directory System Names registry is no longer needed, what effect
will this have on the discussion?

regards

David

-- 
*****************************************************************

David W. Chadwick, BSc PhD
Professor of Information Systems Security
IS Institute, University of Salford, Salford M5 4WT
Tel: +44 161 295 5351  Fax +44 01484 532930
Mobile: +44 77 96 44 7184
Email: [email-masked]
Home Page:  http://www.salford.ac.uk/its024/chadwick.htm
Research Projects: http://sec.isi.salford.ac.uk
Understanding X.500:  http://www.salford.ac.uk/its024/X500.htm
X.500/LDAP Seminars: http://www.salford.ac.uk/its024/seminars.htm
Entrust key validation string: MLJ9-DU5T-HV8J
PGP Key ID is 0xBC238DE5

*****************************************************************

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 09 Aug 2002 14:09:03 -0700

>will this have on the discussion?

None.

The LDAPv2 DN keyword registry ("Directory System Names")
[RFC1777] cannot be reused for LDAPv3 DN name strings as
v2 keywords differ in syntax from v3 name strings.  For,
example, "h i s t o r i c" is a valid LDAPv2 keyword
but not a valid LDAPv3 name string.  And "L-D-A-P-v-3"
is a valid LDAPv3 name, but not a valid LDAPv2 keyword.

If this WG determines that a registry approach is best,
it should either reuse the "Object Identifier Descriptor"
registry [draft-ietf-ldapbis-iana] or establish a new registry
specifically for LDAPv3 DN string names.

At IETF#54, I noted that I am drafting a proposal which
is registry-based.  In particular, it's based upon the
"Object Identifier Descriptor" registry.  I comment on
this separately.  I hope to have this draft ready for
your review shortly (and the WG's review shortly thereafter).

Kurt