Subject: Re: controls

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 01 Oct 2002 14:52:15 -0600

The wording in my latest (yet-to-be-submitted) draft says this:

"Controls should not be combined unless the semantics of the
combination has been specified. The semantics of control combinations,
if specified, are generally found in the control definition most
recently published. In the absence of such a definition, the behavior of
the operation is undefined.  
Additionally, the order of a combination of controls in the SEQUENCE is
ignored unless the control definition explicitly states that ordering
affects the operation."

In other words, we can't say that it matters unless we can say how it
matters. Therefore, we acknowledge that it may matter, but leave it up
to the control definitions to specify if and how it matters.

Jim

>>> "Kurt D. Zeilenga" <[email-masked]> 10/01/02 12:50PM >>>
Likely something needs to be said about whether the order
of controls in the control SEQUENCE matters to processing
of the operation or not.  It's my personal opinion that the
order should matter.

For example, consider MatchedValues and Duplicate Entries.
Match then Duplicate and Duplicate then Match are two different
operations.

Where control processing may only make sense if the controls
are processed in a certain order, only those orders should
be allowed.

For example, if sorting a page of results (as opposed to
returning a page of sorted results) makes no sense, then
specifying the sort control after the paging control should
not be allowed.

Where control processing of two or more controls doesn't
matter, those controls can be provided in any order.  For
example, order of ManageDSAit and Subentries controls are
independent of each other and hence can be specified in
either order.

Comments?

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 01 Oct 2002 14:43:03 -0700

>the operation is undefined.  

s/definition/specification/

>to the control definitions to specify if and how it matters.

I think we need to say how servers are to behave where they
are given a combination of recognized and appropriate controls
types for an operation but they do not support the particular
combination.  I suggest that if the server is unwilling or unable
to perform the operation as extended by the combination, it
should return unwillingToPerform.

Kurt