Subject: RE: controls

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 4 Oct 2002 11:01:01 +1000

If a control X behaved differently depending on whether control Y appeared
before control Z, it would be better to have a data item in control X so
that control X(data=0) and control X(data=1) represented the two behaviours
than to require an implementation to guess which behaviour is required based
on the ordering of other controls.

So I would prefer to see the position as "no control should rely on the
actual order of other controls included in the same request."

Ron.

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Friday, 4 October 2002 4:21 AM
To: Ramsay, Ron; [email-masked]
Cc: [email-masked]
Subject: RE: controls

We could state that the ordering in the sequence is not significant
unless specified by a control specification.

>>> "Kurt D. Zeilenga" <[email-masked]> 10/02/02 08:13PM >>>
At 05:40 PM 2002-10-01, Ramsay, Ron wrote:
>Actually, I think the stand should be that order is not important.

I don't see any reason why we should take a stand here,
especially given that any future extension specification
can override any stand we might take. 

We should, however, clarify whether the default ordering
semantics is "set" or "sequence" so that authors and readers
of control extension specifications don't have to guess
as to what semantics apply in absence of an explicit
statement as to what semantics apply.

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 03 Oct 2002 19:45:08 -0700

>actual order of other controls included in the same request."

We should avoid making statements which restricting LDAP
extensions. Such position statements are better left to
documents detailing "guidelines" for designers of LDAP
extensions.

>unless specified by a control specification.

Yes, this we could state.  It addresses the default
semantics issue without restricting LDAP extensions to
those semantics.

Kurt

---

From: Michael Ströder <[email-masked]>
Date: Fri, 04 Oct 2002 12:16:25 +0200

> documents detailing "guidelines" for designers of LDAP

Kurt, can you give an example for a situation in which it's not possible to 
place two data items in one control as suggested by Ron?

Ciao, Michael.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 04 Oct 2002 07:34:56 -0700

At 03:16 AM 2002-10-04, Michael Ströder wrote:
>Kurt, can you give an example for a situation in which it's not possible to place two data items in one control as suggested by Ron?

I'm not going to enter into a debate about which extension
design approach is "better".   As the "core" technical
specification cannot impose a design approach upon future
extensions, it doesn't matter which design approach is
considered to be "better".

Kurt