Subject: RE: controls

From: "Ramsay, Ron" <[email-masked]>
Date: Mon, 7 Oct 2002 11:21:41 +1000

However, saying that the sequence may be ordered seems to encourage authors
to use the feature. Saying at the outset that the order of controls is not
significant encourages authors to look at other ways of associating multiple
controls.

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]]
Sent: Saturday, 5 October 2002 12:35 AM
To: [email-masked]
Cc: [email-masked]
Subject: Re: controls

At 03:16 AM 2002-10-04, Michael Ströder wrote:
>Kurt D. Zeilenga wrote:
>>At 06:01 PM 2002-10-03, Ramsay, Ron wrote:
>>>So I would prefer to see the position as "no control should rely on the
>>>actual order of other controls included in the same request."
>>We should avoid making statements which restricting LDAP
>>extensions. Such position statements are better left to
>>documents detailing "guidelines" for designers of LDAP
>>extensions.
>
>Kurt, can you give an example for a situation in which it's not possible to
place two data items in one control as suggested by Ron?

I'm not going to enter into a debate about which extension
design approach is "better".   As the "core" technical
specification cannot impose a design approach upon future
extensions, it doesn't matter which design approach is
considered to be "better".

Kurt

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Sun, 06 Oct 2002 19:48:04 -0700

>significant encourages authors to look at other ways of associating multiple

Encouraging (or discouraging) one extension design approach over
another is not within scope of the "core" protocol specification. 
To the "core" protocol, it doesn't matter one iota which design
approach is taken in future extensions.  The choice is theirs
not ours.

Kurt