Subject: Re: Failed or Abandoned Bind operations

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 21 Nov 2002 09:13:33 -0700

The latter (if they wish to determine) — will try to make it more obvious.

Also, what the client really needs to do (in order to determine) is either make use of the BindResponse, and if no BindResponse is recieved, must rebind.

>>> Hallvard B Furuseth <[email-masked]> 11/21 10:29 AM >>>
Jim Sermersheim writes:
> "Clients MUST rebind after abandoning a bind operation in order to
> determine a known authentication state."

Is this "Clients MUST rebind and this explains why", or "clients must
rebind if they wish to determine..."?

-- 
Hallvard

---

From: Hallvard B Furuseth <[email-masked]>
Date: Thu, 21 Nov 2002 22:52:16 +0100

> The latter (if they wish to determine) =97 will try to make it more =
> obvious.

Good.  (BTW, could "determine" be replaced with "have" or have I missed
some nuance?  I like simple words.)

> Also, what the client really needs to do (in order to determine) is
> either make use of the BindResponse, and if no BindResponse is
> recieved, must rebind.

Or unbind, or send/receive a TLS closure alert.  [authmeth] 5.2.2 states
that the latter leaves the connection in an anonymous state.

-- 
Hallvard

---

From: "Ramsay, Ron" <[email-masked]>
Date: Mon, 25 Nov 2002 12:03:18 +1100

I guess for ASN.1 over TCP (ie LDAP), anything is possible - but it could
cause havoc in a SASL bind. For X.500 the situation is a little more complex
as the server may have to contact other servers to complete the bind. Also,
you would normally expect your abstract syntax to be accepted before using
it? (Who provides the presentation contexts - is it the server?)

Ron.

-----Original Message-----
From: Hallvard B Furuseth [mailto:[email-masked]]
Sent: Saturday, 23 November 2002 19:54
To: Ramsay, Ron
Cc: Jim Sermersheim; [email-masked]
Subject: RE: Failed or Abandoned Bind operations

Ramsay, Ron writes:
> But I am intrigued at abandoning a bind. Technically, I don't see how this
> is possible because operations cannot be sent until a bind is completed.

Where is this stated?  I can't find it.

-- 
Hallvard