Subject: Failed or Abandoned Bind operations

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 21 Nov 2002 08:15:58 -0700

The current text in section 4.2.1 of the protocols document says:

"Authentication from earlier binds are subsequently ignored, and so if the bind fails, the connection will be treated as anonymous."

This does not address the issue of an abandoned bind operation. I suggest something like:

"Authentication from earlier binds are subsequently ignored. A failed or abandoned Bind Operation has the effect of leaving the connection in an anonymous state. Clients MUST rebind after abandoning a bind operation in order to determine a known authentication state."

Does this adequately cover the issue? Does it inadvertently introduce anything bad?

Jim

---

From: Hallvard B Furuseth <[email-masked]>
Date: Thu, 21 Nov 2002 16:29:50 +0100

Jim Sermersheim writes:
> "Clients MUST rebind after abandoning a bind operation in order to
> determine a known authentication state."

Is this "Clients MUST rebind and this explains why", or "clients must
rebind if they wish to determine..."?

-- 
Hallvard