Subject: I-D ACTION:draft-ietf-ldapbis-models-03.txt

From: [email-masked]
Date: Thu, 07 Nov 2002 06:25:49 -0500

A New Internet-Draft is available from the on-line Internet-Drafts directories.
This draft is a work item of the LDAP (v3) Revision Working Group of the IETF.

	Title		: LDAP: Directory Information Models
	Author(s)	: K. Zeilenga
	Filename	: draft-ietf-ldapbis-models-03.txt
	Pages		: 45
	Date		: 2002-11-6
	
The Lightweight Directory Access Protocol (LDAP) is an Internet
protocol for accessing distributed directory services which act in
accordance with X.500 data and service models.  This document
describes the X.500 Directory Information Models.

A URL for this Internet-Draft is:
http://www.ietf.org/internet-drafts/draft-ietf-ldapbis-models-03.txt

To remove yourself from the IETF Announcement list, send a message to 
ietf-announce-request with the word unsubscribe in the body of the message.

Internet-Drafts are also available by anonymous FTP. Login with the username
"anonymous" and a password of your e-mail address. After logging in,
type "cd internet-drafts" and then
	"get draft-ietf-ldapbis-models-03.txt".

A list of Internet-Drafts directories can be found in
http://www.ietf.org/shadow.html 
or ftp://ftp.ietf.org/ietf/1shadow-sites.txt

Internet-Drafts can also be obtained by e-mail.

Send a message to:
	[email-masked].
In the body type:
	"FILE /internet-drafts/draft-ietf-ldapbis-models-03.txt".
	
NOTE:	The mail server at ietf.org can return the document in
	MIME-encoded form by using the "mpack" utility.  To use this
	feature, insert the command "ENCODING mime" before the "FILE"
	command.  To decode the response(s), you will need "munpack" or
	a MIME-compliant mail reader.  Different MIME-compliant mail readers
	exhibit different behavior, especially when dealing with
	"multipart" MIME messages (i.e. documents which have been split
	up into multiple messages), so check your local documentation on
	how to manipulate these messages.

Below is the data which will enable a MIME compliant mail reader
implementation to automatically retrieve the ASCII version of the
Internet-Draft.

---

From: Norbert Klasen <[email-masked]>
Date: Fri, 22 Nov 2002 17:25:58 +0100

Hi,
I reviewed draft-ietf-ldapbis-models-03 and found some issues in its ABNFs:

- RFC2252 allows an arbitrary number of spaces in the definition of oids 
between LPAREN, DOLLAR and RPAREN. However, draft-ietf-ldapbis-models-03 
requires exactly one SP to be present. I changed SP to WSP in definition of 
oids and oidlist to give the RFC2252 behavior. This is also consistent with 
the definitions for similiar tokens in draft-ietf-ldapbis-models.

- the rhs of list definitions was optional, which would allow an empty list 
(e.g. "NAME ()").

- BTW: The current form of *list definitions allows a list to only contain 
one element. This allows both "NAME 'cn'" and "NAME ('cn')". Is this 
intended?

- typo in the definition of qdescrs

- definitions for qdstrings and qdstringlist were missing.

- typo in the definition of QS

- typo in the definition of ObjectClassDescription

- the description text of the "DESC" tag seems mangled

- missing parens in the definition of ruleids

-- 
Norbert Klasen
Avinci - The Know-How Company
http://www.avinci.biz

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 25 Nov 2002 19:45:45 -0800

At 05:25 AM 2002-11-22, Norbert Klasen wrote:
>- the rhs of list definitions was optional, which would allow an empty list (e.g. "NAME ()").

This form is not used and likely will cause problems in some parsers.

>- BTW: The current form of *list definitions allows a list to only contain one element. This allows both "NAME 'cn'" and "NAME ('cn')". Is this intended?

Yes.

I concur with the other changes suggested.

Kurt