Subject: RE: short names (descriptors) proposal

From: "Ramsay, Ron" <[email-masked]>
Date: Wed, 6 Nov 2002 16:33:50 +1100

This phrasing, and the previous one, seem to suggest it is a really good
idea to use the same name in different namespaces. Why not

The same name SHOULD NOT be used for different OIDs, even if these OIDs
refer to different schema elements.

It's a bit like glue-sniffing - don't tell people that it happens and don't
tell them how to do it.

Ron.

-----Original Message-----
From: Kurt D. Zeilenga [mailto:[email-masked]]
Sent: Tuesday, 5 November 2002 6:17 AM
To: Michael Ströder
Cc: Timothy Hahn; [email-masked]
Subject: Re: short names (descriptors) proposal

At 06:00 AM 2002-11-04, Michael Ströder wrote:
>Timothy Hahn wrote:
>>Regarding the use of the same name for an attribute type and an object
>>class - I agree that it should be "discouraged".  I don't think the
>>specifications need to explicitly DIS-allow it.
>
>Maybe it would be helpful for application developers if the standard
document explicitly states that an attribute type and an object class MAY
have the same name although discouraged. I had to learn it the hard way...

How about adding the following to 6.2: 
  Note: While discouraged, one name may (for historical reasons)
  be an alias for multiple OIDs each referring to a different kind
  of schema element.  That is, there may be an objectClass 'fubar'
  and an attributeType 'fubar'.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 06 Nov 2002 16:03:48 -0800

At 09:33 PM 2002-11-05, Ramsay, Ron wrote:
>idea to use the same name in different namespaces.

If it was a good idea, it would be encouraged and allowed
for reasons other than historical ones.

Kurt

---

From: Michael Ströder <[email-masked]>
Date: Wed, 06 Nov 2002 22:49:09 +0100

(Note: corrected citation)

Ramsay, Ron wrote:
> idea to use the same name in different namespaces.

I agree that my phrasing with MAY was inappropriate and could encourage 
people to do so.

> Why not

I agree the SHOULD NOT sounds stronger than "While discouraged..".

But I can argue the other way round for your phrase: Many naive implementors 
could read this phrase above like it never happens. It was my original 
intention to give an explicit warning.

How about this:

The same name SHOULD NOT be used for different OIDs. But implementations 
MUST be prepared that the same name might be used for multiple OIDs each 
referring to a different kind of schema element.

Ciao, Michael.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 07 Nov 2002 08:55:31 -0800

In this discussion, I noticed two problems (in both my original
proposal and various suggestions made).

First, it should be noted that there is a significant difference
between a keyword, always written in uppercase, (e.g. MUST, SHOULD,
MAY) and a word (must, should, may) written in lowercase.  Only
keywords have RFC 2119 meaning.

Second, in the "core" technical specification, we should only
use keywords when stating an implementation requirement.  One
test of the use is to reword the sentence in the form:
	Implementations MUST/SHOULD/MAY ...

If you find the keyword applies not to an implementation but
to a user, deployment, a future specification, a registration,
a standards body, etc., then likely the use of the keyword is
inappropriate.

Lastly, keywords are to be used sparingly as discussed in RFC
2119.

I will offer a new wording shortly.

Kurt