Subject: errorMessage when success

From: Hallvard B Furuseth <[email-masked]>
Date: Fri, 15 Nov 2002 14:36:47 +0100

Should the server be allowed to fill the errorMessage field of
LDAPResult even along with a non-error resultCode?  The current text
(4.1.9) implies yes, but that seems a bit strange to me.

-- 
Hallvard

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Fri, 15 Nov 2002 17:57:43 -0800

At 05:36 AM 2002-11-15, Hallvard B Furuseth wrote:
>LDAPResult even along with a non-error resultCode? 

Why disallow it?

>The current text (4.1.9) implies yes, but that seems a bit strange to me.

I don't see this as being all that strange... it may
actually be handy in some success cases.   But maybe
s/error diagnostic/diagnostic/ would be appropriate.
Error implies not just non-success but non-successful.
A number of non-zero codes can be viewed as successful.

BTW, I've seen diagnostic information returned with
success... and haven't heard of any problems with that.

Kurt

---

From: Hallvard B Furuseth <[email-masked]>
Date: Sat, 16 Nov 2002 18:50:26 +0100

>> LDAPResult even along with a non-error resultCode? 

Because it's named an *error* message.

> success... and haven't heard of any problems with that.

OK.

-- 
Hallvard