Subject: Re: Continuation reference to root DN

From: Hallvard B Furuseth <[email-masked]>
Date: Thu, 21 Nov 2002 10:35:35 +0100

Jim Sermersheim writes:
> What would cause a continuation reference to point to the basedn ""?

I think it would have to be something like this DIT:
  c=no
    o=foo     (on server A)
      ou=bar  (on server A)
      ou=baz  (on server B, with DN o=baz)
      ou=quux (on server B, with DN o=quux)
      ...more ou's in server B...

Searches below o=foo return some entries from server A and one reference
to the root of server B.  It could instead return references to each OU
i B, but that would be slow (many repeated searches) if there are many
OUs.

I makes me really sad that can't set up my DIT that way:-)

-- 
Hallvard

---

From: Hallvard B Furuseth <[email-masked]>
Date: Thu, 21 Nov 2002 11:07:18 +0100

Hallvard B Furuseth writes:
> I think it would have to be something like this DIT:  (...)

I just thought of a better reason:

planet=Earth  (on central server)
  c=NO        (on local server)
  c=GB
  ...
We'll need this when LDAP gets extended to work over interplanetary
distances.

-- 
Hallvard

---

From: [email-masked]
Date: Thu, 21 Nov 2002 21:25:36 -0000

From:           	Hallvard B Furuseth <[email-masked]>
To:             	Jim Sermersheim <[email-masked]>
Copies to:      	[email-masked]
Subject:        	Re: Continuation reference to root DN
Date sent:      	Thu, 21 Nov 2002 10:35:35 +0100
Priority:       	non-urgent

Hallvard

You obviously have not heard of NSSRs! (non specific subordinate 
references). They were defined in X.500 for precisely the configuration you 
have here.

I dont like your idea of references to the root. These should be reserved for 
superior references (which LDAP still has to define)

If LDAP only defines one reference type, you cannot expect it to 
comprehensively solve all your referencing problems. LDAP will eventually need 
to define more reference types, as per X.500

regards

David

---

From: Hallvard B Furuseth <[email-masked]>
Date: Thu, 21 Nov 2002 23:42:16 +0100

[email-masked] writes:
> You obviously have not heard of NSSRs!

Yes, I just didn't remember the name.

> I dont like your idea of references to the root.

No, it's certainly a bad way of doing things.

-- 
Hallvard