Subject: RE: short names (descriptors) proposal

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 8 Nov 2002 10:22:55 +1100

Hi Michael,

I'm not too sure about the "MUST" or the phrasing. Could I suggest

The same name SHOULD NOT be used for different OIDs. However, implementors
should be aware that some third party schemas having the same name for an
attribute and an object class have been published.

Ron.

-----Original Message-----
From: Michael Ströder [mailto:[email-masked]]
Sent: Thursday, 7 November 2002 8:49 AM
To: Ramsay, Ron
Cc: [email-masked]
Subject: Re: short names (descriptors) proposal

<snip>

How about this:

The same name SHOULD NOT be used for different OIDs. But implementations 
MUST be prepared that the same name might be used for multiple OIDs each 
referring to a different kind of schema element.

<snip>

Ciao, Michael.

---

From: Michael Ströder <[email-masked]>
Date: Fri, 08 Nov 2002 00:30:31 +0100

> attribute and an object class have been published.

"Have been published" does not imply that they are also used.
But they *are* used!

One will run into serious problems with schema installed as default on some 
very recently released LDAP server implementation if the schema-aware 
application does not internally maintain a different name-OID-mapping for 
each schema element class. I guess it's also true for more schema elements 
than just attributes and an object classes.

Ciao, Michael.

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Thu, 07 Nov 2002 15:43:29 -0800

At 03:30 PM 2002-11-07, Michael Ströder wrote:
>One will run into serious problems with schema installed as default on some very recently released LDAP server implementation if the schema-aware application does not internally maintain a different name-OID-mapping for each schema element class.

... per subschema.

Names of each schema attribute of each subschema is, per the schema
model, in a separate namespace.

>I guess it's also true for more schema elements than just attributes and an object classes.

Yes.

---

From: Michael Ströder <[email-masked]>
Date: Fri, 08 Nov 2002 08:58:32 +0100

Kurt D. Zeilenga wrote:
>> One will run into serious problems with schema installed as
>> default on some very recently released LDAP server implementation if the
>> schema-aware application does not internally maintain a different
>> name-OID-mapping for each schema element class.
> 
> ... per subschema.

Yes.

Ciao, Michael.