Subject: Re: draft-ietf-ldapbis-filter-03.txt

From: John McMeeking <[email-masked]>
Date: Fri, 15 Nov 2002 15:32:29 -0600

Kurt - thanks for the memory refresh.

The original comments addressed binary data containing octets greater than
0x7f.  These octets in an UTF-8 encoded string should not require escaping.
Perhaps:

   The <valueencoding> rule provides that the octets that represent the
   ASCII characters "*" (ASCII 0x2a), "(" (ASCII 0x28), ")" (ASCII
   0x29), "\" (ASCII 0x5c), NUL (ASCII 0x00) are represented as a
   backslash "\" (ASCII 0x5c) followed by the two hexadecimal digits
   representing the value of the encoded octet. Octets greater than 0x7f
   that are not part of an UTF-8 encoded string are similarly escaped.

Or something like that.

John  McMeeking

                      "Kurt D. Zeilenga"                                                                                   
                      <[email-masked]>         To:       [email-masked] (Mark C Smith)                                
                      Sent by:                    cc:       Hallvard B Furuseth <[email-masked]>,                
                      owner-ietf-ldapbis@O         [email-masked]                                               
                      penLDAP.org                 Subject:  Re: draft-ietf-ldapbis-filter-03.txt                           

                      11/15/2002 02:16 PM                                                                                  

At 06:38 AM 2002-11-15, Mark C Smith wrote:
>Hallvard B Furuseth wrote:
>>Why was section 6 "String Search Filter Definition" changed to
>>say that "all octets greater than 0x7f" must be escaped?
>>Shouldn't that at least be "MUST" esacpe them when generating filters,
>>but SHOULD (or MAY) recognize them unescaped, for backwards
>>compatibility?
>
>That change was the result of working group last call comments made by
Steven Legg (but I am the one who wrote the text).

So that everyone change refresh their memory...

Steven's comment:
  http://www.openldap.org/lists/ietf-ldapbis/200105/msg00027.html

and Mark's subsequent reply:
  http://www.openldap.org/lists/ietf-ldapbis/200106/msg00002.html

and last call summary:
  http://www.openldap.org/lists/ietf-ldapbis/200106/msg00003.html

Kurt

---

From: Hallvard B Furuseth <[email-masked]>
Date: Fri, 15 Nov 2002 22:46:19 +0100

Our messages seem to have crossed each other:

John McMeeking writes:
>    (...)                                      Octets greater than 0x7f

Now that the draft talks about the octets in the filter instead of the
characters, I see no reason to consider UTF-8 or other encodings at all,
and no reason to escape non-ASCII characters.

-- 
Hallvard