Subject: Spaces in Delivery Method, Enhanced Guide and Guide

From: Hallvard B Furuseth <[email-masked]>
Date: Sat, 16 Nov 2002 16:42:17 +0100

draft-ietf-ldapbis-syntaxes-02.txt says:

> 3.5  Delivery Method
>      (...)
>      delivery-value = pdm / ( whsp pdm space "$" space delivery-value )
                                ^^^^     ^^^^^     ^^^^^

Why can there be a whitespace in front of a delivery-value?  And since
it can be, why not in front of a single pdm as well?  Also, why are the
spaces around '$' mandatory (instead of 'whsp')?

> 3.10  Enhanced Guide
>      (...)
>      EnhancedGuide = space oid whsp "#" whsp criteria whsp "#" 
                       ^^^^^
>                      whsp subset

Why does it start with space?  That doesn't seem to accomplish anything.

> 3.14  Guide
>      (...)
>      object-class = space oid
                      ^^^^^
Again, why the initial space?

('space' = mandatory space(s), 'whsp' = optional space(s).)

-- 
Hallvard

---

From: "Steven Legg" <[email-masked]>
Date: Wed, 27 Nov 2002 15:30:30 +1100

Hallvard,

> >      delivery-value = pdm / ( whsp pdm space "$" space 

The delivery-value BNF is in error and has been corrected and simplified
for the -04 draft to this:

   DeliveryMethod = pdm *( WSP "$" WSP pdm )

> Why does it start with space?  That doesn't seem to 

This is also in error and has been changed to the following
for the -04 draft:

   EnhancedGuide = object-class "#" WSP criteria WSP "#" WSP subset
   object-class  = WSP oid WSP

Regards,
Steven