Subject: LPAREN, RPAREN, and others

From: Hallvard B Furuseth <[email-masked]>
Date: Mon, 16 Dec 2002 14:33:44 +0100

What is the point of using the names LPAREN, RPAREN, DOT and so on
instead of "(", ")", "." and so on (in quotes)?  I find the latter
far more readable.

-- 
Hallvard

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Mon, 16 Dec 2002 17:51:50 -0800

At 05:33 AM 12/16/2002, Hallvard B Furuseth wrote:
>instead of "(", ")", "." and so on (in quotes)?  I find the latter far more readable.

I find ABNFs which consistently use of common productions
for all literals are more readable than ABNFs which mix
common productions and literals.  But, I think, it's a
matter of style found in uses of many formal languages.
I'm generally of the opinion that it doesn't matter too
much which style you use, as long as you consistently use
that style.

Kurt