Subject: dsa/knowledgeInformation schema removal

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Tue, 10 Dec 2002 12:36:09 -0800

I think the specifications of the 'dsa' objectclass
and the 'knowledgeInformation' should be removed
from the LDAP "core" specification as not having
well defined semantics in LDAP.

Comments?

Kurt

---

From: "Mark Hinckley" <[email-masked]>
Date: Tue, 10 Dec 2002 14:15:30 -0700

I agree that under specified schema should be removed from the core specification.  In general, I think that schema (syntaxes, attributes, classes, matching rules) should be specified by the application that is going to use them, not in the core specification. (Thus the PKI schema movement was exactly the right way to deal with those issues.) 

All these definitions are likely handy for some subset of the LDAP population, but not everyone.  Including them in the core specification typically means some effort spent (it may be minimal, but not always) to support these schema definitions in order to claim full LDAP compliance.  The smaller the core set of schema that is required to be supported, the better (IMO, of course).

So I agree with Kurt on this set of schema, and on the set of schema in his other posting "MHS Schema" also.

I need to re-read the spec again, but I would not be at all surprised to find additional schema that would be good candidates for removal from the Core Spec.

Mark Hinckley

>>> "Kurt D. Zeilenga" <[email-masked]> 12/10/02 01:36PM >>>

Comments?

Kurt