Subject: Re: Models: aliases

From: "Jim Sermersheim" <[email-masked]>
Date: Thu, 30 Jan 2003 15:29:16 -0700

What does the statement in Section 12.3.3 of X.501 mean?

"Note * The object class alias does not specify appropriate attribte types for the RDN of an alias entry. Administrative Authorities may specify subclasses of the class alias which specify useful attribute types for RDNs  of alias entris".

To me, it means that with X.500 directories, you have to subclass the objectclass. LDAP goes one better by defining the extensibleObject class.

Some directories however, do not follow the rules to the letter. It sounds like those that you've tested make an exception. Novell's adopts the rules set up in the target object.

Jim

>>> Hallvard B Furuseth <[email-masked]> 1/30/03 2:48:40 PM >>>
Kurt D. Zeilenga writes:
> You need to add extensibleObject, an objectClass
> which SUPs alias and allows o,

I don't like this: I never needed to do any of this
before - neither with ISODE (X.500) nor OpenLDAP.

It seems rather heavy to force people to get their
own OID and make new object classes just in order
to use aliases, if extensibleObject is not supported
on their server.

> or adjust your DIT
> content rules to allow o in alias entries.

That's not too widely supported yet either, is it?

-- 
Hallvard

---

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 31 Jan 2003 10:24:27 +1100

I think the appropriate way is to subclass an alias object with the required naming attribute. This also requires a new object class. At least it doesn't change the underlying model and it doesn't use an object without definition.

Ron.

-----Original Message-----
From: Hallvard B Furuseth [mailto:[email-masked]]
Sent: Friday, 31 January 2003 08:49
To: Kurt D. Zeilenga
Cc: [email-masked]
Subject: Re: Models: aliases

-- 
Hallvard

---

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 31 Jan 2003 10:27:43 +1100

I believe the only X.500 conformant way of using aliases is to subclass alias objects which contain the required naming attribute.

Ron.

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Friday, 31 January 2003 09:29
To: [email-masked]
Subject: Re: Models: aliases

Jim

-- 
Hallvard