Subject: Models: Matching Rule Uses

From: Hallvard B Furuseth <[email-masked]>
Date: Thu, 30 Jan 2003 23:34:13 +0100

[Models] says:

> 4.1.4. Matching Rule Uses
>
>  A matching rule use lists the attributes which are suitable for use
>  with an extensible matching rule

Please add something like "(in addition to those uses expressed in
AttributeType descriptions)".

BTW, how do Matching Rule Uses relate to the statements in [Syntaxes]
about which matching rules can be used with which syntaxes?
For example, [Syntaxes] 5.2.6 says:

>   The caseIgnoreMatch rule compares an assertion value of the Directory
>   String syntax to an attribute value of a syntax (e.g. the Directory
>   String, Printable String, Country String or Telephone Number syntax)
>   whose corresponding ASN.1 type is DirectoryString or one of its
>   alternative string types, e.g. PrintableString.

-- 
Hallvard

---

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 31 Jan 2003 10:30:59 +1100

caseIgnoreMatch is not an *extensible* matching rule.

-----Original Message-----
From: Hallvard B Furuseth [mailto:[email-masked]]
Sent: Friday, 31 January 2003 09:34
To: [email-masked]
Subject: Models: Matching Rule Uses

-- 
Hallvard