Subject: RE: Models: Subclassing

From: "Pana, Mircea" <[email-masked]>
Date: Tue, 28 Jan 2003 11:31:44 -0600

X501 section 8.3.2 recommends:
  "An object or alias entry is characterised by precisely
   one structural object class superclass chain which has
   a single structural object class as the most subordinate
   object class."

Doesn't this imply that an auxiliary object class can not
subclass a structural object class?

Thanks,
Mircea.

-----Original Message-----
From: Kathy Dally [mailto:[email-masked]]
Sent: Tuesday, January 28, 2003 9:58 AM
To: Jim Sermersheim
Cc: [email-masked]
Subject: Re: Models: Subclassing

Hi Jim!

There are no restrictions in X.501 on structural and auxiliary classes
being subclasses of one another.  Although it doesn't make a lot of
sense to me, I have seen cases where several structural object classes
have an auxiliary as the superclass.  I can't think of an example of the
reverse, off hand.

Thanks,
Kathy

Jim Sermersheim wrote:
> 
> Section 2.4 describes object class subclassing, but should express the
> effect of subclassing (namely that a subclass inherits the MUST and MAY
> list(s) of superior object classes in its superclass chain, but does not
> inherit Name Forms or DIT Content Rules)
> 
> Section 2.4.2 states "Structural object classes cannot subclass
> auxiliary object classes." and Section 2.4.3 states "Auxiliary object
> classes cannot subclass structural object classes.". I can't find these
> restrictions in X.501--can you point out the reference?
> 
> Jim

---

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 28 Jan 2003 10:38:38 -0700

From that, I only see that the most subordinate object class must be
structural, and that there can only be one chain (though there can be
multiple inheriitance), there cannot be two completely different chains
(resulting in multiple structural most-subordinate object classes). It
cannot mean that all superclasses are structural as that would nullify
the use of abstract object classes.

Jim

>>> "Pana, Mircea" <[email-masked]> 1/28/03 10:31:44 AM >>>

Thanks,
Mircea.

-----Original Message-----
From: Kathy Dally [mailto:[email-masked]] 
Sent: Tuesday, January 28, 2003 9:58 AM
To: Jim Sermersheim
Cc: [email-masked] 
Subject: Re: Models: Subclassing

Hi Jim!

There are no restrictions in X.501 on structural and auxiliary classes
being subclasses of one another.  Although it doesn't make a lot of
sense to me, I have seen cases where several structural object classes
have an auxiliary as the superclass.  I can't think of an example of
the
reverse, off hand.

Thanks,
Kathy

---

From: John Strassner <[email-masked]>
Date: Tue, 28 Jan 2003 12:01:45 -0700

I'm sorry, but this is absurd. Having an aux class, which is the object
equivalent of a capsule, serve as the superclass for a structural entry
doesn't make sense at all. Even if X.501 doesn't prevent it, we should.

And yes, sadly, I've seen plenty of examples. None of them, however, could
be justified. ;-)

regards,
John
 
John Strassner
Chief Strategy Officer
Intelliden Corporation
90 South Cascade Avenue
Colorado Springs, CO  80903  USA
phone: +1.719.785.0648
  FAX: +1.719.785.0644
email: [email-masked] 

-----Original Message-----
From: Kathy Dally [mailto:[email-masked]] 
Sent: Tuesday, January 28, 2003 7:58 AM
To: Jim Sermersheim
Cc: [email-masked]
Subject: Re: Models: Subclassing

Hi Jim!

There are no restrictions in X.501 on structural and auxiliary classes being
subclasses of one another.  Although it doesn't make a lot of sense to me, I
have seen cases where several structural object classes have an auxiliary as
the superclass.  I can't think of an example of the reverse, off hand.

Thanks,
Kathy

Jim Sermersheim wrote:
> classes cannot subclass structural object classes.". I can't find 
> these restrictions in X.501--can you point out the reference?
> 
> Jim

---

From: "Jim Sermersheim" <[email-masked]>
Date: Tue, 28 Jan 2003 13:57:28 -0700

That's what I suspected. We should just make sure that:
1) there aren't valid uses of performing these types of subclassing
(especially that are in use today)
2) we attempt to coordinate this clarification with the X.500 people
(at least raise this to their attention)
 
Jim

>>> "Kurt D. Zeilenga" <[email-masked]> 1/28/03 12:06:59 PM >>>
>classes cannot subclass structural object classes.". I can't find
these
>restrictions in X.501--can you point out the reference?

You won't find any clear, explicit statement in X.501 regarding this.

I added the above statements to address what I consider to
be a technical omission in the existing specification.  The
alternative would be describe the semantics of such subclassing.
I didn't take this alternative as such subclassing makes no
sense to me.

Kurt