Subject: Re: objectIdentifierMatch on ambiguous name

From: Hallvard B Furuseth <[email-masked]>
Date: Thu, 2 Jan 2003 14:41:47 +0100

John McMeeking writes:
> Given what you presented, the filter doesn't match anything -- yet.
> You need some entries with an oid attribute:

That's what I meant with "applied to attribute oid=bar".
I.e. a search on this entry:

   dn: cn=some entry
   oid: bar
   ...

> objectIdentifierMatch has nothing to do with OIDs (or names) defined in a
> schema.

Huh?

-- 
Hallvard

---

From: John McMeeking <[email-masked]>
Date: Thu, 2 Jan 2003 07:38:20 -0600

Given what you presented, the filter doesn't match anything -- yet.  You
need some entries with an oid attribute:

  dn: cn=some entry
  oid: 1.2.3.4

  dn: cn=some other entry
  oid: foo

Did you have something else in mind?

John  McMeeking

                      Hallvard B Furuseth                                                                                         
                      <[email-masked]        To:       [email-masked]                                             
                      io.no>                      cc:                                                                             
                      Sent by:                    Subject:  objectIdentifierMatch on ambiguous name                               
                      owner-ietf-ldapbis@O                                                                                        
                      penLDAP.org                                                                                                 

                      01/02/2003 06:10 AM                                                                                         

What does filter component (oid=foo) applied to attribute oid=bar
evaluate to if the schema defines the following?
  object class   ( ... NAME  'foo'        ... )
  object class   ( ... NAME  'bar'        ... )
  attribute type ( ... NAME ('foo' 'bar') ... )
  attribute type ( ... NAME 'oid'
                   EQUALITY objectIdentifierMatch
                   SYNTAX 1.3.6.1.4.1.1466.115.121.1.38 ) ; OID

--
Hallvard