Subject: RE: Models: Matching Rule Uses

From: "Ramsay, Ron" <[email-masked]>
Date: Fri, 31 Jan 2003 11:52:37 +1100

I should think the normal use of a matching rule is in the 'equalityMatch' choice of the filter. I also think 'extensibleMatch' is an attempt to create a new semantic and that the paragraphs below provide the means to scope this new meaning. The use of the matching rule in an attribute definition is automatically scoped.

Ron.

-----Original Message-----
From: Jim Sermersheim [mailto:[email-masked]]
Sent: Friday, 31 January 2003 11:21
To: Ramsay, Ron; [email-masked]; [email-masked]
Subject: RE: Models: Matching Rule Uses

Why not? I may have an attribute who's syntax is caseExactMatch. I may
want to search for values of that attribute using an extensible match
filter where the rule is caseIgnoreMatch.

Jim

>>> "Ramsay, Ron" <[email-masked]> 1/30/03 4:30:59 PM >>>
caseIgnoreMatch is not an *extensible* matching rule.

-----Original Message-----
From: Hallvard B Furuseth [mailto:[email-masked]] 
Sent: Friday, 31 January 2003 09:34
To: [email-masked] 
Subject: Models: Matching Rule Uses

[Models] says:

> 4.1.4. Matching Rule Uses
>
>  A matching rule use lists the attributes which are suitable for use
>  with an extensible matching rule

Please add something like "(in addition to those uses expressed in
AttributeType descriptions)".

BTW, how do Matching Rule Uses relate to the statements in [Syntaxes]
about which matching rules can be used with which syntaxes?
For example, [Syntaxes] 5.2.6 says:

>   The caseIgnoreMatch rule compares an assertion value of the
Directory
>   String syntax to an attribute value of a syntax (e.g. the
Directory
>   String, Printable String, Country String or Telephone Number
syntax)
>   whose corresponding ASN.1 type is DirectoryString or one of its
>   alternative string types, e.g. PrintableString.

-- 
Hallvard

---

From: Hallvard B Furuseth <[email-masked]>
Date: Fri, 31 Jan 2003 13:48:26 +0100

Ramsay, Ron writes:
> From: "Ramsay, Ron" <[email-masked]>
> To: "Jim Sermersheim" <[email-masked]>, <[email-masked]>
> Date: Fri, 31 Jan 2003 11:52:37 +1100
> 
> I should think the normal use of a matching rule is in the
> 'equalityMatch' choice of the filter.

Also substrings, greaterOrEqual and lessOrEqual.

> I also think 'extensibleMatch' is an attempt to create a new semantic
> and that the paragraphs below provide the means to scope this new
> meaning.  The use of the matching rule in an attribute definition is
> automatically scoped.

Yup.

-- 
Hallvard