Subject: RE: How are approxMatch matching rules declared?

From: "Steven Legg" <[email-masked]>
Date: Mon, 3 Mar 2003 14:30:10 +1100

Jim,

Jim Sermersheim wrote:
> Right now it says:
> The matching rule for approxMatch filter items is
> implementation-defined. If approximate matching is not
> supported by the
> server, the filter item should be treated as an equalityMatch.
>
> Does something need to be changed?

Not really (I didn't cross-check the wording before responding to Hallvard),
however I would say "The matching semantics" rather than "the matching rule"
so as to NOT give the impression that a proprietary matching rule definition
is somehow required.

BTW, the assertion syntax for greaterOrEqual, lessOrEqual and particularly
substrings filter items should be the same as the equality matching rule
assertion syntax. The current wording erroneously suggests that the initial,
any and final AssertionValues in a SubstringFilter would each be
SubstringAssertion values (in typical usage).

Regards,
Steven

>
> Jim
>
> >>> "Steven Legg" <[email-masked]> 2/3/03 10:17:29 AM >>>
>
> Hallvard,
>
> Hallvard B Furuseth wrote:
> > [Models] 4.1.2 (Attribute Types) has no
> >     ["APPROX" SP oid]
> > part which can be used to declare the matching rule which
> > approxMatch filters on the attribute should use.
>
> That's because there are practically no matching rules defined
> which describe approximate matching semantics. For the most
> part, if such a field were defined there would be nothing with
> which to populate it. The semantics of an approximate match
> filter item have always been left to the discretion of the
> server implementations.
>
> > Should that be
> > fixed?  Or must an implementation which wants to use implement
> > approxMatch define a syntax like
> >     ["X-APPROX" SP oid]		; approxMatch matching rule
> > or do something like defining an implicit approx matching rule for
> > each syntax which supports approxMatch filters?
>
> In principle, every attribute type with an equality matching rule
> supports approximate matching though in practice it might not differ
> from the equality match.
>
> > Should [Models] say something about this?
>
> More likely the protocol draft since that is where the search
> operation
> is described.
>
> Regards,
> Steven
>
>

---

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 05 Mar 2003 14:54:58 -0700

The -13 version has the assertion syntax wording removed from those
problem areas except substr--not sure why I missed tht one.

I'll work on the "rule" vs "semantics" wording for 14.

Jim

>>> "Steven Legg" <[email-masked]> 3/2/03 8:30:10 PM >>>

Jim,

> Does something need to be changed?

Not really (I didn't cross-check the wording before responding to
Hallvard),
however I would say "The matching semantics" rather than "the matching
rule"
so as to NOT give the impression that a proprietary matching rule
definition
is somehow required.

BTW, the assertion syntax for greaterOrEqual, lessOrEqual and
particularly
substrings filter items should be the same as the equality matching
rule
assertion syntax. The current wording erroneously suggests that the
initial,
any and final AssertionValues in a SubstringFilter would each be
SubstringAssertion values (in typical usage).

Regards,
Steven