Subject: Re: I-D ACTION:draft-ietf-ldapbis-models-07.txt

From: "Jim Sermersheim" <[email-masked]>
Date: Wed, 02 Apr 2003 15:20:47 -0700

extensions (found in schema element syntaxes like
ObjectClassDescription) no longer allows a word like "x-1.2.3.4" This
was not a limitation in the original spec, is there a reason for
allowing only ALPHA HYPHEN, and USCORE? I think it should allow %x21-7E
(after the x-)

Jim

>>> "Kurt D. Zeilenga" <[email-masked]> 3/13/03 8:46:18 AM >>>
In this revision, I have attempted to address issues raised
during the WG Last Call.  Please review.  Kurt

At 12:35 PM 3/7/2003, [email-masked] wrote:
>A New Internet-Draft is available from the on-line Internet-Drafts
directories.
>This draft is a work item of the LDAP (v3) Revision Working Group of
the IETF.
>
>        Title           : LDAP: Directory Information Models
>        Author(s)       : K. Zeilenga
>        Filename        : draft-ietf-ldapbis-models-07.txt
>        Pages           : 49
>        Date            : 2003-3-7
>        
>The Lightweight Directory Access Protocol (LDAP) is an Internet
>protocol for accessing distributed directory services which act in
>accordance with X.500 data and service models.  This document
>describes the X.500 Directory Information Models.
>
>A URL for this Internet-Draft is:
>http://www.ietf.org/internet-drafts/draft-ietf-ldapbis-models-07.txt 
>
>To remove yourself from the IETF Announcement list, send a message to

>ietf-announce-request with the word unsubscribe in the body of the
message.
>
>Internet-Drafts are also available by anonymous FTP. Login with the
username
>"anonymous" and a password of your e-mail address. After logging in,
>type "cd internet-drafts" and then
>        "get draft-ietf-ldapbis-models-07.txt".
>
>A list of Internet-Drafts directories can be found in
>http://www.ietf.org/shadow.html 
>or ftp://ftp.ietf.org/ietf/1shadow-sites.txt 
>
>
>Internet-Drafts can also be obtained by e-mail.
>
>Send a message to:
>        [email-masked].
>In the body type:
>        "FILE /internet-drafts/draft-ietf-ldapbis-models-07.txt".
>        
>NOTE:   The mail server at ietf.org can return the document in
>        MIME-encoded form by using the "mpack" utility.  To use this
>        feature, insert the command "ENCODING mime" before the "FILE"
>        command.  To decode the response(s), you will need "munpack"
or
>        a MIME-compliant mail reader.  Different MIME-compliant mail
readers
>        exhibit different behavior, especially when dealing with
>        "multipart" MIME messages (i.e. documents which have been
split
>        up into multiple messages), so check your local documentation
on
>        how to manipulate these messages.
>                
>                
>Below is the data which will enable a MIME compliant mail reader
>implementation to automatically retrieve the ASCII version of the
>Internet-Draft.
>Content-Type: text/plain
>Content-ID:     <[email-masked]>
>
>ENCODING mime
>FILE /internet-drafts/draft-ietf-ldapbis-models-07.txt
>
><ftp://ftp.ietf.org/internet-drafts/draft-ietf-ldapbis-models-07.txt>

---

From: "Kurt D. Zeilenga" <[email-masked]>
Date: Wed, 02 Apr 2003 23:59:21 -0800

At 02:20 PM 4/2/2003, Jim Sermersheim wrote:
>ObjectClassDescription) no longer allows a word like "x-1.2.3.4"
>This was not a limitation in the original spec, is there a reason for
>allowing only ALPHA HYPHEN, and USCORE?

RFC 2252 did not define a production for terms.  I came
up with xstring by first examining what would be appropriate
for all terms (both private and non-private).  I came up
with:
        term = ALPHA *( ALPHA / HYPHEN / USCORE )

(I don't recall the exact rationale... likely I just thought
keystring then realized USCORE was used in some terms).  I
then derived xstring from this.

I think xstring should be quite restrictive.  But as it unlikely
that adding a few additional characters would break any
implementations, I'm fine with adding one or two additional
characters which folks are currently using or believe would be
useful.

>I think it should allow %x21-7E (after the x-)

I think that would be problematic.

Is xstring known to be too restrictive (e.g., you known of
an existing private term which it disallows)?  Or you just
would like to have some more options?

If yes to either, I prefer to add to only add a few.  Would
adding DOT be sufficient?